MetaModels Workshop in Berlin
Seite 3 von 3 ErsteErste 123
Ergebnis 81 bis 102 von 102

Thema: [tensiderepository] - ExtensionRepository ohne PHP SOAP modul via nusoap benutzen

  1. #81
    Contao-Yoda Avatar von MacKP
    Registriert seit
    15.06.2009.
    Ort
    Duisburg
    Beiträge
    13.117
    User beschenken
    Wunschliste

    Standard

    Hallo Whitedragon,
    findest du natürlich bei den Erweiterungen:

    Hier -> http://www.contao.org/erweiterungsli...000009.de.html

    Viele Grüße

  2. #82
    Contao-Nutzer
    Registriert seit
    11.04.2010.
    Beiträge
    64

    Standard

    Hallo,

    ETA: Wird wohl schon dran gearbeitet

    FYI: Mit aktivierten kann man leider keine Aktualisierungen mehr machen, weil die Versionsliste leer bleibt.

    Manuell geht es natürlich.

    http://www.contao-community.de/showt...Update-auf-2.9
    Geändert von StummerWinter (15.08.2010 um 16:39 Uhr)

  3. #83
    Contao-Nutzer
    Registriert seit
    26.08.2010.
    Beiträge
    14

    Standard Keine Installation möglich

    Hallo,

    habe leider ein Problem mit TR. Habe ein Projekt (2.9.) auf einem Stratoserver (Paket ohne SOAP) und die TR installiert. Die Übersicht vom Erweitungskatalog funktioniert. Wenn ich allerdings dir Erweiterung installieren will, kann ich keine Versionen auswählen und somit auch nix installieren. Was kann ich dagegen tun?

    Viele Grüße,
    Leo

  4. #84
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.014
    User beschenken
    Wunschliste

    Standard

    Das wurde schon x-mal hier beschrieben, das TR derzeit nicht für 2.9 freigegeben ist, weil es damit nicht funktioniert. Es wird dran gearbeitet.
    Deinstallation und die Installationen per Hand durchführen.

    Und wegen Strato sag ich lieber nichts.
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  5. #85
    Contao-Nutzer
    Registriert seit
    10.02.2010.
    Beiträge
    49

    Standard Tenside Repository - Version

    Gibt es dafür denn nun schon eine Lösung in Aussicht? Manch sind auf Tenside angewiesen weil SOAP nicht am Server aktiviert ist. Irgendein Workaround für das Problem?
    lg

  6. #86
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.014
    User beschenken
    Wunschliste

    Standard

    So wie früher, Handbetrieb. Zip runterladen, auspacken, per ftp hochschieben, install.php aufrufen, fertig.
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  7. #87
    Alter Contao-Hase
    Registriert seit
    20.06.2009.
    Ort
    Graz (Austria)
    Beiträge
    1.149

    Standard

    Hallo,

    gibts hierzu schon news betreffend einer neuen Version?
    LG, Andi

  8. #88
    Contao-Nutzer
    Registriert seit
    08.01.2010.
    Beiträge
    109

    Standard Interimslösung

    Habe bis zum Erscheinen einer neuen Version von tensiderepository mal eine Interimslösung als Erweiterung bereit gestellt.

    Diese Erweiterung lautet nusoap und ist hier zu finden.

    Sie nutzt den NuSOAP-Part von Christian Schiffler (xtra) für die Original Erweiterung von Peter Koch. Konkret werden die NuSOAP-Dateien der tensiderepository in ein neues Plugin-Verzeichnis kopiert (war nötig um keinen Konflikt mit einer bestehenden tensiderepository Installation zu bekommen) und der Aufruf des SoapClients aus der Original Repository-Erweiterung wird auf die Wrapper-Klasse von xtra umgeleitet.

    Somit kann auch ohne installiertes SOAP das Extension Repository genutzt werden.
    Diese Lösung werde ich nur solange Pflegen, bis xtra eine kompatible Version veröffentlicht. An der Stelle noch mal Danke für deine Arbeit!

    Hinweis: Eine installiertes tensiderepository muss entweder entfernt oder deaktiviert werden!

    Installation: Genauso wie tensiderepository! Siehe hier. (Bei schritt 3 sollte dann allerdings nusoap nochmals installiert werden)

    Sollten Probleme auftreten, gebt mir bescheid!
    Mfg weke

    Ein Mensch ist immer das Opfer seiner Wahrheiten. (Albert Camus)

  9. #89
    Alter Contao-Hase
    Registriert seit
    20.06.2009.
    Ort
    Graz (Austria)
    Beiträge
    1.149

    Standard

    Hallo,

    ich danke dir, weke.
    Ich hatte diese Erweiterung schon dringenst gebraucht.

    Ich bin nun gespannt, wann xtra eine neue Version veröffentlicht.

    Eigentlich müsste er, wenn ich das so richtig verstanden habe, nichts mehr tun, da ja deine Erweiterung einwandfrei funktioniert. (Wurde soeben getestet).

    Ich bin mal gespannt, ob xtra dieses Projekt abgibt oder ob er an seinem weiter arbeitet.

    Nachtrag:
    Ich habe tensiderepository deinstalliert und dann manuell nusoap installiert. Ich finde es prima, dass die Infos dann weiter da waren, welche Erweiterung man installiert hat.
    Das ist spitze, dass diese INFO weiter hier war, obwohl das tensiderepository deinstalliert wurde.
    Geändert von m-werk (23.09.2010 um 10:51 Uhr) Grund: Nachtrag
    LG, Andi

  10. #90
    Contao-Nutzer
    Registriert seit
    08.01.2010.
    Beiträge
    109

    Standard

    Hallo m-werk,

    Zitat Zitat von m-werk Beitrag anzeigen
    Eigentlich müsste er, wenn ich das so richtig verstanden habe, nichts mehr tun, da ja deine Erweiterung einwandfrei funktioniert. (Wurde soeben getestet).
    Ich würde mich weiterhin freuen, wenn xtra seine Erweiterung an die aktuelle Version anpasst, da sie mehr bietet als die in Contao enthaltene Version.
    Da er jedoch glücklicherweise mehr Arbeit als Zeit hat, habe ich diese interims-Lösung erstellt, bis er in seiner Freizeit eine Aktualisierung fertig gestellt und getestet hat. Meine Erweiterung wird auch nur so lange gepflegt, wie tensiderepository nicht aktualisiert wurde. Es steckt ja auch nahezu keine Eigenleistung drin und baut fast vollständig auf den Arbeiten von Christian Schiffler (xtra) und Peter Koch auf. Meinen Dank an beide!

    Zitat Zitat von m-werk Beitrag anzeigen
    Das ist spitze, dass diese INFO weiter hier war, obwohl das tensiderepository deinstalliert wurde.
    Das liegt nicht an mir, dafür haben xtra und Peter gesorgt. Beide nutzen die selben Tabellen in der DB, wie es auch sein sollte!

    @xtra: Würde mich auch für Vorabtests zur Verfügung stellen, sobald es etwas neues gibt! Einfach PM schicken! Und Danke noch einmal für dein nebenberufliche Engagement!
    Mfg weke

    Ein Mensch ist immer das Opfer seiner Wahrheiten. (Albert Camus)

  11. #91
    Contao-Nutzer
    Registriert seit
    19.04.2010.
    Ort
    Frankfurt
    Beiträge
    19

    Standard

    Danke!

    Funktioniert bei mir prima und anscheinend ohne Probleme!
    Schade, dass es diese Erweiterung nur temporär geben wird, aber sie hilft mir wirklich. Ich brauche eigentlich nicht mehr funktionen, kann jetzt aber wieder beruhigt auf die neue tenside Version warten.

    Danke für deine Zwischenlösung (auch wenn deine Lösung diesen Namen nicht verdient!)

  12. #92
    Contao-Nutzer
    Registriert seit
    01.05.2010.
    Ort
    Hannover
    Beiträge
    31

    Standard Hinweis zur Reihenfolge

    Hallo,

    vielen Dank für die Erstellung der Interimslösung. Voller Freude habe ich mich an die Installation gemacht - zunächst leider ohne Erfolg. Daher ein Hinweis, der für mich so nicht klar war:

    Auf Grund der Probleme, die sich mit 2.9.1 und tensiderepository andeuteten, habe ich zunächst nur auf 2.8.4 nachgezogen.
    Mit der Nachricht zu nusoap war ich nun dabei das ganze auf Contao zu bringen.

    Wenn man allerdings versucht mit 2.8.4 oder älter nusoap zum Laufen zu bringen scheitert man! Erweiterungskatalog hängt sich auf, Erweiterungsverwaltung bleibt leer!

    Somit deutlicher Hinweis: Für nusoap erst auf 2.9. oder jünger bringen und dann tensiderepository gegen nusoap austauschen!

    Ansonsten auch von mir nur DANKE! Es funktioniert wieder...

    Gruß
    Siegel

  13. #93
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.584
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von marsie Beitrag anzeigen
    Wenn man allerdings versucht mit 2.8.4 oder älter nusoap zum Laufen zu bringen scheitert man! Erweiterungskatalog hängt sich auf, Erweiterungsverwaltung bleibt leer!
    Die Erweiterung "nusoap" ist ja auch erst ab Contao 2.9.1 freigegeben!
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  14. #94
    Contao-Nutzer
    Registriert seit
    01.05.2010.
    Ort
    Hannover
    Beiträge
    31

    Lächelndes Gesicht weiß ich...

    ja, schon klar

  15. #95
    Contao-Nutzer
    Registriert seit
    08.01.2010.
    Beiträge
    109

    Standard

    Nachtrag zur Interimslösung NuSOAP!

    Habe mit Build 8 noch einen Fehler in der SoapFault.php korrigiert. Dort hatte ich noch auf die nusoap.php aus der tensiderepository verwiesen.
    Fehler ist wohl nur bei denjenigen aufgetreten, die einen SOAP bedingten Fehler hatten und kein tensiderepository installiert hatten.
    Mfg weke

    Ein Mensch ist immer das Opfer seiner Wahrheiten. (Albert Camus)

  16. #96
    Contao-Nutzer
    Registriert seit
    11.04.2010.
    Beiträge
    64

    Standard

    Funktioniert bestens. Nochmals vielen Danke, weke.

  17. #97
    Contao-Nutzer
    Registriert seit
    14.01.2010.
    Beiträge
    48

    Standard Die Interimslösung NuSOAP läuft nicht.

    Bekomme die Interimslösung NuSOAP nicht zum laufen. Das Problem scheint zu sein, dass der Server meldet:
    Code:
    SOAP extension	 	On
    obwohl dies nicht der Fall ist.

    Jemand eine Idee?

    Der Erweiterungskatalog lässt sich erst gar nicht aufrufen, es erscheinen nur Fehlermeldungen:
    Code:
    Warning: SoapClient::SoapClient() [soapclient.soapclient]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /var/www/www***de/system/modules/nusoap/RepositoryBackendModule.php on line 139
    
    Warning: SoapClient::SoapClient(http://www.contao.org/services/repository.wsdl) [soapclient.soapclient]: failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known in /var/www/www***de/system/modules/nusoap/RepositoryBackendModule.php on line 139
    
    Warning: SoapClient::SoapClient() [soapclient.soapclient]: I/O warning : failed to load external entity "http://www.contao.org/services/repository.wsdl" in /var/www/www***de/system/modules/nusoap/RepositoryBackendModule.php on line 139
    
    Fatal error: Uncaught exception SoapFault with message SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://www.contao.org/services/repository.wsdl' thrown in /var/www/www***de/system/modules/nusoap/RepositoryBackendModule.php on line 139
    Gruß Valentin

    PS: Übrigens, egal ob ich das Modul NuSOAP aktiviere oder deaktiviert, kommt im Erweiterungskatalog die oben gepostete Fehlermeldung.

  18. #98
    Contao-Nutzer
    Registriert seit
    08.01.2010.
    Beiträge
    109

    Standard

    Hallo Valentin,

    wenn der Server die Sagt, das die SOAP Extension aktiviert ist, dann stellt sich meine Erweiterung auf Durchzug, soll heißen, es will dann auch das PHP Modul nutzen.

    Ich habe bei meiner Interimslösung auf das Feature verzichtet, dass in Tensiderepository dafür sorgt, dass das NuSoap-Modul erzwungen werden kann.

    Als Work arround kannst du mal versuchen die Dateien meiner NuSoap Extension manuell zu verändern.
    Suche in der RepositoryManager, RepositoryBackendModule und RepositoryCatalog nach den Funktionsaufrufen extension_loaded('soap') und lösche jeweils das Ausrufezeichen davor. Kommt je Datei einmal vor.
    Damit negierst du die Erkennung des PHP-SOAP-Modules und die "falsche" Servermeldung sollte damit korrigiert werden. Wenn das nicht geht, dann liegt das eher an den anderen Fehlermeldungen.
    Diese sagen, dass du von deinem Server keine Verbindung nach Extern aufbauen kannst. Das ist dann eine Frage der Firewall-Einstellung deines Providers.
    Mfg weke

    Ein Mensch ist immer das Opfer seiner Wahrheiten. (Albert Camus)

  19. #99
    Contao-Nutzer
    Registriert seit
    14.01.2010.
    Beiträge
    48

    Standard

    Okay das Work arround hat schon mal funktioniert. Scheint tatsächlich irgendwie eine "falsche" Meldung des Servers zu sein.

    Die nun auftauchende Fehlermeldung scheint tatsächlich mit dem eigentlichen Problem, das der Server keine externe Verbindung aufbauen kann, zusammenzuhängen:
    Code:
    Fatal error: Uncaught exception SoapFault with message wsdl error: HTTP ERROR: Couldn't open socket connection to server http://www.contao.org/services/repository.wsdl prior to connect(). This is often a problem looking up the host name. thrown in /var/www/www***de/system/modules/nusoap/SoapClient.php on line 77
    Merkwürdig ist ist, dass ich das Problem sowohl auf dem Live-Server als auch auf meinem Localhost habe. Wobei ich zu mindestens bei letzterem die Konfiguration beeinflussen kann.

    Na ja werd' mich mal auf die Suche machen wodurch dieser HTTP ERROR verursacht wird. Gibt es irgendwo ein verständliches HOWTO um SOAP zum Laufen zu bekommen (für ein Debian/Apache-System)?

    Gruß Valentin

    //EDIT//
    Ich habe das Problem, hatte in der localconfig.php noch was für einen Proxy eingetragen... die Variable $GLOBALS['TL_CONFIG']['proxy_url'] war schuld
    Geändert von wittich (23.11.2010 um 20:06 Uhr)

  20. #100
    Contao-Nutzer
    Registriert seit
    02.12.2010.
    Beiträge
    19

    Standard Fehler bei 2.9.2

    Hallo zusammen,

    ich hatte heute Contao auf 2.9.2 aktualisiert und die Datenbank mit dem Installationstool upgedated.

    Anschließend habe nusoap auf 0.2.0 beta1 upgedated.

    Ich kann zwar den Erweiterungskatalog sehen. Sobald ich aber eine Erweiterung auswählen möchte erhalte ich folgenden Fehler:

    USERNAME='XXXXXXX'; if [[ "$USERNAME" =~ ^[a-z0-9][a-z0-9\-]{1,14}[a-z0-9]$ ]]; then CGI=(/usr/share/bin/php-cgi -n -c /etc/square7/ -d memory_limit=64M -d max_execution_time=12 -d max_input_time=20 -d open_basedir="/users/${USERNAME}/temp:/users/${USERNAME}/www" -d upload_tmp_dir="/users/${USERNAME}/temp" -d session.save_path="/users/${USERNAME}/temp" -d sendmail_path="/usr/sbin/sendmail -t -i -fno-reply_${USERNAME}_report-spam-to@square7.ch -F Square7.ch" ) else exit; fi unset PWD USERNAME SHLVL exec -c "${CGI[@]}"

    XXXXXX habe ich ersetzt.

    Bis gestern ging es die Erweiterungen zu installieren.

  21. #101
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.584
    User beschenken
    Wunschliste

    Standard

    Hallo Broichi,

    willkommen in der Contao-Community.

    Du solltest diesbezüglich in den Foren Deines Hosters suchen, denn dort wurde das schon einige Male zur Sprache gebracht.

    Wahrscheinlich wurde Dir jetzt die für diesen Hoster notwendige Anpassung durch das Update überschrieben.
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  22. #102
    Contao-Nutzer
    Registriert seit
    02.12.2010.
    Beiträge
    19

    Standard Vielen Dank

    @xchs,

    Vielen Dank für Deine schnelle Hilfe. Ich wollte schon alles wieder neu Installieren und aufbauen.

    Du hast recht.
    square7 und die komischen Einstellungen (ich wünsche es gäbe einen besseren free webspace).

    Für alle die es interessiert.
    in der Main.php muss folgendes nach "require_once('../system/initialize.php');" eingetragen werden.

    $_SERVER['ORIG_SCRIPT_NAME'] = $_SERVER['SCRIPT_NAME'];

    dann klappt es auch mit square7

Seite 3 von 3 ErsteErste 123

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. Nusoap - Installationsproblem
    Von varix im Forum Sonstige Erweiterungen
    Antworten: 11
    Letzter Beitrag: 20.09.2012, 15:32
  2. Antworten: 11
    Letzter Beitrag: 27.02.2011, 21:52
  3. Antworten: 5
    Letzter Beitrag: 11.10.2010, 12:27
  4. Erweiterungsverwaltung auch ohne SOAP ?
    Von hkunslg38 im Forum Entwickler-Fragen
    Antworten: 8
    Letzter Beitrag: 19.04.2010, 20:04
  5. Kalender Design / Reservierungsplan (ohne "SOAP"!!!)
    Von mane im Forum Nachrichten/Events/FAQ
    Antworten: 8
    Letzter Beitrag: 09.04.2010, 13:05

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •