Ergebnis 1 bis 7 von 7

Thema: Slash im Tag funktioniert nicht!

  1. #1
    Contao-Nutzer Avatar von Der Astronaut
    Registriert seit
    20.07.2012.
    Ort
    Weltall
    Beiträge
    213

    Standard Slash im Tag funktioniert nicht!

    Hallo zusammen,

    für eine meiner Seiten ist es erforderlich, dass manche Tags ein Slash, also ein / beinhalten müssen, weil es die Schreibweise so verlangt, z.b. HSG Rösrath/Forsbach.

    Wenn ich nun aber dieses Tag anklicke, erhalte ich nur eine weiße Seite. Dass der Schrägstrich das Tag-System bzw. Contao in die Bredouille bringt, kann ich nachvollziehen, da Contao denkt, es handle sich um ein weiteres URL-Fragment. Glaube ich zumindest

    Ist dem so, dann ist es wohl schlicht weg nicht möglich, überhaupt Slashs in Tags zu benutzen, die bei Klick auch entsprechende Artikel ausgeben, oder?

    Da ich kein Entwickler bin, fehlt mir da leider die Weitsicht, ob es nicht vielleicht doch eine Lösung für das Problem gibt. Bitte jetzt nicht mit "dann schreibe eben kein Slash" kommen. Auf die Idee bin ich auch schon gekommen, entspricht allerdings nicht mancher Schreibweisen in der Handball-Welt. Denn: Aus "HSG Rösrath/Forsbach" jetzt "HSG Rösrath-Forsbach" zu machen, wäre schlicht weg falsch, da es zwei verschiedene Orte sind, die lediglich im Handball fusionieren und kein Mensch würde es mit Bindestrich schreiben (und was ggf. in unserer Suchfunktion nicht mehr gefunden wird).

    Also... sieht irgendjemand eine Möglichkeit Slashs funktionierend in Tags zu integrieren?

    Danke schon mal für's Lesen und für eure Antworten

  2. #2
    Contao-Urgestein
    Registriert seit
    07.04.2010.
    Ort
    Stuttgart
    Beiträge
    2.733
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Der Astronaut Beitrag anzeigen
    Ist dem so, dann ist es wohl schlicht weg nicht möglich, überhaupt Slashs in Tags zu benutzen, die bei Klick auch entsprechende Artikel ausgeben, oder?
    Ich hatte das mal für eine private Seite "Quick and dirty" gelöst. Habe die Tags immer mit "_" benannt da wo ein Slash hinsollte.
    Dann habe ich nur bei der Frontendausgabe im Template ein str_replace gemacht.

    Wie gesagt... "Quick and dirty".

    Wenn ich euch helfen konnte könnt ihr euch gerne mal
    meine Amazon Wunschliste anschauen. Dankeschön.

  3. #3
    Contao-Urgestein
    Registriert seit
    30.01.2011.
    Ort
    Stuttgart
    Beiträge
    4.024

    Standard

    müsste mit
    HTML-Code:
    /
    auch gehen... zumindest kann ich das so als Seite anlegen...

  4. #4
    Contao-Nutzer Avatar von Der Astronaut
    Registriert seit
    20.07.2012.
    Ort
    Weltall
    Beiträge
    213

    Standard

    Zitat Zitat von psren Beitrag anzeigen
    Ich hatte das mal für eine private Seite "Quick and dirty" gelöst. Habe die Tags immer mit "_" benannt da wo ein Slash hinsollte.
    Dann habe ich nur bei der Frontendausgabe im Template ein str_replace gemacht.

    Wie gesagt... "Quick and dirty".
    Danke für den Tip! So habe ich es jetzt auch gemacht. Ist zwar wirklich etwas dirty, da wir jetzt statt 2013/2014 nun 2013_2014 schreiben müssen, aber immer noch besser als ein toter Link

  5. #5
    Contao-Nutzer Avatar von Der Astronaut
    Registriert seit
    20.07.2012.
    Ort
    Weltall
    Beiträge
    213

    Standard

    Zitat Zitat von magicsepp Beitrag anzeigen
    müsste mit
    HTML-Code:
    /
    auch gehen... zumindest kann ich das so als Seite anlegen...
    Habe ich probiert. Contao wandelt das jedoch in ein Slash um. So besteht das Problem dann immer noch/wieder.

  6. #6
    Contao-Nutzer
    Registriert seit
    10.02.2012.
    Ort
    Basel
    Beiträge
    209
    Partner-ID
    8602

    Standard Problem besteht weiterhin

    Das Problem besteht weiterhin.

    Es existiert jetzt ein Ticket.

  7. #7
    Contao-Nutzer Avatar von Der Astronaut
    Registriert seit
    20.07.2012.
    Ort
    Weltall
    Beiträge
    213

    Standard

    Wird die Erweiterung überhaupt noch betreut? Dein Ticket ist vom 25. Juli und bisher kein Lebenszeichen vom Autor.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •