MetaModels Workshop in Berlin
Ergebnis 1 bis 18 von 18

Thema: Kompatible Hoster

  1. #1
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    6.412
    Partner-ID
    152
    User beschenken
    Wunschliste

    Standard Kompatible Hoster

    Wir pflegen eine (zur Zeit noch recht kurze) Liste der kompatiblen Hostings, der Webhostings, bei denen Composer Probleme macht und derer, bei denen eine Nutzung nach unserer Erfahrung nicht möglich ist.

    Du findest die Liste unter http://de.contaowiki.org/Composer/Ho...ible_Webhoster.

    Bitte erweitere die Liste um eigene Erfahrungen. Vielen Dank.

  2. #2
    Contao-Nutzer
    Registriert seit
    19.06.2009.
    Beiträge
    92

    Standard Composer für die Hosterliste

    Hab das auf einer Projektseite versehentlich installiert, nach der berüchtigten „weißen Seite“ wieder zum laufen gebracht und mich jetzt entschlossen, das als Testprojekt für den Composer weiter zu betreiben. Allerdings kann ich die Infos auf der Webhosterliste nicht aktualisieren...
    Hab ich da nur was nicht richtig verstanden, oder fehlen mir einfach nur die Berechtigungen dazu?

    Gruß von der Pipi

  3. #3
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    6.412
    Partner-ID
    152
    User beschenken
    Wunschliste

    Standard

    Bearbeitung im Wiki geht nach individueller Anmeldung. So halten wir die Spambots draußen. Schreib mir eine Mail und ich schalte Dock gern frei.


    Sent from my iPhone using Tapatalk

  4. #4
    Contao-Fan
    Registriert seit
    05.11.2009.
    Ort
    Liebschützberg (Sachsen)
    Beiträge
    442

    Standard

    Hallo Lucina bitte mal die Liste vervollständigen:

    Kompatibel: GreatNet.de Webspace SMART

    Nicht Kompatibel: INetRobots das altes Webpaket Home

    Steffen Winde

  5. #5
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    6.412
    Partner-ID
    152
    User beschenken
    Wunschliste

    Standard

    Siehe mein vorheriges Posting.

  6. #6
    Contao-Urgestein Avatar von zonky
    Registriert seit
    19.03.2010.
    Ort
    Berlin, Rdf
    Beiträge
    6.164
    User beschenken
    Wunschliste

    Standard

    "nette Liste" - aber ohne Angabe des Zeitpunktes des Eintrages und des zur Verfügung stehenden RAM, ist das leider nicht mal ein Anhaltspunkt für eine Entscheidung :-(

  7. #7
    Contao-Nutzer Avatar von din_SH
    Registriert seit
    31.05.2016.
    Ort
    HRO
    Beiträge
    1

    Frage Composer = in Abhängigkeit zu Cron-Jobs?

    Hallo zusammen

    könnte es ggf. sein, dass ein Anhaltspunkt bei der allgemeinen Suche nach einem passenden Hoster die Unterstützung von Cron-Jobs is?
    @ Wiki Infos
    Beispiel Info von cliffen = Strato: PowerWeb Plus = Cron-Jobs
    Beispiel Info von Andreas = Webgo: Starter = Cronjobs Light

    Klar gibt es natürlich weitere Faktoren, aber seht Ihr hier ggf. eine mögliche ich nenne es mal "Einstiegsabhängigkeit"?
    Gemessen an den Mageren Detail-Infos zu Paketen, sind diese zu mindest angegeben.
    Geändert von din_SH (16.12.2016 um 11:06 Uhr)

  8. #8
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.889
    User beschenken
    Wunschliste

    Standard

    Ich würde eher einen Shell-Zugang (SSH) als allererstes Indiz nehmen. Mehr ist das aber auch nicht. Weder Cron-Job noch Shell-Zugang nutzt dir irgendwas, wenn das RAM oder die maximale Skriptlaufzeit zu gering ist. Oder auch wenn z.B. allow_url_fopen nicht einschaltbar ist.

  9. #9
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.032
    Partner-ID
    7421

    Standard

    Nicht zu vergessen, dass die Liste zumindestens begonnen worden ist vor dem letzten großen Zuwachs an Ressourcenhungrigkeit und das die einzelnen Erweiterungen unterschiedlich viel RAM veim Prüfen der Abhängigkeit benötigen.
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  10. #10
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.889
    User beschenken
    Wunschliste

    Standard

    Tja, gestern auf uberspace unter 3.5.19 mit Composer contao-bootstrap installiert. Mit den Default-Einstellungen ging das bundle schon mal nicht -> memory_limit 1GB reicht dafür nicht mehr. Erst nachdem ich dann die minimale Stabilität auf Alpha-Versionen gesetzt habe lief es dann durch. Da frage ich mich langsam schon, wie das weitergehen soll, wenn ich selbst auf uberspace schon solche Probleme bekomme. Die meisten Seiten die ich so mache sind eher klein bis mittelgroß, denen kann ich keinen Server verkaufen. Wahrscheinlich werde ich über kurz oder lang alles nur noch lokal machen, was aber einen beträchtlichen Teil des Charmes von Contao für mich zunichte macht. Da muss ich mir ein neues Notebook kaufen, sonst kann ich vor Ort beim Kunden keine Erweiterung mehr installieren oder updaten. Auch wenn ein Update im Büro problemlos geht auf dem Desktop-Rechner, da bin ich ja sogar mit einem auf dem Notebook installierten Website-Generatorprogramm schon fast flexibler .

  11. #11
    Administrator Avatar von hofff
    Registriert seit
    02.06.2011.
    Beiträge
    840
    User beschenken
    Wunschliste

    Standard

    Wenn die Composer Cloud fertig ist, gehören diese Probleme der Vergangenheit an! ;-)

    fg
    nicky
    ... alles wird besser!

    Präsident der Contao Association Website/Github | Mitglied der Contao Community Alliance Website/Github

    individuelle Webanwendungen, Erweiterungen und noch viel mehr ... www.hofff.com/Github

  12. #12
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.032
    Partner-ID
    7421

    Standard

    Auf dem Camp in Nürnberg stellte jemand in den Raum, ob es wirklich notwendig ist die Kompatibilität zu älteren Symfony-Versionen weiter aufrecht zu erhalten. Dann würde sich die Zahl der Abhängigkeiten auch verringern. Ich weiss nicht ob in diese Richtung weiter gedacht wird - bin ja kein Entwickler bemühe mich nur darum das alles zu verstehen.
    Lokal entwickle ich ohnehin - das allein schreckt mich also nicht. Eher der Umstand den @xtra noch mal ausführlich erklärt hat - auch die PHP-Version hat für die Abhängigkeiten eine Bedeutung (oder kann das zumindesten haben). Das ist dann mindestens eine zusätzliche Fehlerquelle.
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  13. #13
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.032
    Partner-ID
    7421

    Standard

    Zitat Zitat von hofff Beitrag anzeigen
    Wenn die Composer Cloud fertig ist, gehören diese Probleme der Vergangenheit an! ;-)
    Kannst Du etwas genaueres sagen? Hatte ja da auch schon über mehrere Überlegungen, für und wieder, Schwierigkeiten und natürlich auch anfallende Kosten gehört.
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  14. #14
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.889
    User beschenken
    Wunschliste

    Standard

    Dein Wort in Gottes Ohr. Ich habe da noch so meine Zweifel, wie das dann da kapazitäts- und kostenmäßig ausgeht. Übrigens: Es gibt schon längst ComposerClouds!
    Composercloud

  15. #15
    Administrator Avatar von hofff
    Registriert seit
    02.06.2011.
    Beiträge
    840
    User beschenken
    Wunschliste

    Standard

    Es liegt nicht nur an Symfony ... je nachdem, welche Erweiterung man installieren möchte, kann diese weitere Abhängigkeiten mit sich bringen. Diese Abhängigkeiten bringen wiederum weitere Abhängigkeiten mit und diese können auch noch ... naja ... usw.

    Alle Abhängigkeiten werden dann gegeneinander aufgelöst und es wird geprüft, ob sie nach den übermittelten und von den Entwicklern gegebenen Anforderungen zusammen passen/kompatibel sind. Und das braucht halt Zeit und Speicher. Manchmal kann es eine riesengroße Erweiterung sein und manchmal können es viele kleine sein, die den RAM in Anspruch nehmen.

    fg
    nicky


    Gesendet von iPad mit Tapatalk Pro
    ... alles wird besser!

    Präsident der Contao Association Website/Github | Mitglied der Contao Community Alliance Website/Github

    individuelle Webanwendungen, Erweiterungen und noch viel mehr ... www.hofff.com/Github

  16. #16
    Administrator Avatar von hofff
    Registriert seit
    02.06.2011.
    Beiträge
    840
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von mlweb Beitrag anzeigen
    Kannst Du etwas genaueres sagen? Hatte ja da auch schon über mehrere Überlegungen, für und wieder, Schwierigkeiten und natürlich auch anfallende Kosten gehört.
    Aktuell läuft ein geschlossener Beta-Test an dem ausgewählte Anwender teilnehmen. Es gibt noch ein paar Restriktionen (z.B. bei privaten/lokalen Repos), aber die Grundfunktionalität läuft schon sehr gut. Ich habe es bei mir auf 2 Installationen ausprobiert und war sehr zufrieden. Ich habe dabei eine 1und1 Installation ausprobiert, wo ich es einfach nicht geschafft habe, den Composer am Memory-Limit vorbei zu bekommen, aber mit der Cloud hat es geklappt - mit Avisota, MetaModels und ca. 20 weiteren installierten Erweiterungen. Ich bin deshalb sehr zuversichtlich - eine super Arbeit, die @Toflar bisher gemacht hat.

    Über Kosten haben wir aktuell noch keine verwertbaren Informationen, da es einfach von der Menge abhängig ist.

    Ich könnte mir aber folgendes Vorstellen: wenn wir die Mitgliederanzahl in der Association verdoppeln/verdreifachen könnten, dann könnten wir die Cloud wahrscheinlich für alle kostenlos anbieten. ;-)

    fg
    nicky


    Gesendet von iPad mit Tapatalk Pro
    ... alles wird besser!

    Präsident der Contao Association Website/Github | Mitglied der Contao Community Alliance Website/Github

    individuelle Webanwendungen, Erweiterungen und noch viel mehr ... www.hofff.com/Github

  17. #17
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.032
    Partner-ID
    7421

    Standard

    Zitat Zitat von hofff Beitrag anzeigen
    Es liegt nicht nur an Symfony ... je nachdem, welche Erweiterung man installieren möchte, kann diese weitere Abhängigkeiten mit sich bringen. Diese Abhängigkeiten bringen wiederum weitere Abhängigkeiten mit und diese können auch noch ... naja ... usw.
    Ich weiß, hatte aber zumindesten geglaubt verstanden zu haben, dass die neue Symfony-Version die Anzahl der zu überprüfenden Abhängigkeiten weiter erhöht hat und man das verringern könnte wenn man nur auf die aktuelle Symfony-Version prüft.
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  18. #18
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.032
    Partner-ID
    7421

    Standard

    Zitat Zitat von hofff Beitrag anzeigen

    Ich könnte mir aber folgendes Vorstellen: wenn wir die Mitgliederanzahl in der Association verdoppeln/verdreifachen könnten, dann könnten wir die Cloud wahrscheinlich für alle kostenlos anbieten. ;-)
    Wink verstanden und das gemacht was ich eigentlich schon beim Camp vorhatte. Ihr habt ein neues Mitglied.
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •