Contao Konferenz 2019 in Duisburg - Call for Papers
Ergebnis 1 bis 2 von 2

Thema: PHP-Version in DomainFactory-"Auftragcenter" korrekt einstellen !

  1. #1
    Contao-Nutzer
    Registriert seit
    25.02.2015.
    Beiträge
    3

    Standard PHP-Version in DomainFactory-"Auftragcenter" korrekt einstellen !

    Wenn man eine Domain zu DomainFactory überträgt, dann wird die PHP-Version auf „siehe Auftrag“ gesetzt. In meinem Fall war das PHP 5.0.

    Das passte aber nicht zu den Anforderungen von Contao, und führt zu der folgenden Fehlermeldung

    Warning: require(__DIR__/system/initialize.php) [function.require]: failed to open stream: No such file or directory in /kunden/422846_41189/webseiten/index.php on line 16

    Fatal error: require() [function.require]: Failed opening required '__DIR__/system/initialize.php' (include_path='.:/usr/local/lib/php') in /kunden/422846_41189/webseiten/index.php on line 16

    Um das zu vermeiden, sollte man die PHP-Version für den genannten Webspace editieren. Unter "Für Profis" im Menü "PHP-Einstellungen" mit dem Button "PHP-Verson editieren" gelingt dies ganz schnell.

    Viel Erfolg!

  2. #2
    Contao-Urgestein Avatar von the_scrat
    Registriert seit
    24.02.2010.
    Ort
    Augsburg
    Beiträge
    2.036
    User beschenken
    Wunschliste

    Standard

    Du kannst alternativ auch einfach in deiner .htaccess Datei folgende Zeile hinzufügen:

    AddTypeapplication/x-httpd-php56 .php
    Programmers don't comment their code. It was hard to write, it should be hard to understand...

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •