Contao Konferenz & College 2019 in Duisburg - JETZT TICKET SICHERN!
Ergebnis 1 bis 6 von 6

Thema: Bilder funktionieren nicht. Weiße Seite nach Bild speichern

  1. #1
    Contao-Nutzer
    Registriert seit
    23.05.2012.
    Beiträge
    52

    Standard Bilder funktionieren nicht. Weiße Seite nach Bild speichern

    Hallo,

    der dma_elementgenerator ist an sich eine fantastische Idee und genau das, was ich gerade brauche. Leider verzweifle ich auch gerade völlig daran.

    Mit einfachen Textfeldern funktioniert er auch. Allerdings, sobald ich irgendwas mit Bildern machen möchte, geht nix mehr.

    Genauer beschrieben:
    Ich kann unter „Elementgenerator“ ein Element im BE anlegen (in meinem Fall als Inhaltselement). Füge ein Bild als „Feld“ hinzu und gehe dann in den Artikel einer Seite. Dort füge ich nun mein eigenes Inhaltselement ein und möchte dann im Bildfeld ein Bild auswählen. Auch das klappt und ich wähle mein Bild aus. Wenn ich jetzt aber das Element speichern möchte, kommt immer nur eine weiße Seite. Bei Textelementen funktioniert es wie gesagt.

    Schalte ich in Contao das Error-Log ein, sagt mir das auf der weißen Seite nach dem Speichern:
    Code:
    Fatal error: Cannot use 'String' as class name as it is reserved in /Users/Markus/Dropbox/testseite/system/modules/core/library/Contao/String.php on line 28
    Folgendes habe ich schon probiert:
    – eine komplett frische Installation von Contao 3.5.6 mit nur dem nötigsten angelegt, um eine Seite zum Testen zu haben
    – dma_elementgenerator in neuester Version von Github geladen und manuell in den system>modules Ordner gelegt (nicht den gesamten Github-Download, sondern den Ordner „dma_elementgenerator“).
    – Dann habe ich im Install-Tool noch mal die Datenbank aktualisiert und nochmal ein Test-Element mit Bild angelegt. Wieder das gleiche.

    Was mache ich falsch? Ich denke mal, wenn das generell nicht ginge, würden hier viel mehr Fehlermeldungen aufschlagen. Also hoffe ich mal, ich mache irgendeine dumme Kleinigkeit falsch?!

    Für einen Hinweis wäre ich sehr dankbar!

    Viele Grüße
    Markus

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Auf deinem Webserver läuft anscheinend PHP 7, es sind aber nicht alle Extensions damit kompatibel. Entweder stelle die PHP Version zurück oder deaktiviere alle Extensions (führe Contao im coreOnlyMode aus) und identifiziere die Extension, die das Problem verursacht.

  3. #3
    Contao-Nutzer
    Registriert seit
    23.05.2012.
    Beiträge
    52

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Auf deinem Webserver läuft anscheinend PHP 7 […] Entweder stelle die PHP Version zurück
    Vielen Dank. Das funktioniert auf jeden Fall schonmal. Zumindest in meiner lokalen Entwicklungs-Umgebung. Ich hoffe nur, ich kann die PHP-Version auf dem Server später beeinflussen.

    Zitat Zitat von Spooky Beitrag anzeigen
    …es sind aber nicht alle Extensions damit kompatibel. […] oder deaktiviere alle Extensions (führe Contao im coreOnlyMode aus) und identifiziere die Extension, die das Problem verursacht.
    Meinst Du mit Extensions das, was man in den Contao-Einstellungen auch deaktivieren kann, wenn nicht benötigt? Also Kalender, Nachrichten, Kommentare etc?
    Habe ich mal in der Test-Installation gemacht, aber was bringt mir das? Die Standard Installation von Contao 3.5.6 läuft ohne Probleme. Und mehr Extensions als den DMA_Elementgenerator habe ich in der Testumgebung gar nicht laufen.

    Wird es vielleicht mal ein Update geben, dass ihn zu Contao 3.5.6 kompatibel macht oder ist der Zug abgefahren? Mit Contao 4 komme ich leider gar nicht klar und überlege schon schweren Herzens das CMS zu wechseln…

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Markus1982 Beitrag anzeigen
    Ich hoffe nur, ich kann die PHP-Version auf dem Server später beeinflussen.
    Es wird vermutlich kaum irgendwo einen Hoster geben, der dir schon jetzt PHP 7 aufzwingt.


    Zitat Zitat von Markus1982 Beitrag anzeigen
    Meinst Du mit Extensions das, was man in den Contao-Einstellungen auch deaktivieren kann, wenn nicht benötigt? Also Kalender, Nachrichten, Kommentare etc?
    Ja, genau.


    Zitat Zitat von Markus1982 Beitrag anzeigen
    Habe ich mal in der Test-Installation gemacht, aber was bringt mir das? Die Standard Installation von Contao 3.5.6 läuft ohne Probleme.
    Wie ich schon erwähnt habe ist eine Extension das Problem, nicht Contao.


    Zitat Zitat von Markus1982 Beitrag anzeigen
    Und mehr Extensions als den DMA_Elementgenerator habe ich in der Testumgebung gar nicht laufen.
    DMA_Elementgenerator ist auf jeden Fall noch nicht mit PHP 7 kompatibel, da diese Extension noch die alte String Klasse benutzt.


    Zitat Zitat von Markus1982 Beitrag anzeigen
    Wird es vielleicht mal ein Update geben, dass ihn zu Contao 3.5.6 kompatibel macht oder ist der Zug abgefahren?
    Das kann ich dir nicht sagen, ich habe dazu hier zumindest mal ein Ticket angelegt: https://github.com/DMAGmbH/dma_eleme...ator/issues/99

  5. #5
    Contao-Nutzer
    Registriert seit
    23.05.2012.
    Beiträge
    52

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Es wird vermutlich kaum irgendwo einen Hoster geben, der dir schon jetzt PHP 7 aufzwingt.
    Danke für den Hinweis. Ich mache halt nur Frontend. HTML/CSS kann ich wirklich gut. Javascript auch noch okay. Aber bei PHP und Datenbanken reicht es gerade sich die Templates etwas zurecht zu rücken. (Daher auch mein Problem mit Contao 4…)

    Zitat Zitat von Spooky Beitrag anzeigen
    Das kann ich dir nicht sagen, ich habe dazu hier zumindest mal ein Ticket angelegt: https://github.com/DMAGmbH/dma_eleme...ator/issues/99
    Vielen Dank. Schön wär’s, wenn sowas großartiges und nützliches wie der Elementgenerator kompatibel blieben.

    Vielen Dank für Deine Hilfe noch mal.

  6. #6
    Contao-Fan Avatar von JanoschSkuplik
    Registriert seit
    13.08.2009.
    Ort
    Raesfeld
    Beiträge
    535
    Partner-ID
    6909
    User beschenken
    Wunschliste

    Standard

    @all: Ein Update für die aktuelle Contao-Version (inkl. Entfernung der Altlasten) ist aktuell in Arbeit. Damit wird dann auch die Kompatibilität zu PHP 7 integriert sein. Ich denke, dass wir diese Woche noch zum internen Testen benötigen, anschließend das ganze aber auch gerne durch andere User getestet werden kann.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •