Contao Konferenz & College 2019 in Duisburg - JETZT TICKET SICHERN!
Ergebnis 1 bis 29 von 29

Thema: Bitte um Hilfe beim Composer-Update

  1. #1
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard Bitte um Hilfe beim Composer-Update

    Hallo zusammen,
    ich verzweifle (wieder mal) am Composer. Kann mir jemand weiterhelfen? Es sollte ja möglich sein, denn meine Webseiten laufen fast ausschließlich bei dem von lucina in diesem Thread erwähnten Feld-, Wald- und Wiesenhoster Domainfactory:

    Zitat Zitat von lucina
    Ich versteh's immer noch nicht - die 80% meiner betreuten Webseiten laufen 1a rauf mit Sternchen im zweitgünstigsten Paket des Feld-Wald-und Wiesen-Hosters Domainfactory. Mit Composer. Mit 128 MB RAM.
    Nun möchte ich eine Website updaten, folgende Eckdaten:
    - Contao 3.5.2
    - composer-client 0.15.2
    - composer-plugin 2.3.5

    Composer Einstellungen:
    Minimale Stabilität: stabil (stabil bevorzugen ist angehakt)
    Bevorzugte Installationsart: Distributionsarchiv
    Änderungen verwerfen: lokale Änderungen behalten (Update anhalten)

    Systemeinstellungen:
    Composer Bibliothek automatisch aktualisieren ist aktiviert
    Ausführungsmodus: als eigenständiger Prozess
    PHP-Pfad/Befehl: php5.6.12-cli -d memory_limit=1G -d max_execution_time=900
    Enable profiling: nicht aktiviert
    Ausführlichkeit der Protokollierung: Standard Ausführlichkeit

    Also erst mal den Composer bzw. das Composer-Plugin updaten, dazu die aktuellen Pakete rausgesucht:
    composer_update.JPG

    Nach dem Klick auf "Pakete aktualisieren" erhalte ich folgende Meldungen:
    Code:
    $ php5.6.12-cli -d memory_limit=1G -d max_execution_time=900 composer.phar update --no-ansi --no-interaction
    Zend Optimizer requires Zend Engine API version 220060519.
    The Zend Engine API version 220131226 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.
    
    Deprecation Notice: The Composer\Package\LinkConstraint\EmptyConstraint class is deprecated, use Composer\Semver\Constraint\EmptyConstraint instead. in phar:///.../composer/composer.phar/src/Composer/Package/LinkConstraint/EmptyConstraint.php:17
    Deprecation Notice: The Composer\Package\LinkConstraint\LinkConstraintInterface interface is deprecated, use Composer\Semver\Constraint\ConstraintInterface instead. in phar:///.../composer/composer.phar/src/Composer/Package/LinkConstraint/LinkConstraintInterface.php:17
    Deprecation Notice: The Composer\Package\LinkConstraint\VersionConstraint class is deprecated, use Composer\Semver\Constraint\Constraint instead. in phar:///.../composer/composer.phar/src/Composer/Package/LinkConstraint/VersionConstraint.php:17
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - contao-community-alliance/composer-client 0.16.x-dev requires contao-community-alliance/composer-plugin ^2.3.8 -> satisfiable by contao-community-alliance/composer-plugin[2.3.8, 2.4.0, 2.4.1, 2.4.2, 2.4.3] but these conflict with your requirements or minimum-stability.
        - contao-community-alliance/composer-client 0.16.4 requires contao-community-alliance/composer-plugin ^2.3.8 -> satisfiable by contao-community-alliance/composer-plugin[2.3.8, 2.4.0, 2.4.1, 2.4.2, 2.4.3] but these conflict with your requirements or minimum-stability.
        - Installation request for contao-community-alliance/composer-client >=0.16.4.0,<0.17-dev -> satisfiable by contao-community-alliance/composer-client[0.16.4, 0.16.x-dev].
    Yeah. Wenn ich nun aber bei "Minimale Stabilität" die "Entwicklerversion" auswähle, dann ist wieder nicht mehr genug Speicher vorhanden.

    Ich habe versucht, mich durch sämtliche Threads zum Thema durchzulesen, das endet aber immer irgendwie im geistigen Nirvana.
    Wie muss ich denn hier vorgehen, damit ich aus dieser Endlosschleife rauskomme?
    Geändert von bibib (20.09.2016 um 13:16 Uhr)

  2. #2
    Contao-Urgestein Avatar von Kahmoon
    Registriert seit
    22.06.2009.
    Ort
    München
    Beiträge
    4.172

    Standard

    Kleiner Trick der mir bei 1und1 immer hilft.

    Domain auf PHP 7 stellen, Composer und Erweiterungen updaten, zurück auf die PHP Version davor stellen (z.B. 5.6). Dann bekomme ich keine Speicherfehler.

    Vielleicht klappt das dort auch.

  3. #3
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Zitat Zitat von Kahmoon Beitrag anzeigen
    Domain auf PHP 7 stellen, Composer und Erweiterungen updaten, zurück auf die PHP Version davor stellen (z.B. 5.6). Dann bekomme ich keine Speicherfehler.
    Danke, soeben probiert, aber wenn ich auf PHP 7 umstelle, kommt das:
    Code:
    Fatal error: Uncaught TypeError: Argument 1 passed to __exception() must be an instance of Exception, instance of Error given in /.../system/helper/functions.php:87 Stack trace: #0 [internal function]: __exception(Object(Error)) #1 {main} thrown in /.../system/helper/functions.php on line 87

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Um PHP 7 verwenden zu können brauchst du mindestens Contao 3.5.5.

  5. #5
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Außerdem, dein Problem ist ganz ein anderes. Poste mal deine composer.json.

  6. #6
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Außerdem, dein Problem ist ganz ein anderes. Poste mal deine composer.json.
    Du meinst das hier?

    Code:
    {
        "name": "local/website",
        "description": "A local website project",
        "type": "project",
        "license": "proprietary",
        "require": {
            "contao-community-alliance/composer-client": ">=0.16.4.0,<0.17-dev",
            "contao-community-alliance/composer-plugin": ">=3.0.3.0,<3.1-dev",
            "contao-legacy/ace_extended": ">=1.0.0.6004-RC,<1.1-dev@RC",
            "contao-legacy/backupdb": ">=3.2.1.9009,<3.3-dev",
            "contao-legacy/ce_be_remarks": ">=3.0.0.9018,<3.1-dev",
            "contao-legacy/dma_elementgenerator": ">=1.0.0.9004,<1.1-dev",
            "contao-legacy/efg": ">=2.2.1.9005,<2.3-dev",
            "contao-legacy/registration_extended": ">=1.0.0.3027-beta,<1.1-dev@beta",
            "dklemmt/contao_dk_mmenu": ">=1.5.1.0,<1.6-dev",
            "felixpfeiffer/subcolumns": ">=3.1.3.0,<3.2-dev",
            "jrgregory/m17-sticky-backend-footer": ">=2.0.4.0,<2.1-dev",
            "madeyourday/contao-rocksolid-antispam": ">=1.0.1.0,<1.1-dev",
            "madeyourday/contao-rocksolid-frontend-helper": ">=1.1.1.0,<1.2-dev",
            "madeyourday/contao-rocksolid-slider": ">=1.4.1.0,<1.5-dev",
            "psi/ce_groups": ">=1.1.1.0,<1.2-dev",
            "terminal42/contao-ce-access": ">=2.0.2.0,<2.1-dev",
            "terminal42/contao-easy_themes": ">=2.1.2.0,<2.2-dev"
        },
        "prefer-stable": true,
        "minimum-stability": "stable",
        "config": {
            "preferred-install": "dist",
            "cache-dir": "cache",
            "component-dir": "../assets/components"
        },
        "repositories": [
            {
                "type": "composer",
                "url": "https://legacy-packages-via.contao-community-alliance.org/"
            },
            {
                "type": "artifact",
                "url": "packages"
            }
        ],
        "extra": {
            "contao": {
                "migrated": "done"
            }
        }
    }

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Lösche diesen Eintrag:
    Code:
            "contao-community-alliance/composer-plugin": ">=3.0.3.0,<3.1-dev",

  8. #8
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Ich fass es nicht. Das war alles??
    Scheint geklappt zu haben, vielen vielen Dank!

    Ich habe übrigens noch einen Fall mit gleicher Fehlermeldung. Hier kann ich aber kein Plugin aus der composer.json rauslöschen. Kannst du da erkennen, was falsch läuft?

    Code:
    {
        "name": "local/website",
        "description": "A local website project",
        "type": "project",
        "license": "proprietary",
        "require": {
            "contao-community-alliance/composer": ">=0.13.2.0,<0.14-dev",
            "contao-legacy/ace_extended": ">=1.0.0.6004-RC,<1.1-dev@RC",
            "jrgregory/m17-sticky-backend-footer": ">=2.0.5.0,<2.1-dev",
            "menatwork/synccto": ">=3.0.2.0,<3.1-dev",
            "psi/lightbox4ward": ">=3.0.1.0,<3.1-dev",
            "psi/news4ward": ">=2.2.3.0,<2.3-dev",
            "psi/news4ward_tags": ">=2.1.1.0,<2.2-dev",
            "terminal42/contao-ce-access": ">=2.0.2.0,<2.1-dev",
            "terminal42/contao-easy_themes": ">=2.1.3.0,<2.2-dev"
        },
        "prefer-stable": true,
        "minimum-stability": "dev",
        "config": {
            "preferred-install": "dist",
            "cache-dir": "cache",
            "component-dir": "../assets/components"
        },
        "repositories": [],
        "extra": {
            "contao": {
                "migrated": "done"
            }
        }
    }

  9. #9
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Ersetze
    Code:
            "contao-community-alliance/composer": ">=0.13.2.0,<0.14-dev",
    mit
    Code:
            "contao-community-alliance/composer-client": "~0.16",

  10. #10
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    DANKE, gerettet, made my day!

  11. #11
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Kein Problem

  12. #12
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Guten Morgen,
    ich stehe wieder mal vor einem Composer-Update.
    Bis jetzt hab ich folgendes gemacht:
    - in der Systemwartung alle Daten bereinigt
    - Contao 3.3.5 mit Live-Update auf Contao 3.5.17 aktualisiert (was neueres wurde mir nicht angeboten)

    Beim Klick auf die Paketverwaltung bekomme ich die Meldung
    Deprecated notice: The Composer\Package\LinkConstraint\VersionConstraint class is deprecated, use Composer\Semver\Constraint\Constraint instead. in phar://composer/composer.phar/src/Composer/Package/LinkConstraint/VersionConstraint.php on line 17
    Composer-Bibliothek automatisch aktualisieren ist aktiviert
    Composer Cache geleert

    Composer-Version ist 0.13.2 - wird nichts neueres angeboten
    Composer-Plugin ist 2.2.2 - könnte auf 3.0.4 updaten

    Da ich beim ersten Versuch schon wieder alles zerschossen habe, traue ich mich nun nicht, irgendwas zu tun. Wie muss ich denn jetzt weitermachen? (Und ja, die entsprechenden Threads hab ich natürlich gelesen, aber damit komme ich leider nicht weiter).

  13. #13
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Du musst den composer-client auf die neueste Version aktualisieren. Entweder per composer update oder manuell.

  14. #14
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Danke, ich habe die Version von hier manuell raufgeladen, die Daten bereinigt und den Composer-Cache gelöscht, die Fehlermeldung ist weg, aber es wird immer noch die Version 0.13.2 angezeigt.

  15. #15
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Ja, weil die Information im composer.lock File dadurch nicht aktualisiert wurde. Wenn du jetzt eine Paket Aktualisierung durchführst sollte das behoben sein.

  16. #16
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Nächste Frage
    Bei Update über die Konsole kommt jetzt diese Meldung:


    The "contao-community-alliance/composer-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
    Wo muss ich das "--no-plugins" einfügen?

  17. #17
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Poste deine /composer/composer.json

  18. #18
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Hier:
    Code:
    {
        "name": "local/website",
        "description": "Contao Open Source CMS",
        "license": "LGPL-3.0+",
        "version": "3.2.9",
        "type": "project",
        "require": {
            "contao-community-alliance/composer": ">=0.13.2.0,<0.14-dev",
            "contao-legacy/ace_extended": ">=1.0.0.6004-RC,<1.1-dev@RC",
            "contao-legacy/backupdb": ">=3.2.1.9005,<3.3",
            "contao-legacy/dma_elementgenerator": ">=1.0.0.9004,<1.1-dev",
            "contao-legacy/easy_bg_stretcher": ">=1.2.0.9012,<1.3",
            "contao-legacy/googleanalytics": ">=1.4.0.9011,<1.5",
            "contao-legacy/metapalettes": ">=1.5.1.9002,<1.6",
            "contao-legacy/multicolumnwizard": ">=3.2.0.6010-RC,<3.3",
            "contao-legacy/subcolumns": ">=2.1.1.9009,<2.2",
            "jrgregory/m17-sticky-backend-footer": ">=2.0.4.0,<2.1-dev",
            "madeyourday/contao-rocksolid-antispam": ">=1.0.1.0,<1.1-dev",
            "psi/news4ward": ">=2.2.0.0,<2.3-dev",
            "psi/news4ward_archive-menu": ">=2.0.8.0,<2.1-dev",
            "psi/news4ward_categories": ">=2.1.0.0,<2.2-dev",
            "psi/news4ward_comments": ">=2.1.0.0,<2.2-dev",
            "psi/news4ward_tags": ">=2.1.0.0,<2.2-dev",
            "terminal42/contao-ce-access": ">=2.0.2.0,<2.1-dev",
            "terminal42/contao-easy_themes": ">=2.0.8.0,<2.1-dev"
        },
        "config": {
            "preferred-install": "dist",
            "cache-dir": "cache",
            "component-dir": "../assets/components"
        },
        "repositories": [],
        "minimum-stability": "dev",
        "prefer-stable": true,
        "extra": {
            "contao": {
                "migrated": "done"
            }
        }
    }
    Geändert von bibib (13.12.2016 um 10:28 Uhr)

  19. #19
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Du hast deinen composer-client auf Version 0.13.* fixiert. Ändere das auf "~0.16". Darüberhinaus verwendest du einige legacy Pakete, wo es eigentlich eigentlich native Pakete gibt. Außerdem ist aus irgendeinem Grund dein "repositories" leer? Bin leider gerade unterwegs und kann dir nicht den richtigen Wert sagen.

  20. #20
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Composer-Client habe ich in der composer.json geändert auf: "contao-community-alliance/composer": "~0.16" (hoffe, das ist richtig so)

    Nun bekomme ich diese Meldung:
    Code:
    The "contao-community-alliance/composer-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - The requested package contao-community-alliance/composer ~0.16 exists as contao-community-alliance/composer[0.0.3, 0.0.4, 0.1.0, 0.10, 0.10.1, 0.10.2, 0.11, 0.12, 0.12.1, 0.12.2, 0.12.3, 0.13, 0.13.1, 0.13.2, 0.5, 0.6, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.6.6, 0.7.0, 0.7.1, 0.7.10, 0.7.11, 0.7.12, 0.7.13, 0.7.14, 0.7.2, 0.7.3, 0.7.4, 0.7.5, 0.7.6, 0.7.7, 0.7.8, 0.7.9, 0.8, 0.8.1, 0.8.10, 0.8.11, 0.8.12, 0.8.13, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.9, 0.9-beta1, 0.9-beta2, 0.9-beta3, 0.9-beta4, 0.9-beta5, 0.9-beta6, 0.9.1, 0.9.2, 0.9.3, 0.9.4, 0.9.5] but these are rejected by your constraint.
    Die legacy-Pakete sind wahrscheinlich deshalb drin, weil die Seite alt ist und jetzt erst upgedatet wird. Kann ich mir die "repositories" einfach bei einer anderen Installation abschauen?

  21. #21
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Ah, sorry, hatte übersehen, dass du da noch das alte composer Package eingetragen hast. Du musst das auf ".../composer-client" ändern. Die Installation dürfte schon relativ alt sein?

  22. #22
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Super, danke, das sieht jetzt schon viel besser aus.
    Und ja, die Inst. ist schon relativ alt ...

    Allerdings kann ich die Pakete immer noch nicht updaten.
    Bekomme wieder die Meldung
    Code:
    The "contao-community-alliance/composer-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
    Hier ist nochmal die aktuelle composer.json:
    Code:
    {
        "name": "local/website",
        "description": "Contao Open Source CMS",
        "license": "LGPL-3.0+",
        "version": "3.2.9",
        "type": "project",
        "require": {
            "contao-community-alliance/composer-client": "~0.16",
            "contao-community-alliance/meta-palettes": ">=1.10.0.0,<1.11-dev",
            "contao-legacy/backupdb": ">=3.2.1.9005,<3.3",
            "contao-legacy/dma_elementgenerator": ">=1.0.0.9004,<1.1-dev",
            "contao-legacy/easy_bg_stretcher": ">=1.2.0.9012,<1.3",
            "contao-legacy/googleanalytics": ">=1.4.0.9011,<1.5",
            "felixpfeiffer/subcolumns": ">=3.1.7.0,<3.2-dev",
            "jrgregory/m17-sticky-backend-footer": ">=2.0.4.0,<2.1-dev",
            "madeyourday/contao-rocksolid-antispam": ">=1.0.1.0,<1.1-dev",
            "psi/news4ward": ">=2.2.0.0,<2.3-dev",
            "psi/news4ward_archive-menu": ">=2.0.8.0,<2.1-dev",
            "psi/news4ward_categories": ">=2.1.0.0,<2.2-dev",
            "psi/news4ward_comments": ">=2.1.0.0,<2.2-dev",
            "psi/news4ward_tags": ">=2.1.0.0,<2.2-dev",
            "terminal42/contao-ce-access": ">=2.0.2.0,<2.1-dev",
            "terminal42/contao-easy_themes": ">=2.0.8.0,<2.1-dev"
        },
        "config": {
            "preferred-install": "dist",
            "cache-dir": "cache",
            "component-dir": "../assets/components"
        },
        "repositories": [
            {
                "type": "composer",
                "url": "https://legacy-packages-via.contao-community-alliance.org/"
            },
            {
                "type": "artifact",
                "url": "packages"
            }
        ],
        "minimum-stability": "dev",
        "prefer-stable": true,
        "extra": {
            "contao": {
                "migrated": "done"
            }
        }
    }
    Was kann ich denn jetzt noch probieren?

  23. #23
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Hmm wenn du Konsolen Zugriff hast, den /composer/vendor Ordner löschen und dann zwei mal

    php composer.phar update

    ausführen. Auf eigene Gefahr

    minimum-stability könntest du auch auf "stable" setzen.

  24. #24
    Contao-Nutzer Avatar von Hanski
    Registriert seit
    23.02.2010.
    Beiträge
    59

    Standard

    Poste mal die composer/vendor/contao-community-alliance/composer-plugin/composer.json

  25. #25
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Guten Morgen,

    Zitat Zitat von Hanski Beitrag anzeigen
    Poste mal die composer/vendor/contao-community-alliance/composer-plugin/composer.json
    Code:
    {
        "name": "contao-community-alliance/composer-plugin",
        "description": "Composer plugin that provide contao integration and installer.",
        "type": "composer-plugin",
        "homepage":"http://c-c-a.org/",
        "license": "LGPL-3.0+",
        "minimum-stability": "dev",
        "prefer-stable": true,
        "require": {
            "php": ">=5.3.2",
            "composer-plugin-api": "^1.0"
        },
        "require-dev": {
            "composer/composer": "~1.0@dev",
            "phpcq/all-tasks": "~1.1",
            "contao/core": ">=2.11,<4.0"
        },
        "replace": {
            "contao-community-alliance/composer-installer": "1.7.1"
        },
        "conflict": {
            "contao/core": "3.0.*",
            "contao-community-alliance/composer": "<0.9-dev"
        },
        "autoload": {
            "psr-0": {
                "ContaoCommunityAlliance\\Composer\\Plugin\\": "src/"
            }
        },
        "extra": {
            "class": "ContaoCommunityAlliance\\Composer\\Plugin\\Plugin"
        }
    }

  26. #26
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Hast du nun SSH Zugriff?

  27. #27
    Contao-Nutzer Avatar von Hanski
    Registriert seit
    23.02.2010.
    Beiträge
    59

    Standard

    Hm, also die Abhängigkeit für die API sollte eigentlich passen.

  28. #28
    Contao-Fan Avatar von bibib
    Registriert seit
    19.06.2009.
    Ort
    Linz, Oberösterreich
    Beiträge
    621
    Partner-ID
    8517

    Standard

    Puh, nach einer neuerlichen Paketaktualisierung hat es plötzlich geklappt, sieht alles gut aus. Danke euch allen!
    (Und ja, ich hab SSH-Zugriff )

  29. #29
    Contao-Nutzer Avatar von Hanski
    Registriert seit
    23.02.2010.
    Beiträge
    59

    Standard

    Schön, dann weiterhin viel Spaß mit Composer

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •