Ergebnis 1 bis 13 von 13

Thema: Erste Komponenten als Alpha-Version für Contao 4 verfügbar

  1. #1
    Alter Contao-Hase
    Registriert seit
    29.10.2009.
    Beiträge
    1.178
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard Erste Komponenten als Alpha-Version für Contao 4 verfügbar

    Inzwischen ist mit Contao 4.4 die nächste LTS von Contao veröffentlicht worden. Wie bereits angekündigt wird an einer Version 2 der Contao-Bootstrap Erweiterung gearbeitet. Inzwischen stehen die ersten Komponenten als Alpha-Version zur Verfügung. Auch wenn ein stabiles Release von Bootstrap 4 noch auf sich warten lässt, setzt die Erweiterung zukünftig auf Bootstrap 4.

    Alle Informationen befinden sich auf folgender Seite:
    http://contao-bootstrap.netzmacht.de...erfuegbar.html

  2. #2
    Contao-Fan
    Registriert seit
    20.06.2009.
    Ort
    Küps
    Beiträge
    271

    Standard

    Also ich habe nun über Composer folgende Pakete schon drin.

    twbs/bootstrap
    contao-bootstrap/core
    contao-bootstrap/layout
    contao-bootstrap/navbar

    bitte hier informieren wenn neue Pakete dazukommen. Ich installiere die dann gleich bei mir und kann dir Feedback geben.

  3. #3
    Alter Contao-Hase
    Registriert seit
    29.10.2009.
    Beiträge
    1.178
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Ab sofort steht die vollkommen neu geschriebene Grid-Komponente zur Verfügung. Weitere Informationen im entsprechenden unter:
    http://contao-bootstrap.netzmacht.de...fentlicht.html

    Achtung
    Die gesamten Komponenten für Contao 4 sind noch Alpha. In den heute veröffentlichten Versionen alpha2 oder alpha3 der bereits verfügbaren Paketen, wurden Datenbankfelder, Module, Templates umbenannt. Eine frühere Installation wird daher nicht mehr vollständig funktionieren.

    http://contao-bootstrap.netzmacht.de...a-stadium.html

  4. #4
    Contao-Nutzer Avatar von Seefahrer
    Registriert seit
    20.12.2012.
    Ort
    Midlum
    Beiträge
    127

    Standard

    Habe soeben für eine gute Bekannte unter MAMP 4.2 eine sehr kleine Installation aufgesetzt. Contao 4.4 ist dafür sicherlich überdimensioniert, aber da ich mich damit derweil leidlich auskenne, greife ich eben darauf zurück ...
    Also, die Installation mittels des Contao-Managers verlief (Safari) genau wie erwartet ... ohne Probleme!
    Da ich diesmal aus Kostengründen kein Theme kaufen will, habe ich versucht, die Contao-Bootstrap Erweiterung in der Alpha-Version zu installieren. Leider klappt das nicht, obwohl ich Bugbusters Ratschlägen etc. gefolgt bin.

    Egal, ob ich die Installation über den Manager oder den Composer versuche, der Versuch bricht ab mit:
    Code:
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - Installation request for contao/managed-edition No version set (parsed as 1.0.0) -> satisfiable by contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao-bootstrap/tab 1.0.0 requires contao/core >=3.2,<3.6-dev -> satisfiable by contao/core[3.2.0, 3.2.1, 3.2.10, 3.2.11, 3.2.12, 3.2.13, 3.2.14, 3.2.15, 3.2.16, 3.2.17, 3.2.18, 3.2.19, 3.2.2, 3.2.20, 3.2.21, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.2.7, 3.2.8, 3.2.9, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.3.6, 3.3.7, 3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.5.0, 3.5.1, 3.5.10, 3.5.11, 3.5.12, 3.5.13, 3.5.14, 3.5.15, 3.5.16, 3.5.17, 3.5.18, 3.5.19, 3.5.2, 3.5.20, 3.5.21, 3.5.22, 3.5.23, 3.5.24, 3.5.25, 3.5.26, 3.5.27, 3.5.28, 3.5.3, 3.5.4, 3.5.5, 3.5.6, 3.5.7, 3.5.8, 3.5.9].
        - contao-bootstrap/bundle 1.0.0 requires contao-bootstrap/tab * -> satisfiable by contao-bootstrap/tab[1.0.0].
        - contao/core 3.2.0 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.1 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.10 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.11 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.12 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.13 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.14 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.15 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.16 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.17 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.18 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.19 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.2 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.20 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.21 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.3 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.4 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.5 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.6 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.7 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.8 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.9 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.0 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.1 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.2 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.3 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.4 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.5 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.6 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.7 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.0 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.1 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.2 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.3 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.4 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.5 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.0 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.1 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.10 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.11 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.12 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.13 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.14 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.15 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.16 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.17 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.18 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.19 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.2 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.20 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.21 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.22 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.23 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.24 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.25 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.26 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.27 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.28 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.3 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.4 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.5 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.6 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.7 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.8 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.9 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - Installation request for contao-bootstrap/bundle ^1.0 -> satisfiable by contao-bootstrap/bundle[1.0.0].
    
    
    Installation failed, reverting ./composer.json to its original content.
    Airial:bento georg$ php composer.phar require contao-bootstrap/core 2.0.x-dev
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - Installation request for contao/managed-edition No version set (parsed as 1.0.0) -> satisfiable by contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao-bootstrap/tab 1.0.0 requires contao/core >=3.2,<3.6-dev -> satisfiable by contao/core[3.2.0, 3.2.1, 3.2.10, 3.2.11, 3.2.12, 3.2.13, 3.2.14, 3.2.15, 3.2.16, 3.2.17, 3.2.18, 3.2.19, 3.2.2, 3.2.20, 3.2.21, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.2.7, 3.2.8, 3.2.9, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.3.6, 3.3.7, 3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.5.0, 3.5.1, 3.5.10, 3.5.11, 3.5.12, 3.5.13, 3.5.14, 3.5.15, 3.5.16, 3.5.17, 3.5.18, 3.5.19, 3.5.2, 3.5.20, 3.5.21, 3.5.22, 3.5.23, 3.5.24, 3.5.25, 3.5.26, 3.5.27, 3.5.28, 3.5.3, 3.5.4, 3.5.5, 3.5.6, 3.5.7, 3.5.8, 3.5.9].
        - contao-bootstrap/bundle 1.0.0 requires contao-bootstrap/tab * -> satisfiable by contao-bootstrap/tab[1.0.0].
        - contao/core 3.2.0 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.1 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.10 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.11 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.12 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.13 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.14 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.15 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.16 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.17 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.18 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.19 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.2 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.20 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.21 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.3 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.4 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.5 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.6 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.7 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.8 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.2.9 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.0 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.1 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.2 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.3 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.4 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.5 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.6 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.3.7 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.0 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.1 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.2 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.3 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.4 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.4.5 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.0 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.1 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.10 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.11 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.12 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.13 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.14 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.15 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.16 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.17 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.18 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.19 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.2 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.20 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.21 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.22 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.23 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.24 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.25 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.26 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.27 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.28 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.3 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.4 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.5 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.6 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.7 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.8 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - contao/core 3.5.9 conflicts with contao/managed-edition[No version set (parsed as 1.0.0)].
        - Installation request for contao-bootstrap/bundle ^1.0 -> satisfiable by contao-bootstrap/bundle[1.0.0].
    Ich habe versucht:
    Php composer.phar require contao-bootstrap/bundle (bzw. core) 2.0.x-dev usw. leider ohne Erfolg ...

    Habt ihr eine Idee?

  5. #5
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Beiträge
    13.661
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Seefahrer Beitrag anzeigen
    Installation request for contao/managed-edition No version set (parsed as 1.0.0)
    Poste mal deine composer.json

  6. #6
    Alter Contao-Hase
    Registriert seit
    29.10.2009.
    Beiträge
    1.178
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Seefahrer Beitrag anzeigen
    Habe soeben für eine gute Bekannte unter MAMP 4.2 eine sehr kleine Installation aufgesetzt. Contao 4.4 ist dafür sicherlich überdimensioniert, aber da ich mich damit derweil leidlich auskenne, greife ich eben darauf zurück ...
    Also, die Installation mittels des Contao-Managers verlief (Safari) genau wie erwartet ... ohne Probleme!
    Da ich diesmal aus Kostengründen kein Theme kaufen will, habe ich versucht, die Contao-Bootstrap Erweiterung in der Alpha-Version zu installieren. Leider klappt das nicht, obwohl ich Bugbusters Ratschlägen etc. gefolgt bin.

    Habt ihr eine Idee?
    Da es sich noch um eine Alpha-Version handelt, muss der Contao Manager explizit dazu gebracht werden, dass er diese installiert. Dazu müssen die einzelnen Komponenten mittel Versionsconstraint "~2.0.0@alpha" geladen werden. Möchte man das Bundle nutzen, müssen ggf. sogar folgende Einträge zu der globalen composer.json hinzugefügt werden.
    Code:
    minimum-stability: dev,
    prefer-stable: true
    Nichtsdestotrotz sei nochmal erwähnt, dass es sich für Contao 4.4 um eine Alpha-Version handelt, diese Bugs enthält und sich noch einige Sachen ändern können, die nicht rückwärtskompatibel sein könnten.

  7. #7
    Contao-Nutzer Avatar von Seefahrer
    Registriert seit
    20.12.2012.
    Ort
    Midlum
    Beiträge
    127

    Standard

    Hatte erst heute wieder Zugriff auf meine lokales MAMP, nach o.g. Änderung in der composer.json ließ sich das bundle problemlos via Contao-Manager installieren. Dazu noch easythemes und m17sticky-footer, alles ohne jedes Problem.
    Die genannten Einschränkungen hinsichtlich der Alpha-Version des bootstrap-bundles werde ich bedenken.

    Vielen Dank für Eure Hilfe!!

  8. #8
    Contao-Nutzer Avatar von Seefahrer
    Registriert seit
    20.12.2012.
    Ort
    Midlum
    Beiträge
    127

    Standard Hoppla ...

    ... und bin sofort in das erste Messer i.V.m. easythemes gelaufen:

    Hab easythemes wie gewohnt als BE-Modul in der Gruppe Layout eingerichtet und diesem u.a. die Bootstrap-Konfiguration zugeordnet. Rufe ich diese dann im BE auf, kommt es zu nachfolgender Fehlermeldung:

    Code:
    app.CRITICAL: An exception occurred. {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\ContextErrorException(code: 0): User Error: Could not create a data container object at /Users/georg/Sites/bento/vendor/contao/core-bundle/src/Resources/contao/classes/Backend.php:401)"} []
    Wo sollte ich dazu ein Ticket aufmachen: contao-core, easythemes oder bootstrap?

  9. #9
    Alter Contao-Hase
    Registriert seit
    29.10.2009.
    Beiträge
    1.178
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Seefahrer Beitrag anzeigen
    ... und bin sofort in das erste Messer i.V.m. easythemes gelaufen:

    Hab easythemes wie gewohnt als BE-Modul in der Gruppe Layout eingerichtet und diesem u.a. die Bootstrap-Konfiguration zugeordnet. Rufe ich diese dann im BE auf, kommt es zu nachfolgender Fehlermeldung:

    Code:
    app.CRITICAL: An exception occurred. {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\ContextErrorException(code: 0): User Error: Could not create a data container object at /Users/georg/Sites/bento/vendor/contao/core-bundle/src/Resources/contao/classes/Backend.php:401)"} []
    Wo sollte ich dazu ein Ticket aufmachen: contao-core, easythemes oder bootstrap?
    Zu diesem Fall gibt es schon das Ticket. https://github.com/contao-bootstrap/core/issues/20

    Im Zweifelsfall kannst du ein Ticket, das im Zusammenhang mit der Bootstrap Erweiterung auftritt unter https://github.com/contao-bootstrap/core/issues erstellen, gerne auch bei dem jeweiligen Komponenten, falls eine Zuordnung erkennbar ist.

  10. #10
    Contao-Nutzer Avatar von Seefahrer
    Registriert seit
    20.12.2012.
    Ort
    Midlum
    Beiträge
    127

    Standard

    Danke, nach Anwendung des im Ticket genannten Patches in Zeile 38 der Datei:

    vendor/contao-bootstrap/core/src/Resources/contao/config/config.php

    funktioniert nun alles so, wie es sollte ... vielen Dank!

  11. #11
    Contao-Nutzer
    Registriert seit
    18.08.2017.
    Beiträge
    3

    Standard

    Hallo Zusammen,

    gibt es Neuigkeiten wann weitere Module zur Verfügung stehen? Da ich gerade ein Contao Projekt starte und am überlegen bin, ob es sich lohnt auf die Version 2 zu warten?

  12. #12
    Alter Contao-Hase
    Registriert seit
    29.10.2009.
    Beiträge
    1.178
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von finki007 Beitrag anzeigen
    Hallo Zusammen,

    gibt es Neuigkeiten wann weitere Module zur Verfügung stehen? Da ich gerade ein Contao Projekt starte und am überlegen bin, ob es sich lohnt auf die Version 2 zu warten?
    Grober Zeitplan ist folgender: Im September kommt die Formularunterstützung dazu. Dann sollen die vorhandenen Module stable (ca. Oktober/November) gemacht werden.

    Ob/wann weitere Module folgen, hängt nach Bedarf ab. D.h., wenn ich es in Projekten brauche und refinanziert bekomme, stelle ich diese zur Verfügung. Oder halt wenn ich dafür beauftragt werde.

    Als Basis für die Bootstrap Unterstützung sollten aber die Module Grid, Layout, Form und Navbar schon eine gute Grundlage sein.

  13. #13
    Alter Contao-Hase
    Registriert seit
    29.10.2009.
    Beiträge
    1.178
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Es gibt Neuigkeiten aus dem Contao-Bootstrap Universum. Wie angekündigt habe ich die Formular-Komponente für Contao 4.4 neu geschrieben. Weitere Änderungen sind passiert. Ausführlich erfahrt ihr es auf der Projektwebsite.

    http://contao-bootstrap.netzmacht.de...omponente.html

    Themen im Kurzüberblick
    • Ab sofort Mindestanforderung PHP 7.1
    • Grid-Komponente nun BS 4 Beta kompatibel
    • Formular-Komponente veröffentlicht
    • Ausblick

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •