Ergebnis 1 bis 3 von 3

Thema: Installation von contao-bootstrap/grid scheitert

  1. #1
    Contao-Fan Avatar von Webstylerin
    Registriert seit
    24.08.2009.
    Ort
    Schlüsselfeld, Bayern
    Beiträge
    283
    Partner-ID
    6232

    Standard Installation von contao-bootstrap/grid scheitert

    Hallo ihr Lieben,

    ich schaffe es nicht die Erweiterung contao-bootstrap/grid unter Contao 4.4 mit dem Contao Manager bzw. direkt via Composer zu installieren, kann aber auch keinen Fehler aus der Ausgabe herauslesen. Hat jemand eine Ahnung warum es kracht? Liegt es am Webserver oder an der Erweiterung? Ich weiß, dass sich die Erweiterung noch in einem sehr frühen Stadium befindet, setze sie aber schon erfolgreich auf anderen Seiten/Servern ein.

    LG
    Nicole

    Code:
    - ...
      - Installing contao-bootstrap/core (2.0.0-alpha4): Loading from cache
      - Installing contao-bootstrap/grid (2.0.0-alpha1): Loading from cache
    phpspec/phpspec suggests installing phpspec/nyan-formatters (Adds Nyan formatters)
    sebastian/global-state suggests installing ext-uopz (*)
    phpunit/php-code-coverage suggests installing ext-xdebug (^2.5.5)
    phpunit/phpunit suggests installing phpunit/php-invoker (^1.1)
    phpunit/phpunit suggests installing ext-xdebug (*)
    contao-bootstrap/core suggests installing twbs/bootstrap (Official Bootstrap package)
    contao-bootstrap/core suggests installing components/bootstrap (Bootstrap Components package)
    Package sebastian/git is abandoned, you should avoid using it. No replacement was suggested.
    Writing lock file
    Generating autoload files
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    
    Fatal error: Uncaught TypeError: Return value of ContaoBootstrap\Core\DependencyInjection\ConfigPass::setConfigTypesArgument() must be an instance of ContaoBootstrap\Core\DependencyInjection\void, none returned in /kunden/.../vendor/contao-bootstrap/core/src/DependencyInjection/ConfigPass.php:71
    Stack trace:
    #0 /kunden/.../vendor/contao-bootstrap/core/src/DependencyInjection/ConfigPass.php(34): ContaoBootstrap\Core\DependencyInjection\ConfigPass->setConfigTypesArgument(Object(Contao\ManagerPlugin\Config\ContainerBuilder))
    #1 /kunden/.../vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/Compiler.php(143): ContaoBootstrap\Core\DependencyInjection\ConfigPass->process(Object(Contao\ManagerPlugin\Config\ContainerBuilder))
    #2 /kunden/.../vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/ContainerBuilder.php(737): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Contao\ManagerPlugin\Config\ContainerBuilder))
     in /kunden/.../vendor/contao-bootstrap/core/src/DependencyInjection/ConfigPass.php on line 71
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-update-cmd event terminated with an exception
    
                                                                                
      [RuntimeException]                                                        
      An error occurred while executing the "contao:install-web-dir" command:   
                                                                                
    
    update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...
    
    u18098@abellio ~/w3-tvd $ php7.0.6-cli composer.phar update
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Nothing to install or update
    Package sebastian/git is abandoned, you should avoid using it. No replacement was suggested.
    Generating autoload files
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    
    Fatal error: Uncaught TypeError: Return value of ContaoBootstrap\Core\DependencyInjection\ConfigPass::setConfigTypesArgument() must be an instance of ContaoBootstrap\Core\DependencyInjection\void, none returned in /kunden/.../vendor/contao-bootstrap/core/src/DependencyInjection/ConfigPass.php:71
    Stack trace:
    #0 /kunden/.../vendor/contao-bootstrap/core/src/DependencyInjection/ConfigPass.php(34): ContaoBootstrap\Core\DependencyInjection\ConfigPass->setConfigTypesArgument(Object(Contao\ManagerPlugin\Config\ContainerBuilder))
    #1 /kunden/.../vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/Compiler.php(143): ContaoBootstrap\Core\DependencyInjection\ConfigPass->process(Object(Contao\ManagerPlugin\Config\ContainerBuilder))
    #2 /kunden/.../vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/ContainerBuilder.php(737): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Contao\ManagerPlugin\Config\ContainerBuilder))
     in /kunden/.../vendor/contao-bootstrap/core/src/DependencyInjection/ConfigPass.php on line 71
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-update-cmd event terminated with an exception
    
                                                                                
      [RuntimeException]                                                        
      An error occurred while executing the "contao:install-web-dir" command:   
                                                                                
    
    update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...

  2. #2
    Alter Contao-Hase
    Registriert seit
    29.10.2009.
    Beiträge
    1.127
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Ich bin dabei die Abhängigkeit auf PHP 7.1 zu setzen. Leider hat das aktuelle Release des Cores eine falsche Abhängigkeit drin stehen (PHP 7.0).

    Es gibt folgende Lösungsmöglichkeiten:
    • PHP 7.1 nutzen
    • contao-bootstrap/core explizit als 2.0.0-alpha3 installieren und danach die Grid-Erweiterung

  3. #3
    Contao-Fan Avatar von Webstylerin
    Registriert seit
    24.08.2009.
    Ort
    Schlüsselfeld, Bayern
    Beiträge
    283
    Partner-ID
    6232

    Standard

    Ah! PHP 7.1 hab ich auf dem Server leider nicht zur Verfügung, aber auf den anderen, auf denen es läuft.

    Dann überlege ich mir mal die zweite Variante. Danke webstar.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •