Contao Konferenz & College 2019 in Duisburg - JETZT TICKET SICHERN!
Ergebnis 1 bis 12 von 12

Thema: PHP 7

  1. #1
    Contao-Nutzer Avatar von Luminanz
    Registriert seit
    02.02.2011.
    Beiträge
    198

    Standard PHP 7

    Hallo zusammen

    Ich habe die Erweiterung in der Version 1.6.0 mit contao 3.5.30 im Einsatz.
    Bei Verwendung von PHP 7 erhalte ich folgende Fehlermeldung:
    Fotos sortieren
    Fatal error: Cannot use 'String' as class name as it is reserved in /home/fotogra2/public_html/foto-art/system/modules/core/library/Contao/String.php on line 28

    Hat jemand ähnliche Erfahrungen?

    Ein Ticket habe ich bereits erstellt:
    https://github.com/Craffft/contao-ph...ms2/issues/135

    Danke für eure Rückmeldungen.

  2. #2
    Contao-Nutzer Avatar von Seefahrer
    Registriert seit
    20.12.2012.
    Ort
    Midlum b. Cuxhaven
    Beiträge
    212

  3. #3
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.029
    User beschenken
    Wunschliste

    Standard

    Laut dem Ticket sollte es in 1.6.0 aber behoben sein.

  4. #4
    Contao-Nutzer Avatar von Seefahrer
    Registriert seit
    20.12.2012.
    Ort
    Midlum b. Cuxhaven
    Beiträge
    212

    Standard

    Stimmt, hatte ich damals für mich selber gefixt (s. issue). Mittlerweile habe ich v2.0. im Einsatz mit php7.1 ohne eigene Anpassungen und Probleme.

  5. #5
    Contao-Nutzer Avatar von Luminanz
    Registriert seit
    02.02.2011.
    Beiträge
    198

    Standard

    Danke für die Hinweise. Dieses Ticket habe ich auch gesehen und daher hier im Forum den Beitrag erstellt. Ich habe die Extension auch schon neu installiert (auch manuell), aber ich erhalte leider immer diese Fehlermeldung.
    Daher fragte ich mich, ob die Extension wirklich mit PHP 7 läuft (contao 3.5) oder ob ich etwas falsch mache

  6. #6
    Contao-Nutzer Avatar von Seefahrer
    Registriert seit
    20.12.2012.
    Ort
    Midlum b. Cuxhaven
    Beiträge
    212

    Standard

    Contao cache und browser cache geleert? Oder treibt da noch eine weitere nicht php7 kompatible Erweiterung ihr Unwesen?
    Aus der oben zitierten Fehlermeldung geht der Verursacher nicht hervor ...
    Geändert von Seefahrer (25.10.2017 um 09:58 Uhr)

  7. #7
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.043
    User beschenken
    Wunschliste

    Standard

    Jo, die vollständige Fehlermeldung, also die obige Zeile inkl. der nachfolgenden sogenannten Stack Zeilen wären hilfreich, um zu sehen, wer der Verursacher ist.
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  8. #8
    Contao-Nutzer Avatar von Luminanz
    Registriert seit
    02.02.2011.
    Beiträge
    198

    Standard

    Der Fehler kommt scheinbar von der Extension "image_sort_wizard". Wenn diese deaktiviert ist, kann ich die Fotoalben öffnen.

    Wie genau kann ich mir eine präzisere Fehlermeldung ausgeben lassen?

  9. #9
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.043
    User beschenken
    Wunschliste

    Standard

    Stimmt, die passt nicht.
    Datei system/modules/imagesortwizard/widgets/ImageSortWizard.php Zeile 78
    Datei system/modules/imagesortwizard/widgets/ImageSortWizard.php Zeile 192

    Jeweils
    Code:
    \String::
    durch
    Code:
    \StringUtil::
    ersetzen sollte helfen. (Cache löschen könnte eventuell nötig sein).

    Nachtrag: Ich beziehe mich auf die Composer Version, nicht die aus dem alten ER2, da könnten es je nach Version andere Zeilen sein.

    Ich habe mal ein Ticket erstellt. https://github.com/Craffft/contao-im...izard/issues/3
    Geändert von BugBuster (25.10.2017 um 15:19 Uhr)
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  10. #10
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.043
    User beschenken
    Wunschliste

    Standard

    Anwort: Contao 3.5 hat für Photoalbums2 keinen PHP7 Support.

    Dann musste wohl selber patchen wie beschrieben.
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

  11. #11
    Contao-Nutzer Avatar von Luminanz
    Registriert seit
    02.02.2011.
    Beiträge
    198

    Standard

    Vielen Dank!
    Habe es so angepasst und nun funktioniert alles wie gewünscht!

  12. #12
    Wandelndes Contao-Lexikon Avatar von BugBuster
    Registriert seit
    15.06.2009.
    Ort
    Berlin
    Beiträge
    10.043
    User beschenken
    Wunschliste

    Standard

    Mittlerweile kam nun doch ein Update raus von craffft/contao-imagesortwizard, ist nun in Version 2.3.1 auch PHP7 fähig.
    Grüße, BugBuster
    "view source" is your guide.
    Danke an alle Amazon Wunschlisten Erfüller

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •