Ergebnis 1 bis 7 von 7

Thema: Fatal error: Class 'StringUtil' not found

  1. #1
    Contao-Nutzer
    Registriert seit
    25.01.2016.
    Beiträge
    64

    Standard Fatal error: Class 'StringUtil' not found

    Hallo zusammen,

    bekomme auf einmal wenn ich in einem Artikel ein erstelltes DMA-Element ändern und speichern will immer folgenden Fehler:

    Code:
    Fatal error: Class 'StringUtil' not found in /xxxx/contao-3.3/system/modules/dma_elementgenerator/DMAElementGeneratorCallbacks.php on line 623
    Habe aber eigentlich kein Update o.Ä. vorgenommen..
    Den Cache habe ich bereits manuell vom FTP geleert, hat aber nicht geholfen.

    Beste Grüße

  2. #2
    Contao-Urgestein
    Registriert seit
    29.10.2009.
    Beiträge
    1.818
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Handelt es sich tatsächlich um Contao 3.3, wie im Pfad suggeriert? Der dma_elementgenerator ist offensichtlich nicht mehr mit Contao 3.3 kompatibel.

    Da gab es die Klasse noch nicht. Ein Update auf Contao 3.5 ist eh dringend geraten aufgrund von Sicherheitspatches.

  3. #3
    Contao-Nutzer
    Registriert seit
    25.01.2016.
    Beiträge
    64

    Standard

    Servus webstar,

    die exakte Version ist 3.3.7.
    Auf einer anderen Contao Installtion (auch 3.3.7) funktioniert die Erweiterung noch.
    Das ist das verwirrende.

    Könnte eine Re-Installation helfen?

  4. #4
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    8.039
    User beschenken
    Wunschliste

    Standard

    Eventuell liegt es auch an der PHP-Version. Contao 3.3 ist z.B. mit PHP 7 nicht kompatibel. Allerdings würde ich dann mehr Fehlermeldungen dieser Art erwarten. Oder du benutzt in der anderen Installation eine ältere Version von dma_elemengenerator.

  5. #5
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.389
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    @sss: wie schon erwähnt solltest du auf jeden Fall auf Contao 3.5.31 aktualisieren.

  6. #6
    Contao-Urgestein
    Registriert seit
    29.10.2009.
    Beiträge
    1.818
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von sss Beitrag anzeigen
    Servus webstar,

    die exakte Version ist 3.3.7.
    Auf einer anderen Contao Installtion (auch 3.3.7) funktioniert die Erweiterung noch.
    Das ist das verwirrende.
    Vermutlich nicht in der gleichen Version. Wurde in V1.0.5 geänderthttps://github.com/DMAGmbH/dma_elementgenerator/commit/e1e4ee5924d9a95d8dadd591e23e036e933c4dda

    Zitat Zitat von sss Beitrag anzeigen
    Könnte eine Re-Installation helfen?
    Sorry, aber dazu fällt mir nur das Zitat von Einstein "Die Definition von Wahnsinn ist, immer wieder das Gleiche zu tun und andere Ergebnisse zu erwarten." ;-)

    Wie gesagt, aktualisiere auf Contao 3.5.31.

  7. #7
    Contao-Nutzer
    Registriert seit
    25.01.2016.
    Beiträge
    64

    Standard

    Ihr seid die Besten! Update hat geholfen und funktioniert wieder alles bestens! Dankeschön

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •