Ergebnis 1 bis 3 von 3

Thema: Installation von BackupDB über composer

  1. #1
    Alter Contao-Hase
    Registriert seit
    20.09.2012.
    Ort
    Lüneburger Heide
    Beiträge
    1.413
    User beschenken
    Wunschliste

    Standard Installation von BackupDB über composer

    Hi,

    ich spiele gerade etwas mit dem composer herum und möchte die Erweiterung BackupDB über die Konsole installieren (bei 1und1).

    PHP-Code:
     php7.1-cli composer.phar require do-while/contao-backupdb-bundle 
    Nach diesem Aufruf steht das Bundle in der composer.json zwar drin aber es kommt folgende Meldung:
    PHP-Code:
    Using version ^1.2 for do-while/contao-backupdb-bundle
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies 
    (including require-dev)

    mmap() failed: [12Cannot allocate memory

    mmap
    () failed: [12Cannot allocate memory

    Fatal error
    Out of memory (allocated 620765184) (tried to allocate 20480 bytesin phar:///homepages/10/xyz/htdocs/contao4/composer.phar/src/Composer/DependencyResolver/GenericRule.php on line 36 
    Ich vermute dass das nicht an der Erweiterung selbst liegt.
    Hat da jemand einen Tip für mich?

    Gruß
    tschero

  2. #2
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.857
    User beschenken
    Wunschliste

    Standard

    Kannst Du mal das probieren, was Leo hier vorgeschlagen hat: https://github.com/contao/contao-man...ment-348161139
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  3. #3
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.341
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Bei 1&1 kannst du nur composer install ausführen, kein require oder update. Du musst also die Extension zuerst lokal installieren, dann die composer.lock Datei hinaufladen und am Server composer install ausführen. Beachte, dass du überall die selbe PHP Version verwendest oder in deiner composer.json (remote und lokal) die PHP Version deines remote Webservers festlegst.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •