Seite 2 von 2 ErsteErste 12
Ergebnis 41 bis 76 von 76

Thema: Installation scheitert wegen fehlendem "innodb_large_prefix"

  1. #41
    Alter Contao-Hase Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    1.004

    Standard

    Hi Leute,

    ich habe eben eine weitere Installation von 3.5.x auf 4.5.3 upgedatet, dabei fiel mir auf, dass das Installtoll garnicht über die fehlende "config.yml" bzw. die darin enthaltenen Parameter gemotz hat. Die Installation lief einfach durch. Ich habe dann nachträglich die Datei hochgeladen! Das war ein Fehler, denn beim Abspeichern der Seitenstruktur wurde im Bereich "Alias-Einstellungen" ein Fehler ausgegeben. Da sich mit den zur Verfügung stehenden Einstellungen (Dropdown) keine Lösung erzielen lis, habe ich kurzerhand neu installiert und habe dann vor dem Aufruf des Installtolls die "config.yml" eingefügt. Auch jetzt lief die Installation gut durch aber auch jetzt wurde am selben Punkt in der Seitenstruktur ein Fehler ausgegeben. Dann habe ich mutig die "config.yml" umbenannt und alles war OK.

    Kann sich diese komische Verhalten jemand erklären? Brauche ich die "config.yml" ab jetzt nicht mehr?

    Leicht verwirrte Grüße aus Ludwigsburg
    Jochen
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  2. #42
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Welcher Hoster? Was für ein Fehler? Was für ein Inhalt in der config.yml?

  3. #43
    Alter Contao-Hase Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    1.004

    Standard

    Hi Spooky,

    - DF
    - läßt sich leider nicht mehr reproduzieren
    - Inhalt wie ganz oben empfohlen:

    Code:
    doctrine:
        dbal:
            connections:
                default:
                    default_table_options:
                        charset: utf8
                        collate: utf8_unicode_ci

    Grüße
    JK
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  4. #44
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Ohne Fehlerbeschreibung kann man natürlich nichts näheres dazu sagen.

    Und bzgl. charset und collation Anpassungen der Datenbank: evt. hat DomainFactory entweder die Datenbankservereinstellungen dementsprechend angepasst oder die Datenbankserver aktualisiert, wodurch das nicht mehr notwendig ist.

  5. #45
    Contao-Nutzer
    Registriert seit
    10.01.2011.
    Beiträge
    239

    Standard

    Zitat Zitat von kubjo Beitrag anzeigen
    Hi Tab

    ja, so kann man es auch sehen. Ich bin mir aber momentan nicht sicher, ob ich grinsen, oder mich richtig aufregen soll. Die Anforderungen an ein CMS so dermaßen zu erhöhen, finde ich fast unzumutbar. Ich müßte mein Hostingpaket von 20,-€ / Monat auf 60,-€ im Monat aufstocken und selbst dann wäre es nicht sicher, ob ich den CM störungsfrei verwenden kann. Ebenfalls den Speicherplatz mal kurz mehr als verdreifachen, da frage ich mich: "Wofür das Ganze?" Performance? Ich kann bis jetzt über die Performance von 3.x nicht klagen. Es wäre schön, wenn man die nach außen sichtbaren Vorteile ein wenig besser kommunuzieren würde!

    Grüße
    JK
    Hi JK,

    ich stimme Dir zu. Ich bin auch total enttäuscht und genervt über die Schwierigkeiten die ich habe beim Umzug meiner Kunden von 3.5 auf 4. Meine Kunden sind leider nicht bei einem Provider, und bei jedem ist es anders was beachtet oder angepasst werden muss. Bei Strato soll ich erst mit einem Serverpaket die Möglichkeit haben Contao 4 richtig zum laufen zu bekommen da in den Hostingpaketen keine Möglichkeit der innodb_large_prefix Aktivierung möglich ist. Endlose Anrufe und Email an Strato und komme nicht weiter. Ich möchte meinen Kunden jetzt nicht auch noch ein Providerwechsel zumuten.
    Also ich verstehe dich es ist nicht zum Grinsen!!!

    Gruß

  6. #46
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    6.489
    Partner-ID
    152
    User beschenken
    Wunschliste

    Standard

    Sorry, aber das ist ja wohl ein Problem von Strato (und ein paar wenigen anderen, die von mir aus in der Vorhölle schmoren können).

    Meine Erfahrungen sind da andere. Beispielsweise:
    • hostpoint.ch - komplett unproblematische Installation, da gibt's andere Zinken (200'000 Files, Cache ...)
    • metanet.ch - null Probleme, zu meiner grossen Überraschung
    • hosteurope.de - neue Pakete unproblematisch, allerdings auch bei innodb hinterher. Und man sollte trotzdem da weg.
    • cyon.ch - unproblematisch, da nervt eher mal die WAF, wenn man CSS schreibt
    • alfahosting - unproblematisch, aber warum speichern die Passwörter im Klartext?
    • 1und1 - jaha, sogar die, wenn man auf einer aktuellen Maschine ist ;-)
    • manitu.de - rockt wie immer
    • timmehosting - keine Probleme
    • web4all - unproblematisch
    • hostingwerk.de - wo, wenn nicht da?
    • mittwald.de - unproblematisch - wenn man nur mehrere PHP-Versionen nutzen könnte

    Tja, und dann gibt es die Ganoven, die bevorzugt in Computerzeitschriften mit grossen Bildern werben. Muss man halt schauen, was man möchte - in den meisten Fällen überzeugt es auch Kund*innen, wenn man ihnen im Gespräch vermittelt, dass eine Installation bei einem versierten Hoster in 20 Minuten gemacht ist, er aber man bei einer dieser Werbeklitschen auch mal einen halben Tag berechnen wird. Ich habe da wenig Mittleid.

    Und wenn man dann noch lesen muss, dass diese Bande ihre Kund*innen stundenlang in Supporthotlines aufhält, um ihnen dann als Ausweg ein teureres Produkt aufschwatzen zu wollen, dann kann auch ich echt sauer werden.

    Die verlagern einfach das Problem. Anstatt ihre Hausaufgaben zu machen (Hosting mit sicheren, sinnvollen Konfigurationen auf aktuellem Stand) nutzen sie es als Upsellingargument. Das finde ich - mit Verlaub - zum brechen. Und es vertauscht Ursache und Wirkung.

    Klar in jedem fall allerdings auch: Die Hostingpreise ziehen an. Ich habe neulich mal einen Blick auf die aktuellen Tarife von df.eu getan, und mir ist beinahe das Herz stehen geblieben. Was aber auch korrekt ist: Jahrelang hat niemand für Hosting einen korrekten Preis gezahlt - das waren immer Kampfpreise, die mit Sternchentexten angereichert waren, bei denen Selbstverständlichkeiten als tolle Features verkauft wurden und diejenigen, die tatsächlich mal so ein Angebot ausgereizt haben, ganz schnell vor die Tür gesetzt wurden. Das ändert sich gerade. Schaun wir mal, wohin das führt.

  7. #47
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.084
    Partner-ID
    7421

    Standard

    Und bei Strato in meinem Paket PowerWeb Basic ist es auch verfügbar. Nur leider weiss der Service-Champion eventuell nicht was er tatsächlich anbietet .
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  8. #48
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    8.038
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von mlweb Beitrag anzeigen
    Und bei Strato in meinem Paket PowerWeb Basic ist es auch verfügbar. Nur leider weiss der Service-Champion eventuell nicht was er tatsächlich anbietet .
    Wahrscheinlich wird der Service-Champion dann demnächst damit werben, dass Strato noch viel besser ist als Strato selbst weiss.

  9. #49
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    8.038
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von lucina Beitrag anzeigen
    Sorry, aber das ist ja wohl ein Problem von Strato (und ein paar wenigen anderen, die von mir aus in der Vorhölle schmoren können).
    So sehe ich das auch. Leider immer wieder schade für die Kunden, die auf die Fernsehwerbung reingefallen sind. Wechseln will natürlich keiner gern, wenn alle E-Mail Clients für Strato eingerichtet sind und der Umzug Geld oder zumindest Zeit kostet.
    Zitat Zitat von lucina Beitrag anzeigen
    Meine Erfahrungen sind da andere. Beispielsweise:
    • hostpoint.ch - komplett unproblematische Installation, da gibt's andere Zinken (200'000 Files, Cache ...)
    • metanet.ch - null Probleme, zu meiner grossen Überraschung
    • hosteurope.de - neue Pakete unproblematisch, allerdings auch bei innodb hinterher. Und man sollte trotzdem da weg.
    • cyon.ch - unproblematisch, da nervt eher mal die WAF, wenn man CSS schreibt
    • alfahosting - unproblematisch, aber warum speichern die Passwörter im Klartext?
    • 1und1 - jaha, sogar die, wenn man auf einer aktuellen Maschine ist ;-)
    • manitu.de - rockt wie immer
    • timmehosting - keine Probleme
    • web4all - unproblematisch
    • hostingwerk.de - wo, wenn nicht da?
    • mittwald.de - unproblematisch - wenn man nur mehrere PHP-Versionen nutzen könnte
    • Webgo - meist unproblematisch, im Moment wohl einiges im Umbau - leider momentan auch nur eine PHP-Version nutzbar aber ansonsten (eigener Apache!) ziemlich genial
    • netcup - Unproblematisch, aber Vorsicht bei den supergünstigen Schnäppchenangeboten ohne garantierte Ressourcen!
    • uberspace - wenn der Kunde damit klarkommt.

    Zitat Zitat von lucina Beitrag anzeigen
    Tja, und dann gibt es die Ganoven, die bevorzugt in Computerzeitschriften mit grossen Bildern werben...
    Dieses Upselling geht mir auch auf den Geist. "Das geht in einem shared hosting nicht, da müssen Sie einen Server nehmen!" Natürlich geht das in einem shared hosting, nur nicht bei denen. Wenn man dann bedenkt, dass entsprechende (managed!) Server natürlich richtig Geld kosten ...

    Zumindest shared hosting ist eben in der Regel eine Mischkalkulation. Wenn alle Kunden die angepriesene Leistung auch nur zur Hälfte ausnutzen würden (was ist eigentlich die Hälfte von unlimited traffic?), dann läge der Server winselnd am Boden. Tut er gelegentlich bei manchen Anbietern auch, die einfach zu viele Kunden auf einen Server packen. Vielleicht tut sich da ja mit den steigenden Preisen was, so dass man auch verlässlich die Ressourcen abrufen kann, für die man bezahlt. Oder umgekehrt, dass man nur das bezahlt, was man auch wirklich nutzt. "Fair use" klingt gut, ist mir aber einfach zu schwammig. Sollen die lieber das Geld verlangen das die verbratenen Ressourcen (+ eine Sicherheitsmarge für Stosszeiten) eben kosten.

  10. #50
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    6.489
    Partner-ID
    152
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von tab Beitrag anzeigen
    Wechseln will natürlich keiner gern, wenn alle E-Mail Clients für Strato eingerichtet sind und der Umzug Geld oder zumindest Zeit kostet.
    Auch das kann man mit ein paar DNS-Einträgen lösen, oder man zieht Mails halt auch mit um: https://imapsync.lamiral.info/

    Ich bin es einfach satt, dass es Hoster gibt, denen Kund*innenbelange komplett am *rsch vorbei gehen, und deren Grütze man dann hier noch supporten darf.

    Ich rede die Probleme bei denen nicht klein, ich verstehe auch, dass jemand, der dann in Probleme läuft, auch sauer ist. Aber es wären keine Probleme, wenn einige Hoster ihre Arbeit richtig machen würden.

    Sorry für den Rant, aber ich hatte da auch in den letzten Wochen vermehrt mit zu tun, und das läuft dann auch mal über.

  11. #51
    Contao-Nutzer
    Registriert seit
    26.03.2019.
    Beiträge
    30

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Die Datei ist nie da. Die musst du selber anlegen. Wann du das machst ist unerheblich. Wichtig ist nur, dass du danach den Cache löschst (falls der aufgebaut ist) und das Install Tool aufrufst (sofern Contao schon installiert ist).
    Ich habe das Selbe Problem!
    Habe die Datei erstellt und in das Verzeichnis geschrieben.

    Blöde Frage eines Novizen:
    Wo ist dieser zu löschende Cache? Im Plesk? Aber wo im Plesk?

    Danke für einen Hinweis schon im Voraus.

  12. #52
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Damit ist der Ordner var/cache gemeint. Oder die entsprechenden Kommandos auf der Kommandozeile oder die entsprechende Funktion im Contao Manager.

  13. #53
    Contao-Nutzer
    Registriert seit
    26.03.2019.
    Beiträge
    30

    Gesicht zeigt die Zunge

    Zitat Zitat von Spooky Beitrag anzeigen
    Damit ist der Ordner var/cache gemeint. Oder die entsprechenden Kommandos auf der Kommandozeile oder die entsprechende Funktion im Contao Manager.
    Danke Spoky.

    Ich habe den ContaoManager gestartet und unter Systemverwaltung die zwei Caches gelöscht:

    1.jpg
    Cache der Entwicklungs- und Produktionsumgebung gelöscht


    2.jpg

    und danach über tools --> install-tool wiederum die selbe Fehlermeldung erhalten...:

    Die innodb_large_prefix-Option ist nicht aktiv!



    Die app/config/config.yml liegt bei mir übrigens eine Ordnerebene oberhalb des Ordners web in welchem die cantao-manager.phar.php liegt. Diese Ordner waren so schon dort. Ist das richtig?

    Warum macht es Contao den nicht-Cracs so schwierig mit der Inatallation? Ich war schon mehrmals fast am aufgeben und hätte auch schon aufgegeben, wenn ich eine Alternative wüsste...
    Geändert von gresch (30.03.2019 um 11:35 Uhr)

  14. #54
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    In einer moderneren Server Umgebung hättest du die Probleme nicht.

    Was genau steht nun in deiner config.yml?

  15. #55
    Contao-Nutzer
    Registriert seit
    26.03.2019.
    Beiträge
    30

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    In einer moderneren Server Umgebung hättest du die Probleme nicht.

    Was genau steht nun in deiner config.yml?
    doctrine:
    dbal:
    connections:
    default:
    default_table_options:
    charset: utf8
    collate: utf8_unicode_ci

  16. #56
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Bitte immer in [code] Tags posten.

    Zeige außerdem einen Screenshot vom Contao Install Tool.

  17. #57
    Contao-Nutzer
    Registriert seit
    26.03.2019.
    Beiträge
    30

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Bitte immer in [code] Tags posten.

    Zeige außerdem einen Screenshot vom Contao Install Tool.
    Meinst du mit CodeTags die Einrückungen? Diese sind beim hereinkopieren verschwunden...???

    Ich habe meine config.ini um eine Zeile erweitert, weil dies so irgendwo stand:
    engine: MyISAM

    Danach wieder Cache geleert und CM erneut aufgerufen. Nun lief es durch. Doch konnte ich mich nun nicht mehr im Backend einlogen!!!

    Was ist denn da wieder schief gegangen? Wie komme ich da wieder raus?

    Sorry! Fehlalarm! Ich habe die Anmeldedaten vom VM im Backend verwendet! Es raucht mir langsam der Kopf!

    ABER ES HAT GEKLAPPT!!- ICH BIN AUF 4.7!!

    Vielen Dank
    Geändert von gresch (30.03.2019 um 12:23 Uhr)

  18. #58
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von gresch Beitrag anzeigen
    Meinst du mit CodeTags die Einrückungen? Diese sind beim hereinkopieren verschwunden...???
    Nein, die [code] Tags des Forums.



    Zitat Zitat von gresch Beitrag anzeigen
    Ich habe meine config.ini um eine Zeile erweitert, weil dies so irgendwo stand:
    engine: MyISAM

    Danach wieder Cache geleert und CM erneut aufgerufen. Nun lief es durch.
    Das solltest du nicht machen.

    Wenn du ohnehin Zugriff auf die Konfiguration des MySQL Servers hast, dann solltest du lieber die erwähnten Optionen aktivieren - und nicht die config.yml Anpassung machen. Letzteres ist nur ein Workaround, falls die Konfiguration des MySQL Servers nicht geändert werden kann.

  19. #59
    Contao-Nutzer
    Registriert seit
    26.03.2019.
    Beiträge
    30

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Nein, die [code] Tags des Forums.



    Das solltest du nicht machen.

    Wenn du ohnehin Zugriff auf die Konfiguration des MySQL Servers hast, dann solltest du lieber die erwähnten Optionen aktivieren - und nicht die config.yml Anpassung machen. Letzteres ist nur ein Workaround, falls die Konfiguration des MySQL Servers nicht geändert werden kann.
    Ich verstehe nicht, was die CodeTags des Forums sind :-(

    Auch weiss ich nicht, wie dies mit der Konfiguration des MySQL Servers geht... :-(

    Aber es hat geklappt. Vielleicht werde ich mit der Zeit noch etwas gescheiter.

  20. #60
    Contao-Urgestein Avatar von fiedsch
    Registriert seit
    09.07.2009.
    Ort
    München
    Beiträge
    2.244

    Standard

    Zitat Zitat von gresch Beitrag anzeigen
    Ich verstehe nicht, was die CodeTags des Forums sind :-(
    Du schreibst entweder direkt

    [CODE]
    dein Code hier
    [/CODE]

    hin, oder Du verwendest die Buttons (#, <>, php) des Editors
    Stammtisch Contao Bayern: http://www.contao-bayern.de

  21. #61
    Contao-Nutzer
    Registriert seit
    03.06.2019.
    Beiträge
    23

    Standard "innodb_large_prefix"

    Nach endlosen Versuchen und kryptischen "Java fehlt"- Abbrüchen komme ich endlich ins Backend, kann jedoch keine Vorschau betrachten.
    Kann dieser Fehler: "innodb_large_prefix"

    innodb_large_prefix.jpg

    die Ursache sein?
    Und gibt es irgendwo eine knappe Erklärung, an welcher Position (app/ oder nicht app/; welcher Pfad überhaupt; was ist, wenn sie fehlt?; ) und mit welchem default-Inhalt die config.yml zu finden ist? Ich habe stundenlang nach etwas Verwertbarem gesucht. Ich habe leider noch nicht das "Contao-Nerdlevel", dass sich mir diese Dinge automatisch erschliessen.

    Danke für Hilfe

  22. #62
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    6.489
    Partner-ID
    152
    User beschenken
    Wunschliste

    Standard

    Da Contao kein Javaapplikation ist, wird das auch kein "Java-Fehler" sein, den Du bekommst. Solltest Du trotzdem einen Hinweis bekommen, dass "Java" fehlt, dann bist Du vermutlich im falschen Forum oder hast ein anderes Problem.

    Eine Übersicht über Dateien und Ordner findest Du beispielsweise unter https://de.contaowiki.org/Ordner_und...en_in_Contao_4.

    Die Meldung aus dem geposteten Screenshot kommt in den allermeisten Fällen zustande wenn Dein Hoster seine Hausaufgaben nicht gemacht hat und MySQL nicht zeitgemäss konfiguriert ist. Die genannten Zeilen kannst Du per Copy & Paste in die Datei befördern, in der Deine Datenbank-Nutzung konfiguriert wird. Das sollte /app/config/config.yml sein. Damit weist Du Contao an, auf eine veraltete Konfiguration Rücksicht zu nehmen.

    Ich weiss nicht, welchen Fehler Du bei der Frontendvorschau siehst. Insofern kann ich auch nichts dazu beitragen, ob das eine mit dem anderen zusammen hängt. für mich liegt allerdings nahe, dass eine Applikation nicht wirklich funktionieren kann, wenn sie nicht korrekt installiert ist. Eine Meldung, sei es im Installtool oder im Backend oder im Frontend ist da immer ein starkes Indiz.

  23. #63
    Contao-Nutzer
    Registriert seit
    03.06.2019.
    Beiträge
    23

    Standard danke für die schnelle Antwort

    Da die "Java ist in Ihrem Browser nicht aktiviert"-Fehlermeldung nicht mehr erscheint, kann dieser Punkt hoffentlich als abgehakt betrachtet werden. Ich war beim Suchen im Forum aber nicht allein!

    "Eine Übersicht über Dateien und Ordner findest Du beispielsweise unter https://de.contaowiki.org/Ordner_und...en_in_Contao_4."
    Genau das finde ich in dem Artikel nicht.

    "app/
    app/config/
    app/config/parameters.yml
    Konfigurationsparameter der Anwendung, dies sind u.a. Datenbank-Zugangsdaten usw.

    app/config/config.yml
    Gemeinsame Konfigurationsdatei der Website, hier werden alle "services" konfiguriert."

    Der app-Ordner war bei mir gar nicht angelegt. Es ist auch kein Hinweis zu finden, wo er denn sein soll. Also hab ich unter htdocs/config/ einmal eine config.yml abgelegt und einen app/-Ordner kreiert und die config.yml da auch noch reingetan. Über den Minimal- Inhalt der config.yml bin ich immer noch im Unklaren. Ich weiß auch nicht, ob das was mit der nicht funktionierenden Vorschau zu tun hat oder ob ich mich erst ganz am Schluß gewaltig ärgern werde.

    "Die genannten Zeilen kannst Du per Copy & Paste in die Datei befördern, in der Deine Datenbank-Nutzung konfiguriert wird. Das sollte /app/config/config.yml sein. Damit weist Du Contao an, auf eine veraltete Konfiguration Rücksicht zu nehmen." - Welche Zeilen?

    Ich arbeite mit XAMPP.

  24. #64
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von korgoth Beitrag anzeigen
    Ich arbeite mit XAMPP.
    Welche Version?

  25. #65
    Contao-Nutzer
    Registriert seit
    03.06.2019.
    Beiträge
    23

    Standard 3.2.3

    3.2.3

  26. #66
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Das ist nicht die XAMPP Version, sondern die Version des XAMPP Control Panels. Aber aufgrund dieser Versionsangabe nehme ich an, dass du eine XAMPP Version vom 11.03.2019 oder später hast - also nicht zu alt.

    Du musst
    Code:
    innodb_large_prefix = ON
    innodb_file_format = Barracuda
    in deine my.ini hinzufügen.

  27. #67
    Contao-Nutzer
    Registriert seit
    03.06.2019.
    Beiträge
    23

    Standard

    das mit xampp ist korrekt. ich habe die Änderung vorgenommen.

    gestern lief noch alles. seit heute kommt:
    contao.security.jpg

    ich kann also nicht checken, ob das Erfolg hatte.
    Eine zu ändernde Datei namens contao.security habe ich nicht gefunden.

  28. #68
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Komischer Fehler. Lösche var/cache/ und vendor/ und installiere nochmal die Abhängigkeiten.

  29. #69
    Contao-Nutzer
    Registriert seit
    03.06.2019.
    Beiträge
    23

    Standard

    error 500.jpg

    wie schon so oft

  30. #70
    Contao-Nutzer
    Registriert seit
    03.06.2019.
    Beiträge
    23

    Standard

    repair.jpg

    xampp neustart

    terminated.jpg

  31. #71
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Bitte nicht nur Screenshots posten, sondern die Ausgabe der Konsole.

  32. #72
    Contao-Nutzer
    Registriert seit
    03.06.2019.
    Beiträge
    23

    Standard

    was meinst du damit? Das sind doch die Ausgaben. Wo soll ich gucken?

  33. #73
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    In den Screenshots sieht man natürlich immer nur einen Teil der Konsolenausgabe. Du solltest die gesamte Konsolenausgabe hier posten.

  34. #74
    Contao-Nutzer
    Registriert seit
    03.06.2019.
    Beiträge
    23

    Standard

    ok. kapiert

    Code:
    -------------
    $ C:^\XAMPP^\php^\php.exe "-q" "C:/xampp/htdocs/web/contao-manager.phar.php" "composer" "install" "--prefer-dist" "--no-dev" "--no-progress" "--no-suggest" "--no-ansi" "--no-interaction" "--optimize-autoloader" 2>&1
    
    Loading composer repositories with package information
    Installing dependencies from lock file
    Package operations: 162 installs, 0 updates, 0 removals
      - Installing contao-components/installer (1.3.1): Downloading (100%)
      - Installing ocramius/package-versions (1.5.1): Downloading (100%)
      - Installing symfony/polyfill-ctype (v1.12.0): Downloading (100%)
      - Installing symfony/polyfill-php73 (v1.12.0): Downloading (100%)
      - Installing symfony/polyfill-mbstring (v1.12.0): Downloading (100%)
      - Installing symfony/polyfill-php72 (v1.12.0): Downloading (100%)
      - Installing symfony/polyfill-intl-idn (v1.12.0): Downloading (100%)
      - Installing symfony/mime (v4.3.4): Downloading (100%)
      - Installing symfony/http-foundation (v4.3.4): Downloading (100%)
      - Installing symfony/event-dispatcher-contracts (v1.1.5): Downloading (100%)
      - Installing symfony/event-dispatcher (v4.3.4): Downloading (100%)
      - Installing psr/log (1.1.0): Downloading (100%)
      - Installing symfony/debug (v4.3.4): Downloading (100%)
      - Installing symfony/http-kernel (v4.3.4): Downloading (100%)
      - Installing psr/container (1.0.0): Downloading (100%)
      - Installing symfony/service-contracts (v1.1.6): Downloading (100%)
      - Installing symfony/dependency-injection (v4.3.4): Downloading (100%)
      - Installing symfony/filesystem (v4.3.4): Downloading (100%)
      - Installing symfony/config (v4.3.4): Downloading (100%)
      - Installing symfony/routing (v4.3.4): Downloading (100%)
      - Installing contao/manager-plugin (2.7.1): Downloading (100%)
      - Installing ausi/slug-generator (v1.1.0): Downloading (100%)
      - Installing dasprid/enum (1.0.0): Downloading (100%)
      - Installing bacon/bacon-qr-code (2.0.0): Downloading (100%)
      - Installing contao-components/ace (1.4.4): Downloading (100%)
      - Installing contao-components/chosen (1.2.2): Downloading (100%)
      - Installing contao-components/colorbox (1.6.5): Downloading (100%)
      - Installing contao-components/colorpicker (1.5.1): Downloading (100%)
      - Installing contao-components/contao (9.0.0): Downloading (100%)
      - Installing contao-components/datepicker (2.3.1): Downloading (100%)
      - Installing contao-components/dropzone (5.5.0): Downloading (100%)
      - Installing contao-components/highlight (9.15.6): Downloading (100%)
      - Installing contao-components/jquery (3.4.1): Downloading (100%)
      - Installing contao-components/jquery-ui (1.12.1.1): Downloading (100%)
      - Installing contao-components/mediabox (1.5.5): Downloading (100%)
      - Installing contao-components/mootools (1.6.0.6): Downloading (100%)
      - Installing contao-components/simplemodal (2.1.1): Downloading (100%)
      - Installing contao-components/swipe (2.2.0): Downloading (100%)
      - Installing contao-components/tablesort (4.0.1): Downloading (100%)
      - Installing contao-components/tablesorter (2.1.1): Downloading (100%)
      - Installing contao-components/tinymce4 (4.9.4): Downloading (100%)
      - Installing symfony/yaml (v4.3.4): Downloading (100%)
      - Installing patchwork/utf8 (v1.3.1): Downloading (100%)
      - Installing symfony/options-resolver (v4.3.4): Downloading (100%)
      - Installing psr/http-message (1.0.1): Downloading (100%)
      - Installing php-http/message-factory (v1.0.2): Downloading (100%)
      - Installing clue/stream-filter (v1.4.1): Downloading (100%)
      - Installing php-http/message (1.8.0): Downloading (100%)
      - Installing php-http/discovery (1.7.0): Downloading (100%)
      - Installing php-http/promise (v1.0.0): Downloading (100%)
      - Installing php-http/httplug (v1.1.0): Downloading (100%)
      - Installing ralouphie/getallheaders (3.0.3): Downloading (100%)
      - Installing guzzlehttp/psr7 (1.6.1): Downloading (100%)
      - Installing guzzlehttp/promises (v1.3.1): Downloading (100%)
      - Installing guzzlehttp/guzzle (6.3.3): Downloading (100%)
      - Installing php-http/guzzle6-adapter (v1.1.1): Downloading (100%)
      - Installing php-http/client-common (1.9.1): Downloading (100%)
      - Installing friendsofsymfony/http-cache (2.7.0): Downloading (100%)
      - Installing twig/twig (v2.11.3): Downloading (100%)
      - Installing true/punycode (v2.1.1): Downloading (100%)
      - Installing doctrine/lexer (1.1.0): Downloading (100%)
      - Installing doctrine/annotations (v1.7.0): Downloading (100%)
      - Installing terminal42/service-annotation-bundle (1.0.0): Downloading (100%)
      - Installing symfony/translation-contracts (v1.1.6): Downloading (100%)
      - Installing symfony/twig-bridge (v4.3.4): Downloading (100%)
      - Installing symfony/twig-bundle (v4.3.4): Downloading (100%)
      - Installing symfony/translation (v4.3.4): Downloading (100%)
      - Installing symfony/polyfill-iconv (v1.12.0): Downloading (100%)
      - Installing egulias/email-validator (2.1.11): Downloading (100%)
      - Installing swiftmailer/swiftmailer (v6.2.1): Downloading (100%)
      - Installing symfony/swiftmailer-bundle (v3.2.8): Downloading (100%)
      - Installing symfony/inflector (v4.3.4): Downloading (100%)
      - Installing symfony/property-access (v4.3.4): Downloading (100%)
      - Installing symfony/security (v4.3.4): Downloading (100%)
      - Installing symfony/security-bundle (v4.3.4):     Failed to download symfony/security-bundle from dist: Could not delete C:\xampp\htdocs\vendor/symfony/security-bundle\Tests: 
    This can be due to an antivirus or the Windows Search Indexer locking the file while they are analyzed
        Now trying to download from source
      - Installing symfony/security-bundle (v4.3.4): 
    In Filesystem.php line 217:
                                                                                   
      Could not delete C:\xampp\htdocs\vendor/symfony/security-bundle\Tests\Funct  
      ional:                                                                       
      This can be due to an antivirus or the Windows Search Indexer locking the f  
      ile while they are analyzed                                                  
                                                                                   
    
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...
    
    
    # Process terminated with exit code 1
    # Result: General error
    
    
    ---
    
    ### The background task has stopped unexpectedly ###
    
    ------------
    Geändert von Spooky (16.09.2019 um 10:36 Uhr) Grund: added [code] tags

  35. #75
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.378
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Bitte solche Dinge in [code] Tags posten.

    Hast du das mit dem Antivirus schon überprüft?

  36. #76
    Contao-Nutzer
    Registriert seit
    03.06.2019.
    Beiträge
    23

    Standard

    ok.
    nein. bisher hat das ja geklappt. gestern konnte ich backend arbeiten, heute früh -ohne Neustart- nicht mehr

    Code:
     
      Could not delete C:\xampp\htdocs\vendor/symfony/security-bundle\Tests\Funct  
      ional:                                                                       
      This can be due to an antivirus or the Windows Search Indexer locking the f  
      ile while they are analyzed
    Functional händisch gelöscht:

    Ergebnis:

    Code:
                                                                                  
    
    $ C:^\XAMPP^\php^\php.exe "-q" "C:/xampp/htdocs/web/contao-manager.phar.php" "composer" "install" "--prefer-dist" "--no-dev" "--no-progress" "--no-suggest" "--no-ansi" "--no-interaction" "--optimize-autoloader" 2>&1
    
    Loading composer repositories with package information
    Installing dependencies from lock file
    Nothing to install or update
    Generating optimized autoload files
    Warning: Ambiguous class resolution, "ProxyManager\Generator\Util\ProxiedMethodReturnExpression" was found in both "C:/xampp/htdocs/vendor/ocramius/proxy-manager/src/ProxyManager/Generator/Util/ProxiedMethodReturnExpression.php" and "C:\xampp\htdocs\vendor/symfony/proxy-manager-bridge/Legacy/ProxiedMethodReturnExpression.php", the first will be used.
    ocramius/package-versions: Generating version class...
    ocramius/package-versions: ...done generating version class
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    
    In ArrayNode.php line 327:
                                                                                   
      Unrecognized option "disable_ip_check" under "contao.security". Available o  
      ption is "two_factor".                                                       
                                                                                   
    
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    
    In ScriptHandler.php line 88:
                                                                                   
      An error occurred while executing the "contao:install-web-dir" command:      
      In ArrayNode.php line 327:                                                   
                                                                                   
                                                                                   
        Unrecognized option "disable_ip_check" under "contao.security". Available  
       o                                                                           
        ption is "two_factor".                                                     
                                                                                   
    
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...
    
    
    # Process terminated with exit code 1
    # Result: General error
    
    
    ---
    
    ### The background task has stopped unexpectedly ###

Seite 2 von 2 ErsteErste 12

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •