MetaModels Workshop in Berlin
Ergebnis 1 bis 39 von 39

Thema: Fehler bei der Installation

  1. #1
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard Fehler bei der Installation

    Hi Leute,
    ich habe heute bei der Installation einer Contao 4.5.4 via CM eine Fehlermeldung erhalten, die auf einen zu langen Installationspfad hinweist:

    Code:
    [2018-03-06 10:04:15] app.CRITICAL: An exception occurred. {"exception":"[object] (Doctrine\\DBAL\\Exception\\DriverException(code: 0): An exception occurred while executing 'CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT '' NOT NULL, path VARCHAR(1022) DEFAULT '' NOT NULL, extension VARCHAR(16) DEFAULT '' NOT NULL, hash VARCHAR(32) DEFAULT '' NOT NULL, found CHAR(1) DEFAULT '1' NOT NULL, name VARCHAR(255) DEFAULT '' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC':\n\nSQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 3072 bytes at /var/www/vhosts/hostingxxxxxx.xxxxx.xxxxxx.xxx/httpdocs/XX/xxxxx/contao4-xx/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php:121, Doctrine\\DBAL\\Driver\\PDOException(code: 42000): SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 3072 bytes at /var/www/vhosts/hostingxxxxxx.xxxxx.xxxxxx.xxx/httpdocs/XX/xxxxx/contao4-xx/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:106, PDOException(code: 42000): SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 3072 bytes at /var/www/vhosts/hostingxxxxxx.xxxxx.xxxxxx.xxx/httpdocs/XX/xxxxx/contao4-xx/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:104)"} []
    Komischweise habe ich vor ein paar Tagen in genau gleich "tiefem" Verzeichnis eine erfolgreiche Installation gemacht. Kann es sein, dass sich etwas an den Installationsdateien bzw. der Länge getan hat und es deshalb jetzt zu lang wurde?

    Oder ist es ein ganz anderer Fehler?

    Grüße aus Ludwigsburg
    Jochen Kubik
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    In der Fehlermeldung ist nicht von einem zu langen Installationspfad die Rede, sondern von einer zu langen Key Length für ein Datenbankfeld in tl_files.

    Wo genau tritt dieser Fehler auf? Reproduziere es in der Entwicklungsumgebung und Poste den kompletten Stack Trace.

  3. #3
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard

    Hi Spooky,
    vielen Dank für Deine schnelle Antwort!

    Du gehst immer davon aus, dass man Deine fachlichen Tipps sofort versteht, ich bin schon froh, dass ich die oben gepostete Fehlermeldung gefunden habe!!!
    - Ich habe keine "Entwicklungsumgebung" (was immer das ist!???) Ich installiere Contao auf dem Server, wie man das halt so macht ;-)
    - Meinst Du mit "Wo genau tritt dieser Fehler auf?" wann er auftritt? Wenn ich das Installtool aufrufe und die DB Daten eingegeben habe!
    - Ich weiß immer noch nicht wie ich an den "Stack Trace" komme!!!! (was immer das ist!???)

    Sorry!

    Grüße
    JK
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von kubjo Beitrag anzeigen
    - Meinst Du mit "Wo genau tritt dieser Fehler auf?" wann er auftritt? Wenn ich das Installtool aufrufe und die DB Daten eingegeben habe!
    - Ich weiß immer noch nicht wie ich an den "Stack Trace" komme!!!! (was immer das ist!???)
    Öffne das Install Tool mit https://example.org/app_dev.php/contao/install

  5. #5
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard

    Ok, jetzt bich ich bei "Datenbank aktualisieren"

    Contao Open Source CMS.png
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  6. #6
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard

    Hier scheinen die langen Pfade zu sein:
    Contao Open Source CMS(1).png
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    Du musst den Fehler auslösen und dann den Stack Trace posten.

  8. #8
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard

    Du machst mir Spaß!

    Meinst du das hier?

    Code:
    Doctrine\DBAL\Exception\DriverException:
    An exception occurred while executing 'CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT '' NOT NULL, path VARCHAR(1022) DEFAULT '' NOT NULL, extension VARCHAR(16) DEFAULT '' NOT NULL, hash VARCHAR(32) DEFAULT '' NOT NULL, found CHAR(1) DEFAULT '1' NOT NULL, name VARCHAR(255) DEFAULT '' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC':
    
    SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 3072 bytes
    
      at vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php:121
      at Doctrine\DBAL\Driver\AbstractMySQLDriver->convertException('An exception occurred while executing \'CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT \'\' NOT NULL, path VARCHAR(1022) DEFAULT \'\' NOT NULL, extension VARCHAR(16) DEFAULT \'\' NOT NULL, hash VARCHAR(32) DEFAULT \'\' NOT NULL, found CHAR(1) DEFAULT \'1\' NOT NULL, name VARCHAR(255) DEFAULT \'\' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC\':SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 3072 bytes', object(PDOException))
         (vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php:176)
      at Doctrine\DBAL\DBALException::wrapException(object(Driver), object(PDOException), 'An exception occurred while executing \'CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT \'\' NOT NULL, path VARCHAR(1022) DEFAULT \'\' NOT NULL, extension VARCHAR(16) DEFAULT \'\' NOT NULL, hash VARCHAR(32) DEFAULT \'\' NOT NULL, found CHAR(1) DEFAULT \'1\' NOT NULL, name VARCHAR(255) DEFAULT \'\' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC\':SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 3072 bytes')
         (vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php:150)
      at Doctrine\DBAL\DBALException::driverExceptionDuringQuery(object(Driver), object(PDOException), 'CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT \'\' NOT NULL, path VARCHAR(1022) DEFAULT \'\' NOT NULL, extension VARCHAR(16) DEFAULT \'\' NOT NULL, hash VARCHAR(32) DEFAULT \'\' NOT NULL, found CHAR(1) DEFAULT \'1\' NOT NULL, name VARCHAR(255) DEFAULT \'\' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC')
         (vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php:1014)
      at Doctrine\DBAL\Connection->query('CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT \'\' NOT NULL, path VARCHAR(1022) DEFAULT \'\' NOT NULL, extension VARCHAR(16) DEFAULT \'\' NOT NULL, hash VARCHAR(32) DEFAULT \'\' NOT NULL, found CHAR(1) DEFAULT \'1\' NOT NULL, name VARCHAR(255) DEFAULT \'\' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC')
         (vendor/contao/installation-bundle/src/Database/Installer.php:76)
      at Contao\InstallationBundle\Database\Installer->execCommand('f8e2ce866429d34943e8e53b8fe6d671')
         (vendor/contao/installation-bundle/src/Controller/InstallationController.php:448)
      at Contao\InstallationBundle\Controller\InstallationController->adjustDatabaseTables()
         (vendor/contao/installation-bundle/src/Controller/InstallationController.php:101)
      at Contao\InstallationBundle\Controller\InstallationController->installAction()
         (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:151)
      at Symfony\Component\HttpKernel\HttpKernel->handleRaw(object(Request), 1)
         (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:68)
      at Symfony\Component\HttpKernel\HttpKernel->handle(object(Request), 1, true)
         (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:202)
      at Symfony\Component\HttpKernel\Kernel->handle(object(Request))
         (web/app_dev.php:65)
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  9. #9
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    Vermutlich installierst du Contao 4.5.5, nicht Contao 4.5.4, korrekt?

  10. #10
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard

    Ja, ich starte den CM, der schlägt mit 4.5.5 vor... was ich dann abnicke!
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  11. #11
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    https://github.com/contao/installation-bundle/issues/88

    Welche MySQL/MariaDB Version verwendest du?

  12. #12
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard

    MySQL, v5.7.21 Maria noch nie gehört
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  13. #13
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard

    Dann gehe ich einfach auf 4.5.4 zurück?
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  14. #14
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    Komisch, unter MySQL 5.7.21 sollte es keine Probleme geben.

  15. #15
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard

    Kann ich noch was zur Klärung beitragen?
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  16. #16
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    Du kannst derweil 4.5.4 installieren, Datenbank aktualisieren und danach auf 4.5.5 updaten. Oder du wartest auf 4.5.6.

  17. #17
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard

    Wenn ich auf 4.5.4 gehe reicht da der core oder muß ich alle budles auf 4.5.4 switchen?
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  18. #18
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    Nur core-bundle reicht.

  19. #19
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    Contao 4.5.6 wurde schon released

  20. #20
    Contao-Fan Avatar von kubjo
    Registriert seit
    11.01.2011.
    Ort
    Ludwigsburg
    Beiträge
    990

    Standard

    Klasse, jetzt läuft's wieder!
    Wir sind alle Würmchen, nur glaube ich, daß ich ein Glühwürmchen bin.

  21. #21
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.031
    Partner-ID
    7421

    Standard

    Bei mir tritt dieses Problem mit Contao 4.5.7 und Maria DB 10.1.17 bei Webgo in einem Platinpaket auf (Neuistallation).


    Code:
    Doctrine\DBAL\Exception\DriverException:
    An exception occurred while executing 'CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT '' NOT NULL, path VARCHAR(1022) DEFAULT '' NOT NULL, extension VARCHAR(16) DEFAULT '' NOT NULL, hash VARCHAR(32) DEFAULT '' NOT NULL, found CHAR(1) DEFAULT '1' NOT NULL, name VARCHAR(255) DEFAULT '' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path(768)), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC':
    
    SQLSTATE[HY000]: General error: 1709 Index column size too large. The maximum column size is 767 bytes.
    
      at vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php:125
      at Doctrine\DBAL\Driver\AbstractMySQLDriver->convertException('An exception occurred while executing \'CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT \'\' NOT NULL, path VARCHAR(1022) DEFAULT \'\' NOT NULL, extension VARCHAR(16) DEFAULT \'\' NOT NULL, hash VARCHAR(32) DEFAULT \'\' NOT NULL, found CHAR(1) DEFAULT \'1\' NOT NULL, name VARCHAR(255) DEFAULT \'\' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path(768)), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC\':SQLSTATE[HY000]: General error: 1709 Index column size too large. The maximum column size is 767 bytes.', object(PDOException))
         (vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php:184)
      at Doctrine\DBAL\DBALException::wrapException(object(Driver), object(PDOException), 'An exception occurred while executing \'CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT \'\' NOT NULL, path VARCHAR(1022) DEFAULT \'\' NOT NULL, extension VARCHAR(16) DEFAULT \'\' NOT NULL, hash VARCHAR(32) DEFAULT \'\' NOT NULL, found CHAR(1) DEFAULT \'1\' NOT NULL, name VARCHAR(255) DEFAULT \'\' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path(768)), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC\':SQLSTATE[HY000]: General error: 1709 Index column size too large. The maximum column size is 767 bytes.')
         (vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php:158)
      at Doctrine\DBAL\DBALException::driverExceptionDuringQuery(object(Driver), object(PDOException), 'CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT \'\' NOT NULL, path VARCHAR(1022) DEFAULT \'\' NOT NULL, extension VARCHAR(16) DEFAULT \'\' NOT NULL, hash VARCHAR(32) DEFAULT \'\' NOT NULL, found CHAR(1) DEFAULT \'1\' NOT NULL, name VARCHAR(255) DEFAULT \'\' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path(768)), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC')
         (vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php:1037)
      at Doctrine\DBAL\Connection->query('CREATE TABLE tl_files (id INT UNSIGNED AUTO_INCREMENT NOT NULL, pid BINARY(16) DEFAULT NULL, tstamp INT UNSIGNED DEFAULT 0 NOT NULL, uuid BINARY(16) DEFAULT NULL, type VARCHAR(16) DEFAULT \'\' NOT NULL, path VARCHAR(1022) DEFAULT \'\' NOT NULL, extension VARCHAR(16) DEFAULT \'\' NOT NULL, hash VARCHAR(32) DEFAULT \'\' NOT NULL, found CHAR(1) DEFAULT \'1\' NOT NULL, name VARCHAR(255) DEFAULT \'\' NOT NULL, importantPartX INT DEFAULT 0 NOT NULL, importantPartY INT DEFAULT 0 NOT NULL, importantPartWidth INT DEFAULT 0 NOT NULL, importantPartHeight INT DEFAULT 0 NOT NULL, meta BLOB DEFAULT NULL, INDEX pid (pid), UNIQUE INDEX uuid (uuid), INDEX path (path(768)), INDEX extension (extension), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE = InnoDB ROW_FORMAT = DYNAMIC')
         (vendor/contao/installation-bundle/src/Database/Installer.php:76)
      at Contao\InstallationBundle\Database\Installer->execCommand('627bb3e11eedae7f25e6c83e5abcf403')
         (vendor/contao/installation-bundle/src/Controller/InstallationController.php:445)
      at Contao\InstallationBundle\Controller\InstallationController->adjustDatabaseTables()
         (vendor/contao/installation-bundle/src/Controller/InstallationController.php:101)
      at Contao\InstallationBundle\Controller\InstallationController->installAction()
         (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:151)
      at Symfony\Component\HttpKernel\HttpKernel->handleRaw(object(Request), 1)
         (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:68)
      at Symfony\Component\HttpKernel\HttpKernel->handle(object(Request), 1, true)
         (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:202)
      at Symfony\Component\HttpKernel\Kernel->handle(object(Request))
         (web/app_dev.php:67)
    Webgo hatte aber irgendwann mal zugesagt, dass sie innodb_large_prefix eingestellt haben. Sieht aber dann wohl nicht danach aus, oder?
    Wie kann ich das am besten prüfen?
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  22. #22
    Alter Contao-Hase Avatar von bizon
    Registriert seit
    16.06.2010.
    Beiträge
    1.026

    Standard

    Ich benutze für die Datenbankadministration den Adminer. Dort kann ich die Einstellungen für innodb_large_prefix unter Variablen(Servervariablen) einsehen und kann das bei Uberspace dort auch direkt bearbeiten. Müsste mit PhpMyadmin genauso funktionieren.
    Geändert von bizon (14.04.2018 um 19:38 Uhr)

  23. #23
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.884
    User beschenken
    Wunschliste

    Standard

    Also bei mir (Webgo, CMS Power) ist hat die Variable innodb_large_prefix den Wert "ON".
    Im phpMyAdmin im SQL-Fenster "SHOW VARIABLES" eingeben sollte helfen .

  24. #24
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.031
    Partner-ID
    7421

    Standard

    InnoDB_large ist an, aber das innodb_file_format steht nicht auf Barracuda sondern auf Antelope.
    Soll ich das als Fehler auf github melden?
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  25. #25
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.884
    User beschenken
    Wunschliste

    Standard

    Ja, das ist mal wieder spannend bei Webgo. Bei MYSQL ist der Default Barracuda und bei MariaDB Antelope. Antelope ist das ursprüngliche file format von InnoDB und unterstützt auch das row_format DYNAMIC nicht.

  26. #26
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.031
    Partner-ID
    7421

    Standard

    Ist nicht bei allen (Platin) Paketen so.
    Da ich bei dem einen Paket ja immer wieder die ein oder andere Ungereimtheit hatte, habe ich jetzt das Angebot zum Umzug auf einen anderen Server angenommen.
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  27. #27
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.884
    User beschenken
    Wunschliste

    Standard

    Ist in meinem CMS Power aber auch so. Bisher arbeite ich aber nur mit Contao 4.4 und MySQL Datenbanken, da macht es sich nicht bemerkbar. Aber schon mal gut zu wissen .

  28. #28
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.031
    Partner-ID
    7421

    Standard

    In meinem CMS Power nicht und in einigen Platin Paketen auch nicht.
    Da ich wegen der Umstellung mit Webgo gerade in Kontakt bin, habe ich das Thema der "falschen" bzw. unterschiedlichen Konfiguration gleich mit angesprochen.
    Habe auch Platinpakete ohne innodb_large_prefix.

    Insgesamt hatten sie ja in diesem Thread auf meine allgemeine Anfrage hin eigentlich schon mal mitgeteilt, dass sie das Problem beseitigt hätten.
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  29. #29
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von mlweb Beitrag anzeigen
    InnoDB_large ist an, aber das innodb_file_format steht nicht auf Barracuda sondern auf Antelope.
    Soll ich das als Fehler auf github melden?
    Ja, melde das auf GitHub. Also du kannst melden, dass wenn innodb_large_prefix zwar aktiv ist, innodb_file_format aber nicht auf Barracuda steht, es zu diesem Fehler kommt.

    Unabhängig davon solltest du das natürlich auch bei WebGo beanstanden.

  30. #30
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.031
    Partner-ID
    7421

    Standard

    Webgo habe ich natürlich schon, war mir nur nicht sicher ob das auch ein Thema zum Abfangen für Contao sein sollte.

    https://github.com/contao/installation-bundle/issues/91
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  31. #31
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.561
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Hallo zusammen,
    Stratomontag .

    Update von 3.5 auf 4.4.
    PHP 7.1
    MySQL 5.6.42
    Typ InnoDB
    innodb_file_format: Barracuda
    innodb_file_format_check: ON
    innodb_file_format_max: Barracuda

    Das Installtool bricht ab, solange dieses Statement enthalten ist:

    Code:
    CREATE INDEX path ON tl_files (path(333))'
    Den Trick mit Anlegen der dcaconfig.php habe ich auch versucht - klappte nicht.

    Dann habe ich direkt das Statement in PhpMyAdmin eingetragen und den Wert auf 255 gesetzt.
    Installation läuft nun durch - jetzt bleibt eben nur das Statement mit Wunsch auf 333 statt 255 Zeichen.

    Wie bekomme ich das auch noch gelöst? Danke für Tipps.
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Für Contao abstimmen: https://bitnami.com/product/contao/widget
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 Hoster: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with coding, testing and time.

  32. #32
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.553
    User beschenken
    Wunschliste

    Standard

    Folgende Optionen müssen im MySQL Server (unter einer gewissen Version) aktiv sein:
    Code:
    innodb_large_prefix = 1
    innodb_file_format = Barracuda
    innodb_file_per_table = 1
    Andernfalls musst auf die utf8 Krücke von MySQL ausweichen:
    Code:
    doctrine:
        dbal:
            connections:
                default:
                    default_table_options:
                        charset: utf8
                        collate: utf8_unicode_ci
    Folgendes in einer app/Resources/contao/dca/tl_files.php sollte aber auch funktionieren:
    PHP-Code:
    $GLOBALS['TL_DCA']['tl_files']['config']['sql']['keys']['path'] = 'index(255)'

  33. #33
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.561
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Folgende Optionen müssen im MySQL Server (unter einer gewissen Version) aktiv sein:
    Code:
    innodb_large_prefix = 1
    innodb_file_format = Barracuda
    innodb_file_per_table = 1
    Andernfalls musst auf die utf8 Krücke von MySQL ausweichen:
    Code:
    doctrine:
        dbal:
            connections:
                default:
                    default_table_options:
                        charset: utf8
                        collate: utf8_unicode_ci
    Folgendes in einer app/Resources/contao/dca/tl_files.php sollte aber auch funktionieren:
    PHP-Code:
    $GLOBALS['TL_DCA']['tl_files']['config']['sql']['keys']['path'] = 'index(255)'
    Danke für deine Tipps Spooky.
    Ich habe jetzt einmal die letzet Version versucht und die Ordner angelegt und die tl_files.php mit genanntem Inhalt angelegt.
    Rufe ich jetzt das Installtool auf, bleibt genau die Anpassung wie davor zur Auswahl bestehen.
    Produktiv- wie Symfonycache habe ich geleert…

    Ich habe jetzt die UTF8 Krücke verwendet
    Geändert von planepix (08.04.2019 um 14:30 Uhr)
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Für Contao abstimmen: https://bitnami.com/product/contao/widget
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 Hoster: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with coding, testing and time.

  34. #34
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.561
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Spannend: Nach dem Update auf 4.4.37 ist beim Installtool wieder
    Code:
    CREATE INDEX path ON tl_files (
      path(333)
    )
    da.

    Der Eintrag in der parameters,yml ist noch drin:
    Code:
    doctrine:
        dbal:
            connections:
                default:
                    default_table_options:
                        charset: utf8
                        collate: utf8_unicode_ci
    Gabs da schon Erkennntnisse?
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Für Contao abstimmen: https://bitnami.com/product/contao/widget
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 Hoster: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with coding, testing and time.

  35. #35
    Contao-Fan Avatar von PaddySD
    Registriert seit
    26.10.2016.
    Ort
    Andechs
    Beiträge
    659

    Standard

    Der schon wieder? Ich dachte, der ist in doctrine behoben worden???

    Ich würde da jetzt eher auf irgendwelche "falschen" Updates bzw Versionen tippen. Hast Du die aktuelle Version von doctrine installiert, oder ist da vielleicht was downgegraded worden? Schau doch mal Deine aktuell wirklich installierten Versionen an (composer.lock).

  36. #36
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.561
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Das ist die composer.lock

    Code:
    {
        "_readme": [
            "This file locks the dependencies of your project to a known state",
            "Read more about it at https://getcomposer.org/doc/01-basic-usage.md#installing-dependencies",
            "This file is @generated automatically"
        ],
        "content-hash": "7442b8809d65aa026511ce23a6466fac",
        "packages": [
            {
                "name": "clue/stream-filter",
                "version": "v1.4.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/clue/php-stream-filter.git",
                    "reference": "5a58cc30a8bd6a4eb8f856adf61dd3e013f53f71"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/clue/php-stream-filter/zipball/5a58cc30a8bd6a4eb8f856adf61dd3e013f53f71",
                    "reference": "5a58cc30a8bd6a4eb8f856adf61dd3e013f53f71",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3"
                },
                "require-dev": {
                    "phpunit/phpunit": "^5.0 || ^4.8"
                },
                "type": "library",
                "autoload": {
                    "psr-4": {
                        "Clue\\StreamFilter\\": "src/"
                    },
                    "files": [
                        "src/functions_include.php"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Christian Lück",
                        "email": "christian@lueck.tv"
                    }
                ],
                "description": "A simple and modern approach to stream filtering in PHP",
                "homepage": "https://github.com/clue/php-stream-filter",
                "keywords": [
                    "bucket brigade",
                    "callback",
                    "filter",
                    "php_user_filter",
                    "stream",
                    "stream_filter_append",
                    "stream_filter_register"
                ],
                "time": "2019-04-09T12:31:48+00:00"
            },
            {
                "name": "composer/ca-bundle",
                "version": "1.1.4",
                "source": {
                    "type": "git",
                    "url": "https://github.com/composer/ca-bundle.git",
                    "reference": "558f321c52faeb4828c03e7dc0cfe39a09e09a2d"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/composer/ca-bundle/zipball/558f321c52faeb4828c03e7dc0cfe39a09e09a2d",
                    "reference": "558f321c52faeb4828c03e7dc0cfe39a09e09a2d",
                    "shasum": ""
                },
                "require": {
                    "ext-openssl": "*",
                    "ext-pcre": "*",
                    "php": "^5.3.2 || ^7.0"
                },
                "require-dev": {
                    "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5",
                    "psr/log": "^1.0",
                    "symfony/process": "^2.5 || ^3.0 || ^4.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Composer\\CaBundle\\": "src"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Jordi Boggiano",
                        "email": "j.boggiano@seld.be",
                        "homepage": "http://seld.be"
                    }
                ],
                "description": "Lets you find a path to the system CA bundle, and includes a fallback to the Mozilla CA bundle.",
                "keywords": [
                    "cabundle",
                    "cacert",
                    "certificate",
                    "ssl",
                    "tls"
                ],
                "time": "2019-01-28T09:30:10+00:00"
            },
            {
                "name": "contao-community-alliance/composer-plugin",
                "version": "3.0.9",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-community-alliance/composer-plugin.git",
                    "reference": "2686fb2299fa4fcde1d3a54ec10cd497661d8536"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-community-alliance/composer-plugin/zipball/2686fb2299fa4fcde1d3a54ec10cd497661d8536",
                    "reference": "2686fb2299fa4fcde1d3a54ec10cd497661d8536",
                    "shasum": ""
                },
                "require": {
                    "composer-plugin-api": "^1.0",
                    "php": "^5.4 || ^7.0",
                    "symfony/finder": "^2.7 || ^3.0 || ^4.0",
                    "symfony/process": "^2.7 || ^3.0 || ^4.0"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/core-bundle": "<4.1"
                },
                "require-dev": {
                    "composer/composer": "~1.0",
                    "phpcq/all-tasks": "~1.1",
                    "symfony/phpunit-bridge": "^3.0"
                },
                "type": "composer-plugin",
                "extra": {
                    "class": "ContaoCommunityAlliance\\Composer\\Plugin\\Plugin",
                    "branch-alias": {
                        "dev-master": "3.0.x-dev",
                        "dev-develop": "3.1.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "ContaoCommunityAlliance\\Composer\\Plugin\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0+"
                ],
                "description": "Composer plugin that provides installers for contao-module and legacy-contao-module.",
                "homepage": "http://c-c-a.org/",
                "time": "2018-07-22T21:42:30+00:00"
            },
            {
                "name": "contao-components/ace",
                "version": "1.4.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/ace.git",
                    "reference": "0394ea336b2815eae37c32476cc8602fdb0c79fd"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/ace/zipball/0394ea336b2815eae37c32476cc8602fdb0c79fd",
                    "reference": "0394ea336b2815eae37c32476cc8602fdb0c79fd",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "BSD-3-Clause"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "ACE code editor integration for Contao Open Source CMS",
                "time": "2019-02-15T09:13:04+00:00"
            },
            {
                "name": "contao-components/chosen",
                "version": "1.2.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/chosen.git",
                    "reference": "ea040f6c9a217f3a3d5253634467dc2ac3434485"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/chosen/zipball/ea040f6c9a217f3a3d5253634467dc2ac3434485",
                    "reference": "ea040f6c9a217f3a3d5253634467dc2ac3434485",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Chosen integration for Contao Open Source CMS",
                "time": "2019-03-18T14:17:09+00:00"
            },
            {
                "name": "contao-components/colorbox",
                "version": "1.6.4.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/colorbox.git",
                    "reference": "99774cbad832fa78e5a1073fe8ba1ef07954125f"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/colorbox/zipball/99774cbad832fa78e5a1073fe8ba1ef07954125f",
                    "reference": "99774cbad832fa78e5a1073fe8ba1ef07954125f",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Colorbox integration for Contao Open Source CMS",
                "time": "2017-09-26T07:24:43+00:00"
            },
            {
                "name": "contao-components/colorpicker",
                "version": "1.5.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/colorpicker.git",
                    "reference": "821d3d0cdfc55bbb83448cb4d02f1c4a5fcc528a"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/colorpicker/zipball/821d3d0cdfc55bbb83448cb4d02f1c4a5fcc528a",
                    "reference": "821d3d0cdfc55bbb83448cb4d02f1c4a5fcc528a",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Color picker integration for Contao Open Source CMS",
                "time": "2018-11-29T14:20:38+00:00"
            },
            {
                "name": "contao-components/compass",
                "version": "0.12.2.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/compass.git",
                    "reference": "57f0d49607922a71b78101728cf03a5bde287a28"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/compass/zipball/57f0d49607922a71b78101728cf03a5bde287a28",
                    "reference": "57f0d49607922a71b78101728cf03a5bde287a28",
                    "shasum": ""
                },
                "type": "library",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Compass integration for Contao Open Source CMS",
                "time": "2016-07-07T11:45:34+00:00"
            },
            {
                "name": "contao-components/contao",
                "version": "7.1.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/contao.git",
                    "reference": "13b71489b62b63c5dd72d1e10d821aed551b0558"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/contao/zipball/13b71489b62b63c5dd72d1e10d821aed551b0558",
                    "reference": "13b71489b62b63c5dd72d1e10d821aed551b0558",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Contao Open Source CMS components",
                "time": "2018-02-27T21:13:23+00:00"
            },
            {
                "name": "contao-components/datepicker",
                "version": "2.3.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/datepicker.git",
                    "reference": "034591bf578028beaae704bbc3ad2ffc1588e2fb"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/datepicker/zipball/034591bf578028beaae704bbc3ad2ffc1588e2fb",
                    "reference": "034591bf578028beaae704bbc3ad2ffc1588e2fb",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Date picker integration for Contao Open Source CMS",
                "time": "2018-11-29T14:21:17+00:00"
            },
            {
                "name": "contao-components/dropzone",
                "version": "4.3.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/dropzone.git",
                    "reference": "5d198fb01f58fd79ff1bd7f5b187060393f8c505"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/dropzone/zipball/5d198fb01f58fd79ff1bd7f5b187060393f8c505",
                    "reference": "5d198fb01f58fd79ff1bd7f5b187060393f8c505",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "~1.0"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "DropZone integration for Contao Open Source CMS",
                "time": "2017-01-09T20:15:57+00:00"
            },
            {
                "name": "contao-components/highlight",
                "version": "8.9.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/highlight.git",
                    "reference": "92851aa223c597bfa15ebb170877af92d7243293"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/highlight/zipball/92851aa223c597bfa15ebb170877af92d7243293",
                    "reference": "92851aa223c597bfa15ebb170877af92d7243293",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "~1.0"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Highlight.js integration for Contao Open Source CMS",
                "time": "2015-11-10T13:11:20+00:00"
            },
            {
                "name": "contao-components/html5shiv",
                "version": "3.7.3",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/html5shiv.git",
                    "reference": "15fa06ddc9bc47a09f0c31bb93e26b789c3b43ea"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/html5shiv/zipball/15fa06ddc9bc47a09f0c31bb93e26b789c3b43ea",
                    "reference": "15fa06ddc9bc47a09f0c31bb93e26b789c3b43ea",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "~1.0"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "HTML5 Shiv integration for Contao Open Source CMS",
                "time": "2015-11-10T10:48:13+00:00"
            },
            {
                "name": "contao-components/installer",
                "version": "1.3.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/installer.git",
                    "reference": "0d04932172668f24f3b7af2ff26bf4b7fe0d9de5"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/installer/zipball/0d04932172668f24f3b7af2ff26bf4b7fe0d9de5",
                    "reference": "0d04932172668f24f3b7af2ff26bf4b7fe0d9de5",
                    "shasum": ""
                },
                "require": {
                    "composer-plugin-api": "^1.0",
                    "php": "^5.6 || ^7.0"
                },
                "require-dev": {
                    "composer/composer": "^1.0",
                    "friendsofphp/php-cs-fixer": "^2.12",
                    "php-coveralls/php-coveralls": "^2.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "composer-plugin",
                "extra": {
                    "class": "Contao\\ComponentsInstaller\\Composer\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\ComponentsInstaller\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Contao components installer",
                "time": "2018-12-21T15:54:01+00:00"
            },
            {
                "name": "contao-components/jquery",
                "version": "1.12.4",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/jquery.git",
                    "reference": "59c19392c1544945f90bb360a1b83abacae87a52"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/jquery/zipball/59c19392c1544945f90bb360a1b83abacae87a52",
                    "reference": "59c19392c1544945f90bb360a1b83abacae87a52",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "~1.0"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "jQuery integration for Contao Open Source CMS",
                "time": "2016-09-06T09:45:28+00:00"
            },
            {
                "name": "contao-components/jquery-ui",
                "version": "1.12.1.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/jquery-ui.git",
                    "reference": "1fabbe27469a6b44130c1ad38bd1aa0a2a3720a1"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/jquery-ui/zipball/1fabbe27469a6b44130c1ad38bd1aa0a2a3720a1",
                    "reference": "1fabbe27469a6b44130c1ad38bd1aa0a2a3720a1",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "jQuery UI integration for Contao Open Source CMS",
                "time": "2017-09-26T08:11:43+00:00"
            },
            {
                "name": "contao-components/mediabox",
                "version": "1.5.4.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/mediabox.git",
                    "reference": "728cedff60ed8918f31d5a807b33dedfe8f4b880"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/mediabox/zipball/728cedff60ed8918f31d5a807b33dedfe8f4b880",
                    "reference": "728cedff60ed8918f31d5a807b33dedfe8f4b880",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Mediabox integration for Contao Open Source CMS",
                "time": "2017-09-26T08:25:02+00:00"
            },
            {
                "name": "contao-components/mediaelement",
                "version": "4.2.10",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/mediaelement.git",
                    "reference": "b3b7b802ccab9f5514400bb4f99eaf24ef6d49e2"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/mediaelement/zipball/b3b7b802ccab9f5514400bb4f99eaf24ef6d49e2",
                    "reference": "b3b7b802ccab9f5514400bb4f99eaf24ef6d49e2",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "MediaElement.js integration for Contao Open Source CMS",
                "time": "2019-03-18T12:06:23+00:00"
            },
            {
                "name": "contao-components/mootools",
                "version": "1.6.0.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/mootools.git",
                    "reference": "69eb2a66c4da52de4e7fe3a852181ce53e46a046"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/mootools/zipball/69eb2a66c4da52de4e7fe3a852181ce53e46a046",
                    "reference": "69eb2a66c4da52de4e7fe3a852181ce53e46a046",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "MooTools integration for Contao Open Source CMS",
                "time": "2017-09-26T09:02:35+00:00"
            },
            {
                "name": "contao-components/respimage",
                "version": "1.4.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/respimage.git",
                    "reference": "c8e20216d7e958447b17429d631341dfdd0ebed9"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/respimage/zipball/c8e20216d7e958447b17429d631341dfdd0ebed9",
                    "reference": "c8e20216d7e958447b17429d631341dfdd0ebed9",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "~1.0"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Respimage.js integration for Contao Open Source CMS",
                "time": "2015-11-10T10:49:03+00:00"
            },
            {
                "name": "contao-components/simplemodal",
                "version": "2.1.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/simplemodal.git",
                    "reference": "3c8ccf34ab5deb6bb0fa8376be08c7b7a1fbc28d"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/simplemodal/zipball/3c8ccf34ab5deb6bb0fa8376be08c7b7a1fbc28d",
                    "reference": "3c8ccf34ab5deb6bb0fa8376be08c7b7a1fbc28d",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "SimpleModal integration for Contao Open Source CMS",
                "time": "2018-11-29T14:22:44+00:00"
            },
            {
                "name": "contao-components/swipe",
                "version": "2.1.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/swipe.git",
                    "reference": "ff0d34dcee2c7e1377e503b9e51230ca850a3124"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/swipe/zipball/ff0d34dcee2c7e1377e503b9e51230ca850a3124",
                    "reference": "ff0d34dcee2c7e1377e503b9e51230ca850a3124",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "A JavaScript touch slider with dot menu",
                "time": "2019-03-25T13:04:21+00:00"
            },
            {
                "name": "contao-components/tablesort",
                "version": "3.4.11",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/tablesort.git",
                    "reference": "b4e2ebed2277c80a8f3aedd291e69b1ee877d6b2"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/tablesort/zipball/b4e2ebed2277c80a8f3aedd291e69b1ee877d6b2",
                    "reference": "b4e2ebed2277c80a8f3aedd291e69b1ee877d6b2",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Contao Open Source CMS tablesort",
                "time": "2018-08-13T07:06:20+00:00"
            },
            {
                "name": "contao-components/tablesorter",
                "version": "2.1.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/tablesorter.git",
                    "reference": "b011a12758381caa6c405b7fc90c379b446197f8"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/tablesorter/zipball/b011a12758381caa6c405b7fc90c379b446197f8",
                    "reference": "b011a12758381caa6c405b7fc90c379b446197f8",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "jQuery tablesorter integration for Contao Open Source CMS",
                "time": "2018-08-13T07:06:27+00:00"
            },
            {
                "name": "contao-components/tinymce4",
                "version": "4.6.7.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao-components/tinymce4.git",
                    "reference": "40933994137ae78f88f4f3c336bb80fa81f33d7d"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao-components/tinymce4/zipball/40933994137ae78f88f4f3c336bb80fa81f33d7d",
                    "reference": "40933994137ae78f88f4f3c336bb80fa81f33d7d",
                    "shasum": ""
                },
                "require": {
                    "contao-components/installer": "^1.0.9"
                },
                "type": "contao-component",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-2.1+"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "TinyMCE 4 integration for Contao Open Source CMS",
                "time": "2017-10-07T19:55:54+00:00"
            },
            {
                "name": "contao/calendar-bundle",
                "version": "4.4.37",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/calendar-bundle.git",
                    "reference": "e6a91af61cbe033ede6f1f4add07078ebbe3cf0b"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/calendar-bundle/zipball/e6a91af61cbe033ede6f1f4add07078ebbe3cf0b",
                    "reference": "e6a91af61cbe033ede6f1f4add07078ebbe3cf0b",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\CalendarBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\CalendarBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Adds calendar functionality to Contao 4",
                "time": "2019-04-08T14:13:01+00:00"
            },
            {
                "name": "contao/comments-bundle",
                "version": "4.4.37",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/comments-bundle.git",
                    "reference": "bbe22045639e418fb3798899abeeed4c15667771"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/comments-bundle/zipball/bbe22045639e418fb3798899abeeed4c15667771",
                    "reference": "bbe22045639e418fb3798899abeeed4c15667771",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\CommentsBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\CommentsBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Adds comments functionality to Contao 4",
                "time": "2019-03-25T13:44:36+00:00"
            },
            {
                "name": "contao/conflicts",
                "version": "dev-master",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/conflicts.git",
                    "reference": "04c0e803ec55ad639a0353309b73b1c984b44262"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/conflicts/zipball/04c0e803ec55ad639a0353309b73b1c984b44262",
                    "reference": "04c0e803ec55ad639a0353309b73b1c984b44262",
                    "shasum": ""
                },
                "conflict": {
                    "doctrine/dbal": "2.9.* <2.9.3",
                    "doctrine/doctrine-migrations-bundle": "<1.1",
                    "doctrine/orm": "<2.4",
                    "knplabs/knp-time-bundle": "1.9.0",
                    "lexik/maintenance-bundle": "2.1.4",
                    "symfony/finder": "3.4.7 || 4.0.7",
                    "symfony/security": "3.3.17 || 3.4.7 || 3.4.8 || 3.4.11",
                    "symfony/swiftmailer-bundle": "2.6.* <2.6.2",
                    "symfony/twig-bundle": "4.1.0",
                    "twig/twig": "2.7.0"
                },
                "type": "metapackage",
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Contao 4 conflicting packages",
                "time": "2019-03-13T08:44:21+00:00"
            },
            {
                "name": "contao/core-bundle",
                "version": "4.4.37",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/core-bundle.git",
                    "reference": "fb8b27463025542cb6fab4fbd98af443d6255de9"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/core-bundle/zipball/fb8b27463025542cb6fab4fbd98af443d6255de9",
                    "reference": "fb8b27463025542cb6fab4fbd98af443d6255de9",
                    "shasum": ""
                },
                "require": {
                    "contao-components/ace": "^1.2",
                    "contao-components/chosen": "^1.1.6",
                    "contao-components/colorbox": "^1.6",
                    "contao-components/colorpicker": "^1.4.0.1",
                    "contao-components/compass": "^0.12",
                    "contao-components/contao": "^7.1.4",
                    "contao-components/datepicker": "^2.2.0.2",
                    "contao-components/dropzone": "^4.1.1",
                    "contao-components/highlight": "^8.9",
                    "contao-components/html5shiv": "^3.7.3",
                    "contao-components/jquery": "^1.11.3",
                    "contao-components/jquery-ui": "^1.11.4",
                    "contao-components/mediabox": "^1.5",
                    "contao-components/mediaelement": "^4.1",
                    "contao-components/mootools": "^1.6.0.1",
                    "contao-components/respimage": "^1.4",
                    "contao-components/simplemodal": "^2.0.3",
                    "contao-components/swipe": "^2.0.3",
                    "contao-components/tablesort": "^3.4.5",
                    "contao-components/tablesorter": "^2.0.5.3",
                    "contao-components/tinymce4": "4.6.*",
                    "contao/image": "^0.3.1",
                    "contao/imagine-svg": "^0.1.2 || ^0.2",
                    "doctrine/dbal": "^2.5",
                    "doctrine/doctrine-bundle": "^1.6",
                    "doctrine/doctrine-cache-bundle": "^1.3",
                    "ext-dom": "*",
                    "ext-gd": "*",
                    "ext-pcre": "*",
                    "imagine/imagine": "^0.6 || ^0.7 || ^1.0",
                    "knplabs/knp-menu-bundle": "^2.1",
                    "knplabs/knp-time-bundle": "^1.5.2",
                    "leafo/scssphp": "^0.6 || ^0.7",
                    "league/uri": "^4.0",
                    "matthiasmullie/minify": "^1.3",
                    "michelf/php-markdown": "^1.4",
                    "nelmio/cors-bundle": "^1.5.3",
                    "oyejorge/less.php": "^1.7",
                    "patchwork/utf8": "^1.2",
                    "php": "^5.6 || ^7.0",
                    "phpspec/php-diff": "^1.0",
                    "phpunit/php-token-stream": "^1.4 || ^2.0 || ^3.0",
                    "psr/log": "^1.0",
                    "simplepie/simplepie": "^1.3",
                    "symfony/console": "^3.3.7",
                    "symfony/filesystem": "^3.3",
                    "symfony/finder": "^3.3",
                    "symfony/framework-bundle": "^3.3",
                    "symfony/http-foundation": "^3.3.5",
                    "symfony/security": "^3.3",
                    "symfony/swiftmailer-bundle": "^2.3",
                    "symfony/yaml": "^3.3",
                    "tecnickcom/tcpdf": "^6.2.22",
                    "terminal42/header-replay-bundle": "^1.2",
                    "true/punycode": "^2.1",
                    "twig/twig": "^1.26",
                    "webmozart/path-util": "^2.0"
                },
                "conflict": {
                    "contao-community-alliance/composer-plugin": "<3.0",
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0",
                    "doctrine/dbal": "2.9.* <2.9.3",
                    "doctrine/doctrine-migrations-bundle": "<1.1",
                    "doctrine/orm": "<2.4",
                    "knplabs/knp-time-bundle": "1.9.0",
                    "lexik/maintenance-bundle": "2.1.4",
                    "symfony/finder": "3.4.7",
                    "symfony/security": "3.3.17 || 3.4.7 || 3.4.8 || 3.4.11",
                    "symfony/swiftmailer-bundle": "2.6.* <2.6.2"
                },
                "require-dev": {
                    "composer/composer": "^1.0",
                    "contao/manager-plugin": "^2.2",
                    "doctrine/doctrine-migrations-bundle": "^1.1",
                    "doctrine/orm": "^2.5",
                    "ext-fileinfo": "*",
                    "lexik/maintenance-bundle": "^2.1.3",
                    "monolog/monolog": "^1.22",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7.26",
                    "symfony/phpunit-bridge": "^3.3.11"
                },
                "suggest": {
                    "lexik/maintenance-bundle": "To put the application into maintenance mode"
                },
                "type": "symfony-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\CoreBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\CoreBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "files": [
                        "src/Resources/functions/utf8_bootup.php"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/helper/functions.php",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/",
                        "src/Resources/contao/themes/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Contao 4 core bundle",
                "time": "2019-04-09T08:44:02+00:00"
            },
            {
                "name": "contao/faq-bundle",
                "version": "4.4.37",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/faq-bundle.git",
                    "reference": "809186158808654d9cd266150f453ba98c453c9d"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/faq-bundle/zipball/809186158808654d9cd266150f453ba98c453c9d",
                    "reference": "809186158808654d9cd266150f453ba98c453c9d",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\FaqBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\FaqBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Adds FAQ functionality to Contao 4",
                "time": "2019-02-19T17:43:21+00:00"
            },
            {
                "name": "contao/image",
                "version": "0.3.9",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/image.git",
                    "reference": "c5d4aa8fc3226306a3e85cfd05dd0a764f8cab79"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/image/zipball/c5d4aa8fc3226306a3e85cfd05dd0a764f8cab79",
                    "reference": "c5d4aa8fc3226306a3e85cfd05dd0a764f8cab79",
                    "shasum": ""
                },
                "require": {
                    "contao/imagine-svg": "^0.1.4 || ^0.2",
                    "imagine/imagine": "^0.6 || ^0.7 || ^1.0",
                    "php": "^5.6 || ^7.0",
                    "symfony/filesystem": "^2.8 || ^3.0 || ^4.0",
                    "webmozart/path-util": "^2.0"
                },
                "require-dev": {
                    "friendsofphp/php-cs-fixer": "^2.12",
                    "php-coveralls/php-coveralls": "^2.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-develop": "0.4.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\Image\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Martin Auswöger",
                        "homepage": "https://github.com/ausi"
                    }
                ],
                "description": "Contao image library",
                "time": "2019-01-28T20:29:46+00:00"
            },
            {
                "name": "contao/imagine-svg",
                "version": "0.2.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/imagine-svg.git",
                    "reference": "df9603dce9176eff8a66e1d0c8defffb87275ee3"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/imagine-svg/zipball/df9603dce9176eff8a66e1d0c8defffb87275ee3",
                    "reference": "df9603dce9176eff8a66e1d0c8defffb87275ee3",
                    "shasum": ""
                },
                "require": {
                    "ext-dom": "*",
                    "imagine/imagine": "^0.6 || ^0.7 || ^1.0",
                    "php": "^5.6 || ^7.0"
                },
                "require-dev": {
                    "friendsofphp/php-cs-fixer": "^2.12",
                    "php-coveralls/php-coveralls": "^2.1",
                    "phpunit/phpunit": "^5.7.26",
                    "symfony/filesystem": "^2.8 || ^3.0 || ^4.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-develop": "0.2.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\ImagineSvg\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Martin Auswöger",
                        "homepage": "https://github.com/ausi"
                    }
                ],
                "description": "Contao Imagine SVG library",
                "time": "2019-01-27T12:41:51+00:00"
            },
            {
                "name": "contao/installation-bundle",
                "version": "4.4.37",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/installation-bundle.git",
                    "reference": "8fef694d41ac3276672f135e8e3e40b21d34af9f"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/installation-bundle/zipball/8fef694d41ac3276672f135e8e3e40b21d34af9f",
                    "reference": "8fef694d41ac3276672f135e8e3e40b21d34af9f",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "sensio/distribution-bundle": "^5.0",
                    "sensiolabs/ansi-to-html": "^1.1",
                    "symfony/filesystem": "^3.3",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\InstallationBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\InstallationBundle\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Required to install and update Contao 4",
                "time": "2019-03-25T13:44:36+00:00"
            },
            {
                "name": "contao/listing-bundle",
                "version": "4.4.37",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/listing-bundle.git",
                    "reference": "c32aae08d624c078a353aed624651cb1b85b96cb"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/listing-bundle/zipball/c32aae08d624c078a353aed624651cb1b85b96cb",
                    "reference": "c32aae08d624c078a353aed624651cb1b85b96cb",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\ListingBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\ListingBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Allows to list arbitrary data in the Contao 4 front end",
                "time": "2019-02-19T17:43:21+00:00"
            },
            {
                "name": "contao/manager-bundle",
                "version": "4.4.37",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/manager-bundle.git",
                    "reference": "225d1c64e91adecb40081df4a5d501086a0511ff"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/manager-bundle/zipball/225d1c64e91adecb40081df4a5d501086a0511ff",
                    "reference": "225d1c64e91adecb40081df4a5d501086a0511ff",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "contao/installation-bundle": "self.version",
                    "contao/manager-plugin": "^2.1",
                    "doctrine/doctrine-bundle": "^1.6",
                    "friendsofsymfony/http-cache": "^2.0",
                    "lexik/maintenance-bundle": "^2.1.3",
                    "nelmio/security-bundle": "^2.2",
                    "php": "^5.6 || ^7.0",
                    "php-http/guzzle6-adapter": "^1.1",
                    "symfony/monolog-bundle": "^2.8 || ^3.0",
                    "symfony/swiftmailer-bundle": "^2.3",
                    "symfony/symfony": "^3.3.7",
                    "terminal42/header-replay-bundle": "^1.4.2"
                },
                "require-dev": {
                    "composer/composer": "^1.0",
                    "phpunit/phpunit": "^5.7.26",
                    "symfony/phpunit-bridge": "^3.3.11"
                },
                "bin": [
                    "bin/contao-console"
                ],
                "type": "symfony-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\ManagerBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\ManagerBundle\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Andreas Schempp",
                        "homepage": "https://github.com/aschempp"
                    }
                ],
                "description": "Contao 4 manager bundle",
                "time": "2019-02-19T17:43:21+00:00"
            },
            {
                "name": "contao/manager-plugin",
                "version": "2.7.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/manager-plugin.git",
                    "reference": "fa435ac765be38bc31dc37562c70948e4f1ec951"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/manager-plugin/zipball/fa435ac765be38bc31dc37562c70948e4f1ec951",
                    "reference": "fa435ac765be38bc31dc37562c70948e4f1ec951",
                    "shasum": ""
                },
                "require": {
                    "composer-plugin-api": "^1.1",
                    "php": "^7.1",
                    "symfony/config": "^3.3 || ^4.0",
                    "symfony/dependency-injection": "^3.3 || ^4.0",
                    "symfony/filesystem": "^3.3 || ^4.0",
                    "symfony/http-kernel": "^3.3 || ^4.0",
                    "symfony/routing": "^3.3 || ^4.0"
                },
                "require-dev": {
                    "composer/composer": "^1.1",
                    "contao/core-bundle": "^4.5",
                    "ext-zip": "*",
                    "friendsofphp/php-cs-fixer": "^2.12",
                    "php-coveralls/php-coveralls": "^2.1",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^6.5",
                    "symfony/phpunit-bridge": "^3.4.5"
                },
                "type": "composer-plugin",
                "extra": {
                    "branch-alias": {
                        "dev-2.7": "2.7.x-dev"
                    },
                    "class": [
                        "Contao\\ManagerPlugin\\Composer\\ArtifactsPlugin",
                        "Contao\\ManagerPlugin\\Composer\\ManagerPluginInstaller"
                    ]
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\ManagerPlugin\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Andreas Schempp",
                        "homepage": "https://github.com/aschempp"
                    }
                ],
                "description": "Contao 4 manager plugin",
                "time": "2019-02-06T09:22:58+00:00"
            },
            {
                "name": "contao/news-bundle",
                "version": "4.4.37",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/news-bundle.git",
                    "reference": "e39a25b64308ff7c48a32ea63077b415f4f291a7"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/news-bundle/zipball/e39a25b64308ff7c48a32ea63077b415f4f291a7",
                    "reference": "e39a25b64308ff7c48a32ea63077b415f4f291a7",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1",
                    "phpunit/phpunit": "^5.7.26"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\NewsBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\NewsBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Adds news functionality to Contao 4",
                "time": "2019-02-19T17:43:21+00:00"
            },
            {
                "name": "contao/newsletter-bundle",
                "version": "4.4.37",
                "source": {
                    "type": "git",
                    "url": "https://github.com/contao/newsletter-bundle.git",
                    "reference": "cd5c0b92f99781cb1d83200369664e3dbb8bf1d3"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/contao/newsletter-bundle/zipball/cd5c0b92f99781cb1d83200369664e3dbb8bf1d3",
                    "reference": "cd5c0b92f99781cb1d83200369664e3dbb8bf1d3",
                    "shasum": ""
                },
                "require": {
                    "contao/core-bundle": "self.version",
                    "php": "^5.6 || ^7.0",
                    "symfony/framework-bundle": "^3.3"
                },
                "conflict": {
                    "contao/core": "*",
                    "contao/manager-plugin": "<2.0 || >=3.0"
                },
                "require-dev": {
                    "contao/manager-plugin": "^2.0",
                    "php-http/guzzle6-adapter": "^1.1"
                },
                "type": "contao-bundle",
                "extra": {
                    "contao-manager-plugin": "Contao\\NewsletterBundle\\ContaoManager\\Plugin"
                },
                "autoload": {
                    "psr-4": {
                        "Contao\\NewsletterBundle\\": "src/"
                    },
                    "classmap": [
                        "src/Resources/contao/"
                    ],
                    "exclude-from-classmap": [
                        "src/Resources/contao/config/",
                        "src/Resources/contao/dca/",
                        "src/Resources/contao/languages/",
                        "src/Resources/contao/templates/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "LGPL-3.0-or-later"
                ],
                "authors": [
                    {
                        "name": "Leo Feyer",
                        "homepage": "https://github.com/leofeyer"
                    }
                ],
                "description": "Adds newsletter functionality to Contao 4",
                "time": "2019-03-25T13:44:36+00:00"
            },
            {
                "name": "doctrine/annotations",
                "version": "v1.6.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/annotations.git",
                    "reference": "53120e0eb10355388d6ccbe462f1fea34ddadb24"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/annotations/zipball/53120e0eb10355388d6ccbe462f1fea34ddadb24",
                    "reference": "53120e0eb10355388d6ccbe462f1fea34ddadb24",
                    "shasum": ""
                },
                "require": {
                    "doctrine/lexer": "1.*",
                    "php": "^7.1"
                },
                "require-dev": {
                    "doctrine/cache": "1.*",
                    "phpunit/phpunit": "^6.4"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.6.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\Annotations\\": "lib/Doctrine/Common/Annotations"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    }
                ],
                "description": "Docblock Annotations Parser",
                "homepage": "http://www.doctrine-project.org",
                "keywords": [
                    "annotations",
                    "docblock",
                    "parser"
                ],
                "time": "2019-03-25T19:12:02+00:00"
            },
            {
                "name": "doctrine/cache",
                "version": "v1.8.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/cache.git",
                    "reference": "d768d58baee9a4862ca783840eca1b9add7a7f57"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/cache/zipball/d768d58baee9a4862ca783840eca1b9add7a7f57",
                    "reference": "d768d58baee9a4862ca783840eca1b9add7a7f57",
                    "shasum": ""
                },
                "require": {
                    "php": "~7.1"
                },
                "conflict": {
                    "doctrine/common": ">2.2,<2.4"
                },
                "require-dev": {
                    "alcaeus/mongo-php-adapter": "^1.1",
                    "doctrine/coding-standard": "^4.0",
                    "mongodb/mongodb": "^1.1",
                    "phpunit/phpunit": "^7.0",
                    "predis/predis": "~1.0"
                },
                "suggest": {
                    "alcaeus/mongo-php-adapter": "Required to use legacy MongoDB driver"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.8.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\Cache\\": "lib/Doctrine/Common/Cache"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    }
                ],
                "description": "Caching library offering an object-oriented API for many cache backends",
                "homepage": "https://www.doctrine-project.org",
                "keywords": [
                    "cache",
                    "caching"
                ],
                "time": "2018-08-21T18:01:43+00:00"
            },
            {
                "name": "doctrine/collections",
                "version": "v1.6.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/collections.git",
                    "reference": "d2ae4ef05e25197343b6a39bae1d3c427a2f6956"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/collections/zipball/d2ae4ef05e25197343b6a39bae1d3c427a2f6956",
                    "reference": "d2ae4ef05e25197343b6a39bae1d3c427a2f6956",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.1.3"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^6.0",
                    "phpstan/phpstan-shim": "^0.9.2",
                    "phpunit/phpunit": "^7.0",
                    "vimeo/psalm": "^3.2.2"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.6.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\Collections\\": "lib/Doctrine/Common/Collections"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    }
                ],
                "description": "PHP Doctrine Collections library that adds additional functionality on top of PHP arrays.",
                "homepage": "https://www.doctrine-project.org/projects/collections.html",
                "keywords": [
                    "array",
                    "collections",
                    "iterators",
                    "php"
                ],
                "time": "2019-03-25T19:03:48+00:00"
            },
            {
                "name": "doctrine/common",
                "version": "v2.10.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/common.git",
                    "reference": "30e33f60f64deec87df728c02b107f82cdafad9d"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/common/zipball/30e33f60f64deec87df728c02b107f82cdafad9d",
                    "reference": "30e33f60f64deec87df728c02b107f82cdafad9d",
                    "shasum": ""
                },
                "require": {
                    "doctrine/annotations": "^1.0",
                    "doctrine/cache": "^1.0",
                    "doctrine/collections": "^1.0",
                    "doctrine/event-manager": "^1.0",
                    "doctrine/inflector": "^1.0",
                    "doctrine/lexer": "^1.0",
                    "doctrine/persistence": "^1.1",
                    "doctrine/reflection": "^1.0",
                    "php": "^7.1"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^1.0",
                    "phpunit/phpunit": "^6.3",
                    "squizlabs/php_codesniffer": "^3.0",
                    "symfony/phpunit-bridge": "^4.0.5"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.10.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\": "lib/Doctrine/Common"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    },
                    {
                        "name": "Marco Pivetta",
                        "email": "ocramius@gmail.com"
                    }
                ],
                "description": "PHP Doctrine Common project is a library that provides additional functionality that other Doctrine projects depend on such as better reflection support, persistence interfaces, proxies, event system and much more.",
                "homepage": "https://www.doctrine-project.org/projects/common.html",
                "keywords": [
                    "common",
                    "doctrine",
                    "php"
                ],
                "time": "2018-11-21T01:24:55+00:00"
            },
            {
                "name": "doctrine/dbal",
                "version": "v2.8.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/dbal.git",
                    "reference": "a9019c1e3232eacace373a6ba957a85b66a255c1"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/dbal/zipball/a9019c1e3232eacace373a6ba957a85b66a255c1",
                    "reference": "a9019c1e3232eacace373a6ba957a85b66a255c1",
                    "shasum": ""
                },
                "require": {
                    "doctrine/cache": "^1.0",
                    "doctrine/event-manager": "^1.0",
                    "ext-pdo": "*",
                    "php": "^7.1"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^4.0",
                    "jetbrains/phpstorm-stubs": "^2018.1.2",
                    "phpstan/phpstan": "^0.10.1",
                    "phpunit/phpunit": "^7.1.2",
                    "phpunit/phpunit-mock-objects": "!=3.2.4,!=3.2.5",
                    "symfony/console": "^2.0.5|^3.0|^4.0",
                    "symfony/phpunit-bridge": "^3.4.5|^4.0.5"
                },
                "suggest": {
                    "symfony/console": "For helpful console commands such as SQL execution and import of files."
                },
                "bin": [
                    "bin/doctrine-dbal"
                ],
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.8.x-dev",
                        "dev-develop": "3.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-0": {
                        "Doctrine\\DBAL\\": "lib/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    }
                ],
                "description": "Database Abstraction Layer",
                "homepage": "http://www.doctrine-project.org",
                "keywords": [
                    "database",
                    "dbal",
                    "persistence",
                    "queryobject"
                ],
                "time": "2018-12-04T06:44:25+00:00"
            },
            {
                "name": "doctrine/doctrine-bundle",
                "version": "1.10.2",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/DoctrineBundle.git",
                    "reference": "1f99e6645030542079c57d4680601a4a8778a1bd"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/DoctrineBundle/zipball/1f99e6645030542079c57d4680601a4a8778a1bd",
                    "reference": "1f99e6645030542079c57d4680601a4a8778a1bd",
                    "shasum": ""
                },
                "require": {
                    "doctrine/dbal": "^2.5.12",
                    "doctrine/doctrine-cache-bundle": "~1.2",
                    "jdorn/sql-formatter": "^1.2.16",
                    "php": "^5.5.9|^7.0",
                    "symfony/console": "~2.7|~3.0|~4.0",
                    "symfony/dependency-injection": "~2.7|~3.0|~4.0",
                    "symfony/doctrine-bridge": "~2.7|~3.0|~4.0",
                    "symfony/framework-bundle": "^2.7.22|~3.0|~4.0"
                },
                "conflict": {
                    "symfony/http-foundation": "<2.6"
                },
                "require-dev": {
                    "doctrine/orm": "~2.4",
                    "php-coveralls/php-coveralls": "^2.1",
                    "phpunit/phpunit": "^4.8.36|^5.7|^6.4",
                    "symfony/phpunit-bridge": "~2.7|~3.0|~4.0",
                    "symfony/property-info": "~2.8|~3.0|~4.0",
                    "symfony/validator": "~2.7|~3.0|~4.0",
                    "symfony/web-profiler-bundle": "~2.7|~3.0|~4.0",
                    "symfony/yaml": "~2.7|~3.0|~4.0",
                    "twig/twig": "~1.26|~2.0"
                },
                "suggest": {
                    "doctrine/orm": "The Doctrine ORM integration is optional in the bundle.",
                    "symfony/web-profiler-bundle": "To use the data collector."
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.9.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Bundle\\DoctrineBundle\\": ""
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Symfony Community",
                        "homepage": "http://symfony.com/contributors"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Doctrine Project",
                        "homepage": "http://www.doctrine-project.org/"
                    },
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    }
                ],
                "description": "Symfony DoctrineBundle",
                "homepage": "http://www.doctrine-project.org",
                "keywords": [
                    "database",
                    "dbal",
                    "orm",
                    "persistence"
                ],
                "time": "2019-02-06T13:18:04+00:00"
            },
            {
                "name": "doctrine/doctrine-cache-bundle",
                "version": "1.3.5",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/DoctrineCacheBundle.git",
                    "reference": "5514c90d9fb595e1095e6d66ebb98ce9ef049927"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/DoctrineCacheBundle/zipball/5514c90d9fb595e1095e6d66ebb98ce9ef049927",
                    "reference": "5514c90d9fb595e1095e6d66ebb98ce9ef049927",
                    "shasum": ""
                },
                "require": {
                    "doctrine/cache": "^1.4.2",
                    "doctrine/inflector": "~1.0",
                    "php": ">=5.3.2",
                    "symfony/doctrine-bridge": "~2.7|~3.3|~4.0"
                },
                "require-dev": {
                    "instaclick/coding-standard": "~1.1",
                    "instaclick/object-calisthenics-sniffs": "dev-master",
                    "instaclick/symfony2-coding-standard": "dev-remaster",
                    "phpunit/phpunit": "~4.8.36|~5.6|~6.5|~7.0",
                    "predis/predis": "~0.8",
                    "satooshi/php-coveralls": "^1.0",
                    "squizlabs/php_codesniffer": "~1.5",
                    "symfony/console": "~2.7|~3.3|~4.0",
                    "symfony/finder": "~2.7|~3.3|~4.0",
                    "symfony/framework-bundle": "~2.7|~3.3|~4.0",
                    "symfony/phpunit-bridge": "~2.7|~3.3|~4.0",
                    "symfony/security-acl": "~2.7|~3.3",
                    "symfony/validator": "~2.7|~3.3|~4.0",
                    "symfony/yaml": "~2.7|~3.3|~4.0"
                },
                "suggest": {
                    "symfony/security-acl": "For using this bundle to cache ACLs"
                },
                "type": "symfony-bundle",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.3.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Bundle\\DoctrineCacheBundle\\": ""
                    },
                    "exclude-from-classmap": [
                        "/Tests/"
                    ]
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Symfony Community",
                        "homepage": "http://symfony.com/contributors"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Fabio B. Silva",
                        "email": "fabio.bat.silva@gmail.com"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@hotmail.com"
                    },
                    {
                        "name": "Doctrine Project",
                        "homepage": "http://www.doctrine-project.org/"
                    },
                    {
                        "name": "Fabien Potencier",
                        "email": "fabien@symfony.com"
                    }
                ],
                "description": "Symfony Bundle for Doctrine Cache",
                "homepage": "https://www.doctrine-project.org",
                "keywords": [
                    "cache",
                    "caching"
                ],
                "time": "2018-11-09T06:25:35+00:00"
            },
            {
                "name": "doctrine/event-manager",
                "version": "v1.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/event-manager.git",
                    "reference": "a520bc093a0170feeb6b14e9d83f3a14452e64b3"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/event-manager/zipball/a520bc093a0170feeb6b14e9d83f3a14452e64b3",
                    "reference": "a520bc093a0170feeb6b14e9d83f3a14452e64b3",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.1"
                },
                "conflict": {
                    "doctrine/common": "<2.9@dev"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^4.0",
                    "phpunit/phpunit": "^7.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\": "lib/Doctrine/Common"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    },
                    {
                        "name": "Marco Pivetta",
                        "email": "ocramius@gmail.com"
                    }
                ],
                "description": "Doctrine Event Manager component",
                "homepage": "https://www.doctrine-project.org/projects/event-manager.html",
                "keywords": [
                    "event",
                    "eventdispatcher",
                    "eventmanager"
                ],
                "time": "2018-06-11T11:59:03+00:00"
            },
            {
                "name": "doctrine/inflector",
                "version": "v1.3.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/inflector.git",
                    "reference": "5527a48b7313d15261292c149e55e26eae771b0a"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/inflector/zipball/5527a48b7313d15261292c149e55e26eae771b0a",
                    "reference": "5527a48b7313d15261292c149e55e26eae771b0a",
                    "shasum": ""
                },
                "require": {
                    "php": "^7.1"
                },
                "require-dev": {
                    "phpunit/phpunit": "^6.2"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.3.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\Inflector\\": "lib/Doctrine/Common/Inflector"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    }
                ],
                "description": "Common String Manipulations with regard to casing and singular/plural rules.",
                "homepage": "http://www.doctrine-project.org",
                "keywords": [
                    "inflection",
                    "pluralize",
                    "singularize",
                    "string"
                ],
                "time": "2018-01-09T20:05:19+00:00"
            },
            {
                "name": "doctrine/lexer",
                "version": "v1.0.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/lexer.git",
                    "reference": "83893c552fd2045dd78aef794c31e694c37c0b8c"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/lexer/zipball/83893c552fd2045dd78aef794c31e694c37c0b8c",
                    "reference": "83893c552fd2045dd78aef794c31e694c37c0b8c",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.3.2"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-0": {
                        "Doctrine\\Common\\Lexer\\": "lib/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    }
                ],
                "description": "Base library for a lexer that can be used in Top-Down, Recursive Descent Parsers.",
                "homepage": "http://www.doctrine-project.org",
                "keywords": [
                    "lexer",
                    "parser"
                ],
                "time": "2014-09-09T13:34:57+00:00"
            },
            {
                "name": "doctrine/persistence",
                "version": "v1.1.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/persistence.git",
                    "reference": "c0f1c17602afc18b4cbd8e1c8125f264c9cf7d38"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/persistence/zipball/c0f1c17602afc18b4cbd8e1c8125f264c9cf7d38",
                    "reference": "c0f1c17602afc18b4cbd8e1c8125f264c9cf7d38",
                    "shasum": ""
                },
                "require": {
                    "doctrine/annotations": "^1.0",
                    "doctrine/cache": "^1.0",
                    "doctrine/collections": "^1.0",
                    "doctrine/event-manager": "^1.0",
                    "doctrine/reflection": "^1.0",
                    "php": "^7.1"
                },
                "conflict": {
                    "doctrine/common": "<2.10@dev"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^5.0",
                    "phpstan/phpstan": "^0.8",
                    "phpunit/phpunit": "^7.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.1.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\": "lib/Doctrine/Common"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    },
                    {
                        "name": "Marco Pivetta",
                        "email": "ocramius@gmail.com"
                    }
                ],
                "description": "The Doctrine Persistence project is a set of shared interfaces and functionality that the different Doctrine object mappers share.",
                "homepage": "https://doctrine-project.org/projects/persistence.html",
                "keywords": [
                    "mapper",
                    "object",
                    "odm",
                    "orm",
                    "persistence"
                ],
                "time": "2018-11-21T00:33:13+00:00"
            },
            {
                "name": "doctrine/reflection",
                "version": "v1.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/doctrine/reflection.git",
                    "reference": "02538d3f95e88eb397a5f86274deb2c6175c2ab6"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/doctrine/reflection/zipball/02538d3f95e88eb397a5f86274deb2c6175c2ab6",
                    "reference": "02538d3f95e88eb397a5f86274deb2c6175c2ab6",
                    "shasum": ""
                },
                "require": {
                    "doctrine/annotations": "^1.0",
                    "ext-tokenizer": "*",
                    "php": "^7.1"
                },
                "require-dev": {
                    "doctrine/coding-standard": "^4.0",
                    "doctrine/common": "^2.8",
                    "phpstan/phpstan": "^0.9.2",
                    "phpstan/phpstan-phpunit": "^0.9.4",
                    "phpunit/phpunit": "^7.0",
                    "squizlabs/php_codesniffer": "^3.0"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Doctrine\\Common\\": "lib/Doctrine/Common"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Roman Borschel",
                        "email": "roman@code-factory.org"
                    },
                    {
                        "name": "Benjamin Eberlei",
                        "email": "kontakt@beberlei.de"
                    },
                    {
                        "name": "Guilherme Blanco",
                        "email": "guilhermeblanco@gmail.com"
                    },
                    {
                        "name": "Jonathan Wage",
                        "email": "jonwage@gmail.com"
                    },
                    {
                        "name": "Johannes Schmitt",
                        "email": "schmittjoh@gmail.com"
                    },
                    {
                        "name": "Marco Pivetta",
                        "email": "ocramius@gmail.com"
                    }
                ],
                "description": "Doctrine Reflection component",
                "homepage": "https://www.doctrine-project.org/projects/reflection.html",
                "keywords": [
                    "reflection"
                ],
                "time": "2018-06-14T14:45:07+00:00"
            },
            {
                "name": "fig/link-util",
                "version": "1.0.0",
                "source": {
                    "type": "git",
                    "url": "https://github.com/php-fig/link-util.git",
                    "reference": "1a07821801a148be4add11ab0603e4af55a72fac"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/php-fig/link-util/zipball/1a07821801a148be4add11ab0603e4af55a72fac",
                    "reference": "1a07821801a148be4add11ab0603e4af55a72fac",
                    "shasum": ""
                },
                "require": {
                    "php": ">=5.5.0",
                    "psr/link": "~1.0@dev"
                },
                "require-dev": {
                    "phpunit/phpunit": "^5.1",
                    "squizlabs/php_codesniffer": "^2.3.1"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "1.0.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "Fig\\Link\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "PHP-FIG",
                        "homepage": "http://www.php-fig.org/"
                    }
                ],
                "description": "Common utility implementations for HTTP links",
                "keywords": [
                    "http",
                    "http-link",
                    "link",
                    "psr",
                    "psr-13",
                    "rest"
                ],
                "time": "2016-10-17T18:31:11+00:00"
            },
            {
                "name": "friendsofsymfony/http-cache",
                "version": "2.5.4",
                "source": {
                    "type": "git",
                    "url": "https://github.com/FriendsOfSymfony/FOSHttpCache.git",
                    "reference": "1d2d2bf98cedaa0762d1b3940370127581ad51e1"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/FriendsOfSymfony/FOSHttpCache/zipball/1d2d2bf98cedaa0762d1b3940370127581ad51e1",
                    "reference": "1d2d2bf98cedaa0762d1b3940370127581ad51e1",
                    "shasum": ""
                },
                "require": {
                    "php": "^5.6 || ^7.0.0",
                    "php-http/client-common": "^1.1.0",
                    "php-http/client-implementation": "^1.0.0",
                    "php-http/discovery": "^1.0",
                    "php-http/message": "^1.0.0",
                    "symfony/event-dispatcher": "^3.4 || ^4.0",
                    "symfony/options-resolver": "^3.4 || ^4.0"
                },
                "conflict": {
                    "toflar/psr6-symfony-http-cache-store": "<1.1.2"
                },
                "require-dev": {
                    "mockery/mockery": "~0.9.5",
                    "monolog/monolog": "^1.0",
                    "php-http/guzzle6-adapter": "^1.0.0",
                    "php-http/mock-client": "^0.3.2",
                    "phpunit/phpunit": "^5.7 || ^6.0",
                    "symfony/http-kernel": "^3.4 || ^4.0",
                    "symfony/process": "^3.4 || ^4.0"
                },
                "suggest": {
                    "friendsofsymfony/http-cache-bundle": "For integration with the Symfony framework",
                    "monolog/monolog": "For logging issues while invalidating"
                },
                "type": "library",
                "extra": {
                    "branch-alias": {
                        "dev-master": "2.5.x-dev"
                    }
                },
                "autoload": {
                    "psr-4": {
                        "FOS\\HttpCache\\": "src/"
                    }
                },
                "notification-url": "https://packagist.org/downloads/",
                "license": [
                    "MIT"
                ],
                "authors": [
                    {
                        "name": "Liip AG",
                        "homepage": "http://www.liip.ch/"
                    },
                    {
                        "name": "Driebit",
                        "email": "tech@driebit.nl",
                        "homepage": "http://www.driebit.nl"
                    },
                    {
                        "name": "Community contributions",
                        "homepage": "https://github.com/friendsofsymfony/FOSHttpCache/contributors"
                    }
                ],
                "description": "Tools to manage HTTP caching proxies with PHP",
                "homepage": "https://github.com/friendsofsymfony/FOSHttpCache",
                "keywords": [
                    "caching",
                    "http",
                    "invalidation",
                    "nginx",
                    "purge",
                    "varnish"
                ],
                "time": "2018-10-31T14:11:39+00:00"
            },
            {
                "name": "friendsofsymfony/http-cache-bundle",
                "version": "2.6.1",
                "source": {
                    "type": "git",
                    "url": "https://github.com/FriendsOfSymfony/FOSHttpCacheBundle.git",
                    "reference": "1379ca39784755150546583bae01b5683dacb7c9"
                },
                "dist": {
                    "type": "zip",
                    "url": "https://api.github.com/repos/FriendsOfSymfony/FOSHttpCacheBundle/zipball/1379ca39784755150546583bae01b5683dacb7c9",
                    "reference": "1379ca39784755150546583bae01b5683dacb7c9",
                    "shasum": ""
                },
                "require": {
                    "friendsofsymfony/http-cache": "^2.5.2",
                    "php": "^7.1",
                    "symfony/framework-bundle": "^3.4.4 || ^4.0",
                    "symfony/http-foundation": "^3.4.4 || ^4.0",
                    "symfony/http-kernel": "^3.4.4 || ^4.0"
                },
                "conflict": {
                    "symfony/monolog-bridge": "<3.4.4",
                 
    
    
    <end preview>
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Für Contao abstimmen: https://bitnami.com/product/contao/widget
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 Hoster: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with coding, testing and time.

  37. #37
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.561
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Und noch ergänzend die composer.json:

    Code:
    {
        "type": "project",
        "require": {
            "contao/calendar-bundle": "^4.4",
            "contao/comments-bundle": "^4.4",
            "contao/conflicts": "*@dev",
            "contao/faq-bundle": "^4.4",
            "contao/listing-bundle": "^4.4",
            "contao/manager-bundle": "4.4.*",
            "contao/news-bundle": "^4.4",
            "contao/newsletter-bundle": "^4.4",
            "jrgregory/m17-sticky-backend-footer": "^2.0",
            "madeyourday/contao-rocksolid-antispam": "^2.0",
            "madeyourday/contao-rocksolid-columns": "^2.0",
            "madeyourday/contao-rocksolid-custom-elements": "^2.2",
            "madeyourday/contao-rocksolid-frontend-helper": "^2.0",
            "madeyourday/contao-rocksolid-icon-picker": "^2.0",
            "madeyourday/contao-rocksolid-mega-menu": "^2.0",
            "madeyourday/contao-rocksolid-slider": "^2.0"
        },
        "extra": {
            "contao-component-dir": "assets"
        },
        "scripts": {
            "post-install-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ],
            "post-update-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ]
        }
    }
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Für Contao abstimmen: https://bitnami.com/product/contao/widget
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 Hoster: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with coding, testing and time.

  38. #38
    Contao-Fan Avatar von PaddySD
    Registriert seit
    26.10.2016.
    Ort
    Andechs
    Beiträge
    659

    Standard

    Hmm, installiert ist die doctrine/dbal 2.8.1, sollte also passen. Der Fehler sollte, wenn ich mich korrekt erinnere, erst mit der 2.9.x auftreten...

    Dann hab ich aktuell leider keine Idee, wie man den Fehler weg bekommt....sorry!

  39. #39
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.561
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Danke dir fürs Gucken!!
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Für Contao abstimmen: https://bitnami.com/product/contao/widget
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 Hoster: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with coding, testing and time.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •