Contao Konferenz & College 2019 in Duisburg - JETZT TICKET SICHERN!
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 40 von 50

Thema: Installation über CM bleibt hängen

  1. #1
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Frage Installation über CM bleibt hängen

    Hallo zusammen,

    ich versuche gerade Contao 4.5 über den CM auf einem Strato PowerWeb Perfect Server zu installieren. Contao-Check zeigte alles grün an. PHP steht auf 7.2.

    Die Installation läuft soweit durch, bis ich auf's Installtool klicken kann. Der Link darauf spuckt ein 404 (/contao/install) aus und der CM reagiert mit

    Code:
    ERROR 500 Unknown installation status
    Some files were found on your server but no known Contao version could be detected.
    You must either manually repair your application or remove the following files and folders to install Contao:
    
    - install-5ac602b3bbbf7

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Dieses Problem tritt bei Strato öfter auf, soweit ich das aus den anderen Threads rauslesen konnte. Installiere Contao direkt über die Konsole.

  3. #3
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Dieses Problem tritt bei Strato öfter auf, soweit ich das aus den anderen Threads rauslesen konnte. Installiere Contao direkt über die Konsole.
    Gerade versucht. Gegen Ende bricht's auch hier ab:

    Code:
    // Warming up the cache for the prod environment with debug                    
     // false                                                                       
    
    11:57:15 ERROR     [console] Error thrown while running command "--ansi cache:warmup --env=prod". Message: "MemoryTokenStorage must not be accessed before it was initialized." ["error" => LogicException { …},"command" => "--ansi cache:warmup --env=prod","message" => "MemoryTokenStorage must not be accessed before it was initialized."] []
    
    In MemoryTokenStorage.php line 110:
                                                                          
      MemoryTokenStorage must not be accessed before it was initialized.  
                                                                          
    
    cache:warmup [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--env ENV] [--no-debug] [--] <command>
    
    X-Powered-By: PHP/7.2.3
    Content-type: text/html; charset=UTF-8
    
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-update-cmd event terminated with an exception
    
                                                                                                                                 
      [RuntimeException]                                                                                                         
      An error occurred while executing the "cache:warmup" command: 11:57:15 ERROR     [console] Error thro  
      wn while running command "--ansi cache:warmup --env=prod". Message: "MemoryTokenStorage must not be accessed before it wa  
      s initialized." ["error" => LogicException { …},39;49m
      38;5;208m"command" => "--ansi cache:warmup --env=prod","39;49m
      5;113mmessage" => "MemoryTokenStorage must not be accessed before it was initialized."  
      ] []                                                                                        
      In MemoryTokenStorage.php line 110:                                                                              
                                                                                                                 
        MemoryTokenStorage must not be accessed before it was initialized.                                       
                                                                                                                 
      cache:warmup [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-an  
      si] [-n|--no-interaction] [-e|--env ENV] [--no-debug] [--] <command>                                        
                                                                                                                                 
    
    update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Diesen Fehler kannst du erst mal ignorieren. Lösche einfach den Ordner /var/cache und öffne das Contao Install Tool.

  5. #5
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Diesen Fehler kannst du erst mal ignorieren. Lösche einfach den Ordner /var/cache und öffne das Contao Install Tool.
    Ich habe aber auch noch eine alte Erweiterung (galerie) händisch in den Ordner system/modules kopiert. Wenn ich jetzt das Installtool aufrufe, möchte er mir gerne die entsprechenden Tabellen und Spalten löschen. Vermutlich weil vendor/bin/contao-console cache:clear nicht richtig funktioniert oder?

  6. #6
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Wenn du Erweiterungen manuell installierst oder deinstallierst musst du immer manuell den Ordner /var/cache löschen und danach das Install Tool aufrufen.

  7. #7
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Frage

    Soweit so gut. Beim Aufruf der Seite werden Stylesheets, Fotos etc. nicht gefunden, da die Pfadangaben angeblich nicht stimmen. Tun sie aber. Entsprechende Ordner sind auch öffentlich, Daten bereinigt etc.

    EDIT: Im System-Log steht mehrfach
    Code:
    The symlinks could not be regenerated
    Geändert von mapfei (05.04.2018 um 14:40 Uhr)

  8. #8
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Überprüfe deine Serverumgebung mit dem Contao Check.

  9. #9
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Überprüfe deine Serverumgebung mit dem Contao Check.
    Zitat Zitat von mapfei Beitrag anzeigen
    Contao-Check zeigte alles grün an. PHP steht auf 7.2.
    ^^ nach wie vor alles grün.

  10. #10
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Post die Ausgabe von composer install auf der Konsole.

  11. #11
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Code:
    xxx.de> php composer.phar install
    X-Powered-By: PHP/7.2.3
    Content-type: text/html
    
    Warning: Composer should be invoked via the CLI version of PHP, not the cgi-fcgi SAPI
    sh: sudo: not found
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Nothing to install or update
    Generating autoload files
    ocramius/package-versions:  Generating version class...
    ocramius/package-versions: ...done generating version class
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    The command is already running in another process.
    X-Powered-By: PHP/7.2.3
    Content-type: text/html; charset=UTF-8
    
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    
                                                                                
      [RuntimeException]                                                        
      An error occurred while executing the "contao:install-web-dir" command:   
                                                                                
    
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...

  12. #12
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Du solltest folgendes Kommando verwenden:
    Code:
    /usr/bin/php7.2 composer.phar install -vvv
    Poste die Ausgabe davon.

  13. #13
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Poste die Ausgabe davon.
    Code:
    xxx.de> /usr/bin/php72 composer.phar install -vvv
    X-Powered-By: PHP/7.2.3
    Content-type: text/html
    
    Warning: Composer should be invoked via the CLI version of PHP, not the cgi-fcgi SAPI
    Reading ./composer.json
    Loading config file ./composer.json
    Checked CA file /usr/ssl/certs/ca-bundle.crt: valid
    Executing command (//): git branch --no-color --no-abbrev -v
    Executing command (//): git describe --exact-match --tags
    Executing command (//): git log --pretty="%H" -n1 HEAD
    Executing command (//): hg branch
    Executing command (//): fossil branch list
    Executing command (//): fossil tag list
    Executing command (//): svn info --xml
    Failed to initialize global composer: Composer could not find the config file: /mnt/web315/a3/26/5430526/htdocs/.composer/composer.json
    To initialize a project, please create a composer.json file as described in the https://getcomposer.org/ "Getting Started" section
    Reading ///vendor/composer/installed.json
    Loading plugin PackageVersions\Installer
    Loading plugin Contao\ComponentsInstaller\Composer\Plugin
    Loading plugin ContaoCommunityAlliance\Composer\Plugin\Plugin
    Running 1.5.6 (2017-12-18 12:09:18) with PHP 7.2.3 on SunOS localhost 5.10 Generic_150401-49 i86pc / SunOS localhost 5.10 Generic_150401-49 i86pc
    sh: sudo: not found
    Reading ./composer.lock
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Reading ./composer.lock
    Resolving dependencies through SAT
    Dependency resolution completed in 0.005 seconds
    Analyzed 305 packages to resolve dependencies
    Analyzed 955 rules to resolve dependencies
    Nothing to install or update
    Generating autoload files
    ocramius/package-versions:  Generating version class...
    ocramius/package-versions: ...done generating version class
    > post-install-cmd: Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    The command is already running in another process.
    13:53:46 DEBUG     [console] Command "--ansi contao:install-web-dir -vvv --env=prod" exited with code "1"
    [
      "command" => "--ansi contao:install-web-dir -vvv --env=prod",
      "code" => 1
    ]
    []
    X-Powered-By: PHP/7.2.3
    Content-type: text/html; charset=UTF-8
    
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    
                                                                                                                                 
      [RuntimeException]                                                                                                         
      An error occurred while executing the "contao:install-web-dir" command: 13:53:46 DEBUG     [console]   
      Command "--ansi contao:install-web-dir -vvv --env=prod" exited with code "1"                                               
      [                                                                                                            
        "command" => "--ansi contao:install-web-dir -vvv --env=prod", 
      [m                                                                                                                         
        "code" => 1                                                   
      ]                                                                                                            
      []                                                                                                           
                                                                                                                                 
    
    Exception trace:
     () at ///vendor/contao/manager-bundle/src/Composer/ScriptHandler.php:95
     Contao\ManagerBundle\Composer\ScriptHandler::executeCommand() at ///vendor/contao/manager-bundle/src/Composer/ScriptHandler.php:31
     Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication() at phar://///composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:282
     Composer\EventDispatcher\EventDispatcher->executeEventPhpScript() at phar://///composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:205
     Composer\EventDispatcher\EventDispatcher->doDispatch() at phar://///composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:96
     Composer\EventDispatcher\EventDispatcher->dispatchScript() at phar://///composer.phar/src/Composer/Installer.php:321
     Composer\Installer->run() at phar://///composer.phar/src/Composer/Command/InstallCommand.php:119
     Composer\Command\InstallCommand->execute() at phar://///composer.phar/vendor/symfony/console/Command/Command.php:266
     Symfony\Component\Console\Command\Command->run() at phar://///composer.phar/vendor/symfony/console/Application.php:861
     Symfony\Component\Console\Application->doRunCommand() at phar://///composer.phar/vendor/symfony/console/Application.php:208
     Symfony\Component\Console\Application->doRun() at phar://///composer.phar/src/Composer/Console/Application.php:245
     Composer\Console\Application->doRun() at phar://///composer.phar/vendor/symfony/console/Application.php:127
     Symfony\Component\Console\Application->run() at phar://///composer.phar/src/Composer/Console/Application.php:100
     Composer\Console\Application->run() at phar://///composer.phar/bin/composer:54
     require() at ///composer.phar:23
    
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...

  14. #14
    Contao-Nutzer
    Registriert seit
    26.05.2013.
    Ort
    Berlin
    Beiträge
    227

    Standard

    Spooky
    Diesen Fehler kannst du erst mal ignorieren. Lösche einfach den Ordner /var/cache und öffne das Contao Install Tool.
    diesen Fehler habe ich schon lange bei Strato, hab ihn bisher einfach ignoriert und den Cache manuell per Konsole gelöscht - bisher problemlos verlaufen

  15. #15
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von mapfei Beitrag anzeigen
    Im System-Log steht mehrfach
    Code:
    The symlinks could not be regenerated
    Das Problem bleibt aktuell bestehen, CSS, Images etc. werden nicht angezeigt. Backend funktioniert einwandfrei.

  16. #16
    Contao-Nutzer
    Registriert seit
    26.05.2013.
    Ort
    Berlin
    Beiträge
    227

    Standard

    @mapfei:
    PowerWeb Perfect scheint ja sehr altes Paket zu sein, installiere Contao über die Konsole und nicht über dem CM; bei mir werden in der Systemwartung unter "Symlinks neu erstellen" die Links problemlos erstellt mit der Info im System-Log "Regenerated the symlinks"

  17. #17
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von VGT Beitrag anzeigen
    @mapfei:
    PowerWeb Perfect scheint ja sehr altes Paket zu sein, installiere Contao über die Konsole und nicht über dem CM; bei mir werden in der Systemwartung unter "Symlinks neu erstellen" die Links problemlos erstellt mit der Info im System-Log "Regenerated the symlinks"
    Ich habe Contao ja inzwischen über die Konsole installiert, allerdings bleibt aktuell immer noch der Fehler bestehen, dass im Frontend Images, Stylesheets etc. nicht gefunden werden, vermutlich wegen der Symlink-Sache.

  18. #18
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Frage

    Inzwischen habe ich das Paket auf PowerWeb Plus geupdatet und die Symlinks werden nun erstellt und die Seite wird fehlerfrei aufgerufen - zumindest fast.

    Ich habe die Erweiterung madeyourday/contao-rocksolid-columns installiert. Allerdings wird das CSS hier nicht eingebunden. Hierzu habe ich diesen Thread im Rocksolid-Forum gefunden und die dort geschilderten Schritte ausgeführt - jedoch ohne Erfolg. Das entsprechende CSS wird einfach nicht eingebunden.

    EDIT: Gerade eben nochmal über die Systemwartung "Symlinks neu erstellen" gemacht und es erscheint wieder The symlinks could not be regenerated im System-Log.
    Geändert von mapfei (09.04.2018 um 08:15 Uhr)

  19. #19
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Ich würde den Hoster wechseln.

  20. #20
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Kann ich dem Kunden nur schwer erklären, zumal ich gerade das Paket geupgradet habe.

    Habe eben mal testweise eine frische Installation (manuell) auf einer Subdomain aufgesetzt und Symlinks neu erstellen lassen: The symlinks could not be regenerated. Versuch's jetzt mal über @STRATO_hilft.

  21. #21
    Contao-Nutzer
    Registriert seit
    26.05.2013.
    Ort
    Berlin
    Beiträge
    227

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Ich würde den Hoster wechseln.
    Würde ich nicht so pauschal behaupten, denn bei mir bei dem kleineren Paket PowerWeb Basic habe ich Contao 4.5.7 mit Rocksolid-Paketen und Rocksolid-Theme zu laufen und wie oben geschrieben keine Probleme mit Symlinks bisher.

  22. #22
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von VGT Beitrag anzeigen
    Würde ich nicht so pauschal behaupten, denn bei mir bei dem kleineren Paket PowerWeb Basic habe ich Contao 4.5.7 mit Rocksolid-Paketen und Rocksolid-Theme zu laufen und wie oben geschrieben keine Probleme mit Symlinks bisher.
    Aber was machst du dann anders? Hier übrigens die Antwort vom Strato-Support:

    [...] die Nutzung von Contao unterstützen wir nicht offiziell und können deshalb eine reibungslose Installation und Betrieb nicht garantieren.
    Grundsätzlich kann ich dir empfehlen, mit Hilfe der entsprechenden Fehlermeldung nach möglichen Lösungen bei Google zu suchen.
    Vielen Dank für dein Verständnis.

  23. #23
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Wenn ich composer.phar install -o ausführe, erhalte ich folgenden Fehler:

    Code:
    domain.de> /usr/bin/php72 composer.phar install -o
    X-Powered-By: PHP/7.2.3
    Content-type: text/html
    
    Warning: Composer should be invoked via the CLI version of PHP, not the cgi-fcgi SAPI
    sh: sudo: not found
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Nothing to install or update
    Generating optimized autoload files
    ocramius/package-versions:  Generating version class...
    ocramius/package-versions: ...done generating version class
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    The command is already running in another process.
    X-Powered-By: PHP/7.2.3
    Content-type: text/html; charset=UTF-8
    
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    
                                                                               
      [RuntimeException]                                                       
      An error occurred while executing the "contao:install-web-dir" command:  
                                                                               
    
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...

  24. #24
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Führe mal
    Code:
    /usr/bin/php72 vendor/bin/contao-console contao:install-web-dir
    aus.

  25. #25
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Führe mal
    Code:
    /usr/bin/php72 vendor/bin/contao-console contao:install-web-dir
    aus.
    Code:
    The command is already running in another process.

  26. #26
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Siehe https://community.contao.org/de/show...l=1#post440149

    Die PHP Konfiguration für die PHP Version auf deiner Kommandozeile scheint kein von dir beschreibbares, temporäres Verzeichnis konfiguriert zu haben. Das muss Strato beheben.

  27. #27
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Führe zum testen mal folgendes aus:
    Code:
    /usr/bin/php72 -r "var_dump(is_writable(sys_get_temp_dir()));"

  28. #28
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Führe zum testen mal folgendes aus:
    Code:
    /usr/bin/php72 -r "var_dump(is_writable(sys_get_temp_dir()));"
    Code:
    domain.de> /usr/bin/php72 -r "var_dump(is_writable(sys_get_temp_dir()));"
    Error in argument 1, char 2: option not found r
    Usage: php72 [-q] [-h] [-s] [-v] [-i] [-f <file>]
           php72 <file> [args...]
      -a               Run interactively
      -b <address:port>|<port> Bind Path for external FASTCGI Server mode
      -C               Do not chdir to the script's directory
      -c <path>|<file> Look for php.ini file in this directory
      -n               No php.ini file will be used
      -d foo[=bar]     Define INI entry foo with value 'bar'
      -e               Generate extended information for debugger/profiler
      -f <file>        Parse <file>.  Implies `-q'
      -h               This help
      -i               PHP information
      -l               Syntax check only (lint)
      -m               Show compiled in modules
      -q               Quiet-mode.  Suppress HTTP Header output.
      -s               Display colour syntax highlighted source.
      -v               Version number
      -w               Display source with stripped comments and whitespace.
      -z <file>        Load Zend extension <file>.
      -T <count>       Measure execution time of script repeated <count> times.

  29. #29
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.090
    User beschenken
    Wunschliste

    Standard

    Einer deiner Probleme ist, dass /usr/bin/php72 kein richtiges PHP CLI ist. Du musst herausfinden, wo du ein richtiges PHP CLI zur Verfügung hast. Soweit ich in anderen Threads gelesen habe gibt es bei manchen Servern bzw. Paketen von Strato andere Pfade zu einem PHP CLI, die aber noch nirgends dokumentiert sind.

  30. #30
    Contao-Fan Avatar von mapfei
    Registriert seit
    11.05.2010.
    Ort
    Hennef
    Beiträge
    535
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Einer deiner Probleme ist, dass /usr/bin/php72 kein richtiges PHP CLI ist. Du musst herausfinden, wo du ein richtiges PHP CLI zur Verfügung hast. Soweit ich in anderen Threads gelesen habe gibt es bei manchen Servern bzw. Paketen von Strato andere Pfade zu einem PHP CLI, die aber noch nirgends dokumentiert sind.
    Laut Strato steht PHP CLI nur in selbst administrierten Servern zur Verfügung.

  31. #31
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.060
    Partner-ID
    7421

    Standard

    Zitat Zitat von mapfei Beitrag anzeigen
    Laut Strato steht PHP CLI nur in selbst administrierten Servern zur Verfügung.
    Ja so ist auch mein Kenntnisstand.
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  32. #32
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.997
    User beschenken
    Wunschliste

    Standard

    Dann würde ich denen halt anbieten, den Server zu administrieren .

  33. #33
    Contao-Nutzer
    Registriert seit
    15.10.2009.
    Ort
    Dresden
    Beiträge
    102

    Standard Console?

    Stehe vor dem gleichen Problem mit der Fehlermeldung über dem CM bei der Installation.

    Frage 1
    Was genau ist, die Console von der hier immer gesprochen wird?

    Frage 2
    Wenn ich das mit der "Console" installiert habe, kann ich dann anschließend wieder den CM für Updates nutzen?

  34. #34
    Contao-Nutzer
    Registriert seit
    26.05.2013.
    Ort
    Berlin
    Beiträge
    227

    Standard

    Die Konsole ist ein Bildschirm im Textmodus. Du bist dann auf der Kommandozeile des Webservers. Dazu benötigst du ein lokal installiertes Terminalprogramm um dich mit dem Webserver zu verbinden. Nach der Verbindung landest Du meist auf einem schwarz/weißen Bildschirm in deinem Heimatverzeichnis. Das kannst Du vergleichen mit der Eingabeaufforderung oder dem MS-DOS-Fenster für Windows.
    Wie Du zur Konsole kommst ist hier schon mehrfach beschrieben, hier ist die Anleitung: https://www.strato.de/faq/article/10...TP-Zugang.html

  35. #35
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.805
    User beschenken
    Wunschliste

    Standard

    Bei Strato gibt es jetzt offenbar auch ein PHP CLI Binary, aufrufbar nach diesem Muster: /opt/RZphp{major}{minor}/bin/php-cli

    Beispiele:

    • PHP 7.2: /opt/RZphp72/bin/php-cli
    • PHP 7.1: /opt/RZphp71/bin/php-cli
    • PHP 7.0: /opt/RZphp70/bin/php-cli


    Damit konnte ich dann Contao 4.5 bei STRATO installieren.
    Geändert von xchs (09.05.2018 um 15:37 Uhr)
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  36. #36
    Contao-Nutzer
    Registriert seit
    26.05.2013.
    Ort
    Berlin
    Beiträge
    227

    Daumen hoch

    dieser Hinweis ist ja grandios , funktioniert bestens und composer update auf der Konsole läuft jetzt fehlerfrei durch und bricht bei warming up cache nicht mehr ab mit Fehlermeldung; getestet mit aktueller Contao 4.5.8

  37. #37
    Contao-Nutzer Avatar von Ionesco
    Registriert seit
    01.02.2017.
    Ort
    Kohlenpott
    Beiträge
    36

    Standard

    Wegen eines kurzfristigen Hilferufs eines Freundes stehe ich vor genau dieser Strato-Frage: Gibt es hier niemanden, der Contao 4 bei Strato ohne Konsole zum Laufen gebracht hat? Fühle mich in der Welt der Unix-Befehle sehr unsicher. Bin bis dato durch all-inkl sehr verwöhnt.

  38. #38
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.060
    Partner-ID
    7421

    Standard

    Bei Strato sind nach meiner Erfahrung für den Manager die Skriptlaufzeiten zu kurz und das Ram-Problem schlägt zu.
    Außerdem benötigst Du zwingend Contao PHP 7.2. (Danke @tab)

    Ich weiß, dass an dem Problem gearbeitet wird, aber gerade Strato ist noch ein "Sorgenkind" für den Manager.
    Geändert von mlweb (09.05.2018 um 17:22 Uhr)
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  39. #39
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.997
    User beschenken
    Wunschliste

    Standard

    Hier ist natürlich PHP 7.2 gemeint. Das würde sonst noch eine Weile dauern.

  40. #40
    Contao-Urgestein Avatar von do_while
    Registriert seit
    15.06.2009.
    Ort
    Berlin | Deutschland
    Beiträge
    3.330
    Partner-ID
    1081
    User beschenken
    Wunschliste

    Standard

    War Strato nicht immer in vielen Situationen ein Sorgenkind?
    Ich lehne das ab.

Seite 1 von 2 12 LetzteLetzte

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •