Contao Konferenz & College 2019 in Duisburg - JETZT TICKET SICHERN!
Ergebnis 1 bis 5 von 5

Thema: Voraussetzungen für Contao 4.4/4.5

  1. #1
    Contao-Urgestein Avatar von derRenner
    Registriert seit
    23.10.2012.
    Ort
    hoRn|waldviertel
    Beiträge
    1.542
    User beschenken
    Wunschliste

    Standard Voraussetzungen für Contao 4.4/4.5

    Hallo,

    ich habe wieder einen Hoster, hier in Österreich angeschrieben, ob sie denn nicht doch die Voraussetzungen für Contao 4.4/4.5 aufwärts schaffen könnten.
    Hier ging es mir primär darum, dass ich die eine oder andere Webseite, die dort geparkt ist, von 3.xx auf 4.xx updaten muss/möchte

    dieser Hoster, stellt nun die Gegenfrage
    Ich hab mir also nun die folgenden Punkte aufgeschrieben, welche für Contao 4.X benötigt werden:

    - posix_getpwuid
    - shell_exec()
    - proc_open()
    - proc_close()
    - composer-Installation
    - min. 265MB Memory_limit

    Wäre das alles oder braucht es noch etwas mehr? Wir müssen die Entscheidung treffen, ob wir es sicherheitstechnisch verantworten können, eine entsprechende PHP-Version aufzusetzen.
    Meine Fragen dazu:
    - 256MB memory_limit ... ausreichend? Ich vermute, dass 512MB aufwärts ideal wären
    - gibt es noch weitere Einstellungen, die der Hoster beachten sollte?
    - geht es hier tatsächlich um sicherheitstechnische Verantwortung, die mit diesen Einstellungen "geöffnet" wird? Wenn dem so ist, wie lösen das andere Hoster?
    Grüsse
    Bernhard


  2. #2
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.993
    User beschenken
    Wunschliste

    Standard

    Als fehlend aufgefalls ist mir gleich die intl-Erweiterung. Der neueste Contao-Check prüft auch alle bisher aufgefallenen Voraussetzungen, die möglicherweise fehlen könnten. Kannst den ja mal auf dem bestehenden Setup laufen lassen und schauen, was er so alles anmeckert.

    Ich vermute mal stark, es kommt immer auch darauf an, wie das System konfiguriert ist, ob irgendeine Option sicherheitsrelevante Lücken reisst.

  3. #3
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.081
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von derRenner Beitrag anzeigen
    ich habe wieder einen Hoster, hier in Österreich angeschrieben, ob sie denn nicht doch die Voraussetzungen für Contao 4.4/4.5 aufwärts schaffen könnten.
    Welcher Hoster?



    Zitat Zitat von derRenner Beitrag anzeigen
    dieser Hoster, stellt nun die Gegenfrage
    Ich hab mir also nun die folgenden Punkte aufgeschrieben, welche für Contao 4.X benötigt werden:

    - posix_getpwuid
    - shell_exec()
    - proc_open()
    - proc_close()
    Diese Anforderungen gelten nur für den Contao Manager, nicht für Contao selbst.



    Zitat Zitat von derRenner Beitrag anzeigen
    - min. 265MB Memory_limit
    Meine Fragen dazu:
    - 256MB memory_limit ... ausreichend? Ich vermute, dass 512MB aufwärts ideal wären
    Kommt darauf an, was genau auf der Website passiert. Sollen bspw. sehr große Bilder prozessiert werden oder enthält die Seite sehr, sehr viele Inhalte in Form von Seiten, Artikeln oder Nachrichtenbeiträge bspw. wären 512 MiB natürlich nicht schlecht.

  4. #4
    Contao-Urgestein Avatar von derRenner
    Registriert seit
    23.10.2012.
    Ort
    hoRn|waldviertel
    Beiträge
    1.542
    User beschenken
    Wunschliste

    Standard

    Hoster: Hotdomains
    https://www.hotdomains.at/

    ja, mir geht's eigentlich auch um die Installation und Wartung via Contao Manager.
    SSH wäre OK, aber Konsolen-Anwender muss nicht sein
    Geändert von derRenner (03.06.2018 um 13:53 Uhr)
    Grüsse
    Bernhard


  5. #5
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.081
    User beschenken
    Wunschliste

    Standard

    Nicht vergessen einen Erfahrungsbericht zu posten

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •