Get your ticket! JETZT Ticket sichern! Contao Camp am 03. & 04. November 2018 & Contao College am 02. November 2018 im Basislager Leipzig, Deutschland
Ergebnis 1 bis 6 von 6

Thema: Installation mit Contao-Manager schlägt fehl

  1. #1
    Contao-Nutzer
    Registriert seit
    31.01.2016.
    Beiträge
    122

    Standard Installation mit Contao-Manager schlägt fehl

    Hallo,

    ich wollte über den Contao-Manager Bootstrap installieren und erhalte dabei nachfolgende Fehlermeldung.
    Kann mir bitte jemand erklären, was die Fehlermeldung genau aussagt und wie ich die Installation durchgeführt bekomme? So wie ich es verstehe liegt hier ein Problem mit dem Limit vor. Aber 3 Stunden zuvor hatte ich schon einmal eine Installation über den Contao-Manager durchgeführt und die Installation lief problemlos durch.
    Für Hinweise zur Lösung des Problems wäre ich sehr dankbar.
    Code:
    Loading composer repositories with package information
    Updating dependencies
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - contao-bootstrap/bundle 2.1.1 requires contao-bootstrap/core ~2.0 -> satisfiable by contao-bootstrap/core[2.0.0, 2.0.0-alpha1, 2.0.0-alpha2, 2.0.0-alpha3, 2.0.0-alpha5, 2.0.0-beta1, 2.0.0-beta2, 2.0.1, 2.0.2, 2.0.3, 2.1.x-dev, 2.0.x-dev] but these conflict with your requirements or minimum-stability.
        - contao-bootstrap/bundle 2.1.0 requires contao-bootstrap/core ~2.0 -> satisfiable by contao-bootstrap/core[2.0.0, 2.0.0-alpha1, 2.0.0-alpha2, 2.0.0-alpha3, 2.0.0-alpha5, 2.0.0-beta1, 2.0.0-beta2, 2.0.1, 2.0.2, 2.0.3, 2.1.x-dev, 2.0.x-dev] but these conflict with your requirements or minimum-stability.
        - Installation request for contao-bootstrap/bundle ^2.1 -> satisfiable by contao-bootstrap/bundle[2.1.0, 2.1.1].
    
    <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
    Finished Composer Cloud resolving.

    Gruß
    Thomas

  2. #2
    Alter Contao-Hase
    Registriert seit
    29.10.2009.
    Beiträge
    1.483
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Laut der Ausgabe kann der Composer angeblich contao-bootstrap/core nicht installieren. Dies kann ich mir allerdings nicht erklären, da es in einer stabilen Version mit der angeforderten Version vorliegt.

    Entweder gab es ein temporäres Problem bei Packagist. Ggf. probierst du es nochmal. Oder du hast eine andere Erweiterung installiert oder Abhängigkeit definiert, die er nicht auflösen kann.

    Hast du Zugriff auf die Konsole?

  3. #3
    Contao-Nutzer
    Registriert seit
    31.01.2016.
    Beiträge
    122

    Standard

    Also heute hat die contao-bootstrap/bundle Installation genauso wenig funktioniert wie gestern mit gleicher Fehlermeldung. Bevor ich gestern bootstrap/bundle installieren wollte, habe ich netzmacht/contao-font-awesome und netzmacht/contao-font-awesome-inserttag istalliert, welche problemlos zu installieren waren. Das war gestern ca. 3 bis 4 Stunden vor dem Installationsversuch von bootstrap/bundle. Auch andere bootstrap Pakete wie form usw. lassen sich nicht installieren. Seltsamerweise wird bei jeder bootstrap Installation egal ob form usw. immer zuerst versucht die core Installation durchzuführen.
    Einen Zugriff auf die Konsole habe ich.
    Danke!


    Gruß
    Thomas

  4. #4
    Contao-Nutzer
    Registriert seit
    31.01.2016.
    Beiträge
    122

    Standard Nachtrag

    Unter den Bootstrap Neuigkeiten steht geschrieben, dass die contao-bootstrap Erweiterung PHP 7.1 voraussetzt wird und bei einer niedrigeren Version keine Updates mehr erfolgen. Bei mir war auf dem Host die PHP Version 7.0 eingestellt. Auch die Umstellung auf PHP Version 7.1 brachte keine Änderung herbei.

    Gruß
    Thomas

  5. #5
    Alter Contao-Hase
    Registriert seit
    29.10.2009.
    Beiträge
    1.483
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Thomasge Beitrag anzeigen
    Unter den Bootstrap Neuigkeiten steht geschrieben, dass die contao-bootstrap Erweiterung PHP 7.1 voraussetzt wird und bei einer niedrigeren Version keine Updates mehr erfolgen. Bei mir war auf dem Host die PHP Version 7.0 eingestellt. Auch die Umstellung auf PHP Version 7.1 brachte keine Änderung herbei.

    Gruß
    Thomas
    Läuft auch der Manager mit PHP 7.1? Könnte sein, dass er noch auf PHP 7.0 läuft (Hier wird einen Konsolenprozess erstellt, der unterschiedlich zum Webserver sein kann).

  6. #6
    Contao-Nutzer
    Registriert seit
    31.01.2016.
    Beiträge
    122

    Standard

    Im Contao-Manager wird bei der Systemprüfung unter Serverkonfiguration "Konfiguriert als Host Europe GmbH, PHP-Binary in /usr/bin/php7.1" ausgegeben.
    Muss ich sonst wo noch etwas konfigurieren? Oder hilft vielleicht die letzten beiden Installationen zu deinstallieren, Bootstrap zu installieren und die beiden Pakete wieder zu installieren.
    Danke!


    Gruß
    Thomas

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •