33 geniale Contao-Erweiterungen, die du kennen solltest! - Contao Academy
Seite 2 von 2 ErsteErste 12
Ergebnis 41 bis 59 von 59

Thema: Bilder liefern 403 und werden teilweise dennoch gezeigt

  1. #41
    Contao-Fan Avatar von k-webdesign
    Registriert seit
    07.06.2010.
    Ort
    Karlsruhe
    Beiträge
    585
    Partner-ID
    5911
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von k-webdesign Beitrag anzeigen
    Dieses Bild hier: http://wp1015812.server-he.de/files/...aufsteller.png sehe ich übrigens auch nicht, obwohl es mir im Frontend ausgegeben wird: http://wp1015812.server-he.de/ (Startseite Einleitungstext, rechts im Element)
    steht hier

  2. #42
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.762
    Partner-ID
    10107
    User beschenken
    Wunschliste

  3. #43
    Contao-Fan Avatar von k-webdesign
    Registriert seit
    07.06.2010.
    Ort
    Karlsruhe
    Beiträge
    585
    Partner-ID
    5911
    User beschenken
    Wunschliste

    Standard

    Ich glaub wir reden grad aneinander vorbei. In dem Link siehst du das Bild auch, doch da es broken ist, zeigt es nicht jeder Browser an. Darum mein Screenshot. Du siehst auf http://wp1015812.server-he.de/ im 1. Textabschnitt ("Einfach und schnell ans Ziel...") sind 2 Bilder eingebunden. Eins ist dem Inhaltselement angehängt und es ist sichtbar (Säule rechts) und eins ist im selben Inhaltselement über den Tiny eingebunden (broken). Wenn ich sie über das Backend direkt aufrufe, erhalte ich für beide einen 403 Fehler, obwohl ja eins davon sichtbar ist:
    http://wp1015812.server-he.de/files/...aufsteller.png
    http://wp1015812.server-he.de/files/...e/MRN_logo.jpg

  4. #44
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.762
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Unter http://wp1015812.server-he.de/ ist im Source nichts von einem MRN_Logo zu sehen, daher die Frage, wo das Bild im Frontend sichtbar sein soll.

    In deinem Screenshot sieht man zwei Bilder. Eines funktioniert:

    http://wp1015812.server-he.de/assets...r-4845fc6e.png (ist ein von Contao prozessiertes Bild)

    Das andere nicht:

    http://wp1015812.server-he.de/files/.../Icon_Gold.gif

    Auch bei letzterem Bild kommt ein 403 Response.

  5. #45
    Contao-Fan Avatar von k-webdesign
    Registriert seit
    07.06.2010.
    Ort
    Karlsruhe
    Beiträge
    585
    Partner-ID
    5911
    User beschenken
    Wunschliste

    Standard

    Habs gemerkt und korrigiert, tut mir leid. Da hatte ich wild Bilder getestet, die alle einen 403 warfen. Jetzt ist wieder das MRN_logo.jpg drin.

    Bzw ich hab das MRN_logo.jpg im Content jetzt entfernt und normal als Bild angehängt - das schafft es gar nicht erst ins Frontend, also auch gar nicht in den HTML-Code

  6. #46
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.762
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Wie meinst du das jetzt?

    Jedenfalls ist jetzt ein Bild mit dem Namen MRN_logo.jpg im Source zu finden unter der URL http://wp1015812.server-he.de/files/...e/MRN_logo.jpg . Auch da liefert dein Web Server einen 403 Response.

  7. #47
    Contao-Fan Avatar von k-webdesign
    Registriert seit
    07.06.2010.
    Ort
    Karlsruhe
    Beiträge
    585
    Partner-ID
    5911
    User beschenken
    Wunschliste

    Standard

    stimmt, da ist es. Wurde Opfer meines eigenen Caches.

    Also ich fasse noch mal zusammen:
    - Bilder über den absoluten Pfad aufzurufen ist nicht möglich (403)
    - Teilweise werden Bilder über Contao generiert, dann gehen sie
    - Teilweise werden sie nicht über Contao generiert, obwohl sie dem Textelement angehängt werden (absoluter Pfad wird ausgeliefert -> 403)

    Symlinks hab ich x mal neu angelegt, Caches gelöscht, Ordner auf nicht-öffentlich und dann wieder öffentlich gestellt,... und ich bin ratlos

  8. #48
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.762
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Hast du die Dateirechte schon überprüft? Es kommt ja, wie gesagt ein 403 Response vom Web Server. Das bedeutet, der Web Server sagt dir, dass du nicht auf diese Ressource zugreifen darfst - was wiederum auch bedeuten kann, dass tatsächlich der Web Server nicht auf diese Datei zugreifen darf. Zumindest nicht unter seinem User.

  9. #49
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    8.074
    User beschenken
    Wunschliste

    Standard

    Wie hast du die Symlinks für die public-Verzeichnisse unterhalb von files angelegt? Sind sie danach auch tatsächlich als Symlinks vorhanden? Gehören die Bilder aus den public-Verzeichnissen (/files/...) dem selben User wie die in /assets/...? Falls nein, wie ist der Webserver in Bezug auf SymLinks eingestellt? SymLinksIfOwnerMatch oder FollowSymLinks?

  10. #50
    Contao-Fan Avatar von k-webdesign
    Registriert seit
    07.06.2010.
    Ort
    Karlsruhe
    Beiträge
    585
    Partner-ID
    5911
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Hast du die Dateirechte schon überprüft?
    Die standen wild auf 650 oder 750, obwohl ich rekursive Änderungen angehakt hatte. Jetzt stehen alle auf 770. Ändert nichts...

  11. #51
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.762
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Naja du musst auch user & group überprüfen. 770 heißt dass user & group Vollzugriff haben. Wenn aber der Prozess des Web Servers weder der user ist, noch sich in der group befindet, bringt 770 nichts.

  12. #52
    Contao-Fan Avatar von k-webdesign
    Registriert seit
    07.06.2010.
    Ort
    Karlsruhe
    Beiträge
    585
    Partner-ID
    5911
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von tab Beitrag anzeigen
    Wie hast du die Symlinks für die public-Verzeichnisse unterhalb von files angelegt?
    Öööh... über Contao?

    Zitat Zitat von tab Beitrag anzeigen
    Sind sie danach auch tatsächlich als Symlinks vorhanden? Gehören die Bilder aus den public-Verzeichnissen (/files/...) dem selben User wie die in /assets/...?
    Ja, mittlerweile sind sie alle das. Das alte Problem von vor einem Jahr ist so also nicht mehr ganz vorhanden. Das Rechteproblem weiterhin. Nur wenn ich dem Support schreibe, möcht ich da gern was halbwegs fundiertes in der Hand haben

    Zitat Zitat von tab Beitrag anzeigen
    ... wie ist der Webserver in Bezug auf SymLinks eingestellt? SymLinksIfOwnerMatch oder FollowSymLinks?
    kA, ist ein HostEurope Paket. Keine Ahnung wo ich das finde.

  13. #53
    Contao-Fan Avatar von k-webdesign
    Registriert seit
    07.06.2010.
    Ort
    Karlsruhe
    Beiträge
    585
    Partner-ID
    5911
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Naja du musst auch user & group überprüfen. 770 heißt dass user & group Vollzugriff haben. Wenn aber der Prozess des Web Servers weder der user ist, noch sich in der group befindet, bringt 770 nichts.
    wie krieg ich das raus?

  14. #54
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.762
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von k-webdesign Beitrag anzeigen
    wie krieg ich das raus?
    Code:
    ls -la
    auf der Konsole . Überprüfe Dateien und Parent Ordner.

  15. #55
    Contao-Fan Avatar von k-webdesign
    Registriert seit
    07.06.2010.
    Ort
    Karlsruhe
    Beiträge
    585
    Partner-ID
    5911
    User beschenken
    Wunschliste

    Standard

    das ist der Inhalt vom Ordner /Schisy.biz
    Code:
    drwxrwxr-x 1 wp1015812 wp1015812 4096 Sep 12 16:17 Anwendungsbeispiele
    drwxrwxr-x 1 wp1015812 wp1015812 4096 Sep 12 16:17 Artikel
    drwxrwxr-x 1 wp1015812 wp1015812 4096 Sep 12 16:17 Header-Bilder_Startseite
    -rwxrwxr-x 1 wp1015812 wp1015812  136   Nov  7 21:58 .htaccess
    drwxrwxr-x 1 wp1015812 wp1015812 4096 Nov  7 22:03 Inhalte
    drwxrwxr-x 1 wp1015812 wp1015812   26  Sep 12 16:17 Logo
    drwxrwxr-x 1 wp1015812 wp1015812   98  Sep 12 16:17 Neue Slider
    -rwxrwxr-x 1 wp1015812 wp1015812     0   Nov  7 21:58 .public
    drwxrwxr-x 1 wp1015812 wp1015812 4096 Sep 12 16:17 Systeme

    Das ist der Inhalt von /Inhalte
    Code:
    drwxrwxr-x 1 wp1015812 wp1015812    4096 Nov  7 22:03 .
    drwxrwxr-x 1 wp1015812 wp1015812    4096 Sep 12 16:14 ..
    -rwxrwxr-x 1 wp1015812 wp1015812 1150619 Nov  7 21:58 bildergalerie_02.png
    -rwxrwxr-x 1 wp1015812 wp1015812   39284 Nov  7 21:58 bildergalerie.jpg
    -rwxrwxr-x 1 wp1015812 wp1015812    2185 Nov  7 21:58 email_icon.svg
    -rwxrwxr-x 1 wp1015812 wp1015812  508378 Nov  7 21:58 ePaper_System.png
    -rwxrwxr-x 1 wp1015812 wp1015812     136 Nov  7 21:58 .htaccess
    -rwxrwxr-x 1 wp1015812 wp1015812   61813 Nov  7 21:58 INOX_Halter_01.jpg
    -rwxrwxr-x 1 wp1015812 wp1015812  238392 Nov  7 21:58 Leiste_Schildersysteme_02.png
    -rwxrwxr-x 1 wp1015812 wp1015812  104724 Nov  7 21:58 Leiste_Schildersysteme_03.png
    -rwxrwxr-x 1 wp1015812 wp1015812  118434 Nov  7 21:58 Leiste_Schildersysteme_04.png
    -rwxrwxr-x 1 wp1015812 wp1015812  116110 Nov  7 21:58 Leiste_Schildersysteme_05.png
    -rwxrwxr-x 1 wp1015812 wp1015812   19128 Nov  7 22:02 MRN_logo.jpg
    -rwxrwxr-x 1 wp1015812 wp1015812    8494 Nov  7 21:58 mrn_logo.png
    -rwxrwxr-x 1 wp1015812 wp1015812  273395 Nov  7 21:58 Plano_Schilder_image.png
    -rwxrwxr-x 1 wp1015812 wp1015812     839 Nov  7 21:58 platzhalter.png
    -rwxrwxr-x 1 wp1015812 wp1015812  627747 Nov  7 21:58 Schilder-Layouts_01.png
    -rwxrwxr-x 1 wp1015812 wp1015812  218457 Nov  7 21:58 Schilder-Leiste_02.png
    -rwxrwxr-x 1 wp1015812 wp1015812   34608 Nov  7 21:58 sc_top2.jpg
    -rwxrwxr-x 1 wp1015812 wp1015812  149579 Nov  7 21:58 Unser_Team_Grafik.jpg

  16. #56
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.762
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Da befinden sich .htaccess Dateien. Vermutlich Überbleibsel aus Contao 3? Die musst du löschen.

  17. #57
    Contao-Fan Avatar von k-webdesign
    Registriert seit
    07.06.2010.
    Ort
    Karlsruhe
    Beiträge
    585
    Partner-ID
    5911
    User beschenken
    Wunschliste

    Standard

    Fritz, freu dich bitte einmal über Zelda. Danke!
    Kann ich bestellen oder liegt's dann wieder ewig in der falschen Adresse?

  18. #58
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.762
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von k-webdesign Beitrag anzeigen
    Kann ich bestellen oder liegt's dann wieder ewig in der falschen Adresse?
    Probleme kann's immer geben mit Amazon Logistics, aber bestell ruhig

  19. #59
    Contao-Fan Avatar von k-webdesign
    Registriert seit
    07.06.2010.
    Ort
    Karlsruhe
    Beiträge
    585
    Partner-ID
    5911
    User beschenken
    Wunschliste

    Standard

    <3

Seite 2 von 2 ErsteErste 12

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •