33 geniale Contao-Erweiterungen, die du kennen solltest! - Contao Academy
Ergebnis 1 bis 14 von 14

Thema: Fehler bei Installation / tabs -> beberlei/assert

  1. #1
    Contao-Fan Avatar von PaddySD
    Registriert seit
    26.10.2016.
    Ort
    Andechs
    Beiträge
    659

    Standard Fehler bei Installation / tabs -> beberlei/assert

    Ich habe bei praktisch allen Projekten contao/bootstrap dabei, sowas hatte ich bislang noch nicht. :|

    Frische 4.6 Installation, ohne irgendwas zusätzliches.
    CM aufgerufen -> suchen -> contao-bootstrap/bundle -> Änderungen anwenden

    Es erscheint folgende Fehlermeldung:
    Code:
    Problem 1
        - Conclusion: don't install contao-bootstrap/bundle 2.1.1
        - Installation request for contao-bootstrap/bundle ~2.1 -> satisfiable by contao-bootstrap/bundle[2.1.0, 2.1.1].
        - Conclusion: don't install beberlei/assert v3.1.0
        - contao-bootstrap/bundle 2.1.0 requires contao-bootstrap/tab ~2.0 -> satisfiable by contao-bootstrap/tab[2.0.0, 2.0.3].
        - contao-bootstrap/tab 2.0.0 requires beberlei/assert ^2.9 -> satisfiable by beberlei/assert[v2.9.1, v2.9.2, v2.9.3, v2.9.4, v2.9.5, v2.9.6].
        - contao-bootstrap/tab 2.0.3 requires beberlei/assert ^2.9 -> satisfiable by beberlei/assert[v2.9.1, v2.9.2, v2.9.3, v2.9.4, v2.9.5, v2.9.6].
        - Can only install one of: beberlei/assert[v2.9.1, v3.1.0].
        - Can only install one of: beberlei/assert[v2.9.2, v3.1.0].
        - Can only install one of: beberlei/assert[v2.9.3, v3.1.0].
        - Can only install one of: beberlei/assert[v2.9.4, v3.1.0].
        - Can only install one of: beberlei/assert[v2.9.5, v3.1.0].
        - Can only install one of: beberlei/assert[v2.9.6, v3.1.0].
        - Installation request for beberlei/assert (locked at v3.1.0) -> satisfiable by beberlei/assert[v3.1.0].
    Gehe ich in die CLI und mache dort ein composer update --no-dev läuft alles problemlos durch, will heissen, er zieht sich die 2.9.x von beberlei/assert und installiert entsprechend.

    Wie gesagt, ist ja gelöst, aber vielleicht kann sich das David (@webstar) mal ansehen. Dankeschön!

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    22.020
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Das ist ein allgemeines Problem im Contao Manager. Man kann damit keine Pakete installieren, die ein Downgrade von Abhängigkeiten verursachen würden. Da hilft nur ein komplettes composer update (oder zumindest mit der manuellen Angabe aller involvierten Pakete). Wenn man es trotzdem über den Contao Manager machen möchte, hilft nur die composer.lock zu löschen.

    Seitens contao-bootstrap kann das dahingehend gelöst werden, indem beberlei/assert ^2.9 || ^3.0 required wird, statt nur ^2.9 - falls kompatibel.

  3. #3
    Contao-Fan Avatar von PaddySD
    Registriert seit
    26.10.2016.
    Ort
    Andechs
    Beiträge
    659

    Standard

    Ah danke für die Info, das erklärt den ersten Teil.

    Merkwürdig finde ich trotzdem, dass trotz nicht möglicher Installation offensichtlich das vom CM eingetragene require aber nicht gelöscht wird.

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    22.020
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Ja, das verursacht dann bei jeder versuchten Paket Installation Probleme, denn soweit ich weiß kann man das Paket dann gar nicht innerhalb des Contao Managers löschen, oder? Wenn ja: Ticket öffnen und genaue Beschreibung posten

  5. #5
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    6.529
    Partner-ID
    152
    User beschenken
    Wunschliste

    Standard

    Kann man zur Zeit nicht. Händisch rauslöschen hilft.

  6. #6
    Contao-Fan Avatar von PaddySD
    Registriert seit
    26.10.2016.
    Ort
    Andechs
    Beiträge
    659

    Standard

    Ich hab's ja glücklicherweise ohne weiteres per CLI installiert bekommen. Bei mir steht es auch im CM, alles prima! Wenn sich da nochmal was verhakt, werde ich erstmal schauen, und dann bei github posten und von Hand löschen!

    Webstar müsste halt noch die composer.json anpassen. Ich warte mal ein bisschen, sonst mache ich da einen defect auf.

  7. #7
    Contao-Urgestein
    Registriert seit
    29.10.2009.
    Ort
    Magdeburg
    Beiträge
    1.867
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von PaddySD Beitrag anzeigen
    Ich hab's ja glücklicherweise ohne weiteres per CLI installiert bekommen. Bei mir steht es auch im CM, alles prima! Wenn sich da nochmal was verhakt, werde ich erstmal schauen, und dann bei github posten und von Hand löschen!

    Webstar müsste halt noch die composer.json anpassen. Ich warte mal ein bisschen, sonst mache ich da einen defect auf.
    Bitte mach dazu ein entsprechendes Ticket auf, damit es bei mir nicht untergeht. Die Kompatibilität sollte gewährleistet sein.

  8. #8
    Contao-Fan Avatar von PaddySD
    Registriert seit
    26.10.2016.
    Ort
    Andechs
    Beiträge
    659

    Standard

    Klar mache ich! Ich editiere dann den Link zum Issue hier rein.

  9. #9
    Contao-Nutzer Avatar von dive
    Registriert seit
    17.04.2010.
    Ort
    Perchtoldsdorf, Österreich
    Beiträge
    26

    Standard

    Ein Jahr später ... plötzlich wieder das gleiche Problem. Diesmal mit Contao 4.8.5
    Im Unterschied zum urspr. Thread lässt sich aber diesmal auch per CLI contao-bootstrap/bundle nicht installieren. Was kann ich tun?

    HTML-Code:
        - Conclusion: don't install contao-bootstrap/tab 2.0.4
        - Conclusion: don't install contao-bootstrap/bundle 2.1.1
        - Installation request for symfony/templating (locked at v5.0.1) -> satisfiable by symfony/templating[v5.0.1].
        - Installation request for contao-bootstrap/bundle ^2.1 -> satisfiable by contao-bootstrap/bundle[2.1.0, 2.1.1].
        - Conclusion: don't install beberlei/assert v3.2.6
        - contao-bootstrap/bundle 2.1.0 requires contao-bootstrap/tab ~2.0 -> satisfiable by contao-bootstrap/tab[2.0.0, 2.0.3, 2.0.4].
        - contao-bootstrap/tab 2.0.0 requires beberlei/assert ^2.9 -> satisfiable by beberlei/assert[v2.9.1, v2.9.2, v2.9.3, v2.9.4, v2.9.5, v2.9.6, v2.9.9].
        - contao-bootstrap/tab 2.0.3 requires beberlei/assert ^2.9 -> satisfiable by beberlei/assert[v2.9.1, v2.9.2, v2.9.3, v2.9.4, v2.9.5, v2.9.6, v2.9.9].
        - Can only install one of: beberlei/assert[v2.9.1, v3.2.6].
        - Can only install one of: beberlei/assert[v2.9.2, v3.2.6].
        - Can only install one of: beberlei/assert[v2.9.3, v3.2.6].
        - Can only install one of: beberlei/assert[v2.9.4, v3.2.6].
        - Can only install one of: beberlei/assert[v2.9.5, v3.2.6].
        - Can only install one of: beberlei/assert[v2.9.6, v3.2.6].
        - Can only install one of: beberlei/assert[v2.9.9, v3.2.6].
        - Installation request for beberlei/assert (locked at v3.2.6) -> satisfiable by beberlei/assert[v3.2.6].
    Seltsamerweise habe ich aber in letzter Zeit schon etliche andere 4.8.5 Installationen mit contao-bootstrap/bundle erfolgreich zum Laufen gebracht.

  10. #10
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    22.020
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Hast du alle Pakete zum Update markiert?

  11. #11
    Contao-Nutzer Avatar von dive
    Registriert seit
    17.04.2010.
    Ort
    Perchtoldsdorf, Österreich
    Beiträge
    26

    Standard

    Nein, soll ich?

  12. #12
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    22.020
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Ja

  13. #13
    Contao-Nutzer Avatar von dive
    Registriert seit
    17.04.2010.
    Ort
    Perchtoldsdorf, Österreich
    Beiträge
    26

    Standard

    Tatsächlich, jetzt ist es durchgelaufen! Komisch, habe ich so noch nicht gehabt. Möglicherweise ein anderes Paket, das ebenfalls beberlei/assert als Abhängigkeit hat und für einen Versionskonflikt sorgt?
    Danke jedenfalls für den Tipp!

  14. #14
    Contao-Nutzer
    Registriert seit
    14.06.2016.
    Beiträge
    26

    Daumen hoch

    Zitat Zitat von Spooky Beitrag anzeigen
    Hast du alle Pakete zum Update markiert?
    Ich bedanke mich ebenfalls für den Hinweis!

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •