Contao Konferenz & College 2019 in Duisburg - JETZT TICKET SICHERN!
Ergebnis 1 bis 11 von 11

Thema: parameters.yml --> SMTP-Einstellungen für DomainFactory

  1. #1
    Contao-Nutzer
    Registriert seit
    27.07.2017.
    Beiträge
    127

    Fehler parameters.yml --> SMTP-Einstellungen für DomainFactory

    Hi zusammen,

    bin gerade echt am verzweifeln.

    Irgendwie wollen meine E-Mails nach Ausfüllen des Kontaktformulars nicht versendet werden. Die Seite läuft unter DomainFactory und ich habe in meiner parameters.yml schon folgendes ausprobiert:

    mailer_transport: smtp
    mailer_host: smtp.xxx.de
    mailer_user: info@xxx.de
    mailer_password: xxx
    mailer_port: 587
    mailer_encryption: tls


    mailer_port: 25
    mailer_encryption: tls


    mailer_port: 465
    mailer_encryption: ssl

    mailer_port: 25
    mailer_encryption: ssl


    Hat jemand eine Contao 4 Seite unter DomainFactory laufen und kann mir verraten, was hier die richtigen SMTP-Einstellungen sind???

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Was steht im System Log?

  3. #3
    Contao-Urgestein Avatar von Samson1964
    Registriert seit
    05.11.2012.
    Ort
    Berlin
    Beiträge
    2.361

    Standard

    Ich habe zwei ManagedServer und einen Hostingtarif bei df). In allen habe ich kein SMTP konfiguriert. Bei einem ManagedServer läuft das Kontaktformular über das NotificationCenter. Aber auch im E-Mail-Gateway dort habe ich kein SMTP aktiviert. Funktioniert alles einwandfrei.
    Viele Grüße
    Frank

    Seit Mai 2013 Fan von Contao
    Webmaster vom Deutschen Schachbund und Berliner Schachverband
    Mein Blog: Schachbulle
    Meine Erweiterungen bei GitHub
    Meine Videos auf YouTube: Playlist zur Contao-Programmierung/Einrichtung

  4. #4
    Contao-Nutzer
    Registriert seit
    27.07.2017.
    Beiträge
    127

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Was steht im System Log?
    [2019-03-16 12:14] Form "Kontakt" has been submitted by a guest.
    Löschen Anzeigen
    [2019-03-16 12:14] Could not send email for message ID 2: Connection could not be established with host smtp.fahrradsafe24.de [ #0]
    Löschen Anzeigen
    [2019-03-16 12:13] Form "Kontakt" has been submitted by a guest.
    Löschen Anzeigen
    [2019-03-16 12:13] Could not send email for message ID 2: Connection could not be established with host smtp.fahrradsafe24.de [ #0]
    Löschen Anzeigen
    [2019-03-16 12:11] User "Codehan" has logged in
    Löschen Anzeigen
    [2019-03-16 11:56] Form "Kontakt" has been submitted by a guest.
    Löschen Anzeigen
    [2019-03-16 11:56] Could not send email for message ID 2: Unable to connect with TLS encryption


    Egal welche Kombination ich versuche klappt es nicht..
    Leere auch immer der prod-Cache usw.

  5. #5
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.671
    User beschenken
    Wunschliste

    Standard

    Nach den Änderungen an der parameters.yml hast Du auch jedesmal den Symfony Cache erneuert?
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  6. #6
    Contao-Nutzer
    Registriert seit
    27.07.2017.
    Beiträge
    127

    Standard

    Zitat Zitat von xchs Beitrag anzeigen
    Nach den Änderungen an der parameters.yml hast Du auch jedesmal den Symfony Cache erneuert?
    Ja, die System-Logs reagieren auch immer drauf.. Echt komisch..

  7. #7
    Contao-Nutzer
    Registriert seit
    27.07.2017.
    Beiträge
    127

    Standard

    Zitat Zitat von Samson1964 Beitrag anzeigen
    Ich habe zwei ManagedServer und einen Hostingtarif bei df). In allen habe ich kein SMTP konfiguriert. Bei einem ManagedServer läuft das Kontaktformular über das NotificationCenter. Aber auch im E-Mail-Gateway dort habe ich kein SMTP aktiviert. Funktioniert alles einwandfrei.
    Wie sieht deine parameters.yml? aus?

  8. #8
    Contao-Nutzer
    Registriert seit
    27.07.2017.
    Beiträge
    127

    Standard

    Auf meinem iPhone läuft SLL unter 465 ohne Probleme.

  9. #9
    Contao-Fan
    Registriert seit
    05.11.2009.
    Ort
    Liebschützberg (Sachsen)
    Beiträge
    444

    Standard

    Zitat Zitat von Codehan Beitrag anzeigen
    Hi zusammen,

    bin gerade echt am verzweifeln.

    Irgendwie wollen meine E-Mails nach Ausfüllen des Kontaktformulars nicht versendet werden. Die Seite läuft unter DomainFactory und ich habe in meiner parameters.yml schon folgendes ausprobiert:

    mailer_transport: smtp
    mailer_host: smtp.xxx.de
    mailer_user: info@xxx.de
    mailer_password: xxx
    ?
    Teste mal mit:
    Server sslout.de
    Port 465
    Geändert von swinde (16.03.2019 um 17:54 Uhr)

  10. #10
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.740
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Codehan Beitrag anzeigen
    [2019-03-16 12:14] Form "Kontakt" has been submitted by a guest.
    Löschen Anzeigen
    [2019-03-16 12:14] Could not send email for message ID 2: Connection could not be established with host smtp.fahrradsafe24.de [ #0]
    Löschen Anzeigen
    [2019-03-16 12:13] Form "Kontakt" has been submitted by a guest.
    Löschen Anzeigen
    [2019-03-16 12:13] Could not send email for message ID 2: Connection could not be established with host smtp.fahrradsafe24.de [ #0]
    Löschen Anzeigen
    [2019-03-16 12:11] User "Codehan" has logged in
    Löschen Anzeigen
    [2019-03-16 11:56] Form "Kontakt" has been submitted by a guest.
    Löschen Anzeigen
    [2019-03-16 11:56] Could not send email for message ID 2: Unable to connect with TLS encryption


    Egal welche Kombination ich versuche klappt es nicht..
    Leere auch immer der prod-Cache usw.
    Laut Fehlermeldung kann keine Verbindung zum SMTP Server smtp.fahrradsafe24.de aufgebaut werden. Bist du dir sicher, dass das der richtige Host ist?

  11. #11
    Contao-Urgestein Avatar von Samson1964
    Registriert seit
    05.11.2012.
    Ort
    Berlin
    Beiträge
    2.361

    Standard

    Zitat Zitat von Codehan Beitrag anzeigen
    Wie sieht deine parameters.yml? aus?
    Da steht nichts für SMTP drin. Nur die Datenbank-Zugangsdaten.
    Viele Grüße
    Frank

    Seit Mai 2013 Fan von Contao
    Webmaster vom Deutschen Schachbund und Berliner Schachverband
    Mein Blog: Schachbulle
    Meine Erweiterungen bei GitHub
    Meine Videos auf YouTube: Playlist zur Contao-Programmierung/Einrichtung

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •