MetaModels Workshop in Berlin
Ergebnis 1 bis 10 von 10

Thema: jquery Version veraltet

  1. #1
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Frage jquery Version veraltet

    Moin,
    ich habe gerade eine frische und sonst nackige Contao Version installiert und bekomme per default sofort eine veraltete jquery Version (v1.12.4) mit eingebunden.
    Kann mir jemand verraten wieso es per default eine veraltete und unsichere Version gibt, bzw. wo sonst der Fehler liegen könnte, dass ich diese bekomme?

    Eigentlich würde ich erwarten, dass die jquery version halbwegs aktuell zumindest 3.x sein müßte.

    Danke vorab für eure Mühe.

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.573
    User beschenken
    Wunschliste

    Standard

    Contao 4.4 bindet aufgrund der Rückwärtskompatibilität weiterhin contao-components/jquery in Version 1.x ein. Du kannst aber mit "... as 1.99" eine höhere Version anfordern.

  3. #3
    Contao-Fan Avatar von Franko
    Registriert seit
    22.06.2009.
    Beiträge
    884
    Partner-ID
    6122

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Contao 4.4 bindet aufgrund der Rückwärtskompatibilität weiterhin contao-components/jquery in Version 1.x ein. Du kannst aber mit "... as 1.99" eine höhere Version anfordern.
    Könntest Du das evtl. näher erklären.
    Carpe diem ...

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.573
    User beschenken
    Wunschliste

    Standard

    Code:
    "contao-components/jquery": "^3.0 as 1.99"

  5. #5
    Contao-Urgestein
    Registriert seit
    29.10.2009.
    Beiträge
    1.771
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Contao 4.4 bindet aufgrund der Rückwärtskompatibilität weiterhin contao-components/jquery in Version 1.x ein. Du kannst aber mit "... as 1.99" eine höhere Version anfordern.
    Eigentlich ist Contao darauf ausgelegt, dass die JQuery-Version frei gewählt werden kann, siehe https://github.com/contao/core-bundl...poser.json#L33

    Es reicht daher contao-components/jquery explizit in Version 3 anzufordern (^3.0) über den Contao Manager oder Composer.


    Sorry, gerade erst gesehen, dass du ja für Contao 4.4 anfragst. Da gilt Spookys Aussage weiterhin.

  6. #6
    Contao-Fan Avatar von Franko
    Registriert seit
    22.06.2009.
    Beiträge
    884
    Partner-ID
    6122

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Code:
    "contao-components/jquery": "^3.0 as 1.99"
    Sorry, ich raffs nicht.
    In einer "normalen" 4.4er Installation setze ich dann in der composer.json nachträglich den Eintrag "contao-components/jquery": "^3.0 as 1.99".
    Ohne "as 1.99" würden dann die Contao integrierten jquery scripts nicht laufen? ...
    Carpe diem ...

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.573
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Franko Beitrag anzeigen
    In einer "normalen" 4.4er Installation setze ich dann in der composer.json nachträglich den Eintrag "contao-components/jquery": "^3.0 as 1.99".
    Genau, und dann natürlich eine Paketaktualisierung.


    Zitat Zitat von Franko Beitrag anzeigen
    Ohne "as 1.99" würden dann die Contao integrierten jquery scripts nicht laufen? ...
    Nein, ohne das "as 1.99" könntest du das Paket nicht installieren, denn Contao 4.4 verlangt nach 1.x.

  8. #8
    Contao-Urgestein Avatar von fiedsch
    Registriert seit
    09.07.2009.
    Ort
    München
    Beiträge
    2.208

    Standard

    "^3.0 as 1.99": die 3er Version als 1.99 anfordern, damit diese Zeile aus der composer.json von Contao 4.4 erfüllt werden kann.

    Edit: "natürlich" wieder zu langsam
    Stammtisch Contao Bayern: http://www.contao-bayern.de

  9. #9
    Contao-Fan Avatar von Franko
    Registriert seit
    22.06.2009.
    Beiträge
    884
    Partner-ID
    6122

    Standard

    Ah -Verstanden,
    Danke euch beiden ...
    Carpe diem ...

  10. #10
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.573
    User beschenken
    Wunschliste

    Standard

    Das korrekte requirement für Contao 4.4 ist übrigens
    Code:
    "contao-components/jquery": "3.x-dev as 1.99"
    Hinweis: das installiert den 3.x-dev branch und designiert ihn als Version 1.99 - da Contao 4.4 ^1.x verlangt.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •