Contao Camp 2019 in München - Save the date!
Ergebnis 1 bis 4 von 4

Thema: composer.json: Wie formuliere ich die Abhängigkeiten

  1. #1
    Contao-Urgestein Avatar von do_while
    Registriert seit
    15.06.2009.
    Ort
    Berlin | Deutschland
    Beiträge
    3.283
    Partner-ID
    1081
    User beschenken
    Wunschliste

    Standard composer.json: Wie formuliere ich die Abhängigkeiten

    Ich habe ein Problem beim Definieren der Abhängigkeiten meiner Erweiterung.

    Hintergrund:
    Ab Contao 4.7 ist TCPDF in ein Bundle ausgelagert. Man muss also in der composer.json das Bundle angeben.

    Meine Erweiterung do-while/contao-pdf-template braucht ab 4.7 dieses Bundle.
    Aber: wenn ich die Erweiterung bei <4.7 einsetzen möchte, darf ich das Bundle nicht angeben, da sonst nicht aufgelöst werden kann.

    Muss ich jetzt 2 Zweige der Erweiterung erstellen und pflegen? (wäre nicht sehr schön)

    Oder kann ich irgendwie in der composer.json folgendes angeben:
    IF "contao/core-bundle" >= 4.7 THEN require "contao/tcpdf-bundle"

  2. #2
    Contao-Nutzer Avatar von bjarke
    Registriert seit
    07.06.2011.
    Beiträge
    235

    Standard

    Vielleicht hilft dir dieses Ticket.

  3. #3
    Contao-Nutzer Avatar von Tastaturberuf
    Registriert seit
    14.03.2011.
    Ort
    Berlin
    Beiträge
    181
    User beschenken
    Wunschliste

    Standard

    Brauchst du wirklich das ganze Bundle oder nur tecnickcom/tcpdf?
    Tastaturberuf | Code with ♥ and Contao.

  4. #4
    Contao-Urgestein Avatar von do_while
    Registriert seit
    15.06.2009.
    Ort
    Berlin | Deutschland
    Beiträge
    3.283
    Partner-ID
    1081
    User beschenken
    Wunschliste

    Standard

    Da muss ich noch mal genau gucken.
    Ich denke aber die tcpdf.php Initialisierungsdatei kommt erst mit dem Contao-Bundle.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •