Contao Konferenz 2019 in Duisburg - Call for Papers
Ergebnis 1 bis 3 von 3

Thema: Problem mit "Mehrere bearbeiten" unter Contao 3.5

  1. #1
    Contao-Nutzer
    Registriert seit
    22.09.2016.
    Beiträge
    1

    Standard Problem mit "Mehrere bearbeiten" unter Contao 3.5

    Ich habe ein Problem mit "Mehrere bearbeiten" in einem Projekt unter Contao 3.5.28. Eine Frage zu dieser recht veralteten Version nervt Euch wahrscheinlich, aber ein Update auf Contao 4 ist in diesem Projekt leider nicht möglich und einem Update auf die aktuellste Contao 3.5er stimmt mein Kunde nur zu, wenn ich glaubhaft versichern kann, dass dies das Problem löst. Deshalb brauche ich Eure Einschätzung.

    Das Problem stellt sich folgendermaßen dar:

    Wenn ich bei "Mehrere bearbeiten" die zu bearbeitenden Datensätze auswähle (es handelt sich um eine über pct_customelements erstellte Tabelle) und dann auf "bearbeiten" klicke, dann ist der nächste Schritt die Auswahl der zu bearbeitenden Felder. Hier wird nun schon angezeigt "Es ist ein Fehler aufgetreten" und "Bitte wählen Sie mindestens ein Feld". Dieser Fehler dürfte ja normalerweise erst auftauchen, wenn ich versuche, ohne ein ausgewähltes Feld fortzufahren.

    Interessant: Das passiert nur, wenn spezielle Datensätze zur Bearbeitung ausgewählt wurden. Eine Besonderheit bei diesen Datensätzen fällt mir leider nicht auf.

    Ich kann dann eigentlich normal weitermachen. Möchte ich dann aber die Änderungen an den bearbeiteten Datensätzen abspeichern, so kommt folgende Warning (mehrfach):

    Code:
    Warning: implode(): Invalid arguments passed in system/modules/core/classes/DataContainer.php on line 279
    
    #0 [internal function]: __error(2, 'implode(): Inva...', '/kunden/261105_...', 279, Array)
    #1 system/modules/core/classes/DataContainer.php(279): implode(',', NULL)
    #2 system/modules/core/drivers/DC_Table.php(2356): Contao\DataContainer->row(Array)
    #3 system/modules/core/classes/Backend.php(650): Contao\DC_Table->editAll()
    #4 system/modules/core/controllers/BackendMain.php(131): Contao\Backend->getBackendModule('produkte')
    #5 contao/main.php(20): Contao\BackendMain->run()
    #6 {main}
    Ich habe geprüft, warum der Inhalt der in Zeile 279 verarbeiteten POST-Variablen NULL ist und fand heraus, dass der entsprechende Key in $_POST überhaupt nicht existiert, obwohl er im Formular zuvor nachweislich völlig korrekt vorhanden ist.

    Bei der testweisen Ausgabe von $_POST bemerkte ich, dass dem $_POST-Array seltsame Key/Value-Paare mit kryptischen Keys hinzugefügt werden, z.B. "[snzuy0la6oqacg]". Bearbeite ich nur sehr wenige Datensätze, so hat das Hinzufügen dieser Keys keine negative Auswirkung und die genannte Warning kommt nicht. Bearbeite ich aber recht viele Datensätze, so verschwinden durch das Hinzufügen der komischen Keys andere Keys, die wichtig sind. Sollen diese Keys dann ausgelesen werden, ergibt das Null und die genannte Warning.

    Kommt das irgendjemandem bekannt vor oder hat irgendjemand eine Idee, was hier los sein kann? Wo in Contao könnte es denn zu einer seltsamen Manipulation der Inhalte von $_POST kommen?
    Geändert von dOIOb (17.05.2019 um 11:06 Uhr)

  2. #2
    Contao-Urgestein Avatar von Toflar
    Registriert seit
    15.06.2009.
    Beiträge
    4.382
    Partner-ID
    8667
    User beschenken
    Wunschliste

    Standard

    Ich glaube das liegt dann an den custom elements und ob die Contao 3.5 noch unterstützen, weiss ich nicht.
    terminal42 gmbh
    Wir sind Contao Premium-Partner!
    Für Modulwünsche oder Programmierungen kannst du uns gerne kontaktieren.

  3. #3
    Contao-Nutzer Avatar von JamesdK
    Registriert seit
    02.12.2009.
    Ort
    Leverkusen
    Beiträge
    124
    Partner-ID
    8753

    Standard

    Gibt es eventuell verschiedene Benutzerrechte, die auf den Elementen liegen?
    Also Redakteur A hat angelegt und Redakteur B mit anderen Benutzerrechten darf dann nicht bearbeiten?

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •