MetaModels Workshop in Berlin
Ergebnis 1 bis 14 von 14

Thema: Password Vergessen Fkt. - Backend

  1. #1
    Contao-Nutzer
    Registriert seit
    01.12.2016.
    Beiträge
    126

    Standard Password Vergessen Fkt. - Backend

    Hallo,

    ich habe aktuell einen FileServer mit Contao 4 realisiert. Hier finden im Monat einige wenige Uploads statt.

    Nun möchte ich gerne eine "Passwort vergessen" Funktion für Backend Benutzer einbauen und frage mich, ob es dafür bereits einen Ansatz oder ein Modul gibt.
    Der Standardweg besteht aus der Eingabe einer E-Mail Adresse und das Zurücksetzen des Passwortes über dieses E-Mail Konto.

    Kann mir jmd. dazu helfen?

    Gruß Chris

  2. #2
    Contao-Nutzer Avatar von JamesdK
    Registriert seit
    02.12.2009.
    Ort
    Leverkusen
    Beiträge
    130
    Partner-ID
    8753

    Standard

    Schau mal hier: markocupic/backend-password-recovery-bundle.

    Im übrigen kannst du über http://packages.contao.org ganz einfach nach Paketen suchen.

  3. #3
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.575
    User beschenken
    Wunschliste

    Standard

    Packages heißen jetzt wieder Extensions

    https://extensions.contao.org/
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  4. #4
    Contao-Nutzer
    Registriert seit
    01.12.2016.
    Beiträge
    126

    Standard

    Zitat Zitat von JamesdK Beitrag anzeigen
    Schau mal hier: markocupic/backend-password-recovery-bundle.

    Im übrigen kannst du über http://packages.contao.org ganz einfach nach Paketen suchen.
    Gutes Modul, jedoch benutze ich Contao 4.4 LTS Version. Ich bleibe auch bei der 4.4 Version, weil die 4.7 eine Developer Version ist...

    Habe in der Paketverwaltung gesucht, jedoch taucht dort keins für die Version auf.

    Gibt es außerhalb der Paketverwaltung auch ein Modul?

  5. #5
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.030
    Partner-ID
    7421

    Standard

    Zitat Zitat von c.stege Beitrag anzeigen
    Ich bleibe auch bei der 4.4 Version, weil die 4.7 eine Developer Version ist...
    Es gibt sicher Gründe bei Kundeninstallationen auf LTS-Versionen zu setzen. Mache ich auch häufig. Aber ganz bestimmt ist die 4.7 keine Developer Version. Woher hast Du das denn? Contao 4.7 ist einfach die neueste stable Version von Contao.
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  6. #6
    Contao-Nutzer Avatar von JamesdK
    Registriert seit
    02.12.2009.
    Ort
    Leverkusen
    Beiträge
    130
    Partner-ID
    8753

    Standard

    Die genannte Erweiterung läuft bei uns in einer 4.4 LTS sehr stabil.

  7. #7
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.561
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Welche Version genau?
    Laut diesem Ticket nicht:
    https://github.com/markocupic/backen...undle/issues/2
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Für Contao abstimmen: https://bitnami.com/product/contao/widget
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 Hoster: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with coding, testing and time.

  8. #8
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.546
    User beschenken
    Wunschliste

    Standard

    Version 1.2.0 benötigt Contao 4.7. Die Versionen davor nicht.

    @c.stege alle veröffentlichten Versionen von Contao sind natürlich keine Entwickler Versionen.

  9. #9
    Contao-Nutzer Avatar von JamesdK
    Registriert seit
    02.12.2009.
    Ort
    Leverkusen
    Beiträge
    130
    Partner-ID
    8753

    Standard

    Habs gerade nochmal kontrolliert, wir haben Version 1.1.0 installiert.

  10. #10
    Contao-Nutzer
    Registriert seit
    01.12.2016.
    Beiträge
    126

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Version 1.2.0 benötigt Contao 4.7. Die Versionen davor nicht.

    @c.stege alle veröffentlichten Versionen von Contao sind natürlich keine Entwickler Versionen.
    Ich danke erst einmal allen für die Antworten.

    @Spooky Ich habe jedoch irgendwo mal gelesen, dass kommende Sicherheitsupdates etc. dann nicht für die Version 4.7 rauskommen. Man arbeitet also mehr oder weniger immer mit der Beta-Version, da evtl. neuste Funktionen mit 4.8 kommen, die nicht richtig funktionieren.

    Ansonsten ist die Frage, wie ich ältere Versionen des Moduls installieren kann? Würde dann die letzte 1.1 Version installieren.

    Gruß Chris

  11. #11
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.575
    User beschenken
    Wunschliste

    Standard

    Veröffentlichte Contao-Versionen bekommen so lange Updates, wie das betreffende Release unterstützt wird (siehe https://contao.org/de/release-plan.html).

    Du kannst die gewünschte Version im Contao Manager festlegen und eine Paketaktualisierung starten.
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  12. #12
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    6.408
    Partner-ID
    152
    User beschenken
    Wunschliste

    Standard

    Naja, ich weiss nicht wo Du das gelesen hast - manchmal versteht man's ja auch einfach nicht vollständig.

    Eine Contao-Version wird veröffentlicht, wenn sie fertig ist. Die heisst dann beispielsweise 4.0, 4.1, 4.2, 4.3, 4.4, 4.5 und so weiter. Fertig ist sie, wenn keine bekannten Bugs mehr drin sind. Die aktuelle Contao-Version ist die 4.7, und irgendwann demnächst wird es die 4.8 geben. Irgendwann später wird dann die 4.9 kommen - und so weiter. Diese Versionen sind 'Stable'.

    Wann welche Version erscheint, das siehst Du am Releaseplan unter https://contao.org/de/release-plan.html.

    Versionen, die noch nicht fertig sind, werden vorab veröffentlicht, damit man testen kann. Je nach Status sind dann dann erst Alpha-Versionen (bei denen sich noch etwas an Funktionen bzw. Schnittstellen ändern kann), Beta-Versionen, die den endgültigen Funktionsumfang haben und dann auch RC-Versionen (das sind Release Candidates, bei denen alle der Meinung sind, dass alles gut ist, aber zur Sicherheit noch eine kurze testphase eingeschoben wird).

    Grundsätzlich kann man jede Stable-Version produktiv einsetzen. Sie wird aktiv weiter entwickelt und bekommt Bugfixes. Die aktuelle Stable ist die 4.7.

    Manchen ist - in umfangreichen Produktivumgebungen - die Häufigkeit von neuen Stable-Versionen zu schnell. Extra für die wird dann eine Version zur LTS-Version deklariert. Das bedeutet 'Long-Term-Support', was sich sicher auch inhaltlich erschliesst wenn man diesen englischen Begriff in eine Suchmaschine der Wahl eingibt.

    LTS-Versionen werden nicht aktiv weiter entwickelt - im Sinne von neuen Funktionen oder Änderungen an der API oder oder oder. Long-Term-Support bedeutet aber, dass sie bei allfälligen Fehlern ein Update erhalten. Sie bekommen damit Sicherheitsupdates über die normalerweise veranschlagte Zeit hinaus.

    Welche Version im konkreten Projekt eingesetzt wird bleibt letztlich Dir überlassen. Das kann davon abhängig sein, welche Funktionen gebraucht werden (oder auch nicht gebraucht), was Kunden an Support bezahlen wollen, wieviel Stress man sich selbst machen möchte.

  13. #13
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.546
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von c.stege Beitrag anzeigen
    @Spooky Ich habe jedoch irgendwo mal gelesen, dass kommende Sicherheitsupdates etc. dann nicht für die Version 4.7 rauskommen.
    Eine Contao Version wird so lange aktualisiert, wie es im Release Plan vorgesehen ist.


    Zitat Zitat von c.stege Beitrag anzeigen
    Man arbeitet also mehr oder weniger immer mit der Beta-Version.
    Nein, das sind keine Beta Versionen. Das sind ganz normale Contao Versionen.


    Zitat Zitat von c.stege Beitrag anzeigen
    Ansonsten ist die Frage, wie ich ältere Versionen des Moduls installieren kann? Würde dann die letzte 1.1 Version installieren.
    Einfach in deiner composer.json entsprechend eintragen. zB ^1.0

  14. #14
    Contao-Nutzer
    Registriert seit
    01.12.2016.
    Beiträge
    126

    Standard

    Ich danke euch für die ausführlichen Antworten zum Thema "Versionen". Hat auf jeden Fall Licht ins Dunkle gebracht

    Gruß Chris

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •