Ergebnis 1 bis 4 von 4

Thema: news4ward: Fehler nach PHP-Update

  1. #1
    Contao-Nutzer Avatar von ahelmis
    Registriert seit
    21.07.2010.
    Ort
    Rödermark
    Beiträge
    108

    Standard news4ward: Fehler nach PHP-Update

    Hallo zusammen,

    ich habe aufgrund der PHP-Umstellung bei domainfactory meine Website upgedated:
    - contao 3.5.34 auf 3.5.40 und PHP auf 7.2 stable
    - Erweiterungen upgedated
    - aktuellste news4ward-Version von github (nach dem Hinweis, dass die alte nicht funktioniert, es mit der neuesten aber gehen würde)

    Im fe funktioniert alles.

    Nun wollte ich einen neuen Beitrag mit news4ward erstellen, erhalte aber nach dem Speichern eine Fehlerseite und komme jetzt auch gar nicht mehr in die Beiträge.

    Die error.log sagt folgendes (Serverpfad habe ich ersetzt mit "..."):

    [23-Jun-2019 00:48:15 Europe/Berlin] PHP Fatal error: Uncaught exception 'Error' with message 'Call to undefined method Contao\StringUtil::stripRootDir()' thrown in /.../system/modules/news4ward/Helper.php on line 408
    #0 /.../system/modules/news4ward/Helper.php(292): Psi\News4ward\Helper->generateFiles(Array)
    #1 /.../system/modules/core/controllers/FrontendCron.php(103): Psi\News4ward\Helper->generateFeeds()
    #2 /.../system/cron/cron.php(20): Contao\FrontendCron->run()
    #3 {main}
    [23-Jun-2019 21:30:15 Europe/Berlin] PHP Fatal error: Uncaught exception 'Error' with message 'Call to undefined method Contao\StringUtil::stripRootDir()' thrown in /.../system/modules/news4ward/Helper.php on line 408
    #0 /.../system/modules/news4ward/Helper.php(273): Psi\News4ward\Helper->generateFiles(Array)
    #1 /.../system/cache/dca/tl_news4ward_article.php(542): Psi\News4ward\Helper->generateFeed('1')
    #2 /.../system/modules/core/drivers/DC_Table.php(207): tl_news4ward_article->generateFeed(Object(Contao\DC_Table))
    #3 /.../system/modules/core/classes/Backend.php(408): Contao\DC_Table->__construct('tl_news4ward_ar...', Array)
    #4 /.../system/modules/core/controllers/BackendMain.php(131): Contao\Backend->getBackendModule('news4ward')
    #5 /.../contao/main.php(20): Contao\BackendMain->run()
    #6 {main}
    [23-Jun-2019 21:32:29 Europe/Berlin] PHP Fatal error: Uncaught exception 'Error' with message 'Call to undefined method Contao\StringUtil::stripRootDir()' thrown in /.../system/modules/news4ward/Helper.php on line 408
    #0 /.../system/modules/news4ward/Helper.php(273): Psi\News4ward\Helper->generateFiles(Array)
    #1 /.../system/cache/dca/tl_news4ward.php(429): Psi\News4ward\Helper->generateFeed('1')
    #2 /.../system/modules/core/drivers/DC_Table.php(207): tl_news4ward->generateFeed(Object(Contao\DC_Table))
    #3 /.../system/modules/core/classes/Backend.php(408): Contao\DC_Table->__construct('tl_news4ward', Array)
    #4 /.../system/modules/core/controllers/BackendMain.php(131): Contao\Backend->getBackendModule('news4ward')
    #5 /.../contao/main.php(20): Contao\BackendMain->run()
    #6 {main}

    Kann mir jemand helfen und erklären, was da los ist, was die Fehlermeldung bedeutet und ob es eine Möglichkeit gibt, das wieder zum Laufen zu bringen?

    Andreas

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.343
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Der Fehler wurde hier eingeführt: https://github.com/psi-4ward/news4wa...dcebc6db905b9d

    Die Funktion \Contao\StringUtil::stripRootDir gibt es erst in Contao 4. Version 2.3.5 der Extension ist also nicht mit Contao 3 kompatibel. Du müsstest wenn dann Version 2.3.4 probieren.

    https://github.com/psi-4ward/news4wa...ment-504784829

  3. #3
    Contao-Nutzer Avatar von ahelmis
    Registriert seit
    21.07.2010.
    Ort
    Rödermark
    Beiträge
    108

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Der Fehler wurde hier eingeführt: https://github.com/psi-4ward/news4wa...dcebc6db905b9d

    Die Funktion \Contao\StringUtil::stripRootDir gibt es erst in Contao 4. Version 2.3.5 der Extension ist also nicht mit Contao 3 kompatibel. Du müsstest wenn dann Version 2.3.4 probieren.

    https://github.com/psi-4ward/news4wa...ment-504784829
    Wow Spooky. Danke, danke, danke! Version 2.3.4 funktioniert!!!

    Meine Hochachtung für die schnelle Reaktion und Hilfe!
    Andreas

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.343
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Keine Ursache

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •