Contao Konferenz & College 2019 in Duisburg - JETZT TICKET SICHERN!
Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 40 von 86

Thema: Update von Contao 3.5.40 auf Contao 4.4.40

  1. #1
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard Update von Contao 3.5.40 auf Contao 4.4.40

    hi Leute,

    ich bin mitten drin in einem Update Prozess von Contao 3.5.40 auf contao 4.4.40. Im Moment kann die Seite nicht angezeigt werden. Die log-Datei gibt folgendes aus:
    [2019-07-16 13:48:48] request.INFO: Matched route "contao_index". {"route":"contao_index","route_parameters":{"_toke n_check":true,"_controller":"Contao\\CoreBundle\\C ontroller\\FrontendController::indexAction","_scop e":"frontend","_route":"contao_index"},"request_ur i":"http://web268.s153.goserver.host/","method":"GET"} []
    [2019-07-16 13:48:48] security.INFO: Attempting SimplePreAuthentication. {"key":"frontend","authenticator":"Contao\\CoreBun dle\\Security\\ContaoAuthenticator"} []
    [2019-07-16 13:48:48] app.CRITICAL: An exception occurred. {"exception":"[object] (Exception(code: 0): Could not find template "j_slider" at /home/www/contao4/vendor/contao/core-bundle/src/Resources/contao/library/Contao/TemplateLoader.php:152)"} []
    Ich bin nach diesem howto von Christian Feneberg vorgegangen: https://contao-academy.de/blog/updat...3-auf-contao-4
    Folgende Erweiterungen habe ich noch.
    - pct_autogrid
    - pct_customelements
    - pct_iconpicker
    - pct_themer
    - pct_revolutionslider
    - pct_megamenu

    Wenn ich diese per FTP in das Verzeichnis system/modules übertrage, dann bekomme ich die Meldung Bad Gateway 502.
    Hat mir jemand einen Tipp, wie ich da weiter verfahren kann? Sind die Erweiterung überhaupt unter Contao 4 lauffähig?
    Für eure Hilfe, wäre ich euch sehr dankbar.
    Seien wir realistisch, versuchen wir das Unmögliche

  2. #2
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.054
    Partner-ID
    7421

    Standard

    Laut Fehlermeldung wird der fehlende j_slider angemeckert.
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  3. #3
    Contao-Urgestein Avatar von Kahmoon
    Registriert seit
    22.06.2009.
    Ort
    München
    Beiträge
    4.185

    Standard

    Vermutlich den files bzw. template (enthält die j_slider) Ordner noch nicht nach C4 kopiert.

  4. #4
    Alter Contao-Hase
    Registriert seit
    20.09.2012.
    Ort
    Lüneburger Heide
    Beiträge
    1.402
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von monaco Beitrag anzeigen
    hi
    Folgende Erweiterungen habe ich noch.
    - pct_autogrid
    - pct_customelements
    - pct_iconpicker
    - pct_themer
    - pct_revolutionslider
    - pct_megamenu

    Sind die Erweiterung überhaupt unter Contao 4 lauffähig?
    Hi,

    auf jeden Fall,

    ich habe schon mehrere 3.5.x Versionen mit PCT-Modulen auf 4.4.40 aktualisiert.

    Wie oben schon erwähnt muss in allen Seitenlayouts das j_slider Template aktiviert werden.

    Gruß
    tschero

  5. #5
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.799
    User beschenken
    Wunschliste

    Standard

    Du musst nur sicherstellen, dass du die neuesten Versionen dieser Module verwendest.

  6. #6
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Du musst nur sicherstellen, dass du die neuesten Versionen dieser Module verwendest.
    ok. Ich habe bisher wie schon gesagt die aus 3.5 per ftp die verzeichnisse von oben
    pct_autogrid
    - pct_customelements
    - pct_iconpicker
    - pct_themer
    - pct_revolutionslider
    - pct_megamenu
    rüber in die Contao 4 Installation kopiert. Unter System/modules. Ferner habe ich die j_slider.html5 in den Leider funktioniert der Slider nicht im Frontend und im Backend kann ich mich nicht mehr einloggen. Da bekomme ich ein Bad Gateway 502
    Folgendes steht in der log-Datei......
    request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHtt pException: "Page not found: http://web268.s153.goserver.host/favicon.ico" at /home/www/contao4/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php line 112 {"exception":"[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFou ndHttpException(code: 0): Page not found: http://web268.s153.goserver.host/favicon.ico at /home/www/contao4/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php:112, Contao\\CoreBundle\\Exception\\PageNotFoundExcepti on(code: 0): Page not found: http://web268.s153.goserver.host/favicon.ico at /home/www/contao4/vendor/contao/core-bundle/src/Resources/contao/controllers/FrontendIndex.php:64)"}
    Wie bekomme ich die neueste Version der Module. Kann ich die unter Contao 4 über den Paket - Manager vielleicht installieren? Laufen die Module unter einem anderen Namen?
    Seien wir realistisch, versuchen wir das Unmögliche

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.799
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von monaco Beitrag anzeigen
    Wie bekomme ich die neueste Version der Module.
    Im Download Bereich deines PCT Accounts. Wobei diese Dinge im PCT Forum besser aufgehoben wären.

  8. #8
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    Zitat Zitat von mlweb Beitrag anzeigen
    Laut Fehlermeldung wird der fehlende j_slider angemeckert.
    Ich habe die j_slider.html5 von Contao 3.5 in den Ordner unter Contao 4 in templates kopiert.
    Seien wir realistisch, versuchen wir das Unmögliche

  9. #9
    Alter Contao-Hase
    Registriert seit
    20.09.2012.
    Ort
    Lüneburger Heide
    Beiträge
    1.402
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von monaco Beitrag anzeigen
    Ich habe die j_slider.html5 von Contao 3.5 in den Ordner unter Contao 4 in templates kopiert.
    Welches Theme von PCT nutzt Du?
    - Installiere ein sauberes Contao 4
    - Lade ALLE aktuellen Themedaten hoch
    - Lade Deine anderen files hoch
    - Importiere die Contao 3.5 Datenbank
    - Installtool aufrufen
    - Verzeichnisse veröffentlichen
    - in allen Seitenlayouts das j_slider Template aktivieren --> hier scheint momentan Dein Fehler zu sein -> bitte mach das mal

    Hier noch mal ein Link zum Updatethread im PCT Forum:
    https://forum.premium-contao-themes....ao-3-5-auf-4-4

    So sollte es funktionieren
    Geändert von tschero (17.07.2019 um 15:30 Uhr) Grund: Link ergänzt

  10. #10
    Alter Contao-Hase
    Registriert seit
    20.09.2012.
    Ort
    Lüneburger Heide
    Beiträge
    1.402
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von monaco Beitrag anzeigen

    Wie bekomme ich die neueste Version der Module. Kann ich die unter Contao 4 über den Paket - Manager vielleicht installieren? Laufen die Module unter einem anderen Namen?
    Die liegen in Deinem Account bei PCT zum Download bereit, sind NICHT über Composer oder Contao-Manager zu laden und haben KEINEN anderen Namen.

    Gruß
    tschero

  11. #11
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    in allen Seitenlayouts das j_slider Template aktivieren --> hier scheint momentan Dein Fehler zu sein -> bitte mach das mal
    wow. vielen Dank für den wertvollen Tipp. Wenn ich allerdings die Dateien, Verzeichnisse aus system/modules/ in Contao 4 kopiere, bekomme ich einen Bad Gateway. Das ermöglicht mir keine Anmeldung mehr im Backend. Sonst würde ich ja die j_slider im Seitenlayout aktivieren.
    Seien wir realistisch, versuchen wir das Unmögliche

  12. #12
    Alter Contao-Hase
    Registriert seit
    20.09.2012.
    Ort
    Lüneburger Heide
    Beiträge
    1.402
    User beschenken
    Wunschliste

    Standard

    ... Page not found: http://web268.s153.goserver.host/favicon.ico at /home/www/contao4/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php:112, Contao\\CoreBundle\\Exception\\PageNotFoundExcepti on(code: 0): Page not found: http://web268.s153.goserver.host/favicon.ico at /home/www/contao4/vendor/contao/core-bundle/src/Resources/contao/controllers/FrontendIndex.php:64)"}
    Kopiere mal bitte die favicon.ico Datei in Dein /web Verzeichnis

  13. #13
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.714
    User beschenken
    Wunschliste

    Standard

    Wie sieht Deine Verzeichnisstruktur unterhalb von system/modules/ aus? Für manuell installierte Erweiterungen ist natürlich auch der Cache var/cache manuell zu löschen. Rufe anschließend das Contao Installtool auf und aktualisiere die Datenbank.
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  14. #14
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    Zitat Zitat von tschero Beitrag anzeigen
    Kopiere mal bitte die favicon.ico Datei in Dein /web Verzeichnis
    Das hat funktioniert. Leider zeigt mir die log - Datei immer noch folgende Meldung an:
    [2019-07-18 11:25:34] request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHtt pException: "Page not found: http://web268.s153.goserver.host/assets/jquery/ui/jquery-ui.min.js" at /home/www/contao4/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php line 112 {"exception":"[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFou ndHttpException(code: 0): Page not found: http://web26/assets/jquery/ui/jquery-ui.min.js at /home/www/contao4/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php:112, Contao\\CoreBundle\\Exception\\PageNotFoundExcepti on(code: 0): Page not found: http://web26/assets/jquery/ui/jquery-ui.min.js at /home/www/contao4/vendor/contao/core-bundle/src/Resources/contao/controllers/FrontendIndex.php:64)"} []
    Seien wir realistisch, versuchen wir das Unmögliche

  15. #15
    Contao-Urgestein Avatar von Kahmoon
    Registriert seit
    22.06.2009.
    Ort
    München
    Beiträge
    4.185

    Standard

    Es ist eine neue Fehlermeldung (erst j_slider, dann favicon). Irgendwie fehlen dir da immer wieder DAteien :-(

  16. #16
    Alter Contao-Hase
    Registriert seit
    20.09.2012.
    Ort
    Lüneburger Heide
    Beiträge
    1.402
    User beschenken
    Wunschliste

    Standard

    Hast Du mal den Cache geleert (var/cache/*) und dann noch mal das Installtool aufgerufen?
    Ggf. kannst Du noch mal ein "composer update" ausführen und die Systemwartung durchlaufen lassen falls Du ins BE kommst.

  17. #17
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    hi,

    ich habe ja bereits erwähnt das ich ein Update von 3.5.40 auf die LTS 4.4 durchführe. Ich habe allerdings von einem Bekannten das aktuelle Update des Contao Themes Eclipse bekommen. Ich habe die Verzeichnisse (pct_autogrid, pct_megamenu etc.) per FTP also manuell rüber kopiert. Ist das so in Ordnung oder muss ich da per Installation manager for the Premium Contao Themes: Eclipse
    das Theme neu installieren?
    Ich habe leider diesbezüglich (Installation Manager) keine Erfahrung.
    Seien wir realistisch, versuchen wir das Unmögliche

  18. #18
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.799
    User beschenken
    Wunschliste

    Standard

    Das funktioniert so prinzipiell. Unter Umständen musst du danach aber den Ordner var/cache manuell löschen und dann den Symfony Application Cache neu aufbauen lassen.

  19. #19
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    Danke dir. Ich habe soeben dies gemacht.
    Leider, wenn ich das Backend aufrufen möchte, bekomme ich eine weiße Seite .........
    Wenn ich die Seite aufrufe öffnet sich der Theme Manager......
    http://web268.s153.goserver.host/
    Das ist die Log-Datei:
    [2019-08-12 12:00:07] security.INFO: Attempting SimplePreAuthentication. {"key":"frontend","authenticator":"Contao\\CoreBun dle\\Security\\ContaoAuthenticator"} []
    [2019-08-12 12:00:07] app.CRITICAL: An exception occurred. {"exception":"[object] (Doctrine\\DBAL\\Exception\\TableNotFoundException (code: 0): An exception occurred while executing 'SELECT * FROM tl_pct_themedesigner WHERE tl_pct_themedesigner.active=1 AND tl_pct_themedesigner.theme='eclipse_constructor'': \n\nSQLSTATE[42S02]: Base table or view not found: 1146 Table 'web268_db3.tl_pct_themedesigner' doesn't exist at /home/www/contao4/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php:62, Doctrine\\DBAL\\Driver\\PDOException(code: 42S02): SQLSTATE[42S02]: Base table or view not found: 1146 Table 'web268_db3.tl_pct_themedesigner' doesn't exist at /home/www/contao4/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:109, PDOException(code: 42S02): SQLSTATE[42S02]: Base table or view not found: 1146 Table 'web268_db3.tl_pct_themedesigner' doesn't exist at /home/www/contao4/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:107)"} []
    Hast du mir diesbezüglich einen Tipp?
    Seien wir realistisch, versuchen wir das Unmögliche

  20. #20
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.799
    User beschenken
    Wunschliste

    Standard

    Hast du nach dem Update das Install Tool aufgerufen? Aber eigentlich sollte diese Tabelle ja auch schon vor dem Update existiert haben.

  21. #21
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    Ja das Install Tool habe ich aufgerufen. Und dann die Datenbank aktualisiert.
    Was könnte ich denn noch tun? Ich kann einfach nicht das Backend aufrufen.
    Geändert von monaco (12.08.2019 um 11:53 Uhr)
    Seien wir realistisch, versuchen wir das Unmögliche

  22. #22
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.054
    Partner-ID
    7421

    Standard

    Welche PHP-Version verwendest Du?
    Bei den Gott sei Dank sehr wenigen Berührungspunkten mit PCT-Themes habe ich festgestellt, dass einige Module auch in der neuesten Version höchstens mit PHP 7.1 kompatibel waren. Die letzten Erfahrungen dazu stammen von irgendwann Anfang des Jahres.
    Außerdem gab es bei einer Installation (auch Eclipse) deshalb Probleme, weil ältere PCT-Custom-Elements oder Catalog-Elements (genau weiss ich es leider nicht mehr) scheinbar nicht mit der neuesten Version von Eclipse kompatibel waren. Habe ich allerdings nicht weiter verfolgt, da die betroffene Website zur Zeit so umgebaut wird, dass sie kein PCT-Theme mehr verwendet .
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  23. #23
    Alter Contao-Hase
    Registriert seit
    20.09.2012.
    Ort
    Lüneburger Heide
    Beiträge
    1.402
    User beschenken
    Wunschliste

    Standard

    Die Module müssen natürlich aktuell sein, das ist wie bei allen anderen Erweiterungen auch.
    Evtl. hilft Dir das hier weiter:
    https://forum.premium-contao-themes....ao-3-5-auf-4-4

    Gruß
    tschero

  24. #24
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    Zitat Zitat von mlweb Beitrag anzeigen
    Welche PHP-Version verwendest Du?
    Bei den Gott sei Dank sehr wenigen Berührungspunkten mit PCT-Themes habe ich festgestellt, dass einige Module auch in der neuesten Version höchstens mit PHP 7.1 kompatibel waren. Die letzten Erfahrungen dazu stammen von irgendwann Anfang des Jahres.
    Außerdem gab es bei einer Installation (auch Eclipse) deshalb Probleme, weil ältere PCT-Custom-Elements oder Catalog-Elements (genau weiss ich es leider nicht mehr) scheinbar nicht mit der neuesten Version von Eclipse kompatibel waren. Habe ich allerdings nicht weiter verfolgt, da die betroffene Website zur Zeit so umgebaut wird, dass sie kein PCT-Theme mehr verwendet .
    Ich habe auf 7.1 umgestellt. Leider kann ich mich nach wie vor beim Backend nicht einloggen. Es erscheint eine weiße Seite.
    Seien wir realistisch, versuchen wir das Unmögliche

  25. #25
    Contao-Fan
    Registriert seit
    30.06.2009.
    Beiträge
    300

    Standard

    Zitat Zitat von mlweb Beitrag anzeigen
    Welche PHP-Version verwendest Du?
    Bei den Gott sei Dank sehr wenigen Berührungspunkten mit PCT-Themes habe ich festgestellt, dass einige Module auch in der neuesten Version höchstens mit PHP 7.1 kompatibel waren. Die letzten Erfahrungen dazu stammen von irgendwann Anfang des Jahres.
    Außerdem gab es bei einer Installation (auch Eclipse) deshalb Probleme, weil ältere PCT-Custom-Elements oder Catalog-Elements (genau weiss ich es leider nicht mehr) scheinbar nicht mit der neuesten Version von Eclipse kompatibel waren. Habe ich allerdings nicht weiter verfolgt, da die betroffene Website zur Zeit so umgebaut wird, dass sie kein PCT-Theme mehr verwendet .
    Du solltest deinen Erfahrungsschatz aktualisieren. Das Bashing ist wirklich nicht gerechtfertigt.

    Mit besten Grüßen
    servpoint
    Servicepoint.de - Angebote, Empfehlungen und Dienstleistungen

  26. #26
    Alter Contao-Hase
    Registriert seit
    20.09.2012.
    Ort
    Lüneburger Heide
    Beiträge
    1.402
    User beschenken
    Wunschliste

    Standard

    Hast Du das hier gesehen und beachtet?
    https://community.contao.org/de/show...l=1#post508723

  27. #27
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.799
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von monaco Beitrag anzeigen
    Ich habe auf 7.1 umgestellt. Leider kann ich mich nach wie vor beim Backend nicht einloggen. Es erscheint eine weiße Seite.
    Benutze die app_dev.php und poste einen Stack Trace.

  28. #28
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Benutze die app_dev.php und poste einen Stack Trace.
    bei mit erscheint folgendes

    You are not allowed to access this file. Check app_dev.php for more information.
    Seien wir realistisch, versuchen wir das Unmögliche

  29. #29

  30. #30
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    Ausgabe bei mir:
    cannot load der ionCube PHP-Loader - it was already loaded
    cannot open input file: vendor/bin/contao-console:install-web-dir
    Seien wir realistisch, versuchen wir das Unmögliche

  31. #31
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.799
    User beschenken
    Wunschliste

    Standard

    Du hast einen falschen Befehl eingegeben. Außerdem solltest du vor vendor/bin/contao-console den Pfad zum PHP CLI in der richtigen Version eingeben.

  32. #32
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    Das ist der Stack Trace
    Symfony\Component\Debug\Exception\ContextErrorExce ption:
    Warning: include(/home/www/contao4//be_main.html5): failed to open stream: No such file or directory

    at system/modules/pct_customelements/templates/backend/be_main.html5:12
    at include()
    (system/modules/pct_customelements/templates/backend/be_main.html5:12)
    at include('/home/www/contao4/system/modules/pct_customelements/templates/backend/be_main.html5')
    (vendor/contao/core-bundle/src/Resources/contao/library/Contao/TemplateInheritance.php:96)
    at Contao\Template->inherit()
    (vendor/contao/core-bundle/src/Resources/contao/library/Contao/Template.php:268)
    at Contao\Template->parse()
    (vendor/contao/core-bundle/src/Resources/contao/classes/BackendTemplate.php:33)
    at Contao\BackendTemplate->parse()
    (vendor/contao/core-bundle/src/Resources/contao/classes/BackendTemplate.php:104)
    at Contao\BackendTemplate->compile()
    (vendor/contao/core-bundle/src/Resources/contao/library/Contao/Template.php:298)
    at Contao\Template->getResponse()
    (vendor/contao/core-bundle/src/Resources/contao/controllers/BackendMain.php:273)
    at Contao\BackendMain->output()
    (vendor/contao/core-bundle/src/Resources/contao/controllers/BackendMain.php:136)
    at Contao\BackendMain->run()
    (vendor/contao/core-bundle/src/Controller/BackendController.php:55)
    at Contao\CoreBundle\Controller\BackendController->mainAction()
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:151)
    at Symfony\Component\HttpKernel\HttpKernel->handleRaw(object(Request), 1)
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:68)
    at Symfony\Component\HttpKernel\HttpKernel->handle(object(Request), 1, true)
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:200)
    at Symfony\Component\HttpKernel\Kernel->handle(object(Request))
    (web/app_dev.php:69)



    Seien wir realistisch, versuchen wir das Unmögliche

  33. #33
    Alter Contao-Hase
    Registriert seit
    20.09.2012.
    Ort
    Lüneburger Heide
    Beiträge
    1.402
    User beschenken
    Wunschliste

    Standard

    Scheinbar fehlen Dir Dateien.
    Hast Du wirklich alle PCT Module aus dem Kundenbereich geladen und vollständig auf den Webspace hochgeladen?
    Hast Du ggf. einen größeren Versionssprung bei Eclipse (z.B. von V 7.x auf V. 9.x)?

  34. #34
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    also aktuell sind jetzt alle module auf den server hochgeladen.
    ich bekomme jetzt nur noch folgende Fehlermeldung:
    [2019-08-13 08:56:44] request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHtt pException: "Page not found: http://web268.s153.goserver.host/robots.txt" at /home/www/contao4/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php line 112 {"exception":"[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFou ndHttpException(code: 0): Page not found: http://web268.s153.goserver.host/robots.txt at /home/www/contao4/vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php:112, Contao\\CoreBundle\\Exception\\PageNotFoundExcepti on(code: 0): Page not found: http://web268.s153.goserver.host/robots.txt at /home/www/contao4/vendor/contao/core-bundle/src/Resources/contao/controllers/FrontendIndex.php:64)"} []
    Die Seite liegt aktuell bei webgo. Muss ich hier in diesem Fall die robots.txt anpassen. Wobei ich ja nichts an dieser vorgenommen habe.
    Seien wir realistisch, versuchen wir das Unmögliche

  35. #35
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.799
    User beschenken
    Wunschliste

    Standard

    Das ist keine richtige "Fehlermeldung" - sondern nur ein Hinweis darauf, dass eine URL aufgerufen wurde, die nicht existiert.

  36. #36
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    ich habe nochmal alles kontrolliert und alle Module per FTP übertragen.
    mein aktueller stack trace
    Contao\CoreBundle\Exception\PageNotFoundException:
    Page not found: http://web268.s153.goserver.host/app_dev/contao/login

    at vendor/contao/core-bundle/src/Resources/contao/controllers/FrontendIndex.php:64
    at Contao\FrontendIndex->run()
    (vendor/contao/core-bundle/src/Controller/FrontendController.php:42)
    at Contao\CoreBundle\Controller\FrontendController->indexAction()
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:151)
    at Symfony\Component\HttpKernel\HttpKernel->handleRaw(object(Request), 1)
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:68)
    at Symfony\Component\HttpKernel\HttpKernel->handle(object(Request), 1, true)
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:200)
    at Symfony\Component\HttpKernel\Kernel->handle(object(Request))
    (web/app_dev.php:69)
    at vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php:112
    at Contao\CoreBundle\EventListener\ExceptionConverter Listener->convertToHttpException(object(PageNotFoundExcepti on), 'NotFoundHttpException')
    (vendor/contao/core-bundle/src/EventListener/ExceptionConverterListener.php:71)
    at Contao\CoreBundle\EventListener\ExceptionConverter Listener->onKernelException(object(GetResponseForExceptionE vent), 'kernel.exception', object(TraceableEventDispatcher))
    (vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/Debug/WrappedListener.php:115)
    at Symfony\Component\EventDispatcher\Debug\WrappedLis tener->__invoke(object(GetResponseForExceptionEvent), 'kernel.exception', object(TraceableEventDispatcher))
    (vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/EventDispatcher.php:212)
    at Symfony\Component\EventDispatcher\EventDispatcher->doDispatch(array(object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener)), 'kernel.exception', object(GetResponseForExceptionEvent))
    (vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/EventDispatcher.php:44)
    at Symfony\Component\EventDispatcher\EventDispatcher->dispatch('kernel.exception', object(GetResponseForExceptionEvent))
    (vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/Debug/TraceableEventDispatcher.php:143)
    at Symfony\Component\EventDispatcher\Debug\TraceableE ventDispatcher->dispatch('kernel.exception', object(GetResponseForExceptionEvent))
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:228)
    at Symfony\Component\HttpKernel\HttpKernel->handleException(object(PageNotFoundException), object(Request), 1)
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:79)
    at Symfony\Component\HttpKernel\HttpKernel->handle(object(Request), 1, true)
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:200)
    at Symfony\Component\HttpKernel\Kernel->handle(object(Request))
    (web/app_dev.php:69)
    Leider komme ich nicht weiter und es wird mir nach wie vor eine weisse Seite beim Versuch mich im Backend anzumelden, angezeigt.

  37. #37
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.799
    User beschenken
    Wunschliste

    Standard

    Du hast app_dev statt app_dev.php geschrieben.

  38. #38
    Contao-Fan
    Registriert seit
    03.04.2012.
    Beiträge
    691

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Du hast app_dev statt app_dev.php geschrieben.
    oh sorry. Bei erneutem ausführen der app_dev.php lautet mein stack trace nach wie vor
    Symfony\Component\Debug\Exception\ContextErrorExce ption:
    Warning: include(/home/www/contao4//be_main.html5): failed to open stream: No such file or directory

    at system/modules/pct_customelements/templates/backend/be_main.html5:12
    at include()
    (system/modules/pct_customelements/templates/backend/be_main.html5:12)
    at include('/home/www/contao4/system/modules/pct_customelements/templates/backend/be_main.html5')
    (vendor/contao/core-bundle/src/Resources/contao/library/Contao/TemplateInheritance.php:96)
    at Contao\Template->inherit()
    (vendor/contao/core-bundle/src/Resources/contao/library/Contao/Template.php:268)
    at Contao\Template->parse()
    (vendor/contao/core-bundle/src/Resources/contao/classes/BackendTemplate.php:33)
    at Contao\BackendTemplate->parse()
    (vendor/contao/core-bundle/src/Resources/contao/classes/BackendTemplate.php:104)
    at Contao\BackendTemplate->compile()
    (vendor/contao/core-bundle/src/Resources/contao/library/Contao/Template.php:298)
    at Contao\Template->getResponse()
    (vendor/contao/core-bundle/src/Resources/contao/controllers/BackendMain.php:273)
    at Contao\BackendMain->output()
    (vendor/contao/core-bundle/src/Resources/contao/controllers/BackendMain.php:136)
    at Contao\BackendMain->run()
    (vendor/contao/core-bundle/src/Controller/BackendController.php:55)
    at Contao\CoreBundle\Controller\BackendController->mainAction()
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:151)
    at Symfony\Component\HttpKernel\HttpKernel->handleRaw(object(Request), 1)
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php:68)
    at Symfony\Component\HttpKernel\HttpKernel->handle(object(Request), 1, true)
    (vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:200)
    at Symfony\Component\HttpKernel\Kernel->handle(object(Request))
    (web/app_dev.php:69)
    Ich habe wirklich alle aus dem download von eclipse enthaltenen Module per FTP hochgeladen. Komme an dieser Stelle einfach nicht weiter.
    Hat jemand noch einen Tipp für mich?
    Seien wir realistisch, versuchen wir das Unmögliche

  39. #39
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.714
    User beschenken
    Wunschliste

    Standard

    Gibt es im Verzeichnis system/modules/pct_customelements/templates/backend/ tatsächlich ein Template be_main.html5? Falls ja, könntest Du mal versuchen, dieses Template in be_main.html5.bak umzubenennen?
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  40. #40
    Alter Contao-Hase
    Registriert seit
    20.09.2012.
    Ort
    Lüneburger Heide
    Beiträge
    1.402
    User beschenken
    Wunschliste

    Standard

    Hi,

    so ein Template bringt Eclipse von Haus aus nicht mit.

Seite 1 von 3 123 LetzteLetzte

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •