Contao Konferenz & College 2019 in Duisburg - JETZT TICKET SICHERN!
Ergebnis 1 bis 4 von 4

Thema: Composer package not found in matching version

  1. #1
    Contao-Nutzer
    Registriert seit
    28.11.2018.
    Beiträge
    49

    Standard Composer package not found in matching version

    Hi,
    ich wollte probieren eine Contao 4 Erweiterung zu machen. Ich habe mich dabei hieran orientiert:https://gist.github.com/joergmoldenh...dbc2d039095142

    Ich habe mir einen Github und Packagist Account gemacht und das Bundle angepasst und mein Bundle in der composer.json eingetragen.
    Aber wenn ich
    Code:
    php contao-manager.phar.php composer require localbranding-de/membershiplevels-bundle:1.0
    Code:
    php contao-manager.phar.php composer require localbranding-de/membershiplevels-bundle:dev-master
    oder
    Code:
    php contao-manager.phar.php composer update
    ausführe bekomme ich die Meldung:
    Code:
     Could not find package localbranding-de/membershiplevels-bundle in a version matching 1.1
    bzw.
    Code:
    Problem 1
        - The requested package localbranding-de/memberlevels-bundle could not be found in any version, there may be a typo in the package name.
    
    Potential causes:
     - A typo in the package name
     - The package is not available in a stable-enough version according to your minimum-stability setting
       see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
     - It's a private package and you forgot to add a custom repository to find it
    
    Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
    Dabei ist das Bundle auf Githubhttps://github.com/localbranding-de/...plevels-bundle und Packagist https://packagist.org/packages/local...plevels-bundle
    Muss da noch was konfiguriert werden oder so?
    Grüße Bär
    Geändert von Kannenbär (13.08.2019 um 14:15 Uhr)

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.799
    User beschenken
    Wunschliste

    Standard

    Als Titel für die Releases würde ich dir 1.0.0 & 1.1.0 etc. empfehlen, statt "v1.0" etc.
    Geändert von Spooky (13.08.2019 um 14:44 Uhr)

  3. #3
    Contao-Urgestein Avatar von fiedsch
    Registriert seit
    09.07.2009.
    Ort
    München
    Beiträge
    2.215

    Standard

    Mich irritiert in Deiner composer.json noch die "minimum-stability"-Zeile (https://github.com/localbranding-de/...mposer.json#L4), die nach meinem Verständnis nur in die composer.json des Projekts -- also von Contao -- gehört. Ob das allerdings ein Grund für Dein Problem ist, kann ich Dir leider nicht sagen.
    Stammtisch Contao Bayern: http://www.contao-bayern.de

  4. #4
    Contao-Nutzer
    Registriert seit
    28.11.2018.
    Beiträge
    49

    Standard

    Fortschritt. Ich habe es heute morgen nochmal probiert und es hat funktioniert. Dauert es vielleicht einfach nur etwas?
    Die Installation funktioniert wohl aber die Erweiterung scheint nicht geladen zu werden. Wenn ich den Prod Cache leere und in das Installtool gehe sehe ich keine Anzeige zum Aktualisieren der Datenbank etc.
    Geändert von Kannenbär (14.08.2019 um 13:57 Uhr)

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •