Contao Konferenz & College 2019 in Duisburg - JETZT TICKET SICHERN!
Ergebnis 1 bis 7 von 7

Thema: 4.8. - Kein E-Mail-Versand bei Formularübertragung

  1. #1
    Contao-Nutzer
    Registriert seit
    05.07.2018.
    Beiträge
    13

    Standard 4.8. - Kein E-Mail-Versand bei Formularübertragung

    Hallo zusammen,
    versuche nun seit Stunden Formulareintragungen per E-Mail versenden zu lassen.
    Folgendes habe ich bereits gemacht, geändert, getestet. Es kommt Null raus.
    - anfangs alles über notification center
    - als Gateway STMP-Daten einer neuen E-Mail-Adresse (die funktioniert und aktiv ist) eingetragen (SSL, Port 465)
    - auch getestet mit Port 587 oder mal mit TTL
    - Nachricht so reduziert, dass nur Text enthalten ist (also auch kein syntaktischer Fehler enthalten sein kann)
    - verschiedene Empfängeradresse und Versandadressen getestet
    - E-Mail-Einstellungen mal in die parameters.yml eingetragen inkl. Cache leeren über Contao Manager (alle)
    - dann mal nur versucht eine reine E-Mail über den Formulargenerator versenden zu lassen
    - als nächstes die Formulardaten mal testweise in eine CSV Datei auf dem Server schreiben lassen (das hat funktioniert)
    - in den logs steht kein Fehler, in den Strato-Logs auch keine Fehler
    - bei Strato die Spamfunktion aktiviert und deaktiviert
    - habe auch noch zwei andere Installationen auf STRATO-Accounts. Bei einer ging es sofort, bei einem anderen auch hakelig

    Ich bin ratlos. Hat jemand eine Idee oder Erfahrung woran es noch liegen könnte?

    Contao Version 4.8.0, (15.8.2019, 13:15:57)
    Notification Center Version 1.5.8
    PHP 7.2
    Geändert von tomcat (24.08.2019 um 17:17 Uhr)

  2. #2
    Contao-Fan
    Registriert seit
    16.11.2012.
    Ort
    Freiburg
    Beiträge
    508

    Standard

    Hast du in den Logs von Contao und Server geschaut?
    Grüße
    Alex

  3. #3
    Contao-Nutzer
    Registriert seit
    05.07.2018.
    Beiträge
    13

    Standard

    In den Logs war tatsächlich eine Fehlermeldung zu sehen:

    Could not send email for message ID 1: Expected response code 250 but got code "550", with message "550 5.1.8 <info@xn--testdomain-m09f.de> Unrouteable address Sender verify failed "

    Die E-Mail-Adresse lautete info@test-domain.de, diese war auch eingerichtet und funktionierte. (Domainname nur beispielhaft)
    In der Fehlermeldung lautete diese dann <info@xn--testdomain-m09f.de>

    Habe jetzt bei den "Benachrichtigungen" das Feld "Absender-E-Mail" leer gelassen.
    Damit hat es funktioniert.

    Prima, bin beruhigt. Jedoch: hat da jemand eine Erklärung?

  4. #4
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.637
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Hallo tomcat,
    bei vielen Hostern muss die hinterlegte Mailadresse zur Domain passen.
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Contao Schulungen: https://www.weitzeldesign.com/cms-co...chulungen.html
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 & Manager Hosterhinweise: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with your code, your time to test and your support.

  5. #5
    Contao-Nutzer
    Registriert seit
    05.07.2018.
    Beiträge
    13

    Standard

    Hallo planepix,
    ja E-Mail ist an einer Domain, die im gleichen Account liegt, auch MX ist alles auf Standard und über Strato.
    Was ich mir noch vorstellen könnte (und vielleicht anderen bei denen ähnliche Probleme auftauchen helfen könnte):
    Die Installation war Ergebnis eines Upgrades von Contao 3.x auf 4.x. In der alten Version war efg im Einsatz. Das hatte ich nicht entfernt in der alten Installation, nur nicht installiert in der neuen Installation und dann einfach den Versand über Notification Center gemacht. Vielleicht ist da etwas efg "hängen geblieben" ...

  6. #6
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.637
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Ok, dann schau doch mal, ob du noch etwas vom EFG im /modules Ordner findest.

    Ebenso ob noch Datenbanktabellen vorhanden sind.
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Contao Schulungen: https://www.weitzeldesign.com/cms-co...chulungen.html
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 & Manager Hosterhinweise: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with your code, your time to test and your support.

  7. #7
    Contao-Nutzer
    Registriert seit
    05.07.2018.
    Beiträge
    13

    Standard

    Also in den modules war nichts mehr, in der Datenbank auch nicht.
    Das hatte ich nach dem Migrieren alles gelöscht, was nicht mehr benötigt wurde.
    Habe jetzt heute noch bei einer weiteren, ähnlich gearteten Seite, (mehr oder weniger) genau
    das gleiche gemacht. Der Provider war wieder Strato (anderer Kunde).
    Da flutschte es ohne Probleme auch mit eingetragener Absenderadresse.
    Ich werde in der nächsten Zeit eh noch ein paar solcher Fälle haben, dann werde ich berichten, wenn das
    in der Form wieder auftaucht.
    Danke und viele Grüße

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •