Ergebnis 1 bis 16 von 16

Thema: CONTAO 4.4 - Installation Erweiterung über CONTAO Manager

  1. #1
    Contao-Fan
    Registriert seit
    11.11.2011.
    Beiträge
    341

    Standard CONTAO 4.4 - Installation Erweiterung über CONTAO Manager

    Hallo,


    bei einer 4.4 Installation kann eine Erweiterung (( NICHT installiert werden über den CONTAO- Manager. Es gibt diese Fehlermeldung in der Konsole:

    **************************************
    $ /opt/plesk/php/7.3/bin/php '-q' '/var/www/vhosts/trendbau-gmbh.de/httpdocs/website/web/contao-manager.phar.php' 'composer' 'require' 'bugbuster/contao-visitors-bundle' '--no-suggest' '--no-update' '--no-scripts' '--prefer-stable' '--sort-packages' '--no-ansi' '--no-interaction' 2>&1

    Using version ^1.6 for bugbuster/contao-visitors-bundle
    /var/www/vhosts/trendbau-gmbh.de/httpdocs/website/composer.json has been updated

    # Process terminated with exit code 0
    # Result: OK


    > The Composer Cloud failed with status code 503

    Too many jobs on the Composer Resolver queue.

    Response:
    **************************************



    Muß ich jetzt nur warten auf freie Rechner- Kapazität oder mache ich hier etwas falsch ?



    Vielen Dank für Hinweise.

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.379
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von mv-soft Beitrag anzeigen
    Muß ich jetzt nur warten auf freie Rechner- Kapazität
    Sieht so aus, ja.

  3. #3
    Contao-Fan
    Registriert seit
    11.11.2011.
    Beiträge
    341

    Standard

    Verstehe, ... warte jetzt schon ca. 1h ... ist das normal oder muß ich etwas tun?

  4. #4
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.863
    User beschenken
    Wunschliste

    Standard

    Wenn es schnell gehen muss, könnte man die Erweiterung(en) auch lokal anfordern (resp. die Abhängigkeitsauflösung lokal ausführen).
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  5. #5
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    8.038
    User beschenken
    Wunschliste

    Standard

    Hmm, so langsam glaube ich jetzt nicht mehr daran, dass die Queue voll ist. Habe das jetzt bestimmt 5 Mal oder mehr probiert. Status 503 heißt ja, dass entweder der Service überlastet ist ODER er wegen Wartungsarbeiten down ist. Vielleicht hat er sich auch wegen Überlastung aufgehängt. Oder Fridays for future ...

  6. #6
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.659
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Eben auf Slack Andreas informiert; bei über 100 Jobs hängt es an den Workern.

    Sie sind informiert
    Geändert von planepix (05.10.2019 um 06:53 Uhr)
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Contao Schulungen: https://www.weitzeldesign.com/cms-co...chulungen.html
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 & Manager Hosterhinweise: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with your code, your time to test and your support.

  7. #7
    Contao-Urgestein Avatar von do_while
    Registriert seit
    15.06.2009.
    Ort
    Berlin | Deutschland
    Beiträge
    3.339
    Partner-ID
    1081
    User beschenken
    Wunschliste

    Standard

    Per Slack sind Andi und Yannick informiert, sie werden das korrigieren

    Edit: Planepix war schneller :-)

  8. #8
    Contao-Fan Avatar von elwega
    Registriert seit
    15.09.2009.
    Ort
    Black Forest
    Beiträge
    308

    Standard

    Guten Morgen zusammen,
    Contao 4.8.0
    Gleiches Problem seit gestern. alle Versuche zu aktualisieren oder etwas zu installieren scheitern.
    he Composer Cloud failed with status code 503
    Too many jobs on the Composer Resolver queue.
    Soll man warten oder gibt es eine andere Lösung?
    Beste Grüße
    Wenn der Reiter nichts taugt, ist das Pferd schuld.

  9. #9
    Contao-Nutzer
    Registriert seit
    25.12.2011.
    Beiträge
    63

    Standard

    Contao 4.4: Versuche seit 1 Stunde ein paar Updates reinzufahren. Keine Chance.

    Preisfrage: Ist die Queue wirklich voll oder ist der Server down?

  10. #10
    Contao-Fan
    Registriert seit
    16.11.2012.
    Ort
    Freiburg
    Beiträge
    513

    Standard

    Andere Lösung gibts im Post #4
    Grüße
    Alex

  11. #11
    AG Pressearbeit
    Community-Moderator
    Buchautor 'Contao für Webdesigner'
    Avatar von planepix
    Registriert seit
    05.06.2009.
    Ort
    Stuttgart
    Beiträge
    5.659
    Partner-ID
    107
    User beschenken
    Wunschliste

    Standard

    Yanick ist gut gelandet und hat die Services neu gestartet. Eben erfolgreich getestet. Besten Dank !!!
    Geändert von planepix (05.10.2019 um 16:57 Uhr)
    ---------------------------------
    Beste Grüße planepix
    Contao für Webdesigner (Website), Twitter: @contaowebdesign
    weitzeldesign
    Contao Schulungen: https://www.weitzeldesign.com/cms-co...chulungen.html
    Contao Jahrbuch: www.contao-jahrbuch.de
    Contao Agenturtag: www.contao-agenturtag.de
    Contao Stammtisch Stuttgart: www.contao-stammtisch-stuttgart.de
    Contao 4 Erfahrungen als Gitbook: https://planepix.gitbooks.io/erfahru...tao-4/content/
    Contao 4 & Manager Hosterhinweise: https://github.com/contao/contao-manager/wiki

    It's OpenSource. So invest with your code, your time to test and your support.

  12. #12
    Contao-Fan Avatar von elwega
    Registriert seit
    15.09.2009.
    Ort
    Black Forest
    Beiträge
    308

    Standard

    Alles läuft wieder perfekt, ich schließe mich den Dankesworten von Planepix an Yanick an,
    Dankenschön toller Service,
    schönes WE Euch allen
    Beste Grüße
    Wenn der Reiter nichts taugt, ist das Pferd schuld.

  13. #13
    Contao-Fan
    Registriert seit
    11.11.2011.
    Beiträge
    341

    Standard

    Leider habe ich immer noch das Problem der Paketinstallation, aber jetzt mit einer anderen Fehlermeldung in der Konsole.

    Und im Installtool kann ich die angegebenen Befehle nicht ausführen. Wähle ich nur 1 nacheinander aus, gibt es sogar eine Fehlermeldung. Ich bin mir nicht sicher, ob das mit der Paket- Installation zu tun hat?


    - nutze PHP 7.3.10
    - RAM: 255MB
    - fpm von Apache bedient





    ********************************
    > Resolving dependencies using Composer Cloud v2.0.11

    [389.7MiB/4.10s] Loading composer repositories with package information
    [390.1MiB/4.17s] Updating dependencies
    [2233.1MiB/66.28s] Your requirements could not be resolved to an installable set of packages.
    [2233.1MiB/66.28s]
    Problem 1
    - Conclusion: don't install bugbuster/contao-visitors-bundle 1.6.1
    - Installation request for bugbuster/contao-visitors-bundle ^1.6 -> satisfiable by bugbuster/contao-visitors-bundle[1.6.0, 1.6.1].
    - Conclusion: don't install contao-components/contao 7.1.5
    - bugbuster/contao-visitors-bundle 1.6.0 requires contao/core-bundle ~4.7 -> satisfiable by contao/core-bundle[4.7.0, 4.7.1, 4.7.2, 4.7.3, 4.7.4, 4.7.5, 4.7.6, 4.7.7, 4.8.0, 4.8.1, 4.8.2, 4.8.3, 4.8.4].
    - contao/core-bundle 4.7.0 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.7.1 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.7.2 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.7.3 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.7.4 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.7.5 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.7.6 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.7.7 requires contao-components/contao ^8.0 -> satisfiable by contao-components/contao[8.0.0, 8.0.1, 8.0.2, 8.0.3].
    - contao/core-bundle 4.8.0 requires contao-components/contao ^9.0 -> satisfiable by contao-components/contao[9.0.0].
    - contao/core-bundle 4.8.1 requires contao-components/contao ^9.0 -> satisfiable by contao-components/contao[9.0.0].
    - contao/core-bundle 4.8.2 requires contao-components/contao ^9.0 -> satisfiable by contao-components/contao[9.0.0].
    - contao/core-bundle 4.8.3 requires contao-components/contao ^9.0 -> satisfiable by contao-components/contao[9.0.0].
    - contao/core-bundle 4.8.4 requires contao-components/contao ^9.0 -> satisfiable by contao-components/contao[9.0.0].
    - Can only install one of: contao-components/contao[8.0.0, 7.1.5].
    - Can only install one of: contao-components/contao[8.0.1, 7.1.5].
    - Can only install one of: contao-components/contao[8.0.2, 7.1.5].
    - Can only install one of: contao-components/contao[8.0.3, 7.1.5].
    - Can only install one of: contao-components/contao[9.0.0, 7.1.5].
    - Installation request for contao-components/contao (locked at 7.1.5) -> satisfiable by contao-components/contao[7.1.5].

    [2233.1MiB/66.29s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
    [694.4MiB/73.08s] Memory usage: 694.43MB (peak: 2328.71MB), time: 73.08s.
    [694.4MiB/73.08s] Finished Composer Cloud resolving.


    # Cloud Job ID nsa8aUOV1a9JFh4jp4VPZ0GQxmCPGdIviifAUVwZOVp8kPQOBd GO7cjq93hmJVn4H13vQJeZGAS6CHhZLq2KHnmvIxTVb05AXC failed

    ---

    ### Der Hintergrundprozess wurde unerwartet beendet ###

    ********************************
    Angehängte Grafiken Angehängte Grafiken

  14. #14
    Contao-Urgestein
    Registriert seit
    29.10.2009.
    Beiträge
    1.818
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Wie die Fehlermeldung schon besagt, ist das Visitor-Bundle in Version 1.6 nur mit Contao 4.7 oder höher kompatibel. Vermutlich musst du explizit eine ältere Version definieren.

  15. #15
    Contao-Nutzer Avatar von Fachinger
    Registriert seit
    24.04.2016.
    Ort
    Limburg
    Beiträge
    217

    Standard

    Edit: Falsch gelesen...

  16. #16
    Contao-Fan
    Registriert seit
    11.11.2011.
    Beiträge
    341

    Standard

    staimmt, genau das war mein Fehler.

    Vielen Dank

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •