Ergebnis 1 bis 3 von 3

Thema: [con4gis/pwa] Fehler Installation

  1. #1
    Contao-Nutzer
    Registriert seit
    21.02.2012.
    Beiträge
    34

    Standard [con4gis/pwa] Fehler Installation

    Moin,

    ich wollte die Erweiterung https://packagist.org/packages/con4gis/pwa über den Contao-Manager in Contao 4.4.44 installieren.

    Bekomme da aber diesen Fehler:

    HTML-Code:
    > Resolving dependencies using Composer Cloud v2.0.11
    
    [377.4MiB/7.16s] Loading composer repositories with package information
    [377.7MiB/7.28s] Updating dependencies
    [2294.4MiB/63.23s] Your requirements could not be resolved to an installable set of packages.
    [2294.4MiB/63.24s] 
      Problem 1
        - Conclusion: don't install con4gis/pwa v1.6.2
        - Conclusion: don't install con4gis/pwa v1.6.1
        - Installation request for con4gis/pwa ^1.6 -> satisfiable by con4gis/pwa[v1.6.0, v1.6.1, v1.6.2].
        - Conclusion: don't install contao-components/jquery 1.12.4
        - con4gis/pwa v1.6.0 requires contao-components/jquery ^3.0 -> satisfiable by contao-components/jquery[3.0.0, 3.1.0, 3.1.1, 3.2.0, 3.2.1, 3.3.0, 3.3.1, 3.4.0, 3.4.1].
        - Can only install one of: contao-components/jquery[3.0.0, 1.12.4].
        - Can only install one of: contao-components/jquery[3.1.0, 1.12.4].
        - Can only install one of: contao-components/jquery[3.1.1, 1.12.4].
        - Can only install one of: contao-components/jquery[3.2.0, 1.12.4].
        - Can only install one of: contao-components/jquery[3.2.1, 1.12.4].
        - Can only install one of: contao-components/jquery[3.3.0, 1.12.4].
        - Can only install one of: contao-components/jquery[3.3.1, 1.12.4].
        - Can only install one of: contao-components/jquery[3.4.0, 1.12.4].
        - Can only install one of: contao-components/jquery[3.4.1, 1.12.4].
        - Installation request for contao-components/jquery (locked at 1.12.4) -> satisfiable by contao-components/jquery[1.12.4].
    
    [2294.4MiB/63.24s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
    [690.3MiB/70.90s] Memory usage: 690.32MB (peak: 2404.8MB), time: 70.9s.
    [690.3MiB/70.90s] Finished Composer Cloud resolving.
    
    
    # Cloud Job ID eu8qvURhWJdJV4sWfHN2bzIyb2ZZmcckghe6JzP9jJvwhMvEKe85pmAsaxiPZkxRqSmMLR3WqF failed
    
    ---
    
    ### The background task has stopped unexpectedly ###
    Verstehe das Ganze nicht wirklich.
    Vielleicht hat ja jemand einen Tipp für mich?

    Gruß
    Karsten

  2. #2
    Contao-Urgestein Avatar von mlweb
    Registriert seit
    10.07.2011.
    Beiträge
    4.084
    Partner-ID
    7421

    Standard

    Die verlangten Abhängigkeiten können nicht aufgelöst werden.
    Wenn ich es richtig sehe verlangt Deine Installation jquery 1.12.4 und die Erweiterung benötigt mindestens jquery 3.0.

    Nachtrag: In dem Thread wird erläutert wie man das Problem umgehen kann.
    Geändert von mlweb (07.10.2019 um 12:45 Uhr)
    Für Dinge die man mit html5 und css3 lösen kann, braucht man kein javascript.
    Immer dran denken: Contao-Check zum Testen der Servervoraussetzungen (Contao 2, Contao 3 und Contao 4) und zum Prüfen einer bestehenden Installation (bis Contao 3.5)

  3. #3
    Contao-Nutzer
    Registriert seit
    21.02.2012.
    Beiträge
    34

    Standard

    Vielen Dank für den Tipp, ich konnte das Problem mit der Anleitung im verlinkten Thread nun lösen.

    Folgendes in die composer.json eintragen, composer.lock löschen und dann Pakete updaten über den Manager:

    HTML-Code:
    "contao-components/jquery": "3.x-dev as 1.99"
    Danach konnte ich die gewünschte Erweiterung problemlos installieren.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •