Ergebnis 1 bis 9 von 9

Thema: Kollation utf8mb4_unicode_ci bei Installation

  1. #1
    Contao-Nutzer
    Registriert seit
    10.10.2019.
    Beiträge
    5

    Standard Kollation utf8mb4_unicode_ci bei Installation

    Hallo,

    ich versuche mich gerade an der Erstinstallation von Contao. Soweit funktioniert alles. Doch sobald die Datenbank angelegt werden soll, erhalte ich folgende Fehlermeldung:

    Die konfigurierte Kollation utf8mb4_unicode_ci ist auf Ihrem Server nicht verfügbar. Bitte installieren Sie sie (empfohlen) oder konfigurieren Sie einen anderen Zeichensatz und eine andere Kollation in der Datei config/config.yml.
    [PHP][doctrine:
    dbal:
    connections:
    default:
    default_table_options:
    charset: utf8
    collate: utf8_unicode_ci/PHP]

    Und mit der Installation geht es nicht weiter.

    Benutze derzeit Mysql Version 5.1.73. In dieser Version ist der utf8mb4 Unicode leider nicht enthalten. Welche config.yml muß ich ändern um mir die Neuinstallation von Mysql zu ersparen. Möchte Contao erst einmal testen. Wenn es den Anforderungen genügt, kann ich mich auch gern um den utf8mb4 kümmern.

    Vielen Dank für Eure Mühe. Wünsche ein schönes Wochenende

    Olaf

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.379
    Partner-ID
    10107
    User beschenken
    Wunschliste

  3. #3
    Contao-Nutzer
    Registriert seit
    10.10.2019.
    Beiträge
    5

    Standard

    Vielen Dank. Soetwas habe ich gesucht. Leider ändert sich aber nichts, trotz Änderung der config.yml

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.379
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Hast du nach der Änderung den Symfony Application Cache neu aufgebaut?

  5. #5
    Contao-Nutzer
    Registriert seit
    10.10.2019.
    Beiträge
    5

    Standard

    Ja, das hab ich dann auch gemacht. Trotzdem.

  6. #6
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.379
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Was genau ist der Fehler nach der Änderung?

  7. #7
    Contao-Nutzer
    Registriert seit
    10.10.2019.
    Beiträge
    5

    Standard

    Genau der selbe Fehler wie oben. Keine Änderung.

  8. #8
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.379
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Welche Contao Version, wie lautet der genau Pfad der config.yml, die du nun selbst angelegt hast und was ist der Inhalt davon?
    Geändert von Spooky (11.10.2019 um 13:06 Uhr)

  9. #9
    Contao-Nutzer
    Registriert seit
    10.10.2019.
    Beiträge
    5

    Standard

    Danke, das mit selbst angelegt war der richtige Tipp. Ich hatte nach der Datei gesucht unter /app/config/config.yml und diese geändert. Wer lesen kann ist klar im Vorteil. Jetzt geht es.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •