33 geniale Contao-Erweiterungen, die du kennen solltest! - Contao Academy
Ergebnis 1 bis 9 von 9

Thema: Contao-Bootstrap Konflikte und verwaiste Pakete

  1. #1
    Contao-Nutzer
    Registriert seit
    10.08.2014.
    Beiträge
    68

    Standard Contao-Bootstrap Konflikte und verwaiste Pakete

    Hallo Zusammen,

    wenn ich contao-bootstrap-bundle über den Contao-Manager installieren möchte, werden mir zwei Konflikte angezeigt.

    Konflikte:
    netzmacht/contao-bootstrap
    contao-bootstrap/components

    Sind diese wirklich notwendig? Wie kann ich das beheben?
    Im Contao-Manager werden diese als verwaist angezeigt.

    Gibt es auch eine Anleitung wie ich alles dann auch richtig einbinde?
    Die Seite contao-bootstrap.de hat hierzu keine brauchbaren Informationen.

    Vielen Dank.

    Beste Grüße
    Jörg

  2. #2
    Contao-Urgestein
    Registriert seit
    29.10.2009.
    Ort
    Magdeburg
    Beiträge
    1.849
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Wo ist genau dein Problem? Wenn du die als Konflikte definierte Pakete nicht installiert hast, ist doch alles gut.?

  3. #3
    Contao-Nutzer
    Registriert seit
    10.08.2014.
    Beiträge
    68

    Standard

    Ich war der Meinung, dass die Konflikte anzeigen, welche Pakete ggf. benötigt werden aber fehlen, defekt sind etc. damit das Plugin einwandfrei funktioniert!?!

    Anbei ein Video (03:10) von Netzmacht, wo genau die Erweiterung welche mir als Konflikt angezeigt wird, nachinstalliert wird damit contao-bootstrap funktioniert.
    https://player.vimeo.com/video/108103804

    Aber egal was ich mache, contao-bootstrap lässt sich nicht über den Contao-Manager installieren. Ich bekomme dabei immer folgende Fehlermeldung.
    Was kann ich tun????

    Code:
    $ C:\XAMPP\php\php.exe -q C:/xampp/htdocs/contao/web/contao-manager.phar.php composer require contao-bootstrap/bundle --no-suggest --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction
    
    Using version ^2.1 for contao-bootstrap/bundle
    C:\xampp\htdocs\contao\composer.json has been updated
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    ---
    
    ### Der Hintergrundprozess wurde unerwartet beendet ###
    Vielen Dank für Eure Unterstützung.

    Grüße
    Jörg
    Geändert von TheRedTiger (28.10.2019 um 16:42 Uhr)

  4. #4
    Contao-Urgestein Avatar von fiedsch
    Registriert seit
    09.07.2009.
    Ort
    München
    Beiträge
    2.290

    Standard

    Zitat Zitat von TheRedTiger Beitrag anzeigen
    Ich war der Meinung, dass die Konflikte anzeigen, welche Pakete ggf. benötigt werden aber fehlen, defekt sind etc. damit das Plugin einwandfrei funktioniert!?!
    "conflicts" sind die Pakete, die nicht gleichzeitig installiert sein dürfen, weil es Konflikte zwischen ihnen gibt.

    Was Du beschreibst, sind die unter "requires" angegebenen Pakete. Diese werden benötigt, damit die betreffende Erweiterung funktioniert und werde dann mit installiert.

    Edit: wenn Dir Pakete als conflict angezeigt werden, hast Du diese wohl zuvor installiert. Was steht denn in Deiner composer.json?
    Geändert von fiedsch (28.10.2019 um 16:51 Uhr)
    Contao-Community-Treff Bayern: http://www.contao-bayern.de

  5. #5
    Contao-Nutzer
    Registriert seit
    10.08.2014.
    Beiträge
    68

    Standard

    Code:
    {
        "type": "project",
        "require": {
            "contao/manager-bundle": "4.4.*",
            "contao/calendar-bundle": "4.4.*",
            "contao/comments-bundle": "4.4.*",
            "contao/faq-bundle": "4.4.*",
            "contao/listing-bundle": "4.4.*",
            "contao/news-bundle": "4.4.*",
            "contao/newsletter-bundle": "4.4.*",
            "contao/conflicts": "*@dev"
        },
        "extra": {
            "contao-component-dir": "assets"
        },
        "scripts": {
            "post-install-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ],
            "post-update-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ]
        }
    }
    Das steht in der composer.json.
    Die Contao Installation ist ganz frisch und contao-bootstrap die erste Erweiterung, welche installiert werden soll.

  6. #6
    Contao-Urgestein Avatar von fiedsch
    Registriert seit
    09.07.2009.
    Ort
    München
    Beiträge
    2.290

    Standard

    Und wo werden Dir Konflikte angezeigt. In #3 sehe ich nichts davon?
    Contao-Community-Treff Bayern: http://www.contao-bayern.de

  7. #7
    Contao-Nutzer
    Registriert seit
    10.08.2014.
    Beiträge
    68

    Standard

    Anbei ein Screenshot vom Contao-Manager.

    Hab die Installation gerade nochmal versucht und jetzt hats geklappt.
    Wenn die Pakete unter "Konflikte" nicht benötigt werden, ist ja alles bestens.

    Gilb es dennoch irgendwo eine Dokumentation zu contao-bootstrap mit Inhalt?

    Vielen Dank für Eure Hilfe.
    Angehängte Grafiken Angehängte Grafiken

  8. #8
    Contao-Urgestein Avatar von fiedsch
    Registriert seit
    09.07.2009.
    Ort
    München
    Beiträge
    2.290

    Standard

    Zitat Zitat von TheRedTiger Beitrag anzeigen
    Gilb es dennoch irgendwo eine Dokumentation zu contao-bootstrap mit Inhalt?
    https://contao-bootstrap.de/ und das dort verlinkte https://contao-bootstrap.readthedocs.io/de/latest/
    Contao-Community-Treff Bayern: http://www.contao-bayern.de

  9. #9
    Contao-Nutzer
    Registriert seit
    10.08.2014.
    Beiträge
    68

    Standard

    Perfekt. Jetzt läuft es schon mal wie erwartet.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •