Results 1 to 7 of 7

Thread: quick update question

  1. #1
    New user
    Join Date
    02-13-10.
    Posts
    20

    Default quick update question

    I have to update a few sites from 2.8.0 to 2.8.2
    any problems if I go straight to 2.8.2 with the upgrade?

    Regards,

  2. #2
    User
    Join Date
    06-29-09.
    Posts
    271

    Default Re: quick update question

    It depends. Mostly 2.8.1 and 2.8.2 fix some issues so it should be fine in most cases to update straight away. But if you are using any extensions you might want to be a bit more careful. But mostly it should be fine...

    Upgrading from 2.8.0 is recommended.

  3. #3
    New user
    Join Date
    02-13-10.
    Posts
    20

    Default Re: quick update question

    Quote Originally Posted by Vera
    It depends. Mostly 2.8.1 and 2.8.2 fix some issues so it should be fine in most cases to update straight away. But if you are using any extensions you might want to be a bit more careful. But mostly it should be fine...

    Upgrading from 2.8.0 is recommended.

    Thank-you Vera - yes I saw a security fix in the update notes (plus there are a few problems in 2.8.0)

    What is best practice with regards to extensions for upgrades? I usually make sure all updates, if any, are installed and then back up the related files in system/modules. After I copy over the new typolight files, I copy back the backed up extension files and then run /typolight/install.php (I am only referring specifically to the extension part of the process). See any problems with what I am doing?

    Again, thank you for taking the time to guide me.

  4. #4
    User
    Join Date
    06-29-09.
    Posts
    271

    Default Re: quick update question

    With a manual update I do the same. backup db, backup files. I then delete any original tl file and leave in my own files and extensions, then copy in the new files and run install.php. I take that extra delete step because sometimes files are removed. This might include files from third party software like tinymce.

  5. #5
    User taca's Avatar
    Join Date
    06-20-09.
    Location
    Kyoto, Japan
    Posts
    111

    Default Re: quick update question

    Hi.

    Please care for changes in ticket r317.
    --
    Takahiro Kambe

  6. #6
    User
    Join Date
    12-13-14.
    Posts
    33

    Default

    Quote Originally Posted by Vera View Post
    With a manual update I do the same. backup db, backup files. I then delete any original tl file and leave in my own files and extensions, then copy in the new files and run install.php. I take that extra delete step because sometimes files are removed. This might include files from third party software like tinymce.
    why not just overwrite everything? (just leave localconfig.php)
    and should i update from 2.6.0 all the way from 2.6.1, 2.6.2,....,2.8.3,2.8.4,2.9.0,...3.3.7, etc ?))

  7. #7
    Community-Moderator xchs's Avatar
    Join Date
    06-19-09.
    Posts
    1,100

    Default

    Quote Originally Posted by jimmy2 View Post
    and should i update from 2.6.0 all the way from 2.6.1, 2.6.2,....,2.8.3,2.8.4,2.9.0,...3.3.7, etc ?))
    No, it is not necessary to install every single maintenance update. An update from one minor version to the next should be sufficient.
    Contao Community Moderator
    → Support options

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •