Results 1 to 12 of 12

Thread: [SOLVED] Gallery viewer lightbox

  1. #1
    User
    Join Date
    08-04-09.
    Posts
    230

    Default [SOLVED] Gallery viewer lightbox

    I have got an issue again I cannot seem to solve.

    I am using a gallery on my website. For viewing the entire gallery entry I use the module gallery viewer.
    I have checked the 'view fullsize image' but it is not working. It is just not putting out the rel="lightbox".

    Even when i use fe_page on my page it is not working. Whereas if i include a picture in an article, the lightbox works fine.

    I have checked mootools in the page layout and I have checked fullsize view in the module gallery viewer but also in the gallery itself (I also tried checking and unchecking them)

    I am confused what is going wrong, since it always works like a charm!

    Here's a link to the album viewer: http://www.pukt.nl/wvevents/index.ph...t-gallery.html

    oh, and i have given the images in the content area a fixed width (height:auto) i have also tried removing this in my css, but still no lightbox.

  2. #2
    Experienced user
    Join Date
    06-10-09.
    Location
    Cape Town, South Africa
    Posts
    1,387

    Default Re: Gallery viewer lightbox

    just check this is not a problem with upgrading the gallery, because the NEW templates use gal_xxx.tpl. there must be something wrong on your installation then, as I've personally implemented this on quite a few sites... You have to use the gal_fullsize.tpl template to make it work as well...

  3. #3
    Community-Moderator xchs's Avatar
    Join Date
    06-19-09.
    Posts
    1,100

    Default Re: Gallery viewer lightbox

    Hi lostrisq,

    why do you have selected in your "Page layout" both lightbox variants "Slimbox" and "Mediabox" (section "MooTools templates")? I would activate only one of them!

    Further, I would also recommend adjusting your own page template to mach as well as possible the original page template "fe_page.tpl". As I can see you still have some lines inside your template from previous versions (e.g. the integration of the MooTools framework etc.)
    Contao Community Moderator
    → Support options

  4. #4
    User
    Join Date
    08-04-09.
    Posts
    230

    Default Re: Gallery viewer lightbox

    Hi Thyon,

    Thanks (both of you) for replying so quickly!

    I am using the gal_fullsize.tpl
    and i have just made a fresh install. I removed my old install en reinstalled the gallery extension.

    Also i removed the extension imageflow, I thought maybe it interfered with the galley extension.

    But all without luck.

    @xchs I have also unchecked mediabox, so now only slimbox is checked. But still no appearing of the lightbox (slimbox)
    And my own template page is practicly identical to fe_page, only content changes. All the other functions are in there. I have tried running my page with fe_page.tpl (always a good way to find errors) but then still no lightbox.

    Beats me.....

  5. #5
    Experienced user
    Join Date
    06-10-09.
    Location
    Cape Town, South Africa
    Posts
    1,387

    Default Re: Gallery viewer lightbox

    You also have to ensure that you've enabled FULL SIZE in the Gallery Viewer module as well.. not just in the gallery... as that overrides the setting.

  6. #6
    Community-Moderator xchs's Avatar
    Join Date
    06-19-09.
    Posts
    1,100

    Default Re: Gallery viewer lightbox

    Quote Originally Posted by lostrisq
    All the other functions are in there.
    I guess this line
    Code:
    <?php echo $this->mooScripts; ?>
    is missing in your own page template! Right?

    And please enable in your "Website root" the option "Language fallback", so I (and of course many others) do not get an error message!
    Contao Community Moderator
    → Support options

  7. #7
    User
    Join Date
    08-04-09.
    Posts
    230

    Default Re: Gallery viewer lightbox

    I have checked 'full size' in the gallery viewer module.
    i have also checked in the gallery entry.
    Also I've tried checking and unchecking either one of them in every possible way.

    Indeed <?php echo $this->mooScripts; ?> was not in my page, but that does not make any difference, since it is not working with fe_page.tpl either.

    Thanks for the language fallback tip!

  8. #8
    Community-Moderator xchs's Avatar
    Join Date
    06-19-09.
    Posts
    1,100

    Default Re: Gallery viewer lightbox

    Quote Originally Posted by lostrisq
    Indeed <?php echo $this->mooScripts; ?> was not in my page, but that does not make any difference, since it is not working with fe_page.tpl either.
    For sure, I know. But I think it is always a good idea to have at least partly an almost recent version of page template. Additionally, it would be of course even better not to use an own page template!

    Quote Originally Posted by lostrisq
    Thanks for the language fallback tip!
    Fine. Now I see somewhat on your site!
    Contao Community Moderator
    → Support options

  9. #9
    User
    Join Date
    08-04-09.
    Posts
    230

    Default Re: Gallery viewer lightbox

    I learn everyday ;-)

    I was wondering why the normal extention dit not show anything in Netrenderer. I had to put in the full extention http://www....nl/index.php/home.html instead of http://www....nl
    language fallback was the answer....
    :-)

    But my gallery lightbox is still not working :-(
    I honestly do not know what is happening....

  10. #10
    User
    Join Date
    08-04-09.
    Posts
    230

    Default Re: Gallery viewer lightbox

    Hey guys,

    Today I encountered the problem again. New fresh install, completely up to date gallery intall.

    And again! No lightbox. The gallery viewer did not make any a tags for my images. So no enlargement at all.

    But, I figured it out! I styled my image sizes in css. This meant I did not use the sizes in 'show gallery images' in the gallery viewer module.

    So, instead of using css to size the images, i now sized them in the gallery viewer module.
    Voila!
    A Child can do the laundry as we say in Dutch ;-)

  11. #11
    User
    Join Date
    08-04-09.
    Posts
    230

    Default Re: Gallery viewer lightbox

    Hey guys,

    Today I encountered the problem again. New fresh install, completely up to date gallery intall.

    And again! No lightbox. The gallery viewer did not make any a tags for my images. So no enlargement at all.

    But, I figured it out! I styled my image sizes in css. This meant I did not use the sizes in 'show gallery images' in the gallery viewer module.

    So, instead of using css to size the images, i now sized them in the gallery viewer module.
    Voila!
    A Child can do the laundry as we say in Dutch ;-)

  12. #12
    Experienced user
    Join Date
    06-10-09.
    Location
    Cape Town, South Africa
    Posts
    1,387

    Default Re: [SOLVED] Gallery viewer lightbox

    Umm yeah. You can't view something full-size, when it's already full-size!! :lol:

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •