Results 1 to 4 of 4

Thread: Problem with Additional Head Tags in Page Layout

  1. #1
    New user
    Join Date
    10-31-11.
    Posts
    28

    Default Problem with Additional Head Tags in Page Layout

    Not sure when this started, but probably after my upgrade from 4.4.x to 4.4.34.

    I can no longer save my page layout. I get an error "You have chosen to open application/x-httpd-php, what should firefox do with this file" when I try and save it.

    After some investigation it seems the problem disappears when I delete the "@context" line in the Additional head tags of the following:

    Code:
    <!-- GoogleData -->
    <script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "Organization",
      "url": "http://xxx",
      "name": "xxx",
      "logo": "https://xxx"
    }
    </script>
    <!-- End GoogleData -->
    It seems that contao is having problems with the "@context" line in additional head tags.

    Any idea how to fix?

    Cheers,

    Allen

  2. #2
    New user
    Join Date
    10-31-11.
    Posts
    28

    Default

    I ended up editing the page layout directly in the DB. Not an ideal solution, but it worked.

  3. #3
    Community-Moderator xchs's Avatar
    Join Date
    06-19-09.
    Posts
    1,091

    Default

    Were you able to reproduce the issue in the Contao online demo, too?
    Contao Community Moderator
    → Support options

  4. #4
    New user
    Join Date
    10-31-11.
    Posts
    28

    Default

    Okay.... this is weird.

    I tried the demo and it worked. I went back to my webpage to take a closer look, and the problem has disappeared there also.

    My guess is that it was something in my browser (firefox) that was acting up.

    Thanks anyway,

    Allen

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •