MetaModels Workshop in Berlin
Ergebnis 1 bis 4 von 4

Thema: Lightbox-Link in Table4ward (Lightbox4ward)

  1. #1
    Contao-Nutzer
    Registriert seit
    12.11.2009.
    Beiträge
    28

    Standard Lightbox-Link in Table4ward (Lightbox4ward)

    Hallo,

    ich nutze Table4ward um meinem Kunden die Bearbeitung der Tabellen zu erleichtern, es klappt unter 2.11.3 auch ohne Probleme. Nun soll aber über einen Textlink aus dem Tabellenfeld heraus eine Lightbox mit Bild geöffnet werden. Leider spricht Lightbox4ward nicht auf den gesetzen Link an.

    Wenn ich in das Tabellenfeld (Table4ward) gehe und den Link mit der Lightbox (Einzelnes Element) setze, wird <a rel="lightbox" href="tl_files/webseite/bilder/test.jpg">Link mit Bild...</a> eingetragen. Bei klicken des Link im Frontend öffnet sich das Bild ohne Lightbox4ward "Unterstützung" (Bild nur im Fenster mit grauem Background).

    Müsste nicht folgendes eingetragen sein damit Lightbox4ward greift: <a data-lightbox="" href="tl_files/webseite/bilder/test.jpg">Link mit Bild...</a> ???

    Leider bin ich im Moment ratlos wo genau ich eingreifen muss um table4ward dazu zu bringen die Lightbox4ward Erweiterung zu nutzen. Meinem Kunden kann ich einen Eingriff von Hand in den HTML Code leider nicht zumuten. Hat jemand einen Tipp?

    Gruß,
    Lars

  2. #2
    Contao-Fan Avatar von jubel
    Registriert seit
    18.12.2011.
    Ort
    Waldbronn
    Beiträge
    715
    User beschenken
    Wunschliste

    Standard

    Hast du mal probiert, den Lightbox4ward-Link separat zu definieren und dann als insert_content in die Tabelle zu holen?
    Gruß

    -----------------------------------------------------------------------------------------------------------------
    „Ich versuche immer das zu tun, was ich nicht kann, damit ich hoffentlich lerne, wie es geht.“
    Pablo Picasso

  3. #3
    Contao-Nutzer
    Registriert seit
    12.11.2009.
    Beiträge
    28

    Standard

    Ja, sowohl ein insert-content als auch ein korrektes HTML Element in das Feld öffnet die Lightbox ohne Probleme.

    Ich kann aber meinem User solche Elemente nicht zumuten, zumal dieser viele bilder selbst verknüpfen und immer wieder ändern möchte. Es muss also eine Lösung sein, die dem User die Linkoption mit dem tabel4ward Fenster ermöglicht.

  4. #4
    Contao-Nutzer
    Registriert seit
    08.11.2009.
    Beiträge
    135

    Standard

    Das Thema ist schon etwas älter, aber das Problem besteht immer noch.

    Links mit rel="lightbox" in einer Tabelle werden nicht verarbeitet (data-lightbox="").

    Die Frage ist ob es ein Fehler von Contao oder Table4ward ist.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •