33 geniale Contao-Erweiterungen, die du kennen solltest! - Contao Academy
Ergebnis 1 bis 3 von 3

Thema: syncCto 2.4.0

  1. #1
    Contao-Urgestein Avatar von andreasisaak
    Registriert seit
    07.07.2009.
    Beiträge
    4.097
    User beschenken
    Wunschliste

    Standard syncCto 2.4.0

    Wir haben soeben syncCto 2.4.0 beta1 veröffentlicht. Diese Version ist, wie schon schon angekündigt, die Vorbereitung auf Contao 3. Nur die Vorbereitung weil wir uns komplett vom DC_Memory gelöst haben und als neuen DC den DC_General nutzen. Andere kennen ihn bestimmt schon von MetaModels.

    Die Änderungen sind so gravieren das wir bisher nur rudimentär unter Contao 3.1 testen konnten. Außerdem wurden alle Abhängigkeiten in andere Ordner verschoben weil es unter Contao 3 keine "plugins", "drivers" oder "libraries" gibt. Wenn alles gut geht und die Fehler sind in Grenzen halten dann werden wir schon bald Contao 3 unterstützen. Die benötigten autoload.php Dateien liegen bereits vor, wer jetzt schon testen will der darf das gerne tun und uns berichten.

    Ich möchte alle bitten keine Angst vor dem Update zu haben - sollte doch etwas kaputt sein dann beheben wir das schnell. Und je mehr Leute aktualisieren, desto schneller können wir uns auf Contao 3 konzentrieren.

    Für die neue Version müssen folgende Pakete aktualisiert werden:

    - syncCto 2.4.0 beta1
    - ctoCommunication 1.1.0
    - ZipArchiveCto 1.1.0
    - phpseclib 0.3.1
    - diffiehellman 0.3.0
    - DC_General 0.9.0 beta1

    Am besten ihr installiert syncCto komplett neu damit auch alle neuen Abhängigkeiten installiert werden!!

  2. #2
    Contao-Urgestein Avatar von andreasisaak
    Registriert seit
    07.07.2009.
    Beiträge
    4.097
    User beschenken
    Wunschliste

    Standard

    Um nicht unnötig alte Extensions im System liegen zu haben, würde ich jedem empfehlen nach dem Update auf syncCto 2.4.0 selbstständig die Extension DC_Memory über die Extensionverwaltung zu löschen. Wenn noch eine andere Extension den DC_Memory benötigt dann wird das ER meckern. Wenn nicht, kann man sie ohne Probleme entfernen. Danach kann man sich 3CFramework vornehmen.

    Ein weiterer Schritt wäre die beiden Ordner DiffieHellman und phpseclib unter plugins zu löschen. In der neuen Version liegen beide unter system/modules, leider kann das ER die Altlasten im plugins Ordner nicht löschen

  3. #3
    Contao-Urgestein Avatar von andreasisaak
    Registriert seit
    07.07.2009.
    Beiträge
    4.097
    User beschenken
    Wunschliste

    Standard

    Wir konnten den Fehler eingrenzen:

    https://github.com/contao/core/issues/5636

    Falls es jemanden interessiert, aktualisiert erstmal nur ctoCommunication 1.1.0 damit alte Reste der Extensions gelöscht werden und dann aktualisiert ihr auf syncCto 2.4.0! Bei einer neuen Installation ist das egal. Dort könnt ihr gleich syncCto eingeben.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •