MetaModels Workshop in Berlin
Ergebnis 1 bis 9 von 9

Thema: Update via Composer schlägt fehl

  1. #1
    Contao-Nutzer Avatar von Ynda
    Registriert seit
    02.02.2012.
    Beiträge
    33

    Standard Update via Composer schlägt fehl

    Hallo zusammen,

    beim Composer-Update bekomme ich die Meldung:
    Code:
    $ /usr/bin/env php -d memory_limit=2G -d max_execution_time=900 composer.phar update --no-ansi --no-interaction
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - Installation request for contaoblackforest/contao-doctrine-orm-timestampable >=2.0.7.0,<2.0.8-dev -> satisfiable by contaoblackforest/contao-doctrine-orm-timestampable[2.0.7].
        - contaoblackforest/contao-doctrine-orm-timestampable 2.0.7 requires doctrine/migrations 1.0.x-dev -> no matching package found.
      Problem 2
        - avisota/contao-bundle-all 3.2.0 requires avisota/contao-core ~3.1 -> satisfiable by avisota/contao-core[3.2.0, 3.1.0, 3.1.1, 3.1.2, 3.1.x-dev].
        - avisota/contao-bundle-all 3.2.0 requires avisota/contao-core ~3.1 -> satisfiable by avisota/contao-core[3.2.0, 3.1.0, 3.1.1, 3.1.2, 3.1.x-dev].
        - avisota/contao-core 3.2.0 requires contaoblackforest/contao-doctrine-orm-timestampable ~2.0 -> satisfiable by contaoblackforest/contao-doctrine-orm-timestampable[2.0.7, 2.0.x-dev].
        - avisota/contao-core 3.1.0 requires contaoblackforest/contao-doctrine-orm-timestampable ~2.0 -> satisfiable by contaoblackforest/contao-doctrine-orm-timestampable[2.0.7, 2.0.x-dev].
        - avisota/contao-core 3.1.1 requires contaoblackforest/contao-doctrine-orm-timestampable ~2.0 -> satisfiable by contaoblackforest/contao-doctrine-orm-timestampable[2.0.7, 2.0.x-dev].
        - avisota/contao-core 3.1.2 requires contaoblackforest/contao-doctrine-orm-timestampable ~2.0 -> satisfiable by contaoblackforest/contao-doctrine-orm-timestampable[2.0.7, 2.0.x-dev].
        - avisota/contao-core 3.2.0 requires contaoblackforest/contao-doctrine-orm-timestampable ~2.0 -> satisfiable by contaoblackforest/contao-doctrine-orm-timestampable[2.0.7, 2.0.x-dev].
        - avisota/contao-core 3.1.x-dev requires contaoblackforest/contao-doctrine-orm-timestampable ~2.0 -> satisfiable by contaoblackforest/contao-doctrine-orm-timestampable[2.0.7, 2.0.x-dev].
        - contaoblackforest/contao-doctrine-orm-timestampable 2.0.x-dev requires doctrine/migrations 1.0.x-dev -> no matching package found.
        - contaoblackforest/contao-doctrine-orm-timestampable 2.0.7 requires doctrine/migrations 1.0.x-dev -> no matching package found.
        - Installation request for avisota/contao-bundle-all >=3.2.0.0,<4-dev -> satisfiable by avisota/contao-bundle-all[3.2.0].
    
    Potential causes:
     - A typo in the package name
     - The package is not available in a stable-enough version according to your minimum-stability setting
       see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
    
    Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
    Kennt das jemand schon, bzw. was kann ich unternehmen?

    Danke und Gruß
    Andy

  2. #2
    Contao-Nutzer Avatar von baumannsv
    Registriert seit
    28.01.2015.
    Beiträge
    150

    Standard

    Hallo Andy,

    damit ich dir weiterhelfen kann, müßte ich wissen was für eine Contao Version du benutzt und die composer.json.

    LG Sven Baumann

  3. #3
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.566
    User beschenken
    Wunschliste

    Standard

    Und die PHP Version des PHP CLI und des Vhosts.

  4. #4
    Contao-Nutzer Avatar von Ynda
    Registriert seit
    02.02.2012.
    Beiträge
    33

    Standard Contao und PHP Versionen

    Hallo zusammen,

    ok, natürlich noch ein paar Rahmendaten :-)
    Contao 3.5.27
    vhost PHP 5.6.30
    cli PHP 5.5.9-1ubuntu4.21

    composer.json
    Code:
    {
        "name": "local/website",
        "description": "A local website project",
        "type": "project",
        "license": "proprietary",
        "require": {
            "avisota/contao-bundle-all": ">=3.2.0.0,<4-dev",
            "christianbarkowsky/contao-protectedselect": ">=1.1.3.0,<1.2-dev",
            "codefog/contao-news_categories": "dev-master",
            "comolo/contao-supertheme": ">=2.2.5.0,<2.3-dev",
            "contao-community-alliance/composer-client": "~0.14",
            "contaoblackforest/contao-doctrine-orm-timestampable": ">=2.0.7.0,<2.0.8-dev",
            "delahaye/dlh_googlemaps": ">=2.2.0.0,<2.3-dev",
            "hofff/contao-selectri": ">=3.2.0.0,<3.3-dev",
            "jrgregory/m17-sticky-backend-footer": ">=2.0.6.0,<2.1-dev",
            "ma3xl3/contao-easy-favicon": ">=1.0.2.0,<1.1-dev",
            "madeyourday/contao-rocksolid-custom-elements": ">=1.3.11.0,<1.4-dev",
            "menatwork/selectmodule": ">=1.1.2.0,<1.2-dev",
            "menatwork/semantic_html5": ">=1.2.0.0,<1.3-dev",
            "pimple/pimple": "1.1.x-dev",
            "richardhj/contao-ajax_reload_element": ">=1.0.3.0,<1.1-dev",
            "scyfel/contao-formrecipient": ">=1.2.2.0,<1.3-dev",
            "stefansl/divider": ">=1.3.2.0,<1.4-dev",
            "terminal42/contao-avatar": "dev-master",
            "terminal42/contao-ce-access": ">=2.0.3.0,<2.1-dev",
            "terminal42/contao-changelanguage": ">=3.1.2.0,<3.2-dev",
            "terminal42/contao-folderpage": ">=1.1.6.0,<1.2-dev",
            "twig/twig": ">=1.31.0.0,<1.32-dev"
        },
        "prefer-stable": false,
        "minimum-stability": "dev",
        "config": {
            "preferred-install": "auto",
            "cache-dir": "cache",
            "component-dir": "../assets/components"
        },
        "repositories": [
            {
                "type": "composer",
                "url": "https://legacy-packages-via.contao-community-alliance.org/"
            },
            {
                "type": "composer",
                "url": "https://legacy-packages-via.contao-community-alliance.org",
                "allow_ssl_downgrade": false
            },
            {
                "type": "artifact",
                "url": "packages"
            }
        ],
        "extra": {
            "contao": {
                "migrated": "done",
                "version-locks": {
                    "terminal42/contao-changelanguage": "3.1.0.0"
                }
            }
        }
    }
    Danke und Gruß
    Andy

  5. #5
    Maintainer Avatar von xtra
    Registriert seit
    02.07.2009.
    Ort
    Tuebingen
    Beiträge
    2.007
    User beschenken
    Wunschliste

    Standard

    Problem bei Sven:
    In seiner composer.json hat er noch muss er doctrine migrations als ^1.0.0 eintragen.
    https://github.com/ContaoBlackForest...poser.json#L37
    Bedenke stets: Wenn Du ungenaue oder unzureichende Angaben machst, so koennte dies die Bearbeitung deiner Frage endlos verzoegern (oder sogar dazu fyhren, dass ich zu viel nachdenken muss und die Antwort vergesse!). Kein Support per PN.

  6. #6
    Contao-Nutzer Avatar von Ynda
    Registriert seit
    02.02.2012.
    Beiträge
    33

    Standard Haben auch andere das Problem?

    Bin ich eigentlich der Einzige, der das Problem hat? Aufgrund der Fehlerursache, kann ich mir das kaum vorstellen.
    Vielleicht melden sich noch andere, wenn das Update via Composer Probleme verursacht.

    Wie schon gesagt, versuchen wir mit Avisota eine Projekt für einen Kunden umzusetzen. Wir hatten schon mit Avisota 1 diverse erfolgreiche Umsetzungen gemacht und würden dieses Tool gerne weiter einsetzen. Insbesondere die direkte Verlinkung von Contao-Inhalten ist ein echter und realer Mehrwert, den kaum ein anderes Newsletter-System bieten kann.

    Gruß Andy

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.566
    User beschenken
    Wunschliste

    Standard

    Das Problem hat ja nichts direkt mit Avisota zu tun und tritt nur in Abhängigkeit deiner... Abhängigkeiten auf

  8. #8
    Contao-Nutzer Avatar von Ynda
    Registriert seit
    02.02.2012.
    Beiträge
    33

    Standard

    Ich habe jetzt contaoblackforest/contao-doctrine-orm-timestampable auf die Version 2.0.6 eingefroren, damit ich wieder Updates und Installationen machen kann.
    Die Version 2.0.7 hat eine Abhängigkeit zu doctrine/migrations 1.0.x-dev, die laut xtra und auch laut Composer nicht aufgelöst werden kann.

    Soweit erst mal gut.

    Gruß Andy

  9. #9
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.566
    User beschenken
    Wunschliste

    Standard

    Statt dem festsetzen der Version kannst du die 2.0.7 ja auch als conflict in deiner composer.json eintragen.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •