Contao Konferenz 2019 in Duisburg - Call for Papers
Ergebnis 1 bis 32 von 32

Thema: Installation 4.4 bei DF

  1. #1
    Contao-Fan Avatar von Bas
    Registriert seit
    03.12.2009.
    Ort
    Hamburg
    Beiträge
    534

    Standard Installation 4.4 bei DF

    Mein Paket ist ein Managed Hostind Pro 6 Sterne Performance, aber mittels Contao-Manager kann ich Contao 4.4 nicht installieren, weil das länger als die verfügbare max_execution_time von 180 Sekunden dauert.

    Mit Contao 3.5.x hatte ich keine Probleme, da wähle ich in der Paketverwaltung meine Wunschpakete aus und mach in Folge mittels SSH und dem Befehl "php5.6.22-cli composer.phar update" (hab ich irgendwann mal hier im Forum gefunden) die Aktualisierung. (habe aber ansonsten keine Ahnung von der Konsole)

    Was ich mir wünsche ist eine Step by Step Anweisung wie ich Contao 4.4 bei DF installiere .. und wenn das ohne den Manager geschieht, wie installiert man dann Extension ..?

    Ich hoffe jemand erbarmt sich ... ich hoffe auf Dich Yoda.

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

    Standard

    Wenn die Installation von Contao 4 über den Contao Manager aus welchen Gründen auch immer nicht funktioniert, kannst du Contao 4 ja immer noch manuell installieren (über das Download Archiv oder über composer create-project). Den Contao Manager kannst du ja dann immer noch dazu geben.

  3. #3
    Alter Contao-Hase Avatar von bizon
    Registriert seit
    16.06.2010.
    Beiträge
    1.026

    Standard

    Zitat Zitat von Bas Beitrag anzeigen
    Was ich mir wünsche ist eine Step by Step Anweisung wie ich Contao 4.4 bei DF installiere .. und wenn das ohne den Manager geschieht, wie installiert man dann Extension ..?
    Ich versuchs mal.

    Ich habe selbst keinen Webspace bei DF, aber das sollte egal sein. Wenn du deine Konsole startest, nehme ich an, dass du dich im ROOT deines Webspace befindest.

    Wie man Contao 4.4 per Composer auf der Konsole installiert, steht auf der Contao-Homepage-Installation mittels Composer.

    Anpassen musst du hier nur deine spezielle php-cli-Version und ein Zielverzeichnis angeben, das bei mir immer den Namen des Projektes hat. Das Zielverzeichnis "contao" zu nennen, wie das hier so viele machen, halte ich für irreführend - spätestens dann, wenn auf dem Webspace auch Subdomains angelegt werden sollen.
    Code:
    php5.6.22-cli composer.phar create-project contao/managed-edition <zielverzeichnis> 4.4.*
    Leite die Domain in zielverzeichnis/web und installiere Contao:
    http(s)://domain.tld/contao/install

    Erweiterungen installieren:
    Wechsele auf der Konsole in das zielverzeichnis
    Code:
    cd zielverzeichnis
    Auf https://packagist.org findest du alle notwendigen Angaben. Suche dort nach contao oder gezielter nach z.B.terminal42/notification_center
    Oben unter der Überschrift steht die Composer Anweisung, die du auch wieder deiner CLI anpassen musst:

    Code:
    php5.6.22-cli composer.phar require terminal42/notification_center
    Anschließend das install-tool aufrufen.
    Geändert von bizon (05.07.2017 um 18:02 Uhr)

  4. #4
    Contao-Nutzer
    Registriert seit
    09.09.2009.
    Beiträge
    24

    Standard

    Seit gestern steht ja auch PHP 7.1(.6) bei dF zur Verfügung. Dann geht die Installation beispielsweise mit

    Code:
    php7.1.6-cli composer.phar create-project contao/managed-edition <ziel> 4.4.*
    oder

    Code:
    /usr/bin/env php7-71LATEST-CLI composer.phar create-project contao/managed-edition <ziel> 4.4.*
    Gerade erfolgreich - in einem alten Tarif mit 50MB RAM - getestet inkl. zwei Erweiterungen.

    Beim Contao-Manager scheitert es, wie schon vom OP beschrieben, an der Scriptlaufzeit. Der Paketdownload dauert wohl insgesamt zu lange. Wenn man die Installation dann mit dem Composer vollendet, lässt sich der Manager zumindest im Anschluss normal aufrufen.

  5. #5
    Contao-Fan Avatar von Bas
    Registriert seit
    03.12.2009.
    Ort
    Hamburg
    Beiträge
    534

    Standard

    Ihr seid die Besten ... setze ich mich nachher gleich ran.

  6. #6
    Contao-Fan Avatar von Bas
    Registriert seit
    03.12.2009.
    Ort
    Hamburg
    Beiträge
    534

    Standard

    Zitat Zitat von bizon Beitrag anzeigen
    Code:
    php5.6.22-cli composer.phar create-project contao/managed-edition <zielverzeichnis> 4.4.*
    Frage bzgl <zielverzeichnis> ... das muss dann den Serverpfad enthalten ..? also z.B. bei DF "/www/123456_12345/webseiten/wahlordner" ... korrekt?

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

    Standard

    Wenn du dich bereits in /www/123456_12345/webseiten/wahlordner befindest reicht auch
    Code:
    php5.6.22-cli composer.phar create-project contao/managed-edition
    oder
    Code:
    php5.6.22-cli composer.phar create-project contao/managed-edition . 4.4.*

  8. #8
    Contao-Fan Avatar von Bas
    Registriert seit
    03.12.2009.
    Ort
    Hamburg
    Beiträge
    534

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Wenn du dich bereits in /www/123456_12345/webseiten/wahlordner befindest reicht auch
    Code:
    php5.6.22-cli composer.phar create-project contao/managed-edition
    oder
    Code:
    php5.6.22-cli composer.phar create-project contao/managed-edition . 4.4.*
    Und um das tun zu können muss ich Composer vorher installiert haben .... also navigiere ich mittels 'cd' in meinen 'wahlordner' und führe dort folgendes aus:
    Code:
    php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
    php -r "if (hash_file('SHA384', 'composer-setup.php') === '669656bab3166a7aff8a7506b8cb2d1c292f042046c5a994c43155c0be6190fa0355160742ab2e1c88d40d5be660b410') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
    php composer-setup.php
    php -r "unlink('composer-setup.php');"
    (von https://getcomposer.org/download/)

    Korrekt?

  9. #9
    Contao-Nutzer
    Registriert seit
    09.09.2009.
    Beiträge
    24

    Standard

    Ja, das kannst Du zur Installation des Composers machen, wobei Du das php am Zeilenanfang jeweils wieder ersetzen solltest mit zB php7.1.6-cli. Standardmäßig wird nämlich sonst bei Aufruf von php die Version 4.4.9 verwendet. Das könnte zu Problemen führen.

    Noch einfacher/schneller geht es, wenn Du im Verzeichnis Deiner Wahl einfach die composer.phar direkt herunterlädst mit

    Code:
    wget https://getcomposer.org/download/1.4.2/composer.phar

  10. #10
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Frage

    Bin überrascht, dass es bei euch funktioniert.

    DF quittiert mir die Installation mit folgender Fehlermeldung:


    PHP-Code:
    Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication


      
    [Doctrine\DBAL\Exception\DriverException]
      
    An exception occured in driverSQLSTATE[HY000] [2054Connecting to 3.22,
      
    3.23 4.0 servers is not supported



      
    [Doctrine\DBAL\Driver\PDOException]
      
    SQLSTATE[HY000] [2054Connecting to 3.223.23 4.0 servers is not suppor
      ted



      
    [PDOException]
      
    SQLSTATE[HY000] [2054Connecting to 3.223.23 4.0 servers is not suppor
      ted



      
    [PDOException]
      
    PDO::__construct(): Connecting to 3.223.23 4.0  is not supportedServe
      r is 3.23.58
    -log


    Script Contao
    \ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception


      
    [RuntimeException]
      
    An error occurred while executing the "contao:install-web-dir" command:

        [
    Doctrine\DBAL\Exception\DriverException]
        
    An exception occured in driverSQLSTATE[HY000] [2054Connecting to 3.22,
        
    3.23 4.0 servers is not supported


        
    [Doctrine\DBAL\Driver\PDOException]
        
    SQLSTATE[HY000] [2054Connecting to 3.223.23 4.0 servers is not suppor
        ted


        
    [PDOException]
        
    SQLSTATE[HY000] [2054Connecting to 3.223.23 4.0 servers is not suppor
        ted


        
    [PDOException]
        
    PDO::__construct(): Connecting to 3.223.23 4.0  is not supportedServe
        r is 3.23.58
    -log 
    Hat jemand einen Tip?

  11. #11
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

    Standard

    Welche MySQL Server Version ist bei dir im Einsatz?

  12. #12
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Standard

    Ich kann wählen zwischen:
    Hostname für MySQL 3.23.58
    Hostname für MySQL 4.1.22
    Hostname für MySQL 5.6.19

    Derzeit ist aber noch keine Datenbank angelegt.
    Ich versuche gerade erst Contao überhaupt zu installieren.

    Dieser Fehler ist Resultat von
    PHP-Code:
    php7.1.6-cli composer.phar create-project contao/managed-edition me 

  13. #13
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.780
    User beschenken
    Wunschliste

    Standard

    Der Server existiert auch ohne Datenbank. War da nicht mal was ähnliches mit XAMPP und einem anonymen User, mit dem sich doctrine versucht hat mit dem MySQL-Server zu verbinden?

  14. #14
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Standard

    Ich weis bisher von nichts dergleichen, darum bin ich ja gerade etwas ratlos :-/

  15. #15
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Samuell Beitrag anzeigen
    Ich kann wählen zwischen:
    Hostname für MySQL 3.23.58
    Hostname für MySQL 4.1.22
    Hostname für MySQL 5.6.19
    Du musst MySQL 5.6 wählen. Contao 3 und 4 brauchen mindestens MySQL 5.x.

  16. #16
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Standard

    Danke für den Tip, aber ich komme nicht mal bis zum Install-Tool.
    Dieser Fehler passiert WÄHREND der Installation und hinterlässt eine unvollständige Installation mit den Ordnern

    - App
    - Assets
    - var
    - vendor

    Ich wüßte nicht wo ich an dieser Stelle eine DB wählen könnte.

    Derzeitiger Verlauf:

    Eingabe in die Konsole:
    PHP-Code:
    php7.1.6-cli composer.phar create-project contao/managed-edition me 
    Fehlermeldung
    Ende der Installation

  17. #17
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

  18. #18
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Standard

    Entschuldige, aber ich weis nicht was Du mir mit diesem Link auf das vorangegangene Post sagen möchtest.

  19. #19
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

    Standard

    Du hast diese Frage noch nicht beantwortet.

  20. #20
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Standard

    Doch. Siehe #12.
    Ich habe mehrere Optionen zur Auswahl, jedoch noch keine Datenbank angelegt.
    Ich könnte eine dieser Versionen wählen.
    Allerdings macht das erst Sinn, wenn ich mit der Installation beginnen kann.

  21. #21
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Samuell Beitrag anzeigen
    Doch. Siehe #12.
    Nein, du hast noch nicht erwähnt, welcher MySQL Server nun bei dir konfiguriert ist.


    Zitat Zitat von Samuell Beitrag anzeigen
    Ich habe mehrere Optionen zur Auswahl, jedoch noch keine Datenbank angelegt.
    Ob du eine Datenbank angelegt hast oder nicht ist unerheblich. Du musst den richtigen MySQL Server vor der Installation einrichten.


    Zitat Zitat von Samuell Beitrag anzeigen
    Ich könnte eine dieser Versionen wählen.
    Contao 3 und 4 benötigen mindestens MySQL 5.0.3.


    Zitat Zitat von Samuell Beitrag anzeigen
    Allerdings macht das erst Sinn, wenn ich mit der Installation beginnen kann.
    Nein, du musst das davor machen. Es gibt auch keinen Grund das erst danach zu machen. Du musst ja auch vor der Installation eine Datenbank anlegen, sonst kannst du während der Installation ja nicht die richtige Datenbank einrichten .

  22. #22
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Standard

    Den Datenbank Server richte ich nicht ein. Das ist ein DF Managed Hosting.
    Der Hoster stellt mir also den DB-Server zur Verfügung und ich könnte max. eine DB anlegen.
    Um auf Nr. Sicher zu gehen habe ich auch nach Deiner ersten Frage eine DB (5.6.19) angelegt und die Installation erneut in einem leeren Verzeichnis angestoßen.
    Das brachte keine Veränderung.

  23. #23
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

    Standard

    Eigentlich dürfte das ein generelles Problem bei DomainFactory sein. Wie unter https://www.df.eu/at/support/df-faq/...l-datenbanken/ zu lesen ist, ist der localhost MySQL Server immer ein MySQL3 Server. Das Problem ist nun, dass bei der Installation der Contao Managed Edition während der Ausführung der post install/update scripts noch keine Datenbankverbindung konfiguriert ist - Doctrine aber mit den Default Werten aber dennoch versucht eine Datenbank Verbindung aufzubauen. Und der Default Wert für den Datenbank Hostname ist eben localhost.

    Als Workaround kannst du dir selbst die app/config/parameters.yml mit den korrekten Datenbankverbindungsdaten anlegen. Bspw.
    Code:
    # This file has been auto-generated during installation
    parameters:
        database_host: mysql5.…
        database_port: 3306
        database_user: …
        database_password: …
        database_name: …
        secret: ThisIsNotSoSecretSoChangeIt
    Oder du installierst dir Contao 4 nicht über composer create-project und nicht über den Contao Manager - sondern lädst dir das .zip von contao.org runter. Dann kannst du direkt das Contao Install Tool aufrufen.
    Geändert von Spooky (08.09.2017 um 21:39 Uhr)

  24. #24
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Standard

    Das klingt wiederum plausibel.

    Frage 1 wäre: Warum passiert das den anderen nicht bei der Installation?

    Frage 2: "composer.phar create-project" erwartet einen leeren Ordner.
    Kann ich dieses fehlgeschlagene Kommando "fortsetzen"?

    Denn meines Verständnisses nach tut "composer.phar create-project" nichts anderes als erstmal die Files herunter zu laden und alles "hinter den Kulissen" vorzubereiten, damit ich dann regulär das CMS installieren kann.

  25. #25
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

  26. #26
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Samuell Beitrag anzeigen
    Frage 1 wäre: Warum passiert das den anderen nicht bei der Installation?
    Hier im Thread sehe ich noch keinen Post, der eine erfolgreiche Installation von Contao 4 mittels Contao Manager oder composer create-project vermeldet.

    // andererseits... Christian von der Contao Academy verwendet auch Domain Factory und da hat es ja bisher immer funktioniert. Evt. taucht dieses Problem erst kürzlich auf.


    Zitat Zitat von Samuell Beitrag anzeigen
    Frage 2: "composer.phar create-project" erwartet einen leeren Ordner.
    Kann ich dieses fehlgeschlagene Kommando "fortsetzen"?

    Denn meines Verständnisses nach tut "composer.phar create-project" nichts anderes als erstmal die Files herunter zu laden und alles "hinter den Kulissen" vorzubereiten, damit ich dann regulär das CMS installieren kann.
    Ja, zu dem Zeitpunkt des Fehlers ist alles bereits installiert. Du kannst, wenn du die parameters.yml angelegt hast, ein
    Code:
    composer update
    durchführen, um die Installation "fortzusetzen".
    Geändert von Spooky (08.09.2017 um 21:50 Uhr)

  27. #27
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

    Standard

    @Samuell bevor du die parameters.yml erzeugst: könntest du vielleicht noch ein
    Code:
    composer.phar install -vvv
    Kommando ausführen, um den vollen Stack Trace des Fehlers zu erhalten?

  28. #28
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Standard

    Dann poste ich den in das issue?

  29. #29
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Fehler

    Zwischenerfolg:
    Nach den von @Spooky genannten Punkten hab ich zumindest das Backend soweit zum Laufen bekommen, dass ich mich darin bewegen kann.
    Ob die Installation komplett funktioniert, kann ich an dieser Stelle noch nicht sagen.
    Bei Bedarf kann ich dazu jedoch in den kommenden Tagen mehr berichten und auch zusammenfassen, wie ich an diesen Punkt gelangt bin.

    An dieser Stelle nochmal ein dickes Dankeschön @Spooky für den Support zu später Stunde. Seine Erklärungen haben es ermöglicht diesen Zwischenstand zu erreichen.


    geklärt:
    Die parameters.yml gehört in app/config?
    Interessanterweise ist app nämlich noch leer
    Geändert von Samuell (08.09.2017 um 22:37 Uhr) Grund: Der Lösung näher gekommen

  30. #30
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.049
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Samuell Beitrag anzeigen
    Dann poste ich den in das issue?
    Oder hier.



    Zitat Zitat von Samuell Beitrag anzeigen

    geklärt:
    Die parameters.yml gehört in app/config?
    Interessanterweise ist app nämlich noch leer
    Ja, app ist leer, da die app/config/parameters.yml vom Contao Install Tool angelegt wird.

  31. #31
    Alter Contao-Hase
    Registriert seit
    20.03.2010.
    Ort
    Hannover
    Beiträge
    1.037

    Standard

    composer.phar install -vvv:
    PHP-Code:
    Reading ./composer.json
    Loading config file 
    ./composer.json
    Checked CA file 
    /etc/ssl/certs/ca-certificates.crtvalid
    Executing command 
    (/kunden/xxx/htdocs/projektfolder/contao/v44x/me): git branch --no-color --no-abbrev -v
    Executing command 
    (/kunden/xxx/htdocs/projektfolder/contao/v44x/me): git describe --exact-match --tags
    Executing command 
    (/kunden/xxx/htdocs/projektfolder/contao/v44x/me): git log --pretty="%H" -n1 HEAD
    Executing command 
    (/kunden/xxx/htdocs/projektfolder/contao/v44x/me): hg branch
    Executing command 
    (/kunden/xxx/htdocs/projektfolder/contao/v44x/me): fossil branch list
    Executing command (/kunden/xxx/htdocs/projektfolder/contao/v44x/me): fossil tag list
    Executing command (/kunden/xxx/htdocs/projektfolder/contao/v44x/me): svn info --xml
    Failed to initialize 
    global composerComposer could not find the config file: /kunden/xxx/.composer/composer.json
    To initialize a project
    please create a composer.json file as described in the https://getcomposer.org/ "Getting Started" section
    Reading /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/composer/installed.json
    Loading plugin Contao
    \ComponentsInstaller\Composer\Plugin
    Running 1.5.1 
    (2017-08-09 16:07:22with PHP 7.1.6 on Linux 3.14.79-grsec-pvops-xen-x64
    Reading 
    ./composer.lock
    Loading composer repositories with package information
    Installing dependencies 
    (including require-devfrom lock file
    Reading 
    ./composer.lock
    Resolving dependencies through SAT
    Dependency resolution completed in 0.006 seconds
    Analyzed 268 packages to resolve dependencies
    Analyzed 824 rules to resolve dependencies
    Nothing to install 
    or update
    Generating autoload files
    post-install-cmdContao\ManagerBundle\Composer\ScriptHandler::initializeApplication


      
    [Doctrine\DBAL\Exception\DriverException]
      
    An exception occured in driverSQLSTATE[HY000] [2054Connecting to 3.22,
      
    3.23 4.0 servers is not supported


    Exception trace
    :
     () 
    at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php:115
     Doctrine
    \DBAL\Driver\AbstractMySQLDriver->convertException() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php:145
     Doctrine
    \DBAL\DBALException::driverException() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php:47
     Doctrine
    \DBAL\Driver\PDOMySql\Driver->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php:360
     Doctrine
    \DBAL\Connection->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/ContaoManager/Plugin.php:169
     Contao
    \ManagerBundle\ContaoManager\Plugin->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-plugin/src/Config/ContainerBuilder.php:65
     Contao
    \ManagerPlugin\Config\ContainerBuilder->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/DependencyInjection/MergeExtensionConfigurationPass.php:34
     Symfony
    \Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/Compiler.php:143
     Symfony
    \Component\DependencyInjection\Compiler\Compiler->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/ContainerBuilder.php:746
     Symfony
    \Component\DependencyInjection\ContainerBuilder->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:577
     Symfony
    \Component\HttpKernel\Kernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/HttpKernel/ContaoKernel.php:213
     Contao
    \ManagerBundle\HttpKernel\ContaoKernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:119
     Symfony
    \Component\HttpKernel\Kernel->boot() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Application.php:69
     Symfony
    \Bundle\FrameworkBundle\Console\Application->doRun() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Console/Application.php:125
     Symfony
    \Component\Console\Application->run() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/bin/contao-console:44


      
    [Doctrine\DBAL\Driver\PDOException (2054)]
      
    SQLSTATE[HY000] [2054Connecting to 3.223.23 4.0 servers is not suppor
      ted


    Exception trace
    :
     () 
    at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:47
     Doctrine
    \DBAL\Driver\PDOConnection->__construct() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php:44
     Doctrine
    \DBAL\Driver\PDOMySql\Driver->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php:360
     Doctrine
    \DBAL\Connection->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/ContaoManager/Plugin.php:169
     Contao
    \ManagerBundle\ContaoManager\Plugin->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-plugin/src/Config/ContainerBuilder.php:65
     Contao
    \ManagerPlugin\Config\ContainerBuilder->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/DependencyInjection/MergeExtensionConfigurationPass.php:34
     Symfony
    \Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/Compiler.php:143
     Symfony
    \Component\DependencyInjection\Compiler\Compiler->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/ContainerBuilder.php:746
     Symfony
    \Component\DependencyInjection\ContainerBuilder->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:577
     Symfony
    \Component\HttpKernel\Kernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/HttpKernel/ContaoKernel.php:213
     Contao
    \ManagerBundle\HttpKernel\ContaoKernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:119
     Symfony
    \Component\HttpKernel\Kernel->boot() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Application.php:69
     Symfony
    \Bundle\FrameworkBundle\Console\Application->doRun() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Console/Application.php:125
     Symfony
    \Component\Console\Application->run() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/bin/contao-console:44


      
    [PDOException (2054)]
      
    SQLSTATE[HY000] [2054Connecting to 3.223.23 4.0 servers is not suppor
      ted


    Exception trace
    :
     () 
    at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43
     PDO
    ->__construct() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43
     Doctrine
    \DBAL\Driver\PDOConnection->__construct() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php:44
     Doctrine
    \DBAL\Driver\PDOMySql\Driver->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php:360
     Doctrine
    \DBAL\Connection->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/ContaoManager/Plugin.php:169
     Contao
    \ManagerBundle\ContaoManager\Plugin->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-plugin/src/Config/ContainerBuilder.php:65
     Contao
    \ManagerPlugin\Config\ContainerBuilder->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/DependencyInjection/MergeExtensionConfigurationPass.php:34
     Symfony
    \Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/Compiler.php:143
     Symfony
    \Component\DependencyInjection\Compiler\Compiler->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/ContainerBuilder.php:746
     Symfony
    \Component\DependencyInjection\ContainerBuilder->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:577
     Symfony
    \Component\HttpKernel\Kernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/HttpKernel/ContaoKernel.php:213
     Contao
    \ManagerBundle\HttpKernel\ContaoKernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:119
     Symfony
    \Component\HttpKernel\Kernel->boot() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Application.php:69
     Symfony
    \Bundle\FrameworkBundle\Console\Application->doRun() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Console/Application.php:125
     Symfony
    \Component\Console\Application->run() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/bin/contao-console:44


      
    [PDOException]
      
    PDO::__construct(): Connecting to 3.223.23 4.0  is not supportedServe
      r is 3.23.58
    -log


    Exception trace
    :
     () 
    at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43
     PDO
    ->__construct() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43
     Doctrine
    \DBAL\Driver\PDOConnection->__construct() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php:44
     Doctrine
    \DBAL\Driver\PDOMySql\Driver->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php:360
     Doctrine
    \DBAL\Connection->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/ContaoManager/Plugin.php:169
     Contao
    \ManagerBundle\ContaoManager\Plugin->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-plugin/src/Config/ContainerBuilder.php:65
     Contao
    \ManagerPlugin\Config\ContainerBuilder->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/DependencyInjection/MergeExtensionConfigurationPass.php:34
     Symfony
    \Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/Compiler.php:143
     Symfony
    \Component\DependencyInjection\Compiler\Compiler->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/ContainerBuilder.php:746
     Symfony
    \Component\DependencyInjection\ContainerBuilder->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:577
     Symfony
    \Component\HttpKernel\Kernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/HttpKernel/ContaoKernel.php:213
     Contao
    \ManagerBundle\HttpKernel\ContaoKernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:119
     Symfony
    \Component\HttpKernel\Kernel->boot() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Application.php:69
     Symfony
    \Bundle\FrameworkBundle\Console\Application->doRun() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Console/Application.php:125
     Symfony
    \Component\Console\Application->run() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/bin/contao-console:44

    Script Contao
    \ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception


      
    [RuntimeException]
      
    An error occurred while executing the "contao:install-web-dir" command:

        [
    Doctrine\DBAL\Exception\DriverException]
        
    An exception occured in driverSQLSTATE[HY000] [2054Connecting to 3.22,
        
    3.23 4.0 servers is not supported

      Exception trace
    :
       () 
    at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php:115
       Doctrine
    \DBAL\Driver\AbstractMySQLDriver->convertException() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php:1
      45
       Doctrine
    \DBAL\DBALException::driverException() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php:47
      m
       Doctrine
    \DBAL\Driver\PDOMySql\Driver->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php:360
       Doctrine
    \DBAL\Connection->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/ContaoManager/Plugin.php:169
       Contao
    \ManagerBundle\ContaoManager\Plugin->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-plugin/src/Config/ContainerBuilde
      r
    .php:65
       Contao
    \ManagerPlugin\Config\ContainerBuilder->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKer
      nel
    /DependencyInjection/MergeExtensionConfigurationPass.php:34
       Symfony
    \Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/
      
    Symfony/Component/DependencyInjection/Compiler/Compiler.php:143
       Symfony
    \Component\DependencyInjection\Compiler\Compiler->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Depende
      ncyInjection
    /ContainerBuilder.php:746
       Symfony
    \Component\DependencyInjection\ContainerBuilder->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKern
      el
    /Kernel.php:577
       Symfony
    \Component\HttpKernel\Kernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/HttpKernel/ContaoKernel.php
      
    :213
       Contao
    \ManagerBundle\HttpKernel\ContaoKernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKe
      rnel
    /Kernel.php:119
       Symfony
    \Component\HttpKernel\Kernel->boot() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Applicati
      on
    .php:69
       Symfony
    \Bundle\FrameworkBundle\Console\Application->doRun() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Console/Applic
      ation
    .php:125
       Symfony
    \Component\Console\Application->run() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/bin/contao-console:44

        
    [Doctrine\DBAL\Driver\PDOException (2054)]
        
    SQLSTATE[HY000] [2054Connecting to 3.223.23 4.0 servers is not suppor
        ted

      Exception trace
    :
       () 
    at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:47
       Doctrine
    \DBAL\Driver\PDOConnection->__construct() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php:44
      
    [39m
       Doctrine
    \DBAL\Driver\PDOMySql\Driver->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php:360
       Doctrine
    \DBAL\Connection->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/ContaoManager/Plugin.php:169
       Contao
    \ManagerBundle\ContaoManager\Plugin->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-plugin/src/Config/ContainerBuilde
      r
    .php:65
       Contao
    \ManagerPlugin\Config\ContainerBuilder->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKer
      nel
    /DependencyInjection/MergeExtensionConfigurationPass.php:34
       Symfony
    \Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/
      
    Symfony/Component/DependencyInjection/Compiler/Compiler.php:143
       Symfony
    \Component\DependencyInjection\Compiler\Compiler->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Depende
      ncyInjection
    /ContainerBuilder.php:746
       Symfony
    \Component\DependencyInjection\ContainerBuilder->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKern
      el
    /Kernel.php:577
       Symfony
    \Component\HttpKernel\Kernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/HttpKernel/ContaoKernel.php
      
    :213
       Contao
    \ManagerBundle\HttpKernel\ContaoKernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKe
      rnel
    /Kernel.php:119
       Symfony
    \Component\HttpKernel\Kernel->boot() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Applicati
      on
    .php:69
       Symfony
    \Bundle\FrameworkBundle\Console\Application->doRun() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Console/Applic
      ation
    .php:125
       Symfony
    \Component\Console\Application->run() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/bin/contao-console:44

        
    [PDOException (2054)]
        
    SQLSTATE[HY000] [2054Connecting to 3.223.23 4.0 servers is not suppor
        ted

      Exception trace
    :
       () 
    at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43
       PDO
    ->__construct() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43
       Doctrine
    \DBAL\Driver\PDOConnection->__construct() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php:44
      
    [39m
       Doctrine
    \DBAL\Driver\PDOMySql\Driver->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php:360
       Doctrine
    \DBAL\Connection->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/ContaoManager/Plugin.php:169
       Contao
    \ManagerBundle\ContaoManager\Plugin->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-plugin/src/Config/ContainerBuilde
      r
    .php:65
       Contao
    \ManagerPlugin\Config\ContainerBuilder->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKer
      nel
    /DependencyInjection/MergeExtensionConfigurationPass.php:34
       Symfony
    \Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/
      
    Symfony/Component/DependencyInjection/Compiler/Compiler.php:143
       Symfony
    \Component\DependencyInjection\Compiler\Compiler->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Depende
      ncyInjection
    /ContainerBuilder.php:746
       Symfony
    \Component\DependencyInjection\ContainerBuilder->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKern
      el
    /Kernel.php:577
       Symfony
    \Component\HttpKernel\Kernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/HttpKernel/ContaoKernel.php
      
    :213
       Contao
    \ManagerBundle\HttpKernel\ContaoKernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKe
      rnel
    /Kernel.php:119
       Symfony
    \Component\HttpKernel\Kernel->boot() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Applicati
      on
    .php:69
       Symfony
    \Bundle\FrameworkBundle\Console\Application->doRun() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Console/Applic
      ation
    .php:125
       Symfony
    \Component\Console\Application->run() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/bin/contao-console:44

        
    [PDOException]
        
    PDO::__construct(): Connecting to 3.223.23 4.0  is not supportedServe
        r is 3.23.58
    -log

      Exception trace
    :
       () 
    at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43
       PDO
    ->__construct() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43
       Doctrine
    \DBAL\Driver\PDOConnection->__construct() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php:44
      
    [39m
       Doctrine
    \DBAL\Driver\PDOMySql\Driver->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php:360
       Doctrine
    \DBAL\Connection->connect() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/ContaoManager/Plugin.php:169
       Contao
    \ManagerBundle\ContaoManager\Plugin->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-plugin/src/Config/ContainerBuilde
      r
    .php:65
       Contao
    \ManagerPlugin\Config\ContainerBuilder->getExtensionConfig() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKer
      nel
    /DependencyInjection/MergeExtensionConfigurationPass.php:34
       Symfony
    \Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/
      
    Symfony/Component/DependencyInjection/Compiler/Compiler.php:143
       Symfony
    \Component\DependencyInjection\Compiler\Compiler->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Depende
      ncyInjection
    /ContainerBuilder.php:746
       Symfony
    \Component\DependencyInjection\ContainerBuilder->compile() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKern
      el
    /Kernel.php:577
       Symfony
    \Component\HttpKernel\Kernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/HttpKernel/ContaoKernel.php
      
    :213
       Contao
    \ManagerBundle\HttpKernel\ContaoKernel->initializeContainer() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/HttpKe
      rnel
    /Kernel.php:119
       Symfony
    \Component\HttpKernel\Kernel->boot() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Applicati
      on
    .php:69
       Symfony
    \Bundle\FrameworkBundle\Console\Application->doRun() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/symfony/symfony/src/Symfony/Component/Console/Applic
      ation
    .php:125
       Symfony
    \Component\Console\Application->run() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/bin/contao-console:44


    Exception trace
    :
     () 
    at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/Composer/ScriptHandler.php:109
     Contao
    \ManagerBundle\Composer\ScriptHandler::executeCommand() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/Composer/ScriptHandler.php:72
     Contao
    \ManagerBundle\Composer\ScriptHandler::addWebEntryPoints() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/vendor/contao/manager-bundle/src/Composer/ScriptHandler.php:35
     Contao
    \ManagerBundle\Composer\ScriptHandler::initializeApplication() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:282
     
    Composer\EventDispatcher\EventDispatcher->executeEventPhpScript() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:205
     
    Composer\EventDispatcher\EventDispatcher->doDispatch() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:96
     
    Composer\EventDispatcher\EventDispatcher->dispatchScript() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/src/Composer/Installer.php:307
     
    Composer\Installer->run() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/src/Composer/Command/InstallCommand.php:119
     
    Composer\Command\InstallCommand->execute() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/vendor/symfony/console/Command/Command.php:266
     
    Symfony\Component\Console\Command\Command->run() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/vendor/symfony/console/Application.php:861
     
    Symfony\Component\Console\Application->doRunCommand() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/vendor/symfony/console/Application.php:208
     
    Symfony\Component\Console\Application->doRun() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/src/Composer/Console/Application.php:245
     
    Composer\Console\Application->doRun() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/vendor/symfony/console/Application.php:127
     
    Symfony\Component\Console\Application->run() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/src/Composer/Console/Application.php:100
     
    Composer\Console\Application->run() at phar:///kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar/bin/composer:54
     
    require() at /kunden/xxx/htdocs/projektfolder/contao/v44x/me/composer.phar:24 

  32. #32
    Contao-Fan Avatar von Webstylerin
    Registriert seit
    24.08.2009.
    Ort
    Schlüsselfeld, Bayern
    Beiträge
    342
    Partner-ID
    6232

    Standard

    Hallöchen,

    ich hab es nun geschafft eine Contao 4.4-Installation bei Domainfactory aufzusetzen. Einige graue Haare mehr sind das Nebenergebnis.

    Vielleicht hilft es jemanden, daher nun meine Vorgehensweise:

    • PHP 7.0.6 eingestellt, contao-manager.phar.php ins web-Verzeichnis hochgeladen und aufgerufen. CM-Nutzer angelegt und installieren geklickt.
    • Irgendwann wurde die Installation abgebrochen (Process terminated with exit code 152 Reason: CPU time limit exceeded [signal 24])
    • Habe glücklichweise einen SSH-Zugang bekommen. Habe dort dann den Composer installiert.
    • Als nächstes habe ich die Dateien aus dem install-XYZ-Verzeichnis ins übergordnete Verzeichnis verschoeben und die Installation dann via Konsole und dem Befehl "php7.0.6-cli composer.phar update" abschließen können.
    • Der Contao-Manager scheint zu funktionieren und ich konnte dann auch die DB via install einrichten. Allerdings scheint er es nicht zu schaffen Erweiterungen über den Manager vollständig zu installieren, aber mit "php7.0.6-cli composer.phar update" lässt sich das nachholen bzw. werde ich es jetzt einfach mal direkt über die Konsole probieren.


    Ich bin mir nicht sicher, ob die Vorgehensweise vollkommen korrekt ist bzw. ob es nicht sehr umständlich ist, aber es hat funktioniert. Eine direkte Installation von Contao via Konsole (php7.0.6-cli composer.phar create-project contao/managed-edition) hat auch nicht funktioniert.

    LG
    Nicole
    Geändert von Webstylerin (19.09.2017 um 09:48 Uhr)

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •