Contao Konferenz 2019 in Duisburg - Call for Papers
Ergebnis 1 bis 1 von 1

Thema: E-Mail-Versand funktioniert nicht mehr

  1. #1
    Contao-Fan
    Registriert seit
    03.01.2012.
    Beiträge
    481

    Standard E-Mail-Versand funktioniert nicht mehr

    Hallo,

    bei einer Website (OHNE Contao) werden die E-Mails über das Kontaktformular nicht mehr versendet. Das komische daran ist, dass es das Problem erst seit einigen Tagen gibt. Vorher funktionierte alles perfekt. Ich habe aber seit Monaten nicht mehr an der Website gearbeitet.

    Es wird die PHP mail-Funktion verwendet und die PHP Version 7.0.33.

    Zum Testen habe ich ein minimales Skript geschrieben, das quasi nur die Mail-Funktion enthält

    Code:
    <?php
    // Felder übergeben
    
    $empfaenger = "ich@hallo.de";
    $betreff = "Kontaktanfrage";
    
    $headers = "From: domain.de"."\n";
    $headers .= "Reply-To: ". strip_tags("domain.de") . "\n";
    $headers .= "MIME-Version: 1.0\n";
    $headers .= "Content-Type: text/html; charset=UTF-8\n";
    
    $text = "Hallo.";
    
    if(@mail($empfaenger, $betreff, $text, $headers)) {
    	echo "Es klappt.";
    }
    ?>
    Wenn ich dieses Script lokal auf meinem Rechner teste, funktioniert es. Es wird "Es klappt" ausgegeben und die Mail kommt an. Lokal habe ich auch PHP 7.0

    Wenn ich dieses Skript wiederum auf meiner Website aufrufe, kommt die Mail nicht an und es wird auch nicht der Text "es klappt" ausgegeben.

    Spam, Blacklists usw. kann man eigentlich ausschließen, oder? Denn soweit ich weiß gibt die mail-Funktion true zurück, sobald das Skript in Ordnung ist. Unabhängig davon, ob die E-Mail ankommt. Trotz gleicher PHP-Version kommt es auf der Website aber zu einer false-Rückgabe.

    Welche Gründe kann das haben?

    Danke im Voraus.
    Geändert von dazzle89 (24.01.2019 um 10:57 Uhr)

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •