Contao Konferenz 2019 in Duisburg - Call for Papers
Ergebnis 1 bis 2 von 2

Thema: fehlerhaftes Verhalten (XMLHttpRequest deprecated)

  1. #1
    Contao-Nutzer Avatar von Robby1
    Registriert seit
    18.11.2016.
    Ort
    Hanau (Hessen)
    Beiträge
    48

    Standard fehlerhaftes Verhalten (XMLHttpRequest deprecated)

    Hallo Zusammen,

    ich komme gerade nicht weiter. Ich bin gerade dabei, eine neue Webseite zu erstellen (in einer vorläufigen Subdomain solange entwicklet wird). Dabei habe ich mir aus dem jquery-ui-Projekt das HTML, das dazugehörige JS und das dazugehörige CSS für eine "TAB-Funktion" heruntergeladen und habe alles erstmal testweise auf der Startseite einbebaut. Die Tabs (also die eingebauten Reiter) funtkionieren. -> Siehe http://www.bau2.golletz-baumanagement.de/

    Man kann auf ein Reiterlogo klicken und es erscheint der Reiterinhalt. Soweit alles OK. Danach wollte ich das gleiche in die Unterseite "Projekte" einbauen (da ich dort die Tabfunktion brauche) und die Webseite dreht völlig durch. Siehe http://www.bau2.golletz-baumanagemen...eferenzen.html

    Alles wackelt und der Header mit Menu wird doppelt angezeigt und die Tabs funktionieren nicht. Völliges Chaos.

    Ich habe in den Entwicklertools nachgeschaut und unter "Console" die folgende Meldung erhalten, mit der ich allerdings nichts anfangen kann: "[Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.
    send @ f0e47edd643d.js:4"

    Auf einer "Hilfeseite" erhielt ich den Hinweis: "Fix Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check https://xhr.spec.whatwg.org/. – jquery.js: the use of async: false with jqXHR ($.Deferred) is deprecated. The error above can be solved by setting explicitly async option of XMLHttpRequest to true."

    Mit der Erläuterung kann ich nicht viel anfangen. Ich habe auch nicht verstanden, warum die Tabfunktion auf der Startseite funktioniert und auf einer anderen Seite in einem anderen Layout nicht. Testweise habe ich dann der fehlerhaften Projektseite das gleiche Layout zugewiesen, das die Startseite hat. Aber der Fehler ist leider der gleiche. Die Tabs funktionieren nur auf der Startseite und nicht woanders, auch wenn das gleiche Layout zugewiesen wurde.

    Hat jemand einen Rat? Die Nutzung der Tabfunktion auf der Projektseite ist nämlich erforderlich.

    Falls jemand eine Idee hat: Nützlich wäre ein Codeschnipsel, den ich einbauen kann.

    Im Voraus schon mal vielen Dank für Eure Tips. (Contao-Update auf neueste Version folgt später auch, wenn alles fertig ist.)

    Gruß!

    Robby

  2. #2
    Contao-Nutzer Avatar von Robby1
    Registriert seit
    18.11.2016.
    Ort
    Hanau (Hessen)
    Beiträge
    48

    Standard Problem über andere jquery-/JS-Codevorlage gelöst

    Hallo nochmal,

    ich wollte kurz Bescheid geben, dass ich einfach eine andere jquery-/JS-Code-Vorlage genommen habe. Die jquery-/JS-Code-Vorlage und vor allem das CSS werde ich nun noch anpassen müssen. Somit geht mein Projekt erstmal weiter.

    Daher bitte nicht wundern, wenn man den oben beschriebenen Fehler nicht mehr nachvollziehen kann. Ich habe das entspr. Inhaltselement deaktiviert, da ich eine Alternative gefunden habe.

    Falls jemand trotzdem noch einen Tipp zum o.g. Fehler und eine Lösung hat, wäre ich sehr dankbar. Es würde mich interessieren, wo das Problem ist.

    Gruß!

    Robby

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •