MetaModels Workshop in Berlin
Ergebnis 1 bis 12 von 12

Thema: Metadaten überschreiben - Endlosschleife

  1. #1
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    36

    Frage Metadaten überschreiben - Endlosschleife

    Hallo zusammen,

    sowohl unter Contao 4.4.x als auch unter 4.6.x (verschiedene Installationen) tritt folgender Fehler auf,
    wenn man die Bild Metaangaben überschreiben möchte:

    Failed to load resource: the server responded with a status of 400 (Bad Request)

    Siehe Bild im Anhang.
    Was kann man hier tun?

    Besten Dank für Hinweise.

    Viele Grüße
    Marco
    Angehängte Grafiken Angehängte Grafiken

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.567
    User beschenken
    Wunschliste

    Standard

    Hast du schon auf die neueste Contao Version aktualisiert?

  3. #3
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    36

    Standard

    Ja, ohne Erfolg/Veränderung.

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.567
    User beschenken
    Wunschliste

    Standard

    Welche Extensions sind installiert?

  5. #5
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    36

    Standard

    Siehe Anhang.
    Angehängte Grafiken Angehängte Grafiken

  6. #6
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.567
    User beschenken
    Wunschliste

    Standard

    Poste deine composer.json.

    Sind alle Erweiterungen am neuesten Stand?

  7. #7
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    36

    Standard

    Code:
    {
        "name": "contao/managed-edition",
        "type": "project",
        "description": "Contao Open Source CMS",
        "license": "LGPL-3.0-or-later",
        "authors": [
            {
                "name": "Leo Feyer",
                "homepage": "https://github.com/leofeyer"
            }
        ],
        "require": {
            "php": "^7.1",
            "codefog/contao-cookiebar": "^2.1",
            "contao-bootstrap/bundle": "^2.1",
            "contao-bootstrap/core": "^2.0",
            "contao-bootstrap/form": "^2.1",
            "contao-bootstrap/grid": "^2.0",
            "contao-bootstrap/layout": "^2.0",
            "contao-bootstrap/navbar": "^2.1",
            "contao-bootstrap/tab": "^2.0",
            "contao-bootstrap/templates": "^2.0",
            "contao/calendar-bundle": "^4.6",
            "contao/comments-bundle": "^4.6",
            "contao/conflicts": "*@dev",
            "contao/faq-bundle": "^4.6",
            "contao/listing-bundle": "^4.6",
            "contao/manager-bundle": "4.6.*",
            "contao/news-bundle": "^4.6",
            "contao/newsletter-bundle": "^4.6",
            "heart-bits/contao-article-backgrounds": "^1.0",
            "madeyourday/contao-rocksolid-columns": "^2.0",
            "madeyourday/contao-rocksolid-frontend-helper": "^2.0",
            "madeyourday/contao-rocksolid-slider": "^2.0",
            "netzmacht/contao-font-awesome": "^4.7",
            "netzmacht/contao-font-awesome-inserttag": "^2.0",
            "terminal42/contao-ajaxform": "^1.0",
            "terminal42/contao-changelanguage": "^3.1",
            "terminal42/notification_center": "^1.5",
            "zmyslny/contao-wrapper_tags": "^2.1"
        },
        "conflict": {
            "contao-components/installer": "<1.3"
        },
        "require-dev": {
            "sensiolabs/security-checker": "^4.1"
        },
        "extra": {
            "branch-alias": {
                "dev-4.6": "4.6.x-dev"
            },
            "contao-component-dir": "assets"
        },
        "autoload": {
            "psr-4": {
                "App\": "src/"
            }
        },
        "scripts": {
            "post-install-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ],
            "post-update-cmd": [
                "Contao\\ManagerBundle\\Composer\\ScriptHandler::initializeApplication"
            ]
        }
    }
    Geändert von xchs (29.04.2019 um 20:32 Uhr) Grund: Code-Tags

  8. #8
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.581
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von clyman Beitrag anzeigen
    Ja, ohne Erfolg/Veränderung.
    Deine composer.json deutet aber nicht darauf hin, dass Du auf die aktuellste Version aktualisiert hast, oder? Welche Version wird Dir denn im Backend angezeigt?
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  9. #9
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    36

    Standard

    Habe dieses Phänomen in einer Contao 4.4.38 und 4.6.14 Installation.

    Code:
    (...)=ac68f0f0 400 (Bad Request)
    send @ mootools.min.js,mooRainbow.min.js,chosen.min.js,simplemodal.min....-6c137c7d.js:1
    i.extend.$owner @ mootools.min.js,mooRainbow.min.js,chosen.min.js,simplemodal.min....-6c137c7d.js:1
    send @ mootools.min.js,mooRainbow.min.js,chosen.min.js,simplemodal.min....-6c137c7d.js:1
    i.(anonymous function) @ mootools.min.js,mooRainbow.min.js,chosen.min.js,simplemodal.min....-6c137c7d.js:1
    i.extend.$owner @ mootools.min.js,mooRainbow.min.js,chosen.min.js,simplemodal.min....-6c137c7d.js:1
    toggleSubpalette @ mootools.min.js,mooRainbow.min.js,chosen.min.js,simplemodal.min....-6c137c7d.js:7
    onclick @ contao?do=article&table=tl_content&act=edit&id=281&rt=yVUWSgI7kC9HnNLl1e3n5pBENa63i8Hvf9tULpN1exM&rsfhr=1:528
    Das muss irgendwie mit den Mootools zusammenhängen.

    Und das kommt in den Logs:

    Code:
    ID:	14
    Datum:	2019-04-29 21:49
    Ursprung:	Backend
    Kategorie:	ERROR
    Benutzer:	admin
    Details:	Field "overwriteMeta" is not an allowed selector field (possible SQL injection attempt)
    Funktion:	Contao\Ajax::executePostActions
    Browser:	Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
    Geändert von clyman (29.04.2019 um 20:53 Uhr)

  10. #10
    Administrator Avatar von xchs
    Registriert seit
    19.06.2009.
    Beiträge
    13.581
    User beschenken
    Wunschliste

    Standard

    Tritt dieser Fehler nur bei "Metadaten überschreiben" auf oder auch bei anderen AJAX Requests?
    Contao Community Administrator
    [Unterstützungsmöglichkeiten]

  11. #11
    Contao-Urgestein
    Registriert seit
    22.10.2013.
    Beiträge
    7.887
    User beschenken
    Wunschliste

    Standard

    Wird doch nicht wieder irgendein Sicherheits"feature" sein?

  12. #12
    Contao-Nutzer
    Registriert seit
    21.01.2014.
    Beiträge
    36

    Standard

    Ich konnte die auslösende Erweiterung feststellen:

    heart-bits/contao-article-backgrounds

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •