MetaModels Workshop in Berlin
Ergebnis 1 bis 9 von 9

Thema: Mitgliederbereiche trotz Berechtigung teilweise nicht aufrufbar

  1. #1
    Contao-Nutzer Avatar von Filip
    Registriert seit
    28.07.2017.
    Beiträge
    47

    Standard Mitgliederbereiche trotz Berechtigung teilweise nicht aufrufbar

    Hallo!

    Ich weiß das diese Frage etwas komsich ist, aber ich komme einfach nicht zur Lösung des Problems und hoffe das jemand sowas ähnliches schon mal erlebt hat, da ich diesen Fehler nicht reproduzieren kann.

    Bei einem Projekt für einen Kunden habe ich die komplette Website hinter einem Geschützen Bereich, diese wird über verschiedene Mitgliedgruppen aufgeteilt (bspw. Kategorie-1, Kategorie-2, Frontend-Admin). In den Seiten gebe ich dann den Mitgliedergruppen die entsprechenden Rechte.

    Die Seiten sind generell normal aufrufbar, aber teilweise leider nicht. Das heißt, wenn ich mich mit "Admin" im Frontend anmelde kann es sein das ich mit verschiedenen Browsern andere Ergebnisse erziele und die Seiten einfach überhaupt nicht ausgegeben werden, ich werde in diesem Fall einfach wieder auf die Login Seite geschmissen (was das richtige Verhalten wäre, wenn ich nicht angemeldet wäre oder die entsprechenden Rechte fehlen) auf der ich aber noch normal angemeldet bin als Admin. Das komische ist, dass das Ergebnis variert in verschiedenen Browser und teilweise auch in überhaupt keinen Browsern funktioniert, obwohl keine Änderungen an der Seite vorgenommen wurden. (Ich bin der Admin und niemand anderes hat auf den Backend Zugriff).

    Das einzige, was das Problem vorerst löst, ist wenn ich die Seite dupliziere und ihr einen neuen Alias vergebe. (mit 1:1 den gleichen Einstellungen)

    Viele Grüße und dankeschön an alle Hinweise woran dieses Verhalten liegen könnte,
    Filip

  2. #2
    Contao-Nutzer Avatar von Filip
    Registriert seit
    28.07.2017.
    Beiträge
    47

    Standard

    Ich habe wieder eine Nachricht von einem Kunden bekommen der eine meiner Seiten nicht aufrufen kann, ich habe versucht seinen Nutzer zu duplizieren mit den exakt gleiche Einstellungen und habe bei mir keine Probleme die Seiten aufzurufen.

    Kann es an bestimmten Browsern oder betriebsystemen liegen das manche Nutzer keinen Zugriff auf Seiten haben, zu denen sie eigentlich über die Mitgliedergruppe berechtigt sind?

  3. #3
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.559
    User beschenken
    Wunschliste

    Standard

    Was genau sieht der Kunde?

  4. #4
    Contao-Nutzer Avatar von Filip
    Registriert seit
    28.07.2017.
    Beiträge
    47

    Standard

    Der Kunde wird beim Aufruf der Seite "Profil" auf die 403 Seite weitergeleitet, da ich das aber für unschön hielt, habe ich die 403 Seite auf die Startseite geleitet. Also wird der Kunde immer wieder zur Startseite geleitet wenn er auf "Profil" klickt.

    Auf dieser Seite wird ein Punktestand vom Kunden dargestellt der mit dem CustomCatalog von Premium Contao Themes gepflegt wird, aber selbst wenn ich alle Elemente auf dieser Seite unsichtbar schalte, lädt die Seite nicht.

  5. #5
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.559
    User beschenken
    Wunschliste

    Standard

    Welche Contao Version genau?

  6. #6
    Contao-Nutzer Avatar von Filip
    Registriert seit
    28.07.2017.
    Beiträge
    47

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Welche Contao Version genau?
    Ich benutze zur Zeit die Version 4.4.38.

    Ebenfalls habe ich folgende Plugins installiert:

    bastibuck/contao-force-password-change
    con4gis/import
    christianbarkowsky/contao-tiny-compress-images
    do-while/contao-mpdf-template-bundle
    terminal42/contao-folderpage

    Vom Theme habe ich noch diese weiteren installiert:

    premium-contao-themes/pct_customelements_plugin_cc_frontedit
    premium-contao-themes/pct_theme_installer
    Geändert von Filip (18.06.2019 um 11:42 Uhr)

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    20.559
    User beschenken
    Wunschliste

    Standard

    Aktualisiere Contao, alle Pakete und alle Erweiterungen und teste dann nochmal.

  8. #8
    Contao-Nutzer Avatar von Filip
    Registriert seit
    28.07.2017.
    Beiträge
    47

    Standard

    Zitat Zitat von Spooky Beitrag anzeigen
    Aktualisiere Contao, alle Pakete und alle Erweiterungen und teste dann nochmal.
    Ich habe Contao auf 4.4.40 und die anderen Pakete auch aktualisiert.

    Da ich das Problem nicht bei mir reproduzieren kann, werde ich später hier ein Update posten ob es einen Unterschied macht.

  9. #9
    Contao-Nutzer Avatar von Filip
    Registriert seit
    28.07.2017.
    Beiträge
    47

    Standard

    Zitat Zitat von Filip Beitrag anzeigen
    Ich habe Contao auf 4.4.40 und die anderen Pakete auch aktualisiert.

    Da ich das Problem nicht bei mir reproduzieren kann, werde ich später hier ein Update posten ob es einen Unterschied macht.
    Das Problem besteht leider weiterhin und ich weiß immer noch nicht so wirklich woran es liegen könnte.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •