33 geniale Contao-Erweiterungen, die du kennen solltest! - Contao Academy
Ergebnis 1 bis 5 von 5

Thema: news_full.html5 verursacht Fehlermeldung

  1. #1
    Contao-Urgestein Avatar von derRenner
    Registriert seit
    23.10.2012.
    Ort
    hoRn|waldviertel
    Beiträge
    1.612
    User beschenken
    Wunschliste

    Standard news_full.html5 verursacht Fehlermeldung

    Hallo,

    ich kann den genauen Fehler leider nicht auslesen » siehe https://community.contao.org/de/show...rror-log-datei
    Aber ich kann den Fehler einschränken.

    Was passiert: Beim Aufruf der Detailseite vom news-Teaser weg erscheint 'Es ist ein Fehler aufgetreten'
    Einschränken konnte ich den Fehler nun auf die news_full.html5 und hier drinnen auf die Abfrage des Textblockes bzw. die Ausgabe des Textblock
    Code:
            <?php if ($this->hasText): ?>
              <?= $this->text ?>
            <?php else: ?>
              <div class="ce_text block">
                <?php if (!$this->addBefore): ?>
                  <?= $this->teaser ?>
                <?php endif; ?>
          
                <?php if ($this->addImage): ?>
                  <?php $this->insert('image', $this->arrData); ?>
                <?php endif; ?>
          
                <?php if ($this->addBefore): ?>
                  <?= $this->teaser ?>
                <?php endif; ?>
              </div>
            <?php endif; ?>
    ?
    Code:
    <?= $this->text ?>
    Ich konnte das template soweit kürzen, dass nur diese Zeile den Fehler verursacht.
    [
    Was hat sich in 4.8.4 dahingehend geändert?
    Oder muss ich an anderer Stelle zu suchen beginnen?
    Grüsse
    Bernhard


  2. #2
    Contao-Fan
    Registriert seit
    16.11.2012.
    Ort
    Freiburg
    Beiträge
    516

    Standard

    Ist das auch der ganze Code vom Template?
    Grüße
    Alex

  3. #3
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    21.719
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Schalte den Debug Modus ein und poste den kompletten Stack Trace. Den Debug Modus schaltest du in Contao 4.8 im Backend ein - oder über die .env Datei mit
    Code:
    APP_ENV=dev

  4. #4
    Contao-Urgestein
    Registriert seit
    29.10.2009.
    Ort
    Magdeburg
    Beiträge
    1.842
    Partner-ID
    626
    User beschenken
    Wunschliste

    Standard

    Da text potentiell die Inhaltselemente der News beinhaltet, vermute ich hier einen Fehler in den entsprechenden Inhaltselemente.

  5. #5
    Contao-Urgestein Avatar von derRenner
    Registriert seit
    23.10.2012.
    Ort
    hoRn|waldviertel
    Beiträge
    1.612
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von webstar Beitrag anzeigen
    Da text potentiell die Inhaltselemente der News beinhaltet, vermute ich hier einen Fehler in den entsprechenden Inhaltselemente.
    hier war der Fehler versteckt ...
    Die Galerie-Elemente hatten keinen Template-Eintrag mit übernommen.
    Hierzu muss ich vermerken, dass ich eine 4.4 auf eine 4.8 hochgehoben hatte und hier augenscheinlich, über alle Artikel, beim Gallerie-Inhaltselement die templates nicht fortgeschrieben wurden. Die templates manuell nachgetragen und schon läuft es ohne Fehlermeldung durch.
    Grüsse
    Bernhard


Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •