Das Contao Camp 2020 in Hamburg. LEIDER ABGESAGT!
Ergebnis 1 bis 14 von 14

Thema: Bei Versand werden Mail-Adressen abgewiesen

  1. #1
    Contao-Nutzer Avatar von ErichM
    Registriert seit
    14.11.2011.
    Beiträge
    36

    Standard Bei Versand werden Mail-Adressen abgewiesen

    Seit 4.9 kann ich keine Newsletter mehr versenden.
    Bei Testversand erscheint im Systemlog die Meldung: E-mail address rejected: xxx
    Bei normalen Versand kommen folgende Meldungen im Systemlog: Recipient address "xxx" was rejected and has been deactivated, dann E-mail address rejected: xxx
    Es gibt keinen Eintrag in der Protkolldatei.
    Es sind die neuesten Pakete installiert.
    Wie komme ich nun weiter?

  2. #2
    Contao-Fan Avatar von Ainschy
    Registriert seit
    24.06.2009.
    Ort
    Neuenburg am Rhein
    Beiträge
    566
    Partner-ID
    5666
    User beschenken
    Wunschliste

    Standard

    Wie erfolgt der Versand?

    Sind SMTP Zugangsdaten hinterlegt?

    Anleitung hier: Contao Docs

  3. #3
    Contao-Nutzer Avatar von ErichM
    Registriert seit
    14.11.2011.
    Beiträge
    36

    Standard

    Danke für die schnelle Antwort.
    Habe garnicht mitbekommen, dass jetzt in der parameters.yml Einträge dafür notwendig sind.

    Die parameters.yml habe ich ergänzt:

    mailer_transport: smtp
    mailer_host: mail.your-server.de
    mailer_user: vorsitzender@fotoclub-erding.de
    mailer_password: 'xxxxx'
    mailer_port: 587
    mailer_encryption: tls

    Funktioniert trotzdem nicht (Hinweis: ein Mail-Versand (SMTP) über eine PHP-Prozedur funktioniert).
    Gibt es sonst noch was zu beachten?

    Weitere Frage: Unter mailer_user habe ich die E-Mail-Adresse eingetragen, die auch im Newsletter hinterlegt ist. Ich habe jedoch verschiedene Newsletter mit jeweils anderen Absendern. Wie funktioniert dies dann?

  4. #4
    Contao-Fan Avatar von Ainschy
    Registriert seit
    24.06.2009.
    Ort
    Neuenburg am Rhein
    Beiträge
    566
    Partner-ID
    5666
    User beschenken
    Wunschliste

    Standard

    Hast du nach den Änderungen den Cache gelöscht ? /var/cache -> prod Ordner löschen

  5. #5
    Contao-Nutzer Avatar von ErichM
    Registriert seit
    14.11.2011.
    Beiträge
    36

    Standard

    Ja klar, dann gehts. Danke für den Anstoß.

    Nochmals zum Eintrag "mailer_user". Ich habe hier zwar "vorsitzender" eingetragen jedoch kam das Mail von "vorstand", so wie es im Newsletter bei der individuellen Vorgabe eingetragen ist.
    Eigentlich hätte es von "vorsitzender" kommen müssen, die ich in der paramters-yml Name und Passwort von "vorsitzender" eingetragen habe. Oder sind die Angaben nicht von Bedeutung?
    Kannst du mir das noch erklären? Danke im Voraus.

  6. #6
    Contao-Fan Avatar von Ainschy
    Registriert seit
    24.06.2009.
    Ort
    Neuenburg am Rhein
    Beiträge
    566
    Partner-ID
    5666
    User beschenken
    Wunschliste

    Standard

    Das kannst du über das Notification Center machen, dort können verschiedene Gateways angelegt werden. Der systemweite Eintrag in der parameter.yml dient als Fallback, hier werden die System Mails wie z.B. Newsletter Anmeldung, Mitglieder Registrierung etc drüber versendet. Viele E-Mail Server nehmen Mail aus PHP Scripten nicht mehr entgegen. Daher ist ein echtes SMTP E-Mail Konto die sicherste Variante für einen erfolgreichen Mail Versand.

  7. #7
    Contao-Nutzer Avatar von ErichM
    Registriert seit
    14.11.2011.
    Beiträge
    36

    Standard

    Bei mir ist kein Notification Center im Einsatz.
    ich habe aber festgestellt, dass unterschiedlich Postfächer bei paramaters.yml und bei der Absenderangabe eingegeben werden können.
    Hauptsache es handelt sich um die gleiche Domain (z.B. "aaa@xxx.de" in parameters.yml und "bbb@xxx.de" als Absender)

  8. #8
    Contao-Fan Avatar von Ainschy
    Registriert seit
    24.06.2009.
    Ort
    Neuenburg am Rhein
    Beiträge
    566
    Partner-ID
    5666
    User beschenken
    Wunschliste

    Standard

    Ja das geht, ist aber in Grunde nicht sauber.

  9. #9
    Contao-Fan Avatar von Arno
    Registriert seit
    11.12.2009.
    Ort
    Potsdam-Babelsberg
    Beiträge
    289

    Standard

    Nach der Lektüre des Threads habe ich das gerade mal auf einer meiner Installationen wo auch der Newsletterversand genutzt wird überprüft.
    Dort sind die entsprechenden Parameter NICHT in der parameters.yml hinterlegt. Der Testversand des Newsletters hat aber trotzdem funktioniert.
    Ist die Angabe der Parameter eventuell abhängig von der Hosting Umgebung? Im konkreten Fall liegt die Installation bei all-inkl.

  10. #10
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    6.613
    Partner-ID
    152
    User beschenken
    Wunschliste

    Standard

    Ja. Manchen Hostern ist das komplett egal. Manche Hoster blockieren alles, was ohne entsprechende Mailadresse versendet wird.

    Im Übrigen ist es noch keine Garantie für eine Zustellung, wenn der Postausgang funktioniert.

    Versendet über SMTP, versendet authentifiziert, nutzt SPF, DKIM und DANE gemeinsam. Ich verstehe nicht warum das so schwierig zu verstehen ist.


    Gesendet von iPhone mit Tapatalk

  11. #11
    Contao-Fan Avatar von Arno
    Registriert seit
    11.12.2009.
    Ort
    Potsdam-Babelsberg
    Beiträge
    289

    Standard

    Danke dir für die Erklärung. Die Testmail wurde erfolgreich an die angegebene Adresse zugestellt.

    Zitat Zitat von lucina Beitrag anzeigen
    Ich verstehe nicht warum das so schwierig zu verstehen ist.
    Wenn man sich nicht ständig mit diesen Themen beschäftigt, weiß man es nicht. Dann kann man nachfragen (wie hier geschehen) und auf eine Antwort hoffen. Wenn dich solche Nachfragen nerven, dann musst du ja nicht antworten.

  12. #12
    Administratorin Avatar von lucina
    Registriert seit
    19.06.2009.
    Ort
    Kiel (DE)
    Beiträge
    6.613
    Partner-ID
    152
    User beschenken
    Wunschliste

    Standard

    Zitat Zitat von Arno Beitrag anzeigen
    Wenn man sich nicht ständig mit diesen Themen beschäftigt, weiß man es nicht. Dann kann man nachfragen (wie hier geschehen) und auf eine Antwort hoffen. Wenn dich solche Nachfragen nerven, dann musst du ja nicht antworten.
    Es geht überhaupt nicht darum dass (oder ob) mich das nervt - es geht eher darum, dass es seit einem gefühlten Jahrzehnt Standards gibt, von denen man schon mal was gehört haben könnte und sollte, wenn man sich im Web bewegt. Beispielsweise ist dieser Artikel hier https://www.heise.de/ct/artikel/E-Ma...IM-221505.html von 2008, dieser hier https://www.golem.de/1201/89399.html von 2012, und in diesem hier https://www.heise.de/ct/artikel/Mail...te-221552.html von 2009 ist auch einiges erklärt.

    Ich persönlich finde, dass man sich mit solchen Grundlagen durchaus mal beschäftigen kann, wenn man a) eine Webapplikation mit Mailfunktion sicher betreiben möchte b) dabei nicht zur Spamschleuder mutieren will und c) dafür sorgen möchte, dass Nachrichten des Kunden auch sicher ankommen.

    In diesem Thema geht es darum, Mail zu versenden, für die es keine korrekt gesetzte Absendeadresse gibt. Es gibt ähnliche Themen, bei denen dieses Spoofing noch weiter getrieben wird. Der sichere Weg für alle Beteiligten ist doch, das Procedere zu verstehen, anzuwenden und dann damit belohnt zu werden, dass Nachrichten die Empfänger*innen sicher erreichen. Das ist doch die Kernaufgabe, wenn ich für Kommunikation sorgen soll - und ich finde schon, dass man sich dann auch mit den Grundlagen beschäftigen sollte, anstatt einfach mal ein Formular irgendwo einzubauen und zu hoffen, dass es manchmal ankommt.
    Geändert von lucina (14.03.2020 um 16:50 Uhr)

  13. #13
    Contao-Fan Avatar von Arno
    Registriert seit
    11.12.2009.
    Ort
    Potsdam-Babelsberg
    Beiträge
    289

    Standard

    Du hast recht, ich verstehe was du meinst.

  14. #14
    Contao-Nutzer
    Registriert seit
    25.02.2012.
    Beiträge
    30

    Standard

    Zitat Zitat von Ainschy Beitrag anzeigen
    Hast du nach den Änderungen den Cache gelöscht ? /var/cache -> prod Ordner löschen
    Nach mehreren Aktionen des Löschens (prod Ordner), geht gar nichts mehr. 500 er Fehler

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •