Das Contao Camp 2020 in Hamburg. LEIDER ABGESAGT!
Ergebnis 1 bis 4 von 4

Thema: Update mit Contao-Manager funktioniert nicht

  1. #1
    Contao-Nutzer
    Registriert seit
    29.10.2010.
    Beiträge
    166

    Standard Update mit Contao-Manager funktioniert nicht

    Hallo zusammen,
    ich möchte eine Contao 4.4.45 installation auf 4.4.47 aktualisieren, dabei kommt es zu einem Abbruch während der Installation.
    Im Testlauf funktioniert es problem los, aber bei der richtigen Aktualisierung funktioniert es nicht.

    Ich denke es ist einfach zu lösen, aber weiß nicht wie. Im Testlauf kommt keine Fehlermeldung bzgl. tablesort

    Kann mir jemand helfen? Danke.


    Code:
    $ /opt/php-7.1.6/bin/php -q /var/www/xxxxx/htdocs/web/contao-manager.phar.php composer update contao/manager-bundle contao/news-bundle contao/calendar-bundle contao/faq-bundle contao/comments-bundle contao/newsletter-bundle contao/listing-bundle contao/conflicts contao/core-bundle contao/installation-bundle --with-dependencies --prefer-dist --no-dev --no-progress --no-suggest --no-ansi --no-interaction --optimize-autoloader
    
    Loading composer repositories with package information
    Updating dependencies
    Package operations: 1 install, 52 updates, 0 removals
      - Updating symfony/polyfill-ctype (v1.12.0 => v1.14.0): As there is no 'unzip' command installed zip files are being unpacked using the PHP zip extension.
    This may cause invalid reports of corrupted archives. Besides, any UNIX permissions (e.g. executable) defined in the archives will be lost.
    Installing 'unzip' may remediate them.
    Loading from cache
      - Updating symfony/polyfill-mbstring (v1.12.0 => v1.14.0): Loading from cache
      - Updating twig/twig (v1.42.4 => v1.42.5): Loading from cache
      - Updating symfony/polyfill-php70 (v1.12.0 => v1.14.0): Loading from cache
      - Updating symfony/polyfill-util (v1.12.0 => v1.14.0): Loading from cache
      - Updating symfony/polyfill-php56 (v1.12.0 => v1.14.0): Loading from cache
      - Updating symfony/symfony (v3.4.35 => v3.4.38): Loading from cache
      - Updating contao/manager-plugin (2.7.1 => 2.8.0): Loading from cache
      - Updating symfony/polyfill-intl-icu (v1.12.0 => v1.14.0): Loading from cache
      - Updating symfony/polyfill-apcu (v1.12.0 => v1.14.0): Loading from cache
      - Updating fig/link-util (1.0.0 => 1.1.0): Loading from cache
      - Updating doctrine/reflection (v1.0.0 => v1.1.0): Loading from cache
      - Updating doctrine/cache (1.9.0 => 1.10.0): Loading from cache
      - Updating doctrine/persistence (1.2.0 => 1.3.6): Loading from cache
      - Updating doctrine/common (v2.11.0 => 2.12.0): Loading from cache
      - Updating symfony/polyfill-php73 (v1.12.0 => v1.14.0): Loading from cache
      - Updating symfony/polyfill-php72 (v1.12.0 => v1.14.0): Loading from cache
      - Updating symfony/polyfill-intl-idn (v1.12.0 => v1.14.0): Loading from cache
      - Updating symfony/mime (v4.3.8 => v4.4.5): Loading from cache
      - Installing symfony/service-contracts (v1.1.8): Loading from cache
      - Updating toflar/psr6-symfony-http-cache-store (2.1.1 => 2.2.1): Loading from cache
      - Updating php-http/discovery (1.7.0 => 1.7.4): Loading from cache
      - Updating guzzlehttp/guzzle (6.4.1 => 6.5.2): Loading from cache
      - Updating symfony/http-client (v4.3.8 => v4.4.5): Loading from cache
      - Updating php-http/client-common (1.9.1 => 1.10.0): Loading from cache
      - Updating friendsofsymfony/http-cache (2.7.0 => 2.9.0): Loading from cache
      - Updating monolog/monolog (1.25.2 => 1.25.3): Loading from cache
      - Updating composer/ca-bundle (1.2.4 => 1.2.6): Loading from cache
      - Updating ua-parser/uap-php (v3.9.2 => v3.9.7): Loading from cache
      - Updating nelmio/security-bundle (2.7.0 => v2.9.0): Loading from cache
      - Updating doctrine/doctrine-cache-bundle (1.3.5 => 1.4.0): Loading from cache
      - Updating doctrine/doctrine-bundle (1.11.2 => 1.12.7): Loading from cache
      - Updating webmozart/assert (1.5.0 => 1.7.0): Loading from cache
      - Updating tecnickcom/tcpdf (6.3.2 => 6.3.5): Loading from cache
      - Updating simplepie/simplepie (1.5.3 => 1.5.4): Loading from cache
      - Updating scssphp/scssphp (1.0.5 => 1.0.8): Loading from cache
      - Updating patchwork/utf8 (v1.3.1 => v1.3.2): Loading from cache
      - Updating michelf/php-markdown (1.8.0 => 1.9.0): Loading from cache
      - Updating matthiasmullie/path-converter (1.1.2 => 1.1.3): Loading from cache
      - Updating matthiasmullie/minify (1.3.61 => 1.3.63): Loading from cache
      - Updating knplabs/knp-time-bundle (v1.9.1 => v1.10.0): Loading from cache
      - Updating imagine/imagine (1.2.2 => 1.2.3): Loading from cache
    
    In DownloadManager.php line 156:
                                                                                   
      Package contao-components/tablesort-3.4.12.0 seems not been installed prope  
      rly                                                                          
                                                                                   
    
    update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [--with-all-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>...]
    
    
    # Process terminated with exit code 1
    # Result: General error
    
    
    ---
    
    ### Der Hintergrundprozess wurde unerwartet beendet ###

    TESTLAUF:

    Code:
    $ /opt/php-7.1.6/bin/php -q /var/www/xxxxx/htdocs/web/contao-manager.phar.php composer update contao/manager-bundle contao/news-bundle contao/calendar-bundle contao/faq-bundle contao/comments-bundle contao/newsletter-bundle contao/listing-bundle contao/conflicts contao/core-bundle contao/installation-bundle --with-dependencies --prefer-dist --no-dev --no-progress --no-suggest --no-ansi --no-interaction --optimize-autoloader --dry-run
    
    Loading composer repositories with package information
    Updating dependencies
    Package operations: 1 install, 52 updates, 0 removals
      - Updating symfony/polyfill-ctype (v1.12.0) to symfony/polyfill-ctype (v1.14.0)
      - Updating symfony/polyfill-mbstring (v1.12.0) to symfony/polyfill-mbstring (v1.14.0)
      - Updating twig/twig (v1.42.4) to twig/twig (v1.42.5)
      - Updating symfony/polyfill-php70 (v1.12.0) to symfony/polyfill-php70 (v1.14.0)
      - Updating symfony/polyfill-util (v1.12.0) to symfony/polyfill-util (v1.14.0)
      - Updating symfony/polyfill-php56 (v1.12.0) to symfony/polyfill-php56 (v1.14.0)
      - Updating symfony/symfony (v3.4.35) to symfony/symfony (v3.4.38)
      - Updating contao/manager-plugin (2.7.1) to contao/manager-plugin (2.8.0)
      - Updating symfony/polyfill-intl-icu (v1.12.0) to symfony/polyfill-intl-icu (v1.14.0)
      - Updating symfony/polyfill-apcu (v1.12.0) to symfony/polyfill-apcu (v1.14.0)
      - Updating fig/link-util (1.0.0) to fig/link-util (1.1.0)
      - Updating doctrine/reflection (v1.0.0) to doctrine/reflection (v1.1.0)
      - Updating doctrine/cache (1.9.0) to doctrine/cache (1.10.0)
      - Updating doctrine/persistence (1.2.0) to doctrine/persistence (1.3.6)
      - Updating doctrine/common (v2.11.0) to doctrine/common (2.12.0)
      - Updating symfony/polyfill-php73 (v1.12.0) to symfony/polyfill-php73 (v1.14.0)
      - Updating symfony/polyfill-php72 (v1.12.0) to symfony/polyfill-php72 (v1.14.0)
      - Updating symfony/polyfill-intl-idn (v1.12.0) to symfony/polyfill-intl-idn (v1.14.0)
      - Updating symfony/mime (v4.3.8) to symfony/mime (v4.4.5)
      - Installing symfony/service-contracts (v1.1.8)
      - Updating toflar/psr6-symfony-http-cache-store (2.1.1) to toflar/psr6-symfony-http-cache-store (2.2.1)
      - Updating php-http/discovery (1.7.0) to php-http/discovery (1.7.4)
      - Updating guzzlehttp/guzzle (6.4.1) to guzzlehttp/guzzle (6.5.2)
      - Updating symfony/http-client (v4.3.8) to symfony/http-client (v4.4.5)
      - Updating php-http/client-common (1.9.1) to php-http/client-common (1.10.0)
      - Updating friendsofsymfony/http-cache (2.7.0) to friendsofsymfony/http-cache (2.9.0)
      - Updating monolog/monolog (1.25.2) to monolog/monolog (1.25.3)
      - Updating composer/ca-bundle (1.2.4) to composer/ca-bundle (1.2.6)
      - Updating ua-parser/uap-php (v3.9.2) to ua-parser/uap-php (v3.9.7)
      - Updating nelmio/security-bundle (2.7.0) to nelmio/security-bundle (v2.9.0)
      - Updating doctrine/doctrine-cache-bundle (1.3.5) to doctrine/doctrine-cache-bundle (1.4.0)
      - Updating doctrine/doctrine-bundle (1.11.2) to doctrine/doctrine-bundle (1.12.7)
      - Updating webmozart/assert (1.5.0) to webmozart/assert (1.7.0)
      - Updating tecnickcom/tcpdf (6.3.2) to tecnickcom/tcpdf (6.3.5)
      - Updating simplepie/simplepie (1.5.3) to simplepie/simplepie (1.5.4)
      - Updating scssphp/scssphp (1.0.5) to scssphp/scssphp (1.0.8)
      - Updating patchwork/utf8 (v1.3.1) to patchwork/utf8 (v1.3.2)
      - Updating michelf/php-markdown (1.8.0) to michelf/php-markdown (1.9.0)
      - Updating matthiasmullie/path-converter (1.1.2) to matthiasmullie/path-converter (1.1.3)
      - Updating matthiasmullie/minify (1.3.61) to matthiasmullie/minify (1.3.63)
      - Updating knplabs/knp-time-bundle (v1.9.1) to knplabs/knp-time-bundle (v1.10.0)
      - Updating imagine/imagine (1.2.2) to imagine/imagine (1.2.3)
      - Updating contao-components/tablesort (3.4.12) to contao-components/tablesort (4.0.1)
      - Updating contao-components/chosen (1.2.2) to contao-components/chosen (1.2.4)
      - Updating contao/core-bundle (4.4.45) to contao/core-bundle (4.4.47)
      - Updating contao/installation-bundle (4.4.45) to contao/installation-bundle (4.4.47)
      - Updating contao/manager-bundle (4.4.45) to contao/manager-bundle (4.4.47)
      - Updating contao/news-bundle (4.4.45) to contao/news-bundle (4.4.47)
      - Updating contao/newsletter-bundle (4.4.45) to contao/newsletter-bundle (4.4.47)
      - Updating contao/calendar-bundle (4.4.45) to contao/calendar-bundle (4.4.47)
      - Updating contao/comments-bundle (4.4.45) to contao/comments-bundle (4.4.47)
      - Updating contao/faq-bundle (4.4.45) to contao/faq-bundle (4.4.47)
      - Updating contao/listing-bundle (4.4.45) to contao/listing-bundle (4.4.47)
    Package oyejorge/less.php is abandoned, you should avoid using it. No replacement was suggested.
    
    # Process terminated with exit code 0
    # Result: OK
    
    
    ---
    
    ### Prozess erfolgreich abgeschlossen ###

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    23.098
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Nutze den Cloud Resolver.

  3. #3
    Contao-Nutzer
    Registriert seit
    29.10.2010.
    Beiträge
    166

    Standard

    Habe ich schon mehrfach versucht, aber ohne Erfolg - über mehrere Tage:

    HTTP request to https://composer-resolver.cloud/jobs failed with status code 400 ()

  4. #4
    Contao-Nutzer
    Registriert seit
    29.10.2010.
    Beiträge
    166

    Standard

    Habs jetzt hinbekommen.

    Hab die composer.lock gelöscht, den Ordner contao-components im Verzeichnis Vendor und den Order tablesort im Verzeichnis assets gelöscht bzw. verschoben.

    Anschließend habe ich unter Systemwartung im Manager "Composer Abhängigkeiten -> Installer ausführen" ausgeführt.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •