Das Contao Camp 2020 in Hamburg. LEIDER ABGESAGT!
Ergebnis 1 bis 5 von 5

Thema: Uploading a File with approx. 20 MB - Contao throws a 403 forbidden exception

  1. #1
    Contao-Nutzer
    Registriert seit
    21.01.2020.
    Beiträge
    4

    Standard Uploading a File with approx. 20 MB - Contao throws a 403 forbidden exception

    **Affected version(s)**

    Contao 4.4.47?

    **Description**

    I tried to Upload a File and I get a 403 Error when trying to send the form. The form has be produced by the Form-Generator. I tried this also with another contao-installation and it sends me the same error.... You can reproduce it by going to akkuratio.de/kontakt.html and filling out the form.

    Hope there is a solution for this. The php.ini file has set php-uploads to 500MB and the setting in contao is 248MB.

    So I don't know where the problem is. Couldn't find anything on the web.

  2. #2
    Contao-Nutzer
    Registriert seit
    20.10.2012.
    Ort
    Berlin
    Beiträge
    154

    Standard

    You are using plesk with nginx. <del>Disable the prox-feature</del> Use php handled by apache and see if the Problem still exist's. If it's gone take a look at client_max_body_size before you revert to the old configuration.
    Geändert von andre.saage (19.03.2020 um 15:56 Uhr)

  3. #3
    Contao-Nutzer
    Registriert seit
    21.01.2020.
    Beiträge
    4

    Standard

    where do I set this setting. I disabled the Setting here: https://netz-garage.de/screenshot.png (proxymodus)

  4. #4
    Contao-Nutzer
    Registriert seit
    20.10.2012.
    Ort
    Berlin
    Beiträge
    154

    Standard

    Um den Parameter anzupassen wäre das die richtige Stelle - allerdings fehlen dir die Berechtigungen sodass das Feld für zusätzliche nginx-Einstellungen nicht angezeigt wird.
    Aktivier das wieder und gehe zu Hosting-Einstellungen (nicht Einstellungen für Apache & nginx).
    Wenn du php als Anwendung von Apache ausführst ist der client_max_body_size Parameter belanglos und die php.ini-settings bzw. contao settings sollten in Kraft treten.
    Wenn dein Formular dann funktioniert wäre die Sache zumindest mal eingegrenzt. Ich erinner mich nämlich nichtmehr genau ob ich bei diesem Problem auch eine 403 bekommen hab.
    Anmerkung 2020-03-20 103529.png

  5. #5
    Contao-Nutzer
    Registriert seit
    21.01.2020.
    Beiträge
    4

    Standard

    problem solved I had to set the htaccess to this:
    SecRuleRemoveById 330792

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •