Ergebnis 1 bis 4 von 4

Thema: aktiver URL Präfix - best practice da Fehler 404

  1. #1
    Contao-Nutzer
    Registriert seit
    14.07.2011.
    Beiträge
    206

    Standard aktiver URL Präfix - best practice da Fehler 404

    Hy Leute,

    Ich habe den ULR Präfix aktiviert - das heißt jede Seite wird mit domain.com/de/ ausgegeben was perfekt funktioniert.
    Nur habe ich nun das Problem, dass www.domain.com (wenn man es direkt eingibt) einen Fehler 404 (und zwar den vom Server) ausgibt.

    ist hier noch etwas weiter zu beachten?
    ich möchte nicht über htaccess eine Umleitung machen, weil ich damit ja dann die Spracherkennung von Contao außer Kraft setze.

    Eine Idee wäre es, eine Startseite zu definieren OHNE Präfix und die erste Seite in diesem baum erzeugt dann die Weiterleitung.
    Aber so richtig sauber sieht dass dann nicht aus

    => Start DE (www.domain.com)
    ===> redirect (www.domain.com/de/)
    => Start DE mit Präfix (www.domain.com/de/)
    ===> Startseite Deutsch (auf dieser soll der Besucher dann landen)

    Sprachen sind aktuell 3 geplant

    Habt ihr hier einen Tipp für mich?

    Irgendwie fühlt es sich für mich so an, als würde etwas nicht im Handbuch stehen oder ich übersehe etwas.

    Viele Grüße
    Winchester

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    25.841
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Zeige die Einstellungen deiner Startpunkte.

  3. #3
    Contao-Nutzer
    Registriert seit
    14.07.2011.
    Beiträge
    206

    Standard

    Tja und da liegt auch schon die Lösung

    Aus Angst mich vor einem Urgestein wie dir zu blamieren hab ich nun sorgfältig Screenshots gemacht und alles nochmals geprüft.

    Folgende Config war es:

    Deutsch, kein Fallback / Präfix DE
    Englisch, Fallback / KEIN PRÄFIX

    Nachdem ich bei Englisch ebenfalls den Präfix hatte, klappte es (was im Nachhinein betrachtet komplett logisch ist aber Englisch ist vorerst nur eine Leere Seite deshalb hab ich mich nicht darum gekümmert).

    Und das ist auch schon das Problem gewesen.
    Jetzt funktioniert alles fehlerfrei!

    Falls ich kein Patent auf diese Dummheit habe, hilft es vielleicht mal jemand anderen

    Viele Grüße

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Vienna, Austria
    Beiträge
    25.841
    Partner-ID
    10107
    User beschenken
    Wunschliste

    Standard

    Hehe, passt

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •