Ergebnis 1 bis 4 von 4

Thema: Aktualisierung auf Version 2.7.0 funktioniert nicht

  1. #1
    Contao-Nutzer
    Registriert seit
    23.09.2009.
    Beiträge
    7

    Standard Aktualisierung auf Version 2.7.0 funktioniert nicht

    Hallo,

    ich habe auch schon mehrmals versucht Isotope 2.7.0 (aktuell bei mir 2.6.15) zu installieren. Es passiert aber nix. 2.6 bleibt. Woran liegt das?
    Kann das mit dem Contao/Composer-Update zusammenhängen?

    Hab die Contao Version 4.9.12 (das Update war erfolgreich) unter PHP 7.3.20.

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    26.680
    Partner-ID
    10107

    Standard

    Moderation: Post in einen eigenen Thread verschoben, da der ursprüngliche Thread spezifisch das Thema der PHP 8 Kompatibilität von Isotope behandelt.

    - - - Aktualisiert - - -

    Zitat Zitat von theresia Beitrag anzeigen
    ich habe auch schon mehrmals versucht Isotope 2.7.0 (aktuell bei mir 2.6.15) zu installieren. Es passiert aber nix. 2.6 bleibt. Woran liegt das?
    Du musst die Konsolen-Ausgabe dieser Operation posten, ansonsten kann man nicht sagen, woran das liegt.

  3. #3
    Contao-Nutzer
    Registriert seit
    23.09.2009.
    Beiträge
    7

    Standard

    Code:
    $ /opt/php-7.3.20/bin/php -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=UTC /var/www/clients/client226/web1490/web/vkjk/manager/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-ansi --no-interaction --optimize-autoloader
    
    Using config.component-dir has been deprecated. Please use extra.contao-component-dir instead.
    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Package operations: 0 installs, 4 updates, 0 removals
      - Downloading menatwork/contao-multicolumnwizard-bundle (3.4.10)
      - Downloading codefog/contao-haste (4.24.14)
      - Downloading terminal42/dc_multilingual (4.1.1)
      - Downloading isotope/isotope-core (2.7.0)
      - Upgrading menatwork/contao-multicolumnwizard-bundle (3.4.9 => 3.4.10): Extracting archive
      - Upgrading codefog/contao-haste (4.24.13 => 4.24.14): Extracting archive
      - Upgrading terminal42/dc_multilingual (2.1.7 => 4.1.1): Extracting archive
      - Upgrading isotope/isotope-core (2.6.15 => 2.7.0): Extracting archive
    Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.
    Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
    Package zendframework/zend-code is abandoned, you should avoid using it. Use laminas/laminas-code instead.
    Package zendframework/zend-eventmanager is abandoned, you should avoid using it. Use laminas/laminas-eventmanager instead.
    Generating optimized autoload files
    Class UnitedPrototype\GoogleAnalytics\Internals\Request\SocialinteractionRequest located in ./vendor/isotope/isotope-core/system/modules/isotope/library/UnitedPrototype/GoogleAnalytics/Internals/Request/SocialInteractionRequest.php does not comply with psr-0 autoloading standard. Skipping.
    Class League\Uri\Schemes\AbstractUri located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\Data located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\File located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\Ftp located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\Http located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\Uri located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\UriException located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    Class League\Uri\Schemes\Ws located in ./vendor/league/uri-schemes/src/Schemes/deprecated.php does not comply with psr-4 autoloading standard. Skipping.
    composer/package-versions-deprecated: Generating version class...
    composer/package-versions-deprecated: ...done generating version class
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    84 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    Added the web/app.php file.
    Added the web/index.php file.
    Added the web/preview.php file.
    
     // Clearing the cache for the prod environment with debug                      
     // false                                                                       
    
     [OK] Cache for the "prod" environment (debug=false) was successfully cleared.  
    
    
     // Clearing the cache for the dev environment with debug                       
     // true                                                                        
    
     [OK] Cache for the "dev" environment (debug=true) was successfully cleared.    
    
    
     // Warming up the cache for the prod environment with debug                    
     // false                                                                       
    
    07:23:43 ERROR     [console] Error thrown while running command "cache:warmup --env=prod". Message: "Argument 1 passed to Isotope\Model\AttributeOption::findByAttribute() must implement interface Isotope\Interfaces\IsotopeAttributeWithOptions, instance of Isotope\Model\Attribute\TextField given, called in /var/www/clients/client226/web1490/web/vkjk/manager/vendor/isotope/isotope-core/system/modules/isotope/library/Isotope/Model/Attribute.php on line 260" ["exception" => TypeError { …},"command" => "cache:warmup --env=prod","message" => "Argument 1 passed to Isotope\Model\AttributeOption::findByAttribute() must implement interface Isotope\Interfaces\IsotopeAttributeWithOptions, instance of Isotope\Model\Attribute\TextField given, called in /var/www/clients/client226/web1490/web/vkjk/manager/vendor/isotope/isotope-core/system/modules/isotope/library/Isotope/Model/Attribute.php on line 260"]
    
    In AttributeOption.php line 267:
                                                                                   
      Argument 1 passed to Isotope\Model\AttributeOption::findByAttribute() must   
      implement interface Isotope\Interfaces\IsotopeAttributeWithOptions, instanc  
      e of Isotope\Model\Attribute\TextField given, called in /var/www/clients/cl  
      ient226/web1490/web/vkjk/manager/vendor/isotope/isotope-core/system/modules  
      /isotope/library/Isotope/Model/Attribute.php on line 260                     
                                                                                   
    
    cache:warmup [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--env ENV] [--] 
    
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    
    In ScriptHandler.php line 89:
                                                                                   
      An error occurred while executing the "cache:warmup" command: 07:23:43 ERRO  
      R     [console] Error thrown while running command "cache:warmup --env=prod  
      ". Message: "Argument 1 passed to Isotope\Model\AttributeOption::findByAttr  
      ibute() must implement interface Isotope\Interfaces\IsotopeAttributeWithOpt  
      ions, instance of Isotope\Model\Attribute\TextField given, called in /var/w  
      ww/clients/client226/web1490/web/vkjk/manager/vendor/isotope/isotope-core/s  
      ystem/modules/isotope/library/Isotope/Model/Attribute.php on line 260" ["ex  
      ception" => TypeError { …},"command" => "cache:warmup --env=prod","message"  
       => "Argument 1 passed to Isotope\Model\AttributeOption::findByAttribute()   
      must implement interface Isotope\Interfaces\IsotopeAttributeWithOptions, in  
      stance of Isotope\Model\Attribute\TextField given, called in /var/www/clien  
      ts/client226/web1490/web/vkjk/manager/vendor/isotope/isotope-core/system/mo  
      dules/isotope/library/Isotope/Model/Attribute.php on line 260"]              
                                                                                   
      In AttributeOption.php line 267:                                             
                                                                                   
                                                                                   
        Argument 1 passed to Isotope\Model\AttributeOption::findByAttribute() mus  
      t                                                                            
        implement interface Isotope\Interfaces\IsotopeAttributeWithOptions, insta  
      nc                                                                           
        e of Isotope\Model\Attribute\TextField given, called in /var/www/clients/  
      cl                                                                           
        ient226/web1490/web/vkjk/manager/vendor/isotope/isotope-core/system/modul  
      es                                                                           
        /isotope/library/Isotope/Model/Attribute.php on line 260                   
                                                                                   
                                                                                   
                                                                                   
                                                                                   
      cache:warmup [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--  
      verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--en  
      v ENV] [--]                                                         
                                                                                   
    
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-suggest] [--no-dev] [--no-autoloader] [--no-scripts] [--no-progress] [--no-install] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--apcu-autoloader-prefix APCU-AUTOLOADER-PREFIX] [--ignore-platform-req IGNORE-PLATFORM-REQ] [--ignore-platform-reqs] [--] [...]
    
    
    # Process terminated with exit code 1
    # Result: General error
    ja, sorry

    habe eben eine andere erweiterung installiert da gab es keine probleme ...

  4. #4
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    26.680
    Partner-ID
    10107

    Standard

    Das ist ein Fehler, der in Isotope 2.7.0 Auftritt, siehe https://github.com/isotope/core/issues/2196
    » sponsor me via GitHub or PayPal

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •