Ergebnis 1 bis 14 von 14

Thema: Installation des Bundles "omosde/contao-om-backend" klappt nicht

  1. #1
    Contao-Fan
    Registriert seit
    29.06.2016.
    Beiträge
    333

    Standard Installation des Bundles "omosde/contao-om-backend" klappt nicht

    Hi,

    ich möchte das Bundle "omosde/contao-om-backend" installieren.
    Wenn ich "composer require omosde/contao-om-backend" ausführe, kriege ich folgende Meldung:

    Code:
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - omosde/contao-om-backend[1.6.0, ..., 1.6.11] require wa72/htmlpagedom ^1.3 -> satisfiable by wa72/htmlpagedom[v1.3.0, ..., v1.4.2].
        - wa72/htmlpagedom v1.3.0 requires symfony/dom-crawler ^2.3 <2.8 | ^2.8.3 | ^3.0.1 -> found symfony/dom-crawler[v2.3.0, ..., v2.8.52, v3.0.1, ..., v3.4.47] but the package is fixed to v5.2.4 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
        - wa72/htmlpagedom v1.3.1 requires symfony/dom-crawler ^2.3 <2.8 | ^2.8.3 | ^3.0.1 | ^4 -> found symfony/dom-crawler[v2.3.0, ..., v2.8.52, v3.0.1, ..., v3.4.47, v4.0.0, ..., v4.4.20] but the package is fixed to v5.2.4 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
        - wa72/htmlpagedom[v1.3.2, ..., v1.4.2] require symfony/dom-crawler ^2.3 <2.8 | ^2.8.3 | ^3.0.1 | ^4 <4.3 -> found symfony/dom-crawler[v2.3.0, ..., v2.8.52, v3.0.1, ..., v3.4.47, v4.0.0, ..., v4.2.12] but the package is fixed to v5.2.4 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
        - Root composer.json requires omosde/contao-om-backend ^1.6 -> satisfiable by omosde/contao-om-backend[1.6.0, ..., 1.6.11].
    
    Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
    
    Installation failed, reverting ./composer.json and ./composer.lock to their original content.

    ... ist das Bundle noch nicht ready für die Contao Version 4.11.2?

    Danke für euer Hilfe!

  2. #2
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    26.865
    Partner-ID
    10107

    Standard

    Die Lösung hast du ja eigentlich schon selbst gepostet
    Zitat Zitat von thesweetg Beitrag anzeigen
    Code:
    Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
    »
    Code:
    composer require omosde/contao-om-backend --with-all-dependencies
    » sponsor me via GitHub or PayPal

  3. #3
    Contao-Fan
    Registriert seit
    29.06.2016.
    Beiträge
    333

    Standard

    Hätte es nun mit:
    Code:
    composer require omosde/contao-om-backend --with-all-dependencies
    ... probiert, klappt leider auch nicht.
    Nun bekomme ich die Fehlermeldung:

    Code:
    In ParameterBag.php line 98:
    
      You have requested a non-existent parameter "kernel.root_dir". Did you mean
       one of these: "kernel.project_dir", "kernel.build_dir", "kernel.cache_dir"
      , "kernel.logs_dir"?

  4. #4
    Contao-Fan
    Registriert seit
    29.06.2016.
    Beiträge
    333

    Standard

    .... und nun ist auch das Backend nicht mehr erreichbar

    Kann ich das irgendwie rückgängig machen?

  5. #5
    Contao-Fan
    Registriert seit
    29.06.2016.
    Beiträge
    333

    Standard

    Ok, mit "composer remove omosde/contao-om-backend" ist nun zumindest das Backend wieder aktiv.

  6. #6
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    26.865
    Partner-ID
    10107

    Standard

    Zitat Zitat von thesweetg Beitrag anzeigen
    Hätte es nun mit:
    Code:
    composer require omosde/contao-om-backend --with-all-dependencies
    ... probiert, klappt leider auch nicht.
    Nun bekomme ich die Fehlermeldung:

    Code:
    In ParameterBag.php line 98:
    
      You have requested a non-existent parameter "kernel.root_dir". Did you mean
       one of these: "kernel.project_dir", "kernel.build_dir", "kernel.cache_dir"
      , "kernel.logs_dir"?
    Doch, die Installation des Paketes hat nun funktioniert. Der Fehler ist nun ein anderer: soweit ich mich erinnere tritt dieser Fehler in Verbindung mit der omosde/contao-om-backend Extension auf, wenn Symfony 5 installiert ist.
    » sponsor me via GitHub or PayPal

  7. #7
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    26.865
    Partner-ID
    10107

    Standard

    Der Fehler kommt übrigens von menatwork/contao-multicolumnwizard-bundle.
    » sponsor me via GitHub or PayPal

  8. #8
    Contao-Fan Avatar von Fehrmann
    Registriert seit
    04.07.2009.
    Ort
    Wismar
    Beiträge
    451

    Standard

    Hi,

    vielleicht hilft der Vorschlag in: https://github.com/OMOSde/contao-om-...ment-805840499

    Viele Grüße
    René
    aiDESIGNER - www.ai-designer.de, ehemals als Freelancer www.omos.de

  9. #9
    Contao-Fan
    Registriert seit
    29.06.2016.
    Beiträge
    333

    Standard

    Danke für eure Hilfe bzw. für die Links.

    Werde allerdings nicht so recht schlau daraus:
    D.h. muss auf ein Update von "menatwork/contao-multicolumnwizard-bundle" warten damit ich "omosde/contao-om-backend" wieder betreiben kann?

  10. #10
    Contao-Fan Avatar von Fehrmann
    Registriert seit
    04.07.2009.
    Ort
    Wismar
    Beiträge
    451

    Standard

    Hi,

    oder das hier probieren:

    Alternatively, a conflict can be entered in composer.json (root) for '"symfony/http-kernel":"^5"' (thanks goes to Fritz: menatwork/contao-multicolumnwizard-bundle#107 (comment)). This will switch from Symfony v5 to v4. Contao 4.11 is compatible with v4 and v5 and the conflict can be removed later if possible.
    aiDESIGNER - www.ai-designer.de, ehemals als Freelancer www.omos.de

  11. #11
    Contao-Fan
    Registriert seit
    29.06.2016.
    Beiträge
    333

    Standard

    Hab jetzt das hier in meiner composer.json ergänzt:
    Code:
        "conflict": {
            "contao-components/installer": "<1.3",
            "contao/core-bundle": "<4.4.8",
            "symfony/http-kernel": "^5" 
        },
    Danach habe ich erfolgreich ein "composer update" ausgeführt.

    Bekomme aber trotzdem bei einem "composer require omosde/contao-om-backend" immer noch:

    Code:
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - omosde/contao-om-backend[1.6.0, ..., 1.6.11] require wa72/htmlpagedom ^1.3 -> satisfiable by wa72/htmlpagedom[v1.3.0, ..., v1.4.2].
        - wa72/htmlpagedom v1.3.0 requires symfony/dom-crawler ^2.3 <2.8 | ^2.8.3 | ^3.0.1 -> found symfony/dom-crawler[v2.3.0, ..., v2.8.52, v3.0.1, ..., v3.4.47] but the package is fixed to v5.2.4 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
        - wa72/htmlpagedom v1.3.1 requires symfony/dom-crawler ^2.3 <2.8 | ^2.8.3 | ^3.0.1 | ^4 -> found symfony/dom-crawler[v2.3.0, ..., v2.8.52, v3.0.1, ..., v3.4.47, v4.0.0, ..., v4.4.20] but the package is fixed to v5.2.4 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
        - wa72/htmlpagedom[v1.3.2, ..., v1.4.2] require symfony/dom-crawler ^2.3 <2.8 | ^2.8.3 | ^3.0.1 | ^4 <4.3 -> found symfony/dom-crawler[v2.3.0, ..., v2.8.52, v3.0.1, ..., v3.4.47, v4.0.0, ..., v4.2.12] but the package is fixed to v5.2.4 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
        - Root composer.json requires omosde/contao-om-backend ^1.6 -> satisfiable by omosde/contao-om-backend[1.6.0, ..., 1.6.11].
    
    Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
    
    Installation failed, reverting ./composer.json and ./composer.lock to their original content.
    ... was mache ich da falsch?

  12. #12
    Community-Moderator
    Wandelndes Contao-Lexikon
    Avatar von Spooky
    Registriert seit
    12.04.2012.
    Ort
    Scotland
    Beiträge
    26.865
    Partner-ID
    10107
    Geändert von Spooky (21.04.2021 um 14:51 Uhr)
    » sponsor me via GitHub or PayPal

  13. #13
    Contao-Fan Avatar von Fehrmann
    Registriert seit
    04.07.2009.
    Ort
    Wismar
    Beiträge
    451

    Standard

    Hi,

    ok, das ist neu. Ich schaue es mir am Wochenende an.

    Viele Grüße
    René
    aiDESIGNER - www.ai-designer.de, ehemals als Freelancer www.omos.de

  14. #14
    Contao-Fan Avatar von Fehrmann
    Registriert seit
    04.07.2009.
    Ort
    Wismar
    Beiträge
    451

    Standard

    Hi,

    eine neue Version ist raus: https://github.com/OMOSde/contao-om-...ses/tag/1.6.12

    Viele Grüße
    René
    aiDESIGNER - www.ai-designer.de, ehemals als Freelancer www.omos.de

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •