Ergebnis 1 bis 3 von 3

Thema: Installation von mp_forms mit Composer-Fehlern

  1. #1
    Contao-Nutzer
    Registriert seit
    13.11.2018.
    Beiträge
    13

    Standard Installation von mp_forms mit Composer-Fehlern

    Hallo!

    Der Versuch, die Terminal42-Erweiterung "mp-forms" zu installieren, scheitert bei mir mit einer Vielzahl von Fehlermeldungen. Habt Ihr eine Idee?

    Das System läuft mit Contao 4.4.55 und mp-forms soll in Version 4.2.1 (vom 27. April 2021) installiert werden. Der Testlauf funktioniert reibungslos, soll die Erweiterung aber dann tatsächlich installiert werden, bricht Composer beim letzten Schritt mit einem Fehler ab. Und das sagt die Konsole:

    Code:
    $ /usr/bin/php7.4 -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /home/www/contao44/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-ansi --no-interaction --optimize-autoloader
    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Package operations: 1 install, 1 update, 0 removals
      - Upgrading codefog/contao-haste (4.24.13 => 4.24.15): Extracting archive
      - Installing terminal42/contao-mp_forms (4.2.1): Extracting archive
    Package contao-components/compass is abandoned, you should avoid using it. No replacement was suggested.
    Package doctrine/doctrine-cache-bundle is abandoned, you should avoid using it. No replacement was suggested.
    Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.
    Package oyejorge/less.php is abandoned, you should avoid using it. No replacement was suggested.
    Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.
    Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
    Package sensio/distribution-bundle is abandoned, you should avoid using it. No replacement was suggested.
    Package sensiolabs/security-checker is abandoned, you should avoid using it. Use https://github.com/fabpot/local-php-security-checker instead.
    Generating optimized autoload files
    contao/manager-plugin: Generating plugin class...
    37 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!
    # Process terminated with exit code 255
    # Result: Unknown error
    Im Ergebnis bleibt eine beschädigte Contao-Installation zurück, die auch nicht automatisch zu reparieren ist. Erst mit Wartungsmodus und Neustart läuft sie wieder.

    Wie darf ich denn die Fehlermeldungen verstehen? Und was kann ich dagegen machen?

    Bin für jeden Hinweis dankbar!

    VG, Volker
    Geändert von xchs (30.04.2021 um 23:06 Uhr) Grund: Code-Tags
    Dankbar für jede Hilfe!

  2. #2
    Contao-Nutzer
    Registriert seit
    13.11.2018.
    Beiträge
    13

    Standard Andere Installation, andere Fehlermeldung bei mp_forms

    Hallo!

    Ich habe versucht, auf einer anderen Installation (ebenfalls Contao 4.4 LTS) die Erweiterung "mp_forms" testweise zu installieren - wieder ohne Erfolg. Diese ist die Fehlermeldung eine andere. Hier die Meldung der Konsole:

    Code:
    $ /usr/bin/php7.2 -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /home/www/contao44/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-ansi --no-interaction --optimize-autoloader
    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Package operations: 3 installs, 47 updates, 1 removal
      - Downloading contao-components/installer (1.4.1)
      - Downloading symfony/polyfill-ctype (v1.22.1)
      - Downloading twig/twig (v1.44.2)
      - Downloading symfony/polyfill-mbstring (v1.22.1)
      - Downloading symfony/polyfill-intl-icu (v1.22.1)
      - Downloading symfony/polyfill-apcu (v1.22.1)
      - Downloading psr/container (1.1.1)
      - Downloading fig/link-util (1.1.2)
      - Downloading symfony/symfony (v3.4.47)
      - Downloading contao-community-alliance/composer-plugin (3.1.5)
      - Downloading doctrine/annotations (1.12.1)
      - Downloading doctrine/reflection (1.2.2)
      - Downloading doctrine/cache (1.11.0)
      - Downloading doctrine/inflector (1.4.4)
      - Downloading webmozart/assert (1.10.0)
      - Downloading php-http/message (1.11.0)
      - Downloading php-http/discovery (1.13.0)
      - Downloading symfony/polyfill-php72 (v1.22.1)
      - Downloading symfony/polyfill-intl-normalizer (v1.22.1)
      - Downloading symfony/polyfill-intl-idn (v1.22.1)
      - Downloading guzzlehttp/psr7 (1.8.2)
      - Downloading guzzlehttp/promises (1.4.1)
      - Downloading symfony/service-contracts (v2.4.0)
      - Downloading symfony/polyfill-php80 (v1.22.1)
      - Downloading symfony/polyfill-php73 (v1.22.1)
      - Downloading symfony/http-client-contracts (v2.4.0)
      - Downloading symfony/http-client (v5.2.7)
      - Downloading friendsofsymfony/http-cache (2.10.0)
      - Downloading friendsofsymfony/http-cache-bundle (2.9.2)
      - Downloading tecnickcom/tcpdf (6.4.1)
      - Downloading simplepie/simplepie (1.5.6)
      - Downloading scssphp/scssphp (v1.4.1)
      - Downloading phpunit/php-token-stream (3.1.2)
      - Downloading patchwork/utf8 (v1.3.3)
      - Downloading matthiasmullie/minify (1.3.66)
      - Downloading knplabs/knp-menu (2.6.1)
      - Downloading imagine/imagine (1.2.4)
      - Downloading doctrine/deprecations (v0.5.3)
      - Downloading doctrine/dbal (2.13.1)
      - Downloading doctrine/doctrine-bundle (1.12.13)
      - Downloading codefog/contao-haste (4.24.15)
      - Downloading monolog/monolog (1.26.0)
      - Downloading composer/ca-bundle (1.2.9)
      - Downloading ua-parser/uap-php (v3.9.14)
      - Downloading symfony/deprecation-contracts (v2.4.0)
      - Downloading symfony/mime (v5.2.7)
      - Downloading terminal42/contao-mp_forms (4.2.1)
      - Removing symfony/polyfill-util (v1.18.1)
      - Upgrading contao-components/installer (1.4.0 => 1.4.1): Extracting archive
      - Upgrading symfony/polyfill-ctype (v1.18.1 => v1.22.1): Extracting archive
      - Upgrading twig/twig (v1.43.1 => v1.44.2): Extracting archive
      - Removing symfony/polyfill-php70 (v1.18.1)
      - Installing symfony/polyfill-php70 (v1.20.0)
      - Removing symfony/polyfill-php56 (v1.18.1)
      - Installing symfony/polyfill-php56 (v1.20.0)
      - Upgrading symfony/polyfill-mbstring (v1.18.1 => v1.22.1): Extracting archive
      - Upgrading symfony/polyfill-intl-icu (v1.18.1 => v1.22.1): Extracting archive
      - Upgrading symfony/polyfill-apcu (v1.18.1 => v1.22.1): Extracting archive
      - Upgrading psr/container (1.0.0 => 1.1.1): Extracting archive
      - Upgrading fig/link-util (1.1.1 => 1.1.2): Extracting archive
      - Upgrading symfony/symfony (v3.4.45 => v3.4.47): Extracting archive
      - Upgrading contao-community-alliance/composer-plugin (3.1.1 => 3.1.5): Extracting archive
      - Upgrading doctrine/annotations (1.10.4 => 1.12.1): Extracting archive
      - Upgrading doctrine/reflection (1.2.1 => 1.2.2): Extracting archive
      - Upgrading doctrine/cache (1.10.2 => 1.11.0): Extracting archive
      - Upgrading doctrine/inflector (1.4.3 => 1.4.4): Extracting archive
      - Upgrading webmozart/assert (1.9.1 => 1.10.0): Extracting archive
      - Upgrading php-http/message (1.9.0 => 1.11.0): Extracting archive
      - Upgrading php-http/discovery (1.12.0 => 1.13.0): Extracting archive
      - Upgrading symfony/polyfill-php72 (v1.18.1 => v1.22.1): Extracting archive
      - Upgrading symfony/polyfill-intl-normalizer (v1.18.1 => v1.22.1): Extracting archive
      - Upgrading symfony/polyfill-intl-idn (v1.18.1 => v1.22.1): Extracting archive
      - Upgrading guzzlehttp/psr7 (1.7.0 => 1.8.2): Extracting archive
      - Upgrading guzzlehttp/promises (1.4.0 => 1.4.1): Extracting archive
      - Upgrading symfony/service-contracts (v2.2.0 => v2.4.0): Extracting archive
      - Upgrading symfony/polyfill-php80 (v1.18.1 => v1.22.1): Extracting archive
      - Upgrading symfony/polyfill-php73 (v1.18.1 => v1.22.1): Extracting archive
      - Upgrading symfony/http-client-contracts (v2.2.0 => v2.4.0): Extracting archive
      - Upgrading symfony/http-client (v5.1.6 => v5.2.7): Extracting archive
      - Upgrading friendsofsymfony/http-cache (2.9.2 => 2.10.0): Extracting archive
      - Upgrading friendsofsymfony/http-cache-bundle (2.9.0 => 2.9.2): Extracting archive
      - Upgrading tecnickcom/tcpdf (6.3.5 => 6.4.1): Extracting archive
      - Upgrading simplepie/simplepie (1.5.5 => 1.5.6): Extracting archive
      - Upgrading scssphp/scssphp (1.2.1 => v1.4.1): Extracting archive
      - Upgrading phpunit/php-token-stream (3.1.1 => 3.1.2): Extracting archive
      - Upgrading patchwork/utf8 (v1.3.2 => v1.3.3): Extracting archive
      - Upgrading matthiasmullie/minify (1.3.63 => 1.3.66): Extracting archive
      - Upgrading knplabs/knp-menu (2.6.0 => 2.6.1): Extracting archive
      - Upgrading imagine/imagine (1.2.3 => 1.2.4): Extracting archive
      - Installing doctrine/deprecations (v0.5.3): Extracting archive
      - Upgrading doctrine/dbal (2.10.4 => 2.13.1): Extracting archive
      - Upgrading doctrine/doctrine-bundle (1.12.10 => 1.12.13): Extracting archive
      - Upgrading codefog/contao-haste (4.24.9 => 4.24.15): Extracting archive
      - Upgrading contao/conflicts (dev-master ba331b1 => dev-main ccb69e2)
      - Upgrading monolog/monolog (1.25.5 => 1.26.0): Extracting archive
      - Upgrading composer/ca-bundle (1.2.8 => 1.2.9): Extracting archive
      - Upgrading ua-parser/uap-php (v3.9.13 => v3.9.14): Extracting archive
      - Installing symfony/deprecation-contracts (v2.4.0): Extracting archive
      - Upgrading symfony/mime (v5.1.6 => v5.2.7): Extracting archive
      - Installing terminal42/contao-mp_forms (4.2.1): Extracting archive
        Failed to extract codefog/contao-haste: (9) unzip -qq  '/home/www/contao44/vendor/composer/tmp-180f54197489a2b05f2a527a0e19c7e6' -d '/home/www/contao44/vendor/composer/a74106ca'
    unzip:  cannot find or open /home/www/contao44/vendor/composer/tmp-180f54197489a2b05f2a527a0e19c7e6.
        This most likely is due to a custom installer plugin not handling the returned Promise from the downloader
        See https://github.com/composer/installe...1ac68fb1c5c9bb for an example fix
        Failed to extract terminal42/contao-mp_forms: (9) unzip -qq  '/home/www/contao44/vendor/composer/tmp-7a7025d29ecf38fd63d4c986a898295d' -d '/home/www/contao44/vendor/composer/0b97c020'
    unzip:  cannot find or open /home/www/contao44/vendor/composer/tmp-7a7025d29ecf38fd63d4c986a898295d.
        This most likely is due to a custom installer plugin not handling the returned Promise from the downloader
        See https://github.com/composer/installe...1ac68fb1c5c9bb for an example fix
    Package contao-components/compass is abandoned, you should avoid using it. No replacement was suggested.
    Package doctrine/doctrine-cache-bundle is abandoned, you should avoid using it. No replacement was suggested.
    Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.
    Package oyejorge/less.php is abandoned, you should avoid using it. No replacement was suggested.
    Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.
    Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
    Package sensio/distribution-bundle is abandoned, you should avoid using it. No replacement was suggested.
    Generating optimized autoload files
    contao/manager-plugin: Generating plugin class...
    contao/manager-plugin: ...done generating plugin class
    35 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!
    > Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication
    In ContaoModuleBundle.php line 36:
                                                                
      The module folder "system/modules/haste" does not exist.  
                                                                
    Script Contao\ManagerBundle\Composer\ScriptHandler::initializeApplication handling the post-install-cmd event terminated with an exception
    In ScriptHandler.php line 113:
                                                                                
      An error occurred while executing the "contao:install-web-dir" command:   
      In ContaoModuleBundle.php line 36:                                        
                                                                                
        The module folder "system/modules/haste" does not exist.                
                                                                                
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-suggest] [--no-dev] [--no-autoloader] [--no-scripts] [--no-progress] [--no-install] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--apcu-autoloader-prefix APCU-AUTOLOADER-PREFIX] [--ignore-platform-req IGNORE-PLATFORM-REQ] [--ignore-platform-reqs] [--] [<packages>...]
    # Process terminated with exit code 1
    # Result: General error
    Anschließend vermeldet der Contao-Manager noch einen Fehler beim Schließen:

    Code:
    ERROR 403
    HTTP-Anfrage für "DELETE api/task" fehlgeschlagen.
    Der Server hat eine Antwort mit Status-Code 403 gesendet.
    Active task cannot be deleted
    Hat jemand eine Idee, was hier verkehrt läuft?

    Danke und Grüße!
    Geändert von xchs (02.05.2021 um 15:02 Uhr) Grund: Code-Tags
    Dankbar für jede Hilfe!

  3. #3
    Contao-Nutzer
    Registriert seit
    13.11.2018.
    Beiträge
    13

    Standard Die Probleme gehen weiter...

    Hallo,

    ein kurzes Update: Ich habe den Composer nun auf die aktuelle Version 2 aktualisiert und die Erweiterung "Contao-Haste" von Codefog separat installiert (erfolgreich). "mp_forms" mag aber weiterhin mit der Contao 4.4.55 nicht zusammenarbeiten (bei einer Contao 4.9.x eines anderen Kunden bei dem selben Hoster funktioniert die Erweiterung hingegen).

    Während der Testlauf mit Composer ohne Fehlermeldung klappt, scheitert die reale Installation. Hier die Konsolenmeldung, die sich über veraltete Module beschwert:

    $ /usr/bin/php7.4 -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /home/www/contao44/web/contao-manager.phar.php composer require terminal42/contao-mp_forms --no-update --no-scripts --prefer-stable --sort-packages --no-ansi --no-interaction

    Using version ^4.2 for terminal42/contao-mp_forms
    /home/www/contao44/composer.json has been updated

    # Process terminated with exit code 0
    # Result: OK


    > Resolving dependencies using Composer Cloud v3.1.1
    !!! Current server is sponsored by: Contao Association !!!


    [5.8MiB/0.17s] Loading composer repositories with package information
    [61.3MiB/1.65s] Updating dependencies
    [135.1MiB/15.25s] Lock file operations: 1 install, 0 updates, 0 removals
    [135.1MiB/15.25s] - Locking terminal42/contao-mp_forms (4.2.1)
    [134.6MiB/15.26s] Writing lock file
    [78.0MiB/15.30s] Package contao-components/compass is abandoned, you should avoid using it. No replacement was suggested.
    [78.0MiB/15.31s] Package doctrine/doctrine-cache-bundle is abandoned, you should avoid using it. No replacement was suggested.
    [78.0MiB/15.31s] Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.
    [78.0MiB/15.31s] Package oyejorge/less.php is abandoned, you should avoid using it. No replacement was suggested.
    [78.0MiB/15.31s] Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.
    [78.0MiB/15.31s] Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
    [78.0MiB/15.31s] Package sensio/distribution-bundle is abandoned, you should avoid using it. No replacement was suggested.
    [78.0MiB/15.32s] Package sensiolabs/security-checker is abandoned, you should avoid using it. Use https://github.com/fabpot/local-php-security-checker instead.
    [78.3MiB/15.32s] Memory usage: 78.31MB (peak: 1404.32MB), time: 15.32s.
    [78.3MiB/15.32s] Finished Composer Cloud resolving.


    # Job ID HWd2c9OQEWPLfUlcOg2LLFou68hOz7Xh6Sw0n6ORrNPqo1SFIQ 2WM74CLZGQsy3G9ufG5WA5qrPu9Tm5GNJChLWU completed in 13 seconds
    # Memory usage: 78.31MB (peak: 1404.32MB), time: 15.32s.

    $ /usr/bin/php7.4 -q -dmax_execution_time=0 -dmemory_limit=-1 -dallow_url_fopen=1 -ddisable_functions= -ddate.timezone=Europe/Berlin /home/www/contao44/web/contao-manager.phar.php composer install --prefer-dist --no-dev --no-progress --no-ansi --no-interaction --optimize-autoloader

    Installing dependencies from lock file
    Verifying lock file contents can be installed on current platform.
    Package operations: 1 install, 0 updates, 0 removals
    - Installing terminal42/contao-mp_forms (4.2.1): Extracting archive
    Package contao-components/compass is abandoned, you should avoid using it. No replacement was suggested.
    Package doctrine/doctrine-cache-bundle is abandoned, you should avoid using it. No replacement was suggested.
    Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.
    Package oyejorge/less.php is abandoned, you should avoid using it. No replacement was suggested.
    Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.
    Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
    Package sensio/distribution-bundle is abandoned, you should avoid using it. No replacement was suggested.
    Package sensiolabs/security-checker is abandoned, you should avoid using it. Use https://github.com/fabpot/local-php-security-checker instead.
    Generating optimized autoload files
    contao/manager-plugin: Generating plugin class...
    37 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!

    # Process terminated with exit code 255
    # Result: Unknown error
    Soll ich ein Ticket bei GitHub aufmachen - oder liegt es an meiner Blödheit?

    Danke!
    Dankbar für jede Hilfe!

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •